The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 19 posts ] 
Author Message
PostPosted: Thu Sep 30, 2010 4:11 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 06, 2009 12:58 pm
Posts: 32
All I want to do is embed a google calendar into the body of an article. I don't want to use gcalendar or any other extension. I have calendars set up as wrappers in menus, but can't figure out how to get a google calendar into an article. Thanks.


Top
 Profile  
 
PostPosted: Mon Oct 04, 2010 12:38 am 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Nov 09, 2006 2:46 pm
Posts: 4874
Location: Kampala, Uganda
There are several ways to do this.

First of all, Google gives you the code to embed in your article that will put the calendar in there for you.

Normally you would have to switch to <html> view to put the embed code, but extensions like Sourcerer and Jumi do make it a lot easier.

But, you can do it just using the Joomla editor if don't want to use any extensions.

So, edit your article. At the place you want to embed the Google Calendar code, switch to <html> or <source code> view ... paste the code that Google gives you (it's a basic "iframe" code) and then save your article, That should do it for you.

_________________
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com


Top
 Profile  
 
PostPosted: Mon Oct 04, 2010 1:39 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 06, 2009 12:58 pm
Posts: 32
I downloaded Sourcerer and installed. But, I can't get it to work. Here is my iframe code from Google:

<iframe src="https://www.google.com/calendar/embed?mode=AGENDA&amp;height=600&amp;wkst=1&amp;bgcolor=%23FFFFFF&amp;src=anwsu.org_2d3835363737353435373236%40resource.calendar.google.com&amp;color=%232F6309&amp;src=anwsu.org_cr8b2baqfpldni0h8etd8lcr9g%40group.calendar.google.com&amp;color=%23691426&amp;src=vergenneselementary%40anwsu.org&amp;color=%23853104&amp;src=lsprague%40anwsu.org&amp;color=%238C500B&amp;ctz=America%2FNew_York" style=" border-width:0 " width="400" height="600" frameborder="0" scrolling="no"></iframe>

When I click the "insert code" button and place that code between the two instances of "source" it just displays the code in the article. It doesn't actually show the calendar. What am I missing here?


Top
 Profile  
 
PostPosted: Mon Oct 04, 2010 1:58 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Nov 09, 2006 2:46 pm
Posts: 4874
Location: Kampala, Uganda
I'm not sure, but make sure that you "enabled" the Sourcerer plugin.

Go to Extensions -> Plugin Manager. Find the Sourcerer plug in and make sure that it is "enabled."

Let us know how it goes.

_________________
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com


Top
 Profile  
 
PostPosted: Mon Oct 04, 2010 3:53 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Sun Aug 08, 2010 2:54 pm
Posts: 171
whatch wrote:
All I want to do is embed a google calendar into the body of an article. I don't want to use gcalendar or any other extension. I have calendars set up as wrappers in menus, but can't figure out how to get a google calendar into an article. Thanks.


Go to Google Gadgets For Your Webpage http://www.google.com/ig/directory?synd=open&hl=en&gl=&q=calendar, select the gadget format that you required, click the tab "Add To Your Webpage", Change the Display Settings & Gadget Settings till you are satisfied with the preview. Then click on "Get The Code", copy the HTML code provided. Login to your Joomla admin, open the article, click on the HTML icon, insert the Gadget HTML code into the body of the article. Click update. After updated, click save.

_________________
DoBizOn9 - Consolidated Online Business Startup Guide: Online Business Ideas | Online Business Opportunity | Online Jobs . Include JOOMLA GUIDE at http://www.dobizon9.com/webdesigning/cms/joomla.html


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 1:40 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Fri Feb 03, 2006 3:23 pm
Posts: 281
Location: Georgia, United States
I'm trying to do exactly the same thing as this poster... however, when I save the article, the html disappears. It happens every time. I've tried turning off the editor (as suggested in other posts) but that also turns off the html option.

Help! This should be simple but so far has taken hours of my time. I've even tried an Extension, which didn't work, so I'm back to trying to do it the old-fashioned way.

Any suggestions? Thanks!!

_________________
Be part of the solution -- not part of the problem.


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 3:58 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Nov 09, 2006 2:46 pm
Posts: 4874
Location: Kampala, Uganda
By default, the Tiny MCE editor does indeed "clean up" your html code (especially iframes / wrappers) which have some inherent risk.

So, in Joomla 1.5, be sure that you have turned off the "cleanup html" in the editor plug-in.

Extensions -> Plug-in manager -> Editor - Tiny MCE

Likewise, go to the article manager and click on the "Parameters" option in the upper right corner.

Scroll down near the bottom and set "super-admin" (or whatever level you are) to be "No html filtering."

See if that makes a difference for you.

_________________
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 4:28 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Fri Feb 03, 2006 3:23 pm
Posts: 281
Location: Georgia, United States
Thanks jmuehleisen for trying to help. I've set everything as you suggested; still doesn't work. I can see the calendar in the article until I save it; then it disappears, even with all the html code settings set as directed.

Any other ideas?? :/

_________________
Be part of the solution -- not part of the problem.


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 4:37 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Nov 09, 2006 2:46 pm
Posts: 4874
Location: Kampala, Uganda
Well, something (obviously) is cleaning up the code for you.

Which editor are you using? Tiny MCE or JCE? (the JCE settings are elsewhere if you are using that editor).

_________________
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 4:50 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Fri Feb 03, 2006 3:23 pm
Posts: 281
Location: Georgia, United States
I've tried every editor that I have installed, which are/is several: Tiny MCE, JoomlaCK, JoomlaFCK, JCE 1.5.6, and No Editor. I've tried with all 3, but most recently with Tiny MCE after following your instructions for turning off the html cleaning.

I wonder if I need to disable all the other editors first under Plugins rather than in Global Config? I would think that if an editor wasn't 'turned on' in GC then it wouldn't have any effect, but I guess it's worth a shot unless you have another idea.

_________________
Be part of the solution -- not part of the problem.


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 5:02 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Nov 09, 2006 2:46 pm
Posts: 4874
Location: Kampala, Uganda
Hmmm.

Check if you have specified a default editor for yourself in the user manager (it should be set to "Select Editor")

_________________
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 5:57 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Fri Feb 03, 2006 3:23 pm
Posts: 281
Location: Georgia, United States
Thanks... it is set to -Select Editor- (meaning no editor is selected).

I also disabled ALL the other editors in my Plugins manager, even though I don't think that would affect anything.

Still no dice.

I had already searched for "html disappears" in this forum prior to posting on this thread, but none of the suggestions I found worked.

I agree with you -- *something* is stripping the html, but what? If you have any other ideas, I'm all ears. Thanks so much for spending your valuable time trying to help me. :)

_________________
Be part of the solution -- not part of the problem.


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 6:36 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Nov 09, 2006 2:46 pm
Posts: 4874
Location: Kampala, Uganda
Hmmm. You are doing everything that I would do.

My only suggestion is go back and double check everything, but I suspect you've already triple checked it.

_________________
John Muehleisen
Visit my "Getting Started with Joomla" site, now with videos, tips, and new user tutorials:  http://welcometojoomla.com


Top
 Profile  
 
PostPosted: Wed Nov 09, 2011 9:23 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Nov 09, 2011 9:07 pm
Posts: 1
I've had this problem since I started using 1.7, in 1.5 I had no problem getting it done by disabling the editor, but anyhow this is the only way I have been able to get it to work in 1.7(and I assume 1.6 is the same)

What I had to do was edit the table in mysql and put the embed code there. In my case I wanted the google calendar embedded in a category page, so i added the embed code <iframe src="blahblahblah"</iframe> into the description field for the category i wanted it in... for categories they are in xxxxx_categories, for articles I believe you can find it in xxxxx_content in mysql and past the code in the intotext or fulltext field(i haven't tried doing it in an article myself so i'm speculating here).

Anyhow, putting the code into the db itself is the only way I have been able to embed google calendars into a page. I've tried endless editors and the code is always stripped out when I hit save, hope this helps ya.

One caveat to this is if you go to edit the article/category after, it will strip out the code again; so you'll want to do the calendar last, or you will have to edit the db again to replace it.


Top
 Profile  
 
PostPosted: Mon Feb 20, 2012 5:59 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Nov 21, 2008 11:45 pm
Posts: 34
Seriously that is the only way to do it? Hard to believe!


Top
 Profile  
 
PostPosted: Fri Mar 02, 2012 1:33 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Mar 02, 2012 1:30 pm
Posts: 2
Hi
I have the same problem in Joomla 2.5, so far I have spent a day on it. Have checked everything and still no chance. Is it possible that there is a bug in Joomla?

Any Help greatly appriciated!


Top
 Profile  
 
PostPosted: Fri Mar 02, 2012 1:42 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Mar 02, 2012 1:30 pm
Posts: 2
Ok, i found it! iFrame was disabled under the plugin properties. it works fine now...


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Mon Mar 19, 2012 7:36 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Feb 15, 2012 5:20 pm
Posts: 47
Location: Ohio
mush2004 wrote:
Ok, i found it! iFrame was disabled under the plugin properties. it works fine now...



Having the same problem - where exactly did you correct this please. Can't find it... :-[

Upon further investigation I found it in the Plugin Manager .... Editor - TinyMCE

_________________
Thanks,
Tom


Top
 Profile  
 
PostPosted: Fri Apr 05, 2013 9:42 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 12, 2011 8:37 pm
Posts: 16
You can create the iframe wrapper menu. Enter url as "https://www.google.com/calendar/embed?src=~" but without quotation marks. I am still to investigating how to adjust the size, but without any style codes, it appears to be fine.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ] 



Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group