The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 32 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Sun Dec 18, 2011 4:04 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue May 17, 2011 7:10 pm
Posts: 42
Hello and thank you for viewing my post any help would be greatly appreciated. I have been using joomla 1.7 on godaddy with my joomla directory on the root. Every so often I will randomly get the error "no input file specified." I then have to wait a couple of minutes (amount of time is different every time) for my webpage to open again. Now I have tried everything I could think of to fix this issue including the steps below. I don't want to turn off SEF like many user do. What should I do?

So far:

1)I have Apache mod_rewrite = Yes, and Search Engine Friendly URLs = Yes as well. Then in the .htaccess file

Options +FollowSymLinks
Options -MultiViews
RewriteEngine On
RewriteBase /

A full explanation can be found here http://www.joomlart.com/forums/showthre ... d-Accounts.

This didn't work for me but it seems to have helped others.

2) I checked my config.php to see if live_site was set to the correct directory and it is.

3) I also did this though it seemed like it was wrong and it was it made it worse.
In your Joomla root directory, there’s a file called htaccess.txt . Open it with a text editor and find the following line:

Options +FollowSymLinksThen simply comment it out like this:

#Options +FollowSymLinksNow save the file and upload it via ftp to your hosting account. Now rename it to .htaccess .


Top
 Profile  
 
PostPosted: Sun Dec 18, 2011 4:05 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue May 17, 2011 7:10 pm
Posts: 42
Below is my .htaccess file

##
# @version $Id: htaccess.txt 21101 2011-04-07 15:47:33Z dextercowley $
# @package Joomla
# @copyright Copyright (C) 2005 - 2011 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks
Options -MultiViews

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
SetEnv PHPRC /home/content/55/6067155/html/tmp
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.


Top
 Profile  
 
PostPosted: Sun Dec 18, 2011 4:25 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue May 17, 2011 7:10 pm
Posts: 42
[Bump]

Any ideas?


Top
 Profile  
 
PostPosted: Tue Dec 20, 2011 12:51 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Oct 10, 2008 9:03 pm
Posts: 60
i had this issue when i migrated my cpanel to another account. in my account root i :( had a php.ini file for overiding features. so i deleted it and created a new one with my new accounts settings.

so i think it is related to your php.ini . if you do not overide perhaps godaddy is having resource issues when scanning for php overide files


Top
 Profile  
 
PostPosted: Wed Dec 21, 2011 4:57 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue May 17, 2011 7:10 pm
Posts: 42
Thank you for replying shoulders I really appreciate you taking the time to help. But I have found the answer!!!!! Godaddy users please pay attention since this seems to affect us the most.

First do the following:

1) From the Joomla Control Panel go to "global setting" and under the Site Tab turn off SEF and Apache ("Use URL rewriting" for 1.7 users).

2) Now move your .htaccess file to your computer via FTP if you don't have this file move htaccess.txt to your pc and open the file.

3) Remove any #'s if any from RewriteEngine On and RewriteBase /
Note: if your site is on a sub-directory the above should appear like this
RewriteBase /yourJoomlaRootFolder/

4) Search for Options +FollowSymLinks and add the below right after it.
Options -MultiViews

5) Save the file and move it back to your server. *If the file was originally named htaccess.txt rename it to .htaccess and then move it back to the server.

6) Turn on SEF and Apache ("Use URL rewriting" for 1.7 users)

7) Now Check to see if it is working. If it still isn't working or its happening less frequently move on to step 8.

8) In your Joomla root directory look for "php.ini" and rename it "php5.ini" (no quotes). If the file does not exist on your local computer open notepad if it does test again to see if it works. If it doesn't proceed to step 9.

9) Move the new php5.ini file to your computer (if it didn't exist keep notepad open)

10) Add this line, "cgi.fix_pathinfo = 1" (no quotes), to the document and save the file by going to File -> Save As -> under Save as type change it to All Files -> Change the file name to php5.ini if it isn't already named that.
Note: You may also want to add the below to the document to change your
max doc upload to joomla (you may edit it as needed).

cgi.fix_pathinfo = 1
memory_limit = 50M
post_max_size = 10M
file_uploads = On
upload_max_filesize = 10M
upload_tmp_dir = /home/content/55/6067155/html/tmp

11) Check your site thoroughly again before moving on to the last step which solved my problem.

12) Login to your Godaddy Account. Go to your hosting account.
Go to Settings > File Extensions Management
and edit .php and .php5 from "PHP5.2xFastCGI" to "PHP5.2X"

13) Test out your site if this still doesn't work contact godaddy and make sure you send them all of the above information because you may have a server issue.

This help came from searching over 2 weeks and lots and lots of trial and error. But I have to Thank Magneto's forum since half of it came from their site and the rest I pieced together. Check out their post below for more info.
http://www.magentocommerce.com/boards/v ... ad/242297/

I hope this helps you as it did me and if it does let me know I love posting up thorough fixes on these forums. But I especially love knowing that it helped you out. Good luck on your site and if anything changes regarding this I will keep you posted.


Top
 Profile  
 
PostPosted: Wed Jan 04, 2012 8:41 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Jan 04, 2012 8:39 pm
Posts: 1
Thanks, I got to step 10 and mine started working on Godaddy


Top
 Profile  
 
PostPosted: Tue Jan 10, 2012 6:53 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 13, 2011 3:17 pm
Posts: 41
excellent response worked for me at step 12 !

Thanks cyphergt - took me months to try and figure this one out.


Top
 Profile  
 
PostPosted: Thu Jan 19, 2012 7:28 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Dec 26, 2005 7:51 pm
Posts: 10
Thank you cyphergt! Great information; I'm sure it saved me hours and hours of trial and error!!


Top
 Profile  
 
PostPosted: Thu Jan 19, 2012 12:43 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jul 25, 2011 8:00 pm
Posts: 14
9ce 1 bro. worked for me @ step 7. Wz already gettn frustrated & thn i found ur post. Sincerely gratful. Cheerz


Top
 Profile  
 
PostPosted: Mon Jan 23, 2012 11:39 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jun 07, 2010 5:40 am
Posts: 23
Step 12 was all I had to fix on the go daddy host. ""PHP5.2xFastCGI" to "PHP5.2X""

Thank you so much for this info.


Top
 Profile  
 
PostPosted: Mon Jan 23, 2012 11:37 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri May 27, 2011 10:08 pm
Posts: 19
Location: Calgary, Alberta, Canada
No Luck. I have contacted Godaddy.

**Important** - What finally worked for me is that after the above changes were made the previously created articles and buttons would display 404 error. The articles and buttons created after the above changes were made work great as SEF URLs.

So bottom line is get the SEF URLs working for the site before creating your pages.

I also have url rewriting set to no and it is working fine. Did not work with it set to yes.

_________________
Surf Web Design
http://www.surfwebdesign.ca/


Top
 Profile  
 
PostPosted: Tue Jan 31, 2012 9:12 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Jan 31, 2012 9:08 pm
Posts: 1
Hi
my problem gets fixed when i turn off SEF, the first step, but i don't want to turn SEF off. any suggestions for me?
thanks a lot for this post.
Rez


Top
 Profile  
 
PostPosted: Tue Jan 31, 2012 10:13 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri May 27, 2011 10:08 pm
Posts: 19
Location: Calgary, Alberta, Canada
I realized that a fresh install of Joomla 1.7 from godaddy comes with SEF URls. I would recommend that anyone setting up a fresh Joomla site to let Godaddy do it. They can also update it when a newer version is stable enough. Right now they are using Joomla 1.7.1 but Joomla 2.5 was just released Jan 24 / 2012. Your other option is to use the one click updating found in Joomla 1.6 and above.

I guess I am getting off topic here but for me I just updated from Joomla 1.7.1 to Joomla 2.5 with Godaddy using the extensions/extensions manager/update/find updates/selected Joomla 2.5 and clicked update.

When there was a error I purged the cache and on the database tab I click fix (top right). All fixed and now it works great.

_________________
Surf Web Design
http://www.surfwebdesign.ca/


Top
 Profile  
 
PostPosted: Wed Feb 08, 2012 5:25 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Feb 08, 2012 5:19 am
Posts: 1
Hello cyphergt,

Thanks a lot for your time into this post. I faced the same problem and I have only applied Step-10 to my installation and everything is working fine now.

- Dinesh.


Top
 Profile  
 
PostPosted: Thu Feb 09, 2012 6:38 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Feb 09, 2012 6:27 pm
Posts: 6
I'm using Joomla 2.5.1 and PHP 5.3 on an Apache server at GoDaddy. This solved my problem:
1. In the Joomla Administrator, I went to Site --> Global Configuration --> Site.
2. Under SEO settings, I changed "Use URL rewriting" from "No" to "Yes".
3. In my FTP program, I renamed the file, "htaccess.txt", on the root of the server, to ".htaccess" (this step was per the instructions given when you hover over the ! icon next to the "Use URL rewriting" setting).


Top
 Profile  
 
PostPosted: Fri Feb 10, 2012 4:47 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jan 13, 2012 8:49 pm
Posts: 14
I am using Joomla! 2.5.1 and my host is Godaddy, I had the same problem and thank you cyphergt my problem is solved.


Top
 Profile  
 
PostPosted: Wed Feb 15, 2012 12:22 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 10, 2011 7:50 am
Posts: 10
@cyphergt you're a genius. Thanks..i hate GoDaddy but have to work w/it because of clients' preferences. Thanks again!


Top
 Profile  
 
PostPosted: Fri Mar 02, 2012 8:44 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Nov 18, 2011 1:29 am
Posts: 1
This was extremely helpful. I had a bunch of sites, 1.7.3 and 2.5.1 on goDaddy 4GH shared servers that were working fine but mysteriously all started showing this symptom at the same time one evening.

I had to go all the way to step 12 to fix it. I'd like to add (to save someone else the time) the following step.

Since my hosting account was set up to run PHP 5.3, before I could do step 12 I had to downgrade the PHP to 5.2. This is done in the goDaddy hosting account, go to Content -> Programming Languages. They say it takes about 45 mins, on one account it happened immediately, the other took about 2 hours.

I had to go back to 5.2 because there was no option to change the file extension management to "5.3.X" (only "5.3.X FastCGI" was available.) Maybe by the time you try this you'll have that option for you to try first.

FWIW this also meant I had to comment out another line in the .htaccess I'd added (on the advice of a goDaddy support article) to get PHP 5.3 to work properly. namely:

# AddHandler x-httpd-php5-3 .php


Top
 Profile  
 
PostPosted: Sun Mar 18, 2012 2:01 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Aug 21, 2008 12:23 am
Posts: 16
Thanks so much for this! I've been a Joomla user for years, but I've been using 1.5. I just built my first site with 2.5 today, and was discouraged to find all my links getting this error. I'm a GoDaddy user, but installed Joomla myself (wish I would have known that doing it through GoDaddy might have saved me some trouble).

I got to step 7 and this fixed my issue. Great post!


Top
 Profile  
 
PostPosted: Sun Apr 15, 2012 5:19 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Apr 15, 2012 5:16 pm
Posts: 1
For me, all it took was changing a value in php.ini

open_basedir=/home/[MAKE SURE THE VALUE HERE MATCHES YOUR BASE DIRECTORY]/public_html

For me, it was open_basedir=/home/techmedx/public_html

That fixed it right away.

PS - This was in Joomla 2.5


Top
 Profile  
 
PostPosted: Thu Apr 26, 2012 11:24 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Apr 25, 2012 2:46 pm
Posts: 3
Thanks BRO!

12) Login to your Godaddy Account. Go to your hosting account.
Go to Settings > File Extensions Management
and edit .php and .php5 from "PHP5.2xFastCGI" to "PHP5.2X"

running Joomla! 2.5 on GoDaddy. Step 12 fixed it. thanks


Top
 Profile  
 
PostPosted: Thu May 17, 2012 3:56 pm 
Joomla! Intern
Joomla! Intern

Joined: Mon Nov 05, 2007 8:12 pm
Posts: 52
Location: Atlanta, Georgia
Many of our clients are using Joomla! 2.5.x on GoDaddy (and affiliate) servers. In order to resolve this issue, simply turn on caching (Global Configuration) once you are certain you wish to launch the site. Caching decreases the number of requests to the database, etc. and that may be the cause of the error. Turning on caching seems to work. We typically use "Conservative" for most sites. For Joomla! versions prior to 2.5, any form of caching available should work.

_________________
Visit toneee.com to
move @ the speed of business™


Top
 Profile  
 
PostPosted: Wed May 30, 2012 8:51 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Sep 23, 2009 10:17 pm
Posts: 2
shoulders wrote:
i had this issue when i migrated my cpanel to another account. in my account root i :( had a php.ini file for overiding features. so i deleted it and created a new one with my new accounts settings.

so i think it is related to your php.ini . if you do not overide perhaps godaddy is having resource issues when scanning for php overide files


The point is yours. It has worked for me. THX!!!


Top
 Profile  
 
PostPosted: Sun Jun 03, 2012 1:57 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun May 27, 2012 7:17 pm
Posts: 28
I host on Godaddy and both htaccess.txt and .htaccess are in the directory. What should I do?


Top
 Profile  
 
PostPosted: Tue Jun 12, 2012 6:39 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon May 28, 2012 6:26 am
Posts: 20
Try this
It surtely works
1) All SEO Options are set to “yes”
2) I renamed the file to .htaccess
3) Took out the # in front of Rewritebase /
4) Put a # in front of Options +FollowSymLinks


Top
 Profile  
 
PostPosted: Thu Jun 21, 2012 3:10 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jun 21, 2012 2:33 am
Posts: 1
i use godaddy hosting. the issue was fixed in step 6. thanks, cyphergt


Top
 Profile  
 
PostPosted: Mon Jul 02, 2012 8:39 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jan 19, 2012 7:45 pm
Posts: 6
cyphergt wrote:
Hello and thank you for viewing my post any help would be greatly appreciated. I have been using joomla 1.7 on godaddy with my joomla directory on the root. Every so often I will randomly get the error "no input file specified." I then have to wait a couple of minutes (amount of time is different every time) for my webpage to open again. Now I have tried everything I could think of to fix this issue including the steps below. I don't want to turn off SEF like many user do. What should I do?

So far:

1)I have Apache mod_rewrite = Yes, and Search Engine Friendly URLs = Yes as well. Then in the .htaccess file

Options +FollowSymLinks
Options -MultiViews
RewriteEngine On
RewriteBase /

A full explanation can be found here http://www.joomlart.com/forums/showthre ... d-Accounts.

This didn't work for me but it seems to have helped others.

2) I checked my config.php to see if live_site was set to the correct directory and it is.

3) I also did this though it seemed like it was wrong and it was it made it worse.
In your Joomla root directory, there’s a file called htaccess.txt . Open it with a text editor and find the following line:

Options +FollowSymLinksThen simply comment it out like this:

#Options +FollowSymLinksNow save the file and upload it via ftp to your hosting account. Now rename it to .htaccess .


After spending, literally, hours searching for answers all it took for me was to just rename the php.ini file to php5.ini - I didn't have to make any changes to my .htaccess or anything else.


Top
 Profile  
 
PostPosted: Thu Aug 16, 2012 2:23 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 11, 2010 11:08 am
Posts: 32
Awesome! You're a legend, can't thank you enough!


Top
 Profile  
 
PostPosted: Fri Aug 31, 2012 6:56 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Aug 31, 2012 6:46 pm
Posts: 1
Than you very very much!


Top
 Profile  
 
PostPosted: Thu Sep 13, 2012 7:11 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Sep 13, 2012 7:06 pm
Posts: 1
Thanks...cyphergt......You so guuudddddd........May the lord repay all your favor...... :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 32 posts ]  Go to page 1, 2  Next



Who is online

Users browsing this forum: Google [Bot] and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group