The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Tue Dec 27, 2011 10:27 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Dec 11, 2011 1:01 am
Posts: 16
I renamed htaccess.txt to .htaccess but it told me that the file already existed

so I renamed htaccess to .htaccess.

After saving that my htacces disapeared from my cpanel

Then I turned on Apache mod_rewrite & friendly URLs

My URLs are friendly but not a single link on my site works!!

I how no idea on how to solve this, I read some posts but nothing seems to work without the htaccess file.

Please, help! :(


Top
 Profile  
 
PostPosted: Tue Dec 27, 2011 12:29 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Tue Dec 06, 2011 11:35 am
Posts: 107
I didn't try it personally but I think .htaccess. don't work and you need to have .htaccess

remove the last dot, you can check whether an .htaccess already exists there.

_________________
Joomla Template Design Software
www.TemplateToaster.com


Top
 Profile  
 
PostPosted: Tue Dec 27, 2011 8:30 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Dec 11, 2011 1:01 am
Posts: 16
TemplateToaster wrote:
I didn't try it personally but I think .htaccess. don't work and you need to have .htaccess

remove the last dot, you can check whether an .htaccess already exists there.


Yes but when I typed the last dot .htaccess disappeared, is not in my public_html

I how no idea how to put it back on.

Friendly URL don't work for many many people, this is a huge joombla bug that I didnt know.


Top
 Profile  
 
PostPosted: Thu Dec 29, 2011 1:59 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Dec 11, 2011 1:01 am
Posts: 16
Solved.

I could find the file in my FTP, for some reason it did not show up in my cpanel.


BTW, it is funny how you can fix a problem and then make 2 new problems, and that's how joombla works, I guess I have to get used to going 2 steps foward and one step back.


Top
 Profile  
 
PostPosted: Sun Jan 01, 2012 7:37 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Aug 02, 2009 7:58 am
Posts: 11
if you are using cpanel

please check the box for show hidden files

Image


Top
 Profile  
 
PostPosted: Wed May 02, 2012 7:43 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed May 02, 2012 7:19 pm
Posts: 3
.htaccess? You're on IIS aren't you?
On IIS you need "URL Rewriter" and web.config, instead of .htaccess


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 



Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group