Strict standards : Non-static methods called statically

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
zarvan
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Mon Aug 29, 2011 12:55 pm

Re: Strict standards : Non-static methods called statically

Postby zarvan » Fri Sep 02, 2011 6:58 am

hi Kev261266
thanks for your solution but i use appserver
how can i find php.ini

colruyt
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Thu Sep 22, 2011 9:15 pm

Re: Strict standards : Non-static methods called statically

Postby colruyt » Thu Sep 22, 2011 10:11 pm

houldsworth1 wrote:
sitelerinsitesi wrote:Ok, I am sorry. I have the same problem as the first poster.


Don't be sorry - that's what forums are for.

Have you tried modifying your php.ini file?

Mine was as follows (using lampp)

Code: Select all

Change /opt/lampp/etc/php.ini
set error_reporting to E_ALL & ~E_NOTICE
display_errors = Off


Then (very important because I missed this at first) you need to stop and start the lampp server (if you are not using lampp then bounce whichever webserver you are using).

I hope that helps.


Hi, thanks, it is extremely helpful to mention the stop and restart part!
I am using XAMPP, and I attempted many times by just exiting and restarting XAMPP, but however you need to stop Apache and MySql, and restart them!

SparkyCanLearn
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Sep 10, 2011 2:18 pm

Re: Strict standards : Non-static methods called statically

Postby SparkyCanLearn » Sun Sep 25, 2011 2:05 am

judy2segev,
Thank you so much for your post. Solved my problem as soon as I found the file. Edited it with notepad from -1 to 6135. Works like a charm. Thanks.
>> Dennis

mr_jamesw
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Nov 09, 2011 10:47 am

Re: Strict standards : Non-static methods called statically

Postby mr_jamesw » Wed Nov 09, 2011 11:02 am

Thank you all for your kind replies to OP. I spent a good two hours trying all this. Some body mentioned that you should restart your computer, I thought that was a silly thing to do as clearing all browsing history should be satisfactory.

However, I ended up restarting it with my fingers crossed and what do you know, it worked straight off after restarting. Made an account to tell you this, in case you're in a position similar to I was.

I modified php.ini (located in xampp>>php>>php.ini (a config. file)

open with notepad

line without the ";" change it to the following:

"set error_reporting to E_ALL & ~E_NOTICE"

then go to joomla config. file (xampp>>htdocs>>Joomla15*>>configuration.php

open with notepad

half way across first line change the $error_reporting value to "6135" from "-1"

restart xampp, restart computer. Good luck.



*your joomla folder, joomla15 recommended in Joomla setup guide

dedejoe
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Nov 11, 2011 10:20 am

Re: Strict standards

Postby dedejoe » Fri Nov 11, 2011 10:47 am

I did the following and it worked correctly:

Changed the following in php.ini

From: error_reporting = E_ALL | E_STRICT
To: error_reporting = E_ALL & ~E_STRICT

From: display_errors = On
To: display_errors = Off

Also in configuration.php file
Changed: var $error_reporting = ‘-1′; to var $error_reporting = ’6135′;

You can try it also. Have fun with joomla.

jfdutoit
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Mar 28, 2011 2:43 pm

Re: Strict standards : Non-static methods called statically

Postby jfdutoit » Wed Dec 21, 2011 8:16 am

Hi There,

I found the quote bellow on Apache Friends' forum, and this solved the issue for me. I know it is an old issue, but I recently encountered this problem. Well, I'm happy - hope it can help someone else. ;D


"geethupendra is correct and what you need to do is change the following line in the php.ini file:

Line 516: error_reporting = E_ALL | E_STRICT

TO

Line 516: error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

Save that and restart Apache and you should be good to go with installing and working with Joomla! on XAMPP 1.7.4"


http://www.apachefriends.org/f/viewtopic.php?p=182516

darthcricket
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Mon Dec 05, 2011 2:29 am

Re: Strict standards : Non-static methods called statically

Postby darthcricket » Sat Jan 14, 2012 4:06 pm

I have tried all of the changes to the code above and still I get the Strict standards errors. I have set up a site on Joomla 1.7 with these corrections and they have worked fine, but I can't get it to work on the 1.5

What is happening? Help.

jhcorsair
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Sat Aug 07, 2010 12:03 pm
Location: East Coast US
Contact:

Re: Strict standards : Non-static methods called statically

Postby jhcorsair » Tue Jan 17, 2012 1:49 am

arobert wrote:I Think most of people makes the same mistake I made.
Actually, in php.ini (provided with EasyPhp3 (at last)) 'error_reporting' and 'display_errors' appear twice in the file ... So be care to edit the last one, because default value for this variables are :

Code: Select all

error_reporting = E_ALL | E_STRICT
display_errors = On

despite what is written at the first begginig of this file.
So the Full answer to this problem is :
In Apache php.ini (For easyPhp in %EASYPHP_HOME%/conf_files/php.ini
1/ change

Code: Select all

error_reporting = E_ALL | E_STRICT
by

Code: Select all

error_reporting = E_ALL & ~E_STRICT

2/ change

Code: Select all

display_errors = On
by

Code: Select all

display_errors = Off

Warning : Be sure your error_reporting and display_errors variables are the last one to be read in the php.ini file, else yours could be overwritten by default values.
Furthermore, you can leave var $error_reporting = '-1'; unchanged in joomla configuration.php


I can't thank you enough for providing this final solution. I wasted a lot of time till I got to your post.

darthcricket
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Mon Dec 05, 2011 2:29 am

Re: Strict standards : Non-static methods called statically

Postby darthcricket » Mon Feb 06, 2012 6:34 pm

thanks for all the information. I was only looking for the changes at the top, but I found there was the same information further down that also needed to change. I used the "find" function on my notepad. All's well!

User avatar
tsaimsbond
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 191
Joined: Wed Feb 15, 2012 8:28 pm

Re: Strict standards : Non-static methods called statically

Postby tsaimsbond » Tue Mar 13, 2012 12:25 pm

http://forum.joomla.gr/viewtopic.php?f=103&t=23547

Strict Standards: Accessing static property JCache::$_handler as non static in C:\xampp\htdocs\joomla\libraries\joomla\cache\cache.php on line 420

Here is an elegant solution:

Go to ..\xampp\htdocs\joomlaxxx\configuration.php and change
public $error_reporting = 'maximum';

or from joomla backpanel

1. http://localhost/joomlaxxx/administrator/ --> menu...
2. Site --> Global Configuration --> ...Server....
3. Error Reporting = maximum;

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 31268
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards : Non-static methods called statically

Postby Webdongle » Tue Mar 13, 2012 11:50 pm

@tsaimsbond

That solution does not work for 1.5 and this is a 1.5 forum

bskaluba
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed May 12, 2010 1:00 pm

Re: Strict standards : Non-static methods called statically

Postby bskaluba » Fri Mar 30, 2012 11:27 pm

8) Hi thanks a lot for the advice. adding this code to index.php in both admin folder and site woked for me:

error_reporting( E_ERROR | E_PARSE | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING );

Arun7987
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jul 27, 2012 10:50 am

Re: Strict standards : Non-static methods called statically

Postby Arun7987 » Fri Jul 27, 2012 11:42 am

igrimpe wrote:E_SCRIPT ???

E_ALL = E_ERROR | E_WARNING | E_PARSE | E_NOTICE | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING | E_USER_ERROR | E_USER_WARNING | E_USER_NOTICE | E_RECOVERABLE_ERROR

Since E_STRICT is not in E_ALL, one has to OR it in.
If you don't want E_NOTICE you have to ANDNOT it out.

Simply set $error_reporting in configuration.php to 6135 if you want all errors except E_NOTICE and E_STRICT


Hi, Thanks for the solution.I am new to Joomla, I've encounter this kind of error(may be not) and i changed the php.ini file error_reporting it didn't worked may be I did something wrong .But when i changed the $error_reporting in configuration.php from 'default' to 6135 .I got the problem solved.My question is what happened here :( ?What is the reason of this kind of Error :( here ( Please forgive my English :-[ ].belowis the screenshot of my login screen(i've cropped the login part)
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 31268
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards : Non-static methods called statically

Postby Webdongle » Sun Jul 29, 2012 8:12 pm

In 2.5 the error reporting can be set in Global config to override the server setting. But IMHO it's best to leave Global config error setting at it's default value and edit the xampp php.ini file correctly.

jasmine89
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu May 12, 2011 4:16 am

Re: Strict standards : Non-static methods called statically

Postby jasmine89 » Thu Dec 06, 2012 9:28 am

Thanks mdias,
It works for me. No more errors. :)
But thing I would like to know is
Will it affect to somewhere if put like that?
What's the reasons why those error came out?

Hope anyone can help to answer these questions. Thank you! :)



mdias wrote:Put this right after "define( '_JEXEC', 1 );" on index.php:

Code: Select all

error_reporting( E_ERROR | E_PARSE | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING );


You may need to do that on your administrator folder too.

euro-space
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Apr 19, 2013 5:02 pm
Location: Sweden. UK.
Contact:

Re: Strict standards : Non-static methods called statically

Postby euro-space » Fri Apr 19, 2013 5:11 pm

These are most common Joomla errors under PHP >5.3

The easiest way is to add (or change to) following in php.ini configuration file:

date.timezone = UTC
display_startup_errors = off
display_errors = off
html_errors = off
docref_root = 0
docref_ext = 0

If there's no access to php.ini, then you can add corresponding directives to .htaccess :

# supress php errors
php_flag display_startup_errors off
php_flag display_errors off
php_flag html_errors off
php_value docref_root 0
php_value docref_ext 0

Also, in configuration.php change following value to:

var $error_reporting = '6135';

Cheers!

User avatar
essiele
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 100
Joined: Mon Oct 03, 2011 9:52 am

Re: Strict standards : Non-static methods called statically

Postby essiele » Fri Apr 19, 2013 8:06 pm

Ok... this is my first time not creating a Joomla! website online; I'm using WAMP.

So I was having the same problem on 2.5.9 with the Web Links facility.
wamp_err.jpg

I followed the instructions and the issue is gone.

1. In php.ini, amend the line

Code: Select all

error_reporting = E_ALL
to show

Code: Select all

error_reporting = E_ALL & ~E_NOTICE
and save the file.

3. In configuration.php, amend the line

Code: Select all

public $error_reporting = 'default'
to show

Code: Select all

public $error_reporting = '6135'
and save the file. NOTE: the value you see may not be 'default' but '-1', as mentioned in earlier posts.

4. Stop and restart your WAMP server.
You do not have the required permissions to view the files attached to this post.
Ess'iele
... seeing things.

User avatar
essiele
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 100
Joined: Mon Oct 03, 2011 9:52 am

Re: Strict standards : Non-static methods called statically

Postby essiele » Fri Apr 19, 2013 8:11 pm

essiele wrote:Ok... this is my first time not creating a Joomla! website online; I'm using WAMP.

So I was having the same problem on 2.5.9 with the Web Links facility.
wamp_err.jpg

I followed the instructions and the issue is gone.

1. In php.ini, amend the line

Code: Select all

error_reporting = E_ALL
to show

Code: Select all

error_reporting = E_ALL & ~E_NOTICE
and save the file.

3. In configuration.php, amend the line

Code: Select all

public $error_reporting = 'default'
to show

Code: Select all

public $error_reporting = '6135'
and save the file. NOTE: the value you see may not be 'default' but '-1', as mentioned in earlier posts.

4. Stop and restart your WAMP server.


I wondered where my "2." went! Here goes my erratum:

2. Still in php.ini, amend the line

Code: Select all

display_errors = On
to show

Code: Select all

display_errors = Off
and save the file.
Ess'iele
... seeing things.

umisakurai
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Dec 28, 2012 8:12 am
Location: Laguna, Philippines

Re: Strict standards : Non-static methods called statically

Postby umisakurai » Sun Jun 23, 2013 7:20 am

Kev261266 wrote:Hi wdemilly,

As I previously posted, do the following:

Go to the file:

D:\XAMPP\PHP\php.ini
In my install this was on line 109

change
error_reporting = E_ALL | E_STRICT
to
error_reporting = E_ALL & ~E_NOTICE

Next go to

D:\XAMPP\HTDOCS\"yourjoomlainstallname"\configuration.php
(line 20 in my installation)

Change the $error_reporting value to 6135

If you have not already turned XAMPP off then turn it off (fully off) turn it back on and the error notices will no longer appear.

Condensed or what?

Kev.


this help me for my problem with strict standards... Thank you!

cottonparrot
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jul 11, 2013 11:29 am

Re: Strict standards : Non-static methods called statically

Postby cottonparrot » Thu Jul 11, 2013 11:35 am

FYI, I fixed the same problem by changing

Code: Select all

public $error_reporting = 'development';

to

Code: Select all

public $error_reporting = 'production';

in line 23, configuration.php.

Hope this helps.

Aly
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Aug 22, 2005 8:56 pm

Re: Strict standards : Non-static methods called statically

Postby Aly » Wed Sep 04, 2013 5:42 am

mdias wrote:Put this right after "define( '_JEXEC', 1 );" on index.php:

Code: Select all

error_reporting( E_ERROR | E_PARSE | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING );


You may need to do that on your administrator folder too.



THANK YOU SO MUCH!! I've spent hours combing the internet and this has completely resolved the issue I was having with Warnings on my homepage.

quoclong5
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Oct 04, 2012 7:13 am
Contact:

Re: Strict standards : Non-static methods called statically

Postby quoclong5 » Thu Sep 26, 2013 6:45 am

Try

ini_set('display_errors', '0'); # don't show any errors...
error_reporting(E_ALL | E_STRICT); # ...but do log them
***** Manual signatures are NOT allowed *****
Last edited by alikon on Sun Nov 10, 2013 6:17 am, edited 1 time in total.
Reason: Manual Signature Removed. See forum rules.

TorbenOlsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Jun 26, 2012 8:39 am

Re: Strict standards : Non-static methods called statically

Postby TorbenOlsen » Tue Dec 31, 2013 2:40 pm

Dear Friends,

I feel like I've tried every single combination to avoid displaying error messages on my Joomla site. Both by adding the code to configuration.php and php.ini but none seem to work.

I still get the following error notification on my www.monovents.com site:

Strict Standards: Only variables should be assigned by reference in /home/sportwo/public_html/monovents.com/modules/mod_facebookall_login/mod_facebookall_login.php on line 20


and

Strict Standards: Declaration of JParameter::loadSetupFile() should be compatible with JRegistry::loadSetupFile() in /home/sportwo/public_html/monovents.com/libraries/loader.php on line 197


Are anybody able to help me remove this message on my site?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 31268
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards : Non-static methods called statically

Postby Webdongle » Tue Dec 31, 2013 3:43 pm

pm me a su login and I will take a quick look

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 31268
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards : Non-static methods called statically

Postby Webdongle » Thu Jan 02, 2014 4:22 pm

Hi Torben

Got your PM and logged in as admin. It looks like the setting in global config is not being observed. This could be due to several reasons ... but it could be because your Joomla is old 2.5(this is a 1.5 forum). Please make a backup and update to the latest version 2.5 and makes sure your extensions are up to date ... then see if the setting works.

TorbenOlsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Jun 26, 2012 8:39 am

Re: Strict standards : Non-static methods called statically

Postby TorbenOlsen » Thu Jan 02, 2014 4:45 pm

OK... Many thanks. I will try that...

TorbenOlsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Jun 26, 2012 8:39 am

Re: Strict standards : Non-static methods called statically

Postby TorbenOlsen » Fri Jan 03, 2014 10:26 am

I tried to update my Joomla but returned with the following error message:

JInstaller: :Install: Error SQL DB function failed with error number 1060
Duplicate column name 'ordering' SQL=ALTER TABLE `jos_languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;
SQL =
ALTER TABLE `#__languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;
Files Update: SQL error file DB function failed with error number 1060
Duplicate column name 'ordering' SQL=ALTER TABLE `jos_languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;
SQL =
ALTER TABLE `#__languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;


However, it now says Joomla! 2.5.17 in the bottom but still 2.5.13 in the button "Update Now".

It doesn't sound too good... Any suggestions? Your temp user is still active...

Torben.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 31268
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards : Non-static methods called statically

Postby Webdongle » Fri Jan 03, 2014 1:20 pm

Extensions >>> extension manager ... database tab ... Fix ... sorted out the mis match of version display.

Downloaded a backup and installed on localhost ... set error reporting off in wamp php.ini file ... but site loaded showing errors. Possibly the template is overriding the settings ?

The 2 modules that show errors are the FB login and the latest news.

Suggest you change the Template.

btw ... you might try removing the site name from the live_site var in the configuration.php it probably is not needed.

TorbenOlsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Jun 26, 2012 8:39 am

Re: Strict standards : Non-static methods called statically

Postby TorbenOlsen » Fri Jan 03, 2014 2:39 pm

Thanks Webdongle... I really appreciate your help. I've just tried to change the template (used the pre-installed Atomic) and the same error messages come up. I have also tried to remove the Facebook module and re-install it with no success...

What do you mean by removing the site name from configuration.php? Do you mean the url that's in there now and should I just leave it blank instead?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 31268
Joined: Sat Apr 05, 2008 9:58 pm

Re: Strict standards : Non-static methods called statically

Postby Webdongle » Fri Jan 03, 2014 5:11 pm

remove the url not the two '' (note they are 2 apostrophise not 1 quotation mark)

Perhaps uninstall your default Template and then use a standard one ? Apart from that a complete rebuild ? You can use j2xml to export/import categories/articles/weblinks/ (and maybe users?).

Looks like your site was originally older than 2.5.x ? To completely get rid of errors a rebuild would probably be needed.


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 7 guests