The Joomla! Forum ™






Post new topic Reply to topic  [ 60 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Mon Sep 10, 2007 3:04 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Aug 18, 2005 12:39 pm
Posts: 4023
Location: São Paulo - Brazil
Seria legal você postar a solução né??

_________________
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.


Top
 Profile  
 
PostPosted: Mon Sep 10, 2007 3:17 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Feb 02, 2007 1:21 pm
Posts: 89
Vou tentar explicar:

criei uma index na pasta raiz assim:
Code:
<html>
<head>
<title>:: NATANAEL VIDEO ::</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="195,*" frameborder="NO" border="0" framespacing="0" cols="*">
  <frame src="topframe.html" name="topFrame" scrolling="NO" noresize >
  <frame src="http://www.natanaelvideo.com.br/home/index.php" name="mainFrame">
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>


ele chama a index e a topframe.html (que estao na raiz)

para visualizar é so acessar o link http://www.natanaelvideo.com.br/home/index.html


Top
 Profile  
 
PostPosted: Mon Sep 10, 2007 4:52 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Aug 18, 2005 12:39 pm
Posts: 4023
Location: São Paulo - Brazil
Ah êêê... Parabéns.

Roni

_________________
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.


Top
 Profile  
 
PostPosted: Mon Sep 10, 2007 5:16 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Feb 02, 2007 1:21 pm
Posts: 89
:P
pois é, demorou mas a caxola funfou!

:D


Top
 Profile  
 
PostPosted: Mon Sep 10, 2007 8:08 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
igornicolai wrote:
custou mas acabei acertando, obrigado a todos pelo auxilio, agora vou desenhar um site novo porque o site ficou tosco coma frame... kkkkk ....

:P

valeuzao galera!


Nicolai, gostaria de saber como você fez, nesse fim de semana passei ele todo dando uma melhorada em um outro site ( http://www.cpaco.com.br ). Por favor me ajude...

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Mon Sep 10, 2007 8:30 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Aug 18, 2005 12:39 pm
Posts: 4023
Location: São Paulo - Brazil
igornicolai wrote:

Code:
<html>
<head>
<title>:: NATANAEL VIDEO ::</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="195,*" frameborder="NO" border="0" framespacing="0" cols="*">
  <frame src="topframe.html" name="topFrame" scrolling="NO" noresize >
  <frame src="http://www.natanaelvideo.com.br/home/index.php" name="mainFrame">
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>


_________________
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.


Top
 Profile  
 
PostPosted: Mon Sep 10, 2007 8:50 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
Desculpe, mas eu ainda não tinha notado que tinha a página 2 e já com a solução. Então a solução é colocar o index.html na raiz, juntamente com o frame superior e o corpo da página, index.php, em uma pasta diferente onde o joomla está instalado. Amanha vou tentar fazer... Espero que dê certo, obrigado a todos

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Tue Sep 11, 2007 5:40 am 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
Eu também consegui, finalmente.... Confiram nesse site ( http://www.tabajara.am.br ), não ficou muito legal, mas o importante é que tá funcionando direitinho. Só tem um problema, o frame superior só é carregado se eu digitar o endereço inicial da página, se eu acessar diretamente através de uma página que não seja a inicial ele só abre a mainbody.

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Tue Sep 11, 2007 6:18 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Tue Oct 03, 2006 6:19 pm
Posts: 65
Location: Campina Grande - PB - Brasil
Aêê...

Estive meio ausente esses dias, mas agora pude ver que conseguiram... Igor conseguiu entender minha idéia.. soh que no frame principal nao precisa colocar o endereço completo, basta apenas o index.php, pois os outros arquivos tb estão na pasta raiz do site...

E como foi comentado, tb acho q fica meio estranho uma pagina com frames, parece site antigo.. hehehe.. mas como o cliente desejava uma musica tocando continuamente, sem pausas, tinha q ser assim.. :(

Abraços e sempre disposto a contribuir...

_________________
Hugo Leonardo
http://www.futeboldaparaiba.com


Top
 Profile  
 
PostPosted: Tue Sep 11, 2007 8:21 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
hleorabelo wrote:
Aêê...

Estive meio ausente esses dias, mas agora pude ver que conseguiram... Igor conseguiu entender minha idéia.. soh que no frame principal nao precisa colocar o endereço completo, basta apenas o index.php, pois os outros arquivos tb estão na pasta raiz do site...

E como foi comentado, tb acho q fica meio estranho uma pagina com frames, parece site antigo.. hehehe.. mas como o cliente desejava uma musica tocando continuamente, sem pausas, tinha q ser assim.. :(

Abraços e sempre disposto a contribuir...




Este também foi o meu caso, estava há meses tentando descobrir como fazer, graças a Deus e a vocês deu certo, valeu companheiros

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Tue Sep 23, 2008 8:30 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Sep 23, 2008 7:32 pm
Posts: 1
Olá... notei que esse post é bem antigo, mas procurando sobre frame fixo para player, só encontrei isso aqui..

A dúvida é: como administrar esse player no jommla depois? colocar musicas, etc...
e mais, posso fazer o design desse player?

vcs colocaram td sobre o que fazer com os arquivos html e php, ainda nao tentei nada, mas gostaria de uma explicaçao detalhada sobre como proseguir a partir de todas essas outras questoes que citei acima..


Gostei mto do player (apesar de nao tocar nada ainda..rs) do www.guaiamumproducoes.com.br que nosso amigo hleorabelo mandou nesse mesmo post dando exemplo, mas nao consigo falar com ele...


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 1:06 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Nov 02, 2008 2:24 am
Posts: 5
estou com um problema num site. foi criado a iframe para o rádio, um iframe para a página (carregando o arquivo index.php), porém ,quando clico no menu (inicio), ele está chamando o endereço da página, e dai recarrega novamente o iframe do topo, preciso alterar o link do menu principal (inicio), para entrar apenas no inicio. como fazer isso?


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 3:52 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
eltonmelo wrote:
estou com um problema num site. foi criado a iframe para o rádio, um iframe para a página (carregando o arquivo index.php), porém ,quando clico no menu (inicio), ele está chamando o endereço da página, e dai recarrega novamente o iframe do topo, preciso alterar o link do menu principal (inicio), para entrar apenas no inicio. como fazer isso?


Elton, eu sofri um bocado para fazer isso e o segredo é o seguinte:
Coloque o index.html na raiz, juntamente com o frame superior

Para dar certo o joomla deve estar instalado em um pasta, então no arquivo index.html você deve incluir o código do outro frame que deverá chamar o arquivo index.php da instalação joomla.

Dê uma olhada neste site que eu fiz: www.tabajara.am.br

Qualquer dúvida é só reportar. Valeu

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 3:57 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
eltonmelo wrote:
estou com um problema num site. foi criado a iframe para o rádio, um iframe para a página (carregando o arquivo index.php), porém ,quando clico no menu (inicio), ele está chamando o endereço da página, e dai recarrega novamente o iframe do topo, preciso alterar o link do menu principal (inicio), para entrar apenas no inicio. como fazer isso?


Ficaria mais ou menos assim o arquivo index.html que deve ficar na raiz do site

<html>
<head>
<title>:: TITULO DO SITE ::</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="195,*" frameborder="NO" border="0" framespacing="0" cols="*">
<frame src="topframe.html" name="topFrame" scrolling="NO" noresize >
<frame src="http://www.enderecodosite.com.br/pastadojoomla/index.php" name="mainFrame">
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>

Neste caso o frame com o código do rádio deveria ficar no arquivo topframe.html, sendo que deveria ficar na pasta raiz do site juntamente com o arquivo index.html, enquanto que o arquivo index.php (joomla) deve ficar em uma outra pasta. Senão não dá certo. Valeu

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 4:17 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Nov 02, 2008 2:24 am
Posts: 5
Arley, obrigado pela sua atenção. mas parece que também há outra solução, ou seja pelo jeito há um plugin java script que impede o reload do frame do topo, eu copei o código de uma rádio de uma amigo, e parece que deu certo - veja em www.ibipatobranco.org. - O problema de instalar o joomla em outra pasta, é que muda todos os links, mas vi que é uma solução.


Top
 Profile  
 
PostPosted: Sat Nov 08, 2008 5:45 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Mon May 14, 2007 6:46 am
Posts: 87
Location: Iguatu - Ceará - Brasil
eltonmelo wrote:
Arley, obrigado pela sua atenção. mas parece que também há outra solução, ou seja pelo jeito há um plugin java script que impede o reload do frame do topo, eu copei o código de uma rádio de uma amigo, e parece que deu certo - veja em http://www.ibipatobranco.org. - O problema de instalar o joomla em outra pasta, é que muda todos os links, mas vi que é uma solução.


Dei uma olhada agora. Ficou ótimo! Parabéns!!

_________________
Arley Rodrigues
Webmaster e Professor
http://www.portalgigaweb.com.br


Top
 Profile  
 
PostPosted: Sat Dec 27, 2008 4:43 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 02, 2008 3:36 am
Posts: 45
pow, n consegui nem em local como em hospedagem, fiz tudo normal mas n rolou, vejam www.sonoragospel.com.br


Top
 Profile  
 
PostPosted: Sat Dec 27, 2008 4:53 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Aug 18, 2005 12:39 pm
Posts: 4023
Location: São Paulo - Brazil
Pelo que vi está faltando o arquivo index.php

_________________
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.


Top
 Profile  
 
PostPosted: Sat Dec 27, 2008 11:23 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 02, 2008 3:36 am
Posts: 45
sim, mas porem como vcs explicam, tem q por o index em um outro local certo? no caso deixei na raiz do site o topframe q é o radio, o index,html e criei uma pasta home onde deixei o index.php.


Top
 Profile  
 
PostPosted: Sun Dec 28, 2008 1:32 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 02, 2008 3:36 am
Posts: 45
olhas o pessoal, so aparece isso :

Restricted access


abaixo ta :

<html>
<head>
<title>Sonora Gospel</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="58,*" frameborder="NO" border="0" framespacing="0" cols="*">
<frame src="topframe.htm" name="topFrame" scrolling="NO" noresize >
<frame src="http://www.sonoragospel.com.br/main/index.php" name="mainFrame">
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>


ou seja, ta tudo certo , n sei pq aparece esse tal de Restricted access


Top
 Profile  
 
PostPosted: Sun Dec 28, 2008 1:42 am 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Thu Aug 18, 2005 12:39 pm
Posts: 4023
Location: São Paulo - Brazil
http://www.sonoragospel.com.br/main/index.php

Esse é o seu site Joomla né?? Não ta aparecendo primeiro arrume isso depois o frame vai funcinar.

_________________
http://www.ronildo.com.br/blog/ pt-br | twitter: twitter.com/ronildo
http://forum.joomla.org/viewtopic.php?f=23&t=144443 - FAQ Joomla [pt]
Pessoal por favor não tiro dúvidas por e-mail nem mensagem privada, por favor não insistam.


Top
 Profile  
 
PostPosted: Sun Dec 28, 2008 4:03 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 02, 2008 3:36 am
Posts: 45
sim, mas apenas se entrar como www.sonoragospel.com.br vai entrar, e so vai aparecer a parte da radio la em cima q é o frame. esse de cima q vc colocou é a pasta q criei pra por o index.php. la tem apenas o index.php nesse main. se vc digitar apenas no www.sonoragospel.com.br o site vai abrir


Top
 Profile  
 
PostPosted: Tue Jan 20, 2009 3:07 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Jan 20, 2009 2:22 am
Posts: 1
bom... é antigo o post, mas fica ae para a posteridade.

Muitos perguntam porque frameset, simplesmente para quem usa um player de radio no seu joomla, o frameset é a saída.

Com isso você meio que obriga as pessoas a escutarem a rádio quando acessa o site.

A solução é usar o html que é prioridade no php, no caso do index, a chave da questão é se o seu site está configurado para não mostrar o index.php no endereço base, por exemplo: se tiver configurado para http://www.meusite.com.br, quando você colocar o index.html com as configurações mostradas pelos colegas, e o site está configurado para a base do endereço sem index.php, vai acontecer o loop. Pensem, vocês colocaram o html (base: http://www.meusite.com.br) para chamar o index.php (que está configurado base: http://www.meusite.com.br) com isso vai acontecer flood ou loops, e não vai funcionar.

A solução encontrada pelos colegas, criar uma subpasta para colocar o joomla, com isso com a base http://www.meusite.com.br/home não vai acontecer o loop. Mas o problema que temos alguns scripts ou extensões que não se dão bem com o joomla em subpastas da raiz. É um risco a se correr.

Outra solução, é usar a extensão sh404SEF para configurar a base (http://www.meusite.com.br) para automaticamente colocar http://www.meusite.com.br/index.php, ou seja, se você digitar http://www.meusite.com.br, automaticamente vai para a base http://www.meusite.com.br/index.php, fugindo do http://www.meusite.com.br que cairia no index.htlm e com isso geraria o loop.

Assim, se você digitar o http://www.meusite.com.br, vai chamar o index.html, com os dois frames, uma da radio e outra do index.php, que com o index.php, vai gerar o http://www.meusite.com.br/index.php, fugindo do http://www.meusite.com.br.

Vamos entender um pouco do frameset para as rádios.

O frameset é uma das soluções para navegar com um player, pois, mesmo que ele abra em outra aba, e continue com a página principal aberta o player funcionará e não haverá duplicidade ao se abrir outra aba.

A grande questão é que o frameset detona o SEO para o teu site. Isso sim é algo a se pensar, para quem não sabe SEO são tecnicas desenvolvidas pelos motores de busca (google, yahoo, msn) e a otimização para obter boa colocação no rank de pesquisa, é essencial, já que a grande maioria das visitas vem dos motores de buscas.

E com o frameset, acaba a otmização, mesmo cadastrado nas ferramentas de webmaster do google e outros, mesmo com os sitemaps, não haverá otimização.

Com o sh404SEF, ajudamos os motores de busca, muitos ainda não sabem otimizá-los, vários sites em joomlas estão com o famoso links gerado pelo joomla sem especificações que ajudam os motores de busca.

Vamos pegar um exemplo do belo site http://www.guaiamumproducoes.com.br, como estamos com o frameset, qualquer link sempre vai ser o http://www.guaiamumproducoes.com.br, saindo do frameset http://www.guaiamumproducoes.com.br/index.php, e clickando no menu noticias, obteremos o seguinte link >> http://www.guaiamumproducoes.com.br/ind ... t&Itemid=5 , isso é terrível para os motores de busca, usando o sh404SEF, poderia ficar http://www.guaiamumproducoes.com.br/noticiais, otimizando os motores de busca, agora atenção!!! >> mesmo com http://www.guaiamumproducoes.com.br/ind ... t&Itemid=5, o google vai catalogar, mas temos outra grande questão!!!

As visitas do google serão dos links sem o frameset, quer dizer, sem o player da rádio. Tudo dos motores de busca serão sem o player da rádio, sinceramente, pensamos, onde a maioria de densidade vem dos motores de busca, vale sacrificar o SEO pela obrigatoriedade de ter um player de rádio?

Vejam esse exemplo do google da Rádio Tabajara > http://www.google.com.br/search?q=%22A+ ... +inicio%22, vejam que a pesquisa foi direcionado para a pagina sem o player do radio, já que o frameset da Rádio Tabajara não é catalogado com os artigos.

A solução sensata para ter otimização do SEO e uma rádio no joomla, faça um player com popup, não obriguem as pessoas a escutar a rádio, tenha algo com qualidade e bom gosto que com certeza todos abriram o popup da rádio para escutar. Sei de pessoas que nem frequentam muito o site, mas toda vez que entram na net, puxam o popup da rádio de um site, pois a rádio é de boa qualidade e bom gosto.

A escolha é sua >> ter ouvintes pela obrigação de escutar a rádio ou ter ouvintes pela qualidade e bom gosto da rádio.

Espero ter ajudado.

abraços


Top
 Profile  
 
PostPosted: Fri Aug 14, 2009 12:29 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Aug 10, 2009 9:20 pm
Posts: 5
me explique eu tenho nos templastes o index.php e index.html em qual deles tenho que criar o frame para inserir a minha radio no joomla valeu
aguardo respostas


Top
 Profile  
 
PostPosted: Mon Aug 24, 2009 1:00 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Aug 02, 2007 2:29 pm
Posts: 37
Olá amigos!

Pelo o que entendi vcs criaram um frame para o componente de som e outro para o Joomla!. Até dá pra fazer, testei e funcionou, mas como o J! não foi feito para funcionar com frames, acho que não deve ser legal. Outra coisa, como tudo ficará "abaixo" ou "dentro" de um index.html não é ruim para o ranking de SEO? Eu procurei no google pelos sites que vcs indicame e os encontrei, mas o problema é que o link joga para o link J!, ou seja, o frame com o componente não aparece, só se eu abrir pela url da primeira página.

Alguém sabe me dizer se há como manter um div aberto por mais de uma página? Ou se tem como aproveitar um div de uma página para a outra? Não sei se faz muito sentido, mas é uma tentativa.

Paz e bem!

_________________
Bonaiva Soluções Profissionais
Visite: www.bonaiva.com.br


Top
 Profile  
 
PostPosted: Thu Jan 06, 2011 5:44 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Jan 06, 2011 5:24 pm
Posts: 1
Boas pessoal. Fiz tudo o que disseram em cima. tenho um ficheiro HTML com player na raíz do site, juntamente com o index.html que chama as 2 frames. O site está noutra pasta chamada site.

Estranhamente acontece-me 2 coisas distintas. Se no ficheiro index.html chamar a mainframe de site/index.php, quando digito o nome do site a topframe (player.html) é carregada mas depois desaparece. Ainda consigo ver a topframe durante 1 segundo, mas depois entra a mainframe e desaparece a topframe. Não tem a ver com o tamanho da topframe, pois já aumentei bastante.

A outra situação, é quando no index.html digito o caminho para o index.php do template tipo site/templates/templateX/index.php. Aqui a topframe aparece mas na mainframe apenas aparece a mensagem Restricted Access.

Alguém me pode ajudar com isso ? Tou precisando de fazer um site com uma topframe mas estou parado precisamente por causa disto.

Qualquer ajuda, agradeço imenso. Abraço a todos.


Top
 Profile  
 
PostPosted: Thu May 26, 2011 9:13 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu May 26, 2011 8:54 pm
Posts: 1
Sei que o Post é velho, mas tenho de agradecer que graças isto consegui por o meu player a funcionar! :D E só me custou... 5 minutos?

Eu uso o WORDPRESS (Em PHP). Fui ao Header.PHP em Appearence, no Editor.
Depois da primeira tag <head> usei o código do site que o dono postou em primeiro lugar que me permitiu colocar o player :

Código Completo -
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>R&aacute;dio Tabajara AM 870 Khz - Ao Vivo</title>

<style type="text/css">
<!--
body {
   margin-left: 0px;
   margin-top: 0px;
   margin-right: 0px;
   margin-bottom: 0px;
   background-color: #E3E3DD;
   align: "center"
}
-->
</style>
<script language="JavaScript" type="text/JavaScript">
<!--
function MM_reloadPage(init) {  //reloads the window if Nav4 resized
  if (init==true) with (navigator) {if ((appName=="Netscape")&&(parseInt(appVersion)==4)) {
    document.MM_pgW=innerWidth; document.MM_pgH=innerHeight; onresize=MM_reloadPage; }}
  else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH) location.reload();
}
MM_reloadPage(true);
//-->
</script>
</head>

<body>
</font>
<table  border="0" align="center" cellpadding="0" cellspacing="0" >
  <tr>
    <td width="825" bgcolor="#E3E3DD"><div align="center">
  <div align="center" id="Layer1" style="position:center; width:825px; height:38px; z-index:1; background-image: url(fundo.gif); layer-background-image: url(fundo.gif);">
  <object classid="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,4,5,715" type="application/x-oleobject" width="250" height="37" align="right" standby="Loading MicrosoftÆ Windows Mediaô Player components..." id="MediaPlayer">
    <param name="FileName" value="http://tabajara.am.br/main/radio.asx" />
    <param name="AutoStart" value="true" />
    <param name="ShowStatusBar" value="false" />
    <param name="ShowControls" value="true" />
    <param name="PlayCount" value="1" />
    <param name="TransparentAtStart" value="false" />
    <param name="ShowDisplay" value="false" />
    <param name="showtracker" value="false" />
    <param name="showgotobar" value="false" />
    <param name="showpositioncontrols" value="false" />
    <param name="showaudiocontrols" value="0" />
    <param name="volume" value="1" />
    <param name="AllowScan" value="false" />
    <param name="showdisplay" value="false" />
    <param name="autosize" value="true" />
    <!-- MSIE check -->
    <embed src="http://tabajara.am.br/main/radio.asx" width="250" height="37" autostart="true" align="right" type="application/x-mplayer2" controls="smallconsole" showcontrols="1" showdisplay="0" showpositioncontrols="0" showstatusbar="0"></embed>
  </object>
</div>
</div></td>

  </tr>
</table>
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-2175461-1");
pageTracker._initData();
pageTracker._trackPageview();
</script>
</body>
</html>


Exerto do código acima, que utilizei no head.php do wordpress -
Code:
<script language="JavaScript" type="text/JavaScript">
<!--
function MM_reloadPage(init) {  //reloads the window if Nav4 resized
  if (init==true) with (navigator) {if ((appName=="Netscape")&&(parseInt(appVersion)==4)) {
    document.MM_pgW=innerWidth; document.MM_pgH=innerHeight; onresize=MM_reloadPage; }}
  else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH) location.reload();
}
MM_reloadPage(true);
//-->
</script>

<table  border="0" align="center" cellpadding="0" cellspacing="0" >
  <tr>
    <td width="825" bgcolor="#E3E3DD"><div align="center">
  <div align="center" id="Layer1" style="position:center; width:825px; height:38px; z-index:1; background-image: url(fundo.gif); layer-background-image: url(fundo.gif);">
  <object classid="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,4,5,715" type="application/x-oleobject" width="250" height="37" align="right" standby="Loading MicrosoftÆ Windows Mediaô Player components..." id="MediaPlayer">
    <param name="FileName" value="http://tabajara.am.br/main/radio.asx" />
    <param name="AutoStart" value="true" />
    <param name="ShowStatusBar" value="false" />
    <param name="ShowControls" value="true" />
    <param name="PlayCount" value="1" />
    <param name="TransparentAtStart" value="false" />
    <param name="ShowDisplay" value="false" />
    <param name="showtracker" value="false" />
    <param name="showgotobar" value="false" />
    <param name="showpositioncontrols" value="false" />
    <param name="showaudiocontrols" value="0" />
    <param name="volume" value="1" />
    <param name="AllowScan" value="false" />
    <param name="showdisplay" value="false" />
    <param name="autosize" value="true" />
    <!-- MSIE check -->
    <embed src="http://tabajara.am.br/main/radio.asx" width="250" height="37" autostart="true" align="right" type="application/x-mplayer2" controls="smallconsole" showcontrols="1" showdisplay="0" showpositioncontrols="0" showstatusbar="0"></embed>
  </object>
</div>
</div></td>

  </tr>
</table>
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-2175461-1");
pageTracker._initData();
pageTracker._trackPageview();
</script>


As únicas modificações a fazer é aqui : <embed src="http://tabajara.am.br/main/radio.asx" width="250" height="37" (http://tabajara.am.br/main/radio.asx é o link da rádio, o link. Pode ser HTML, PHP, o formato em que a rádio estiver.), (Width é a largura e a height é a altura).

<param name="FileName" value="http://tabajara.am.br/main/radio.asx" /> (O mesmo que o acima, trocar isso pelo link da sua rádio)

width="250" height="37" (Os tamanhos de novo)

Ah, se não tiver um código desses, assim http://tabajara.am.br/main/radio.asx, coloque : http://Ip.da.sua.radio:porta/ que será apenas números. Coloque o ip:radio ou o link.

Anyway, vou tentar modificar o código para que apareça a imagem que eu quero (do player que eu já fiz com o play.html e stop.html), o que vai ser complicado visto que eu pouco sei disso :( foi um caso de sorte (e saber pensar) ter achado esse código. Pelo que parece, a imagem do player no site da http://tabajara.am.br faz parte do background (acho eu), porque no código não aparece nada relacionado com a mesma. Isso quer dizer que eles estão apenas a usar o Windows Media Player que se vê perfeitamente... (que é muito feio...)

Mais uma vez obrigado :)


Top
 Profile  
 
PostPosted: Sun Jan 22, 2012 6:51 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Jan 22, 2012 6:47 pm
Posts: 1
Fala galera, esse topico eh bem antigo mas eh o UNICO que achei na net que fala bem sobre esse assunto, fala tao bem que so consegui fazer atravez daki. Dai gostaria de saber como pegar esse player em html e transforma-lo em um modulo do joomla, nao deve ser facil, pois como eh em frame,esta aparte do joomla :/

e qndo faço a chamada normal, da um erro no $this do modulo, mas eh um erro obvio, haja vista q onde fica o player nao referencia ao joomla. Oq fazer nesse caso?

Abraço!


Top
 Profile  
 
PostPosted: Wed Oct 02, 2013 2:23 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Oct 02, 2013 1:59 pm
Posts: 2
igornicolai wrote:
Vou tentar explicar:

criei uma index na pasta raiz assim:
Code:
<html>
<head>
<title>:: NATANAEL VIDEO ::</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="195,*" frameborder="NO" border="0" framespacing="0" cols="*">
  <frame src="topframe.html" name="topFrame" scrolling="NO" noresize >
  <frame src="http://www.natanaelvideo.com.br/home/index.php" name="mainFrame">
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>


ele chama a index e a topframe.html (que estao na raiz)

para visualizar é so acessar o link http://www.natanaelvideo.com.br/home/index.html


Top
 Profile  
 
PostPosted: Mon Mar 03, 2014 3:40 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Feb 21, 2014 4:08 pm
Posts: 2
Pessoal, puxei o tópico novamente porque apesar de está correto o código estou com problemas no site abaixo (joomla 3).
Tudo funciona nos menus, mas pelo módulo de noticias (Lof K2SlideShow) e no Equipe (BT Content Slider) levam a nova página sem o frame da rádio no topo.
Já tentei com URLs Amigáveis e Usar mod_rewrite do Apache ativados ou não, não resolveu. Aliás com Usar mod_rewrite do Apache apareceu o frame do topo mas totalmente em branco nas páginas internas.
O problema é dos módulos e tem solução?

http://www.radiolitoralsulfm.com.br


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 60 posts ]  Go to page Previous  1, 2



Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group