Disappearing articles after 2.5 upgrade [SOLVED]

Need help upgrading your Joomla! website or converting to Joomla! 2.5?
Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
miggalvez
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Sat Jul 01, 2006 4:00 pm

Disappearing articles after 2.5 upgrade [SOLVED]

Postby miggalvez » Tue Jan 24, 2012 5:56 pm

Hi there,

I have just upgraded to 2.5 from 1.7.3 and the only problem I have is that the articles that I wrote (super-admin) are not being published. They still show up in the backend but not in the frontend. Other articles written by other users do show up.

Miguel

UPDATE:

New articles published by me don't show up either. They are saved normally in the backend, but nothing shows up in the frontend.
Last edited by miggalvez on Fri Jan 27, 2012 11:19 am, edited 1 time in total.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16702
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Disappearing articles after 2.5 upgrade

Postby leolam » Tue Jan 24, 2012 6:13 pm

Check the article permissions

Leo 8)
- Joomla Professional Support Services :https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Joomla Professional Web Development :www.gws-studio.com -
- Member Joomla Bug Squad & J-CMS Release Team

robert2a
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jan 26, 2012 9:06 am

Re: Disappearing articles after 2.5 upgrade

Postby robert2a » Thu Jan 26, 2012 9:16 am

I experience the same problem and I have checked the article permissions. I can access articles using their url, but no article shows using the menu as they used to. If I make a new article, it shows using the menu.

Robert

RJ2012
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jan 26, 2012 9:38 am

Re: Disappearing articles after 2.5 upgrade

Postby RJ2012 » Thu Jan 26, 2012 9:41 am

Same problem here...

Other articles from non superusers are also not shown anymore. I'm searching but have not found anything yet.

miggalvez
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Sat Jul 01, 2006 4:00 pm

Re: Disappearing articles after 2.5 upgrade

Postby miggalvez » Thu Jan 26, 2012 11:14 am

I had to create a new user using the same name and switch the authorship of all my articles to that new user. I was lucky because I only had around 15 articles, but I'm sure others are not so lucky.

RJ2012
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jan 26, 2012 9:38 am

Re: Disappearing articles after 2.5 upgrade

Postby RJ2012 » Thu Jan 26, 2012 11:19 am

miggalvez wrote:I had to create a new user using the same name and switch the authorship of all my articles to that new user. I was lucky because I only had around 15 articles, but I'm sure others are not so lucky.


This does 'solve' the problem. But, just like you wrote, this is not an option because I have to switch the authorship of many articles.

robert2a
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jan 26, 2012 9:06 am

Re: Disappearing articles after 2.5 upgrade

Postby robert2a » Thu Jan 26, 2012 9:14 pm

Deleted all files and restored my latest 1.7.3 backup but keept the my SQL DB unchanged. This solved the problem and my site started working again. I then updated to 1.7.4 successfully. I by the way use the bizblue template from http://mambasana.ru/ . They have an updated template for 2.5 but that did not solve the problem. I do not know if the problem is related to the template or why I can not update to 2.5.

Any suggestions?

RJ2012
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jan 26, 2012 9:38 am

Re: Disappearing articles after 2.5 upgrade

Postby RJ2012 » Thu Jan 26, 2012 9:55 pm

Same here, restored only the files and everything is working again.

Made a separate install of the site (backup of 1.7.3) on another location (including original DB) to test. Update to 1.7.4 works perfect. Then uninstalled all extra components and plugins and tried to update to 2.5 again. No probs during update but again all articles gone in the frontend of the last month.

User avatar
MarijkeS
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 230
Joined: Sun Nov 25, 2007 6:13 am
Location: Enschede, Netherlands
Contact:

Re: Disappearing articles after 2.5 upgrade

Postby MarijkeS » Fri Jan 27, 2012 1:39 am

Ok, I've tested this and here's what I found out.

If you have a user linked to a contact that is unpublished, the articles written by this user don't show up in the front.
So please check if you have a unpublished contact linked to user that wrote the articles. Also check the trashed contacts for this.

The solution would be to publish the contact or to completely remove them, so empty the trash.
Coordinator Translationteam JoomlaCommunity.eu | Member Dutch Translation Team - http://joomlacode.org/gf/project/nederlands/l
Joomla! Translation Coordination Team

RJ2012
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jan 26, 2012 9:38 am

Re: Disappearing articles after 2.5 upgrade

Postby RJ2012 » Fri Jan 27, 2012 7:02 am

Yes that did the trick. Everything is working properly. Thanx!

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16702
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Disappearing articles after 2.5 upgrade

Postby leolam » Fri Jan 27, 2012 7:21 am

MarijkeS wrote:here's what I found out.

If you have a user linked to a contact that is unpublished, the articles written by this user don't show up in the front.
So please check if you have a unpublished contact linked to user that wrote the articles. Also check the trashed contacts for this.

The solution would be to publish the contact or to completely remove them, so empty the trash.
That is some discovering Marijke! That is some cool digging! Me thinking though that this is not 'normal' and that we need to address this for next releases. I have posted a referral to this post of yours on the bugsquad.

Leo 8)
- Joomla Professional Support Services :https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Joomla Professional Web Development :www.gws-studio.com -
- Member Joomla Bug Squad & J-CMS Release Team

User avatar
sycorax
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Fri Nov 18, 2005 10:18 pm
Location: Aachen, Germany
Contact:

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby sycorax » Sat Jan 28, 2012 1:44 am

Go to plugins -> User - Contact Creator
Change Autopublish the contact from "No" to "Yes"
It seems to be a new option in Joomla 2.5

If a new user is created, it will autopublish the contact by default. Existing users must be publihed after upgrade manually.

Crumpet
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri Jan 27, 2012 4:47 pm

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby Crumpet » Sat Jan 28, 2012 12:05 pm

I had each article showing three times (triple)
Triple display of articles in front end (duplicates)

This solved it for me:
Crumpet wrote:Awesome,
this worked for me:

I had 3 contacts linked to 1 user:
made 3 new users, linked these to the contacts.
Checked everything in, (site > maintenance)
rebuild all menus, (menus > menu manager)
rebuild the submenus (in my case those contact related)
rebuild all modules (extensions > module manager),
cleared all cache, (site > maintenance)
purged expired cache, (site > maintenance)
and it is fixed now.

It is an odd problem, linked users shouldn't be affecting this (display of articles) in such a manner, but they did....
Good luck for those with similar (and other) problems! :)

Thank you a lot MarijkeS!

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby mcsmom » Sat Jan 28, 2012 11:13 pm

I'm trying to reproduce this problem.
I linked a contact to my user record.
I unpublished the contact.
But all of the articles are still showing.
What step am i missing.
There has been no change to the contact creator since 1.6 so that's not the issue.
Are you talking about list views or single article or blog or all of these?
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

miggalvez
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Sat Jul 01, 2006 4:00 pm

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby miggalvez » Sat Jan 28, 2012 11:21 pm

mcsmom wrote:I'm trying to reproduce this problem.
I linked a contact to my user record.
I unpublished the contact.
But all of the articles are still showing.
What step am i missing.
There has been no change to the contact creator since 1.6 so that's not the issue.
Are you talking about list views or single article or blog or all of these?


Did you try to write a new article with the contact unpublished?

In my case the articles that I published before I linked my user record to a contact were showing, but the ones that I published after I linked the user record to a contact were not.

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby mcsmom » Sun Jan 29, 2012 4:55 pm

AH ha I have only been looking at old articles. Will look at that now.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby mcsmom » Sun Jan 29, 2012 5:03 pm

OK so ... I made a NEW contact, linked it and unpublished it. Is that what you did, make a NEW contact? Or were these existing contacts?
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

Crumpet
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri Jan 27, 2012 4:47 pm

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby Crumpet » Mon Jan 30, 2012 11:33 am

I do not know exactly what you want to reproduce,
but the best way to achieve this, might be by using a 1.7.3 or a 1.7.4 set up,
create the problem there (create one user with more contacts, or the other problems are described in this thread).
And then reproduce the steps to update to 2.5.

=================
In my situation, the probem derived from having a lot of articles, some blogs.
With 1 user linked to 3 contact forms.

Then I updated to 2.5 (from 1.7.4) and I think I didn't rebuild the menu's and modules yet.
Thought it was all ok. Then I posted a new article on a blog, check this, and then to discover the problem of each article showing 3 times in the blog.

Then I started searching, and did all the cache clearing (again) and rebuild the menu's and modules.
Still to end up with the problem of each article showing 3 times in the blog.

Then to discover that the contacts had somethign to do with it, as informed about in the aforementioned solution.
=============

This might help you to reproduce the problem?

User avatar
MarijkeS
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 230
Joined: Sun Nov 25, 2007 6:13 am
Location: Enschede, Netherlands
Contact:

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby MarijkeS » Mon Jan 30, 2012 10:27 pm

The issue is already fixed in trunk so will be in the next release.
http://joomlacode.org/gf/project/joomla ... m_id=27886
Coordinator Translationteam JoomlaCommunity.eu | Member Dutch Translation Team - http://joomlacode.org/gf/project/nederlands/l
Joomla! Translation Coordination Team

mishi
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Tue Mar 09, 2010 2:14 pm

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby mishi » Wed Mar 21, 2012 4:40 pm

I am having the same issue but it doesn't appear to be a Contact issue. I have all of mine published, have checked in and even created a new article with a new published article and it is still not showing.

I did an upgrade from 1.5.25 to 2.5.3 and converted my template...anything else that could cause this problem? All modules, menus, etc are working fine.

Thanks :)

***Update....when I activate a default template they are showing up...any ideas where to check in my template for an error?

dontstop99
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Aug 23, 2011 3:07 pm

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby dontstop99 » Thu May 17, 2012 2:22 am

I am facing the same issue, it does not look like the contacts issue as I have all of them published. Even deleting the contacts did not solve the issue.

While I am able to access some articles, I am unable to access most of the articles in front-end.
Even if category and author of 2 articles is same, I am able to access one and not the other one.

For example:
I can access - http://localhost/site/jupgrade/index.ph ... kes-201058

but not - http://localhost/site/jupgrade/index.ph ... 44&Itemid=

The error I get is "Category not found" but the category is present.
Could this be a content component issue?

denken
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Nov 17, 2012 3:41 pm

Re: Disappearing articles after 2.5 upgrade [SOLVED]

Postby denken » Sat Nov 17, 2012 3:48 pm

I'll post what worked for me. If you are migrating a template, make sure that all files are compatible. I've realized that after migrating from 1.5 to 2.5, my html folder inside my new installed 2.5 template used the same files as the 1.5 version, so caused conflicts (had just copied the entire old template folder).

After deleting that html folder, everything was okay. Had to take html/com_content from another 2.5 template and re-edit html/php code.


Return to “Migrating and Upgrading to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 2 guests