The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 60 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Tue Sep 14, 2010 10:21 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jun 28, 2007 9:09 pm
Posts: 11
Suma5566 wrote:
Same Problem!!
i have windows 2008 R2 and IIS 7.5
wordpress is working but Joomla won't work :(
any Solution?


fomat c:


Top
 Profile  
 
PostPosted: Wed Oct 27, 2010 5:03 pm 
Joomla! Intern
Joomla! Intern

Joined: Tue Nov 06, 2007 4:13 am
Posts: 75
same or similar issue here

joomla 1.5.21
This just start to happen randomly...the site was 1.5.15 for a long time and just out of the blue it started.

I updated the site to 1.5.20 when .20 was released and it seemed that this corrected any issues.
but it started happening again just randomly.

...no changes made to the host..no upgrades or downgrades to any server files or PHP versions
I know because this is a dedicated box and we maintain the OS on it.

all of the other sites that were cloned from this install are working fine with no errors at all.
and they are all on the same box...using the same or similar version of components and Joomla

sometimes it gives the 500 error and you cannot login but then come back in ten minutes and you can login again...?

This happens on all browsers


this appears to be triggered anytime I add a user or makes changes to a users username/pass it does this. and anytime a user updates his account it occurs.

I can still login as admin on the frontend when this occurs.

I am not using CB or any user management program.

My admin folder permissions are 755 as is index and index2
(this is the natural setting for my folders...777 is not used on any of my folders)

I have reset my htaccess to a standard stock non-modified version and I have also tried the joomla .txt version.

It occurs just the same and with no error reported


- tried to comment out the ldap.dll in php.ini but it does not exist on my php.ini file
- memory settings, timeout and upload setting are all set very high for this site.


It just freekin strange that after about 10 minutes that it goes away and I can login again.


centOS-5
Joomla 1.5.21
php 5.2.13
apache 2.2.3
cgi/fcgi


any help would be appreciated...because this is dang aggravating, I just cant seem to track it down.


Top
 Profile  
 
PostPosted: Wed Jan 12, 2011 11:49 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Jul 23, 2010 4:46 am
Posts: 6
This is pretty ridicules for a so called community. An issue which has given numerous people such a serious problem and not one response from any one in "support".

I've got 1.5.22, and cannot access my article manager getting a 500 error.


Top
 Profile  
 
PostPosted: Fri Jan 14, 2011 8:31 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jan 14, 2011 8:04 am
Posts: 2
yeah me to, i use joomla 1.5.1 , my joomla running 2 years and look everything fine. and then after i delete joomlastat and joomla social, i can't login through admin page. I use admin or user after click login , the page turn to blank page, http://www.xxxxx.com/administrator/index.php , using google chrome. When try other browser IE7, HTTP 500 Internal Server Error.

please help


Top
 Profile  
 
PostPosted: Wed Feb 16, 2011 3:56 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Aug 27, 2010 3:12 pm
Posts: 6
Quote:
Hey guys, just spent an hour trying to fix this so I registered to the joomla.org forum to post my solution :)

Previously, I had changed the permissions for the /administrator folder to 777 because when I used the install module extension it kept giving me errors.

This error only came up when I moved my site over from one hosting service to another. Just packed up all my files in a zip and unzipped it in public_html folder of new host and moved my sql database over.

I changed the /administrator folder back to 755 and everything is peachy now. Along the way when I was looking for a solution to the 500 Internal Server Error problem I also changed index.php, administrator/index.php, and administrator/index2.php to 755 permissions... but that alone didnt fix it until I did 755 on the administrator folder.

Hope this helps,

Stephen


Thank you man it is working good :laugh: :laugh: :laugh:


Top
 Profile  
 
PostPosted: Fri Feb 25, 2011 12:47 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Feb 25, 2011 12:21 pm
Posts: 2
HI

I had the same problem trying to login into Joomla! administrator. I got Internal server error, Apache error log said: .htaccess RewriteBase: argument is not a valid URL

Here is what was wrong in my case if it helps someone. If you look into Joomla's administrator folder there is another htaccess file beside the one in Joomla's root directory.

For some reason I mystakenly changed both of them to .htaccess and that coused the Internal server error I suppose due to multiple rewrite base.

So, just rename the file in your Joomla administrator folder back to htaccess.txt, thus making it inactive.

Hope it helps someone


Top
 Profile  
 
PostPosted: Sat Aug 13, 2011 6:20 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Aug 13, 2011 5:57 am
Posts: 3
My problem was similar to the one posted here.

Joomla ver 1.5.8

All options would work.
Click on Article Manager and the "Internal server ..." error would show.

Tried all the options given above.

In my case it was being caused by the fact that I have about 4000 articles and the Article Manager was set to display all articles

Solved it by -
Going to Global Config > turning debug on
Go to Article Manager
From the filter for Section or Category Manager, choose one that has a small number of articles
Go to end of page - change display 20, 25, 30 (something)
Return to global config > turn debug off


That did it for me. Hope it helps you too !!


Top
 Profile  
 
PostPosted: Wed Sep 28, 2011 3:49 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Sep 26, 2011 6:56 am
Posts: 8
I had the same problem. I downloaded the new Joomla, 1.7.1 and it seemed to fix the problem... :)


Top
 Profile  
 
PostPosted: Fri Sep 30, 2011 11:26 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Sep 30, 2011 2:23 am
Posts: 2
zimbo wrote:
I had the same problem. I downloaded the new Joomla, 1.7.1 and it seemed to fix the problem... :)



Zimbo...you download Joomla 1.7.1 , and install or upgrade !? because i have the same problem and I don't like making a new installation of Joomla, but a upgrade maybe fix the problem.

Thank you


Top
 Profile  
 
PostPosted: Sun Oct 02, 2011 10:37 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Sep 01, 2011 10:15 pm
Posts: 6
Hey there,

I also had the issue and got it fixed.

there were a few issues... let me go through them all...

The first was that the folder the joomla installation was in was set to 777 for permissions. This should always be 755.

Second, when I ported over the files, I did it using the unix command cp path/to/files/. new/path/to/files/ this had to be done as root... therefore the owner/group permissions were set to root.

the owner/group permissions needed to be changed. This is done with the Unix command chmod -R newowner:newowner . (when you're in the correct folder).

I'm new to joomla and newer to Unix... but I thought that may help someone! Just take what I have to say with a grain of salt (or two!!)


Top
 Profile  
 
PostPosted: Thu Oct 13, 2011 11:40 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Oct 08, 2009 9:57 pm
Posts: 21
I have got the same problem but in my case it happens when a non existing user tries to log in. Normally you get a error that the user isnt registered or has a wrong password. In my case i get a 500 error. This is the temporary website. http://concordia.website-zeeland.nl

The login field is in the right bottom. Anyone knows the problem?


Top
 Profile  
 
PostPosted: Thu Oct 13, 2011 12:17 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Sep 26, 2011 6:56 am
Posts: 8
babelattke wrote:
zimbo wrote:
I had the same problem. I downloaded the new Joomla, 1.7.1 and it seemed to fix the problem... :)



Zimbo...you download Joomla 1.7.1 , and install or upgrade !? because i have the same problem and I don't like making a new installation of Joomla, but a upgrade maybe fix the problem.

Thank you



babelattke
I did a clean install of 1.7.1..


Top
 Profile  
 
PostPosted: Tue Dec 27, 2011 9:02 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Dec 27, 2011 8:51 pm
Posts: 1
Hello everyone i spent around 5 hours trying to fix this probelm as well.

I know many of you must be tired but this was my case. I was migrating from One Cpanel to the next, by the way AKeeba Backup does this effortlesssly just backup site download back file and use kickstart you will still need to install a joomla kit but akeeba does the rest.

The PHP.ini was hopeless because the fields were already uncommented.
All my Cpanel folders had the correct 755 permissions so i was lost not knowing what to do.

However the FIX to this was quite simple. Head into the Administrator Folder and Edit the HTaccess file extentsion and change it to TXT so it automatically kills itself. Joomla will then read The HTaccess file in the primary directory.

If your unable to see it using normal Cpanel Use Filzilla I did the change and presto the site came back instantly! Apprantely the two files caused a conflict.

P.S
One more thing if you did any changes to the simple file or whatever in the Libraries folders change it back do not uncomment or change lines 1519 and 1520 or else when you finally login in your admin page will be messed up.

Hope i helped someone

:D Ramone from Classified Plazas Jamaica


Top
 Profile  
 
PostPosted: Sun Jan 29, 2012 5:40 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Aug 07, 2008 6:48 pm
Posts: 1
Hi everybody,

I RESOLVE it just changing permissions: on /logs/error.php to 777.
Also verifiy if the log path in configuration.php is correct.

Hope this help

I do it on joomla 2.5 and 1.7

Regards

Jonathan


Top
 Profile  
 
PostPosted: Fri Feb 03, 2012 6:58 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Feb 03, 2012 6:50 am
Posts: 1
PLEASE HELP.

i am running joomla 1.5 and i get a blank page once i log into the /administrator page. i also get a blank page when clicking on the jomsocial tab on my front end. site URL=www.md2phd.com

any help would be appreciated!

The day the problem started i had installed jomsocial and jom_comments


UPDATE: Problem solved. /plugins/system/jomsocialupdate.php was removed and the admin side of joomla came back. jomsocial front end still a blank page. moving in the right direction!


Top
 Profile  
 
PostPosted: Tue Feb 14, 2012 12:46 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Aug 11, 2010 8:16 am
Posts: 10
Hello. Im using windows 7, and i moved my website to a localhost. How can i solve this problem on localhost? How can i change permission to 755?
Pls


Top
 Profile  
 
PostPosted: Sun Mar 04, 2012 4:48 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Mar 31, 2011 6:34 pm
Posts: 4
Quote:
The PHP.ini was hopeless because the fields were already uncommented.
All my Cpanel folders had the correct 755 permissions so i was lost not knowing what to do.

However the FIX to this was quite simple. Head into the Administrator Folder and Edit the HTaccess file extentsion and change it to TXT so it automatically kills itself. Joomla will then read The HTaccess file in the primary directory.

If your unable to see it using normal Cpanel Use Filzilla I did the change and presto the site came back instantly! Apprantely the two files caused a conflict.

P.S
One more thing if you did any changes to the simple file or whatever in the Libraries folders change it back do not uncomment or change lines 1519 and 1520 or else when you finally login in your admin page will be messed up.

Hope i helped someone

:D Ramone from Classified Plazas Jamaica


Thanks Ramone! Worked for me! Tried everything else but simply changed administrator>.htaccess to htaccess.txt and voila! Backend showing again.
Thanks to everyone who left suggestions here!


Top
 Profile  
 
PostPosted: Fri Jun 22, 2012 10:09 am 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Oct 15, 2008 9:18 am
Posts: 210
Location: India - Pune
stephersiu wrote:
Hey guys, just spent an hour trying to fix this so I registered to the joomla.org forum to post my solution :)

Previously, I had changed the permissions for the /administrator folder to 777 because when I used the install module extension it kept giving me errors.

This error only came up when I moved my site over from one hosting service to another. Just packed up all my files in a zip and unzipped it in public_html folder of new host and moved my sql database over.

I changed the /administrator folder back to 755 and everything is peachy now. Along the way when I was looking for a solution to the 500 Internal Server Error problem I also changed index.php, administrator/index.php, and administrator/index2.php to 755 permissions... but that alone didnt fix it until I did 755 on the administrator folder.

Hope this helps,

Stephen


Thank you very much, changing the administrator folder permission to 755 solved the problem.

_________________
Regards
Amit Patekar
Follow me on twitter @amitpatekar
Or visit http://www.itdesignlab.com


Top
 Profile  
 
PostPosted: Thu Aug 02, 2012 7:16 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Fri Dec 16, 2011 6:13 pm
Posts: 1256
Location: Millersburg, OH
Changing the Administrator permissions to 755 fixed it for me (using J! 2.5.6). Thanks for that suggestion!

_________________
Ryan
Numinous Productions
Custom Joomla Templates, Joomla Troubleshooting and Personalized Tutorials
http://www.numinousmedia.com


Top
 Profile  
 
PostPosted: Thu Aug 30, 2012 4:24 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Dec 06, 2011 4:13 pm
Posts: 4
I have a site on GoDaddy and I can't make those permission changes as mentioned. Also, I don't have a .htaccess in the administrator folder. I do have a htaccess.txt in the root. I am running 1.5.

My details:
HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred.
Detailed Error Information
Module FastCgiModule
Notification ExecuteRequestHandler
Handler FastCGI-PHP
Error Code 0x00000000
Requested URL http://web.org:80/administrator/index.php
Physical Path D:\Hosting\5380579\html\administrator\index.php
Logon Method Anonymous
Logon User Anonymous

I do have a work around getting into the backend. Once I get the 500 Error, I change the URL to:

http://web.org/administrator/index.php?option=com_media

and I am able to get in. Once in the backend, I can replicate the 500 error every time I select the menu item SITE\CONTROL PANEL

To add ... I backed up my site with Akeeba and restored it to my local PC running WAMP. This made no difference, the problem followed the site.

Any assistance would be greatly appreciated.


Top
 Profile  
 
PostPosted: Sat Oct 13, 2012 8:49 am 
I've been banned!

Joined: Sat Sep 17, 2011 4:05 pm
Posts: 21
indycamper11 is it your server windows?
if it is windows you must use web.config

_________________
http://[spam].ir
http://www.[spam].ir


Top
 Profile  
 
PostPosted: Wed Jan 30, 2013 7:00 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Jan 30, 2013 5:07 pm
Posts: 1
Based on dates, I'm certain that these two posters have already gotten answers, but for those who venture here and make it this far . . .

NEO-BAHAMUT- wrote:
Hi guys,
. . . Can anyone tell me how i change my permissions through IIS7 like stephen is saying?


latrommi wrote:
Hello. Im using windows 7 . . . How can i change permission to 755?


Hi -
to change permissions, if you are looking to just copy UNIX type permissions and are very familiar with *nix, then install Cygwin, and open cygwin as administrator and use the chmod command you're familar with in *nix. But, after you're through with getting things working, secure it carefully.

If you're a Windows admin, understand that the 755 is RWX (read write execute) for the owner, RW for all other users. Of course, you'll want to be more granular with ownership and permissions in a Windows environment.

File permissions fixed my problem as well. I'm very new to Joomla (2 weeks) and the whole WIMuP stack (Windows, IIS, MySQL, unsupported PHP) idea has been challenging. Of course, I'd not suggest this except for the purpose of upgrade and/or transitioning.

I've installed (for transition purposes)

Windows 2008 R2
IIS 7.5
PHP 4.4.9
MySQL 5.0.91
Joomla 1.5.26


Top
 Profile  
 
PostPosted: Wed Mar 06, 2013 11:48 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Feb 03, 2013 3:54 pm
Posts: 3
Same nuissance.
I was installing joomfish. At one point during installation I intended to change the JFrouter Pro Status and ever since I locked out of the Joomla administrator.

I tried to set 755 permissions to the whole administrator folder. No good.
I increased the internal memory limit in my php.ini file No good
I cannot find an htaccess file in my administrator folder eventhough I'm using filezilla.

Any help is extremely welcome.

Joomla 2.5
Joomfish 2.51

PHP versie: 5.3.3-7+squeeze14
Web Server software: Apache
Server Operating system: Linux
Webserver to PHP Interface: php 5.3
Database Version: mysql Ver 14.14 Distrib 5.1.66, for debian-linux-gnu (i486) using readline 6.1 memory_limit from your phpinfo tab: 64M


Top
 Profile  
 
PostPosted: Wed Mar 06, 2013 12:21 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Feb 03, 2013 3:54 pm
Posts: 3
By the way if I turn off the friendly HTTP error messages I get a white page,...


Top
 Profile  
 
PostPosted: Mon Jun 24, 2013 2:30 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Sep 21, 2009 6:06 pm
Posts: 18
Did you ever resolve this?


Top
 Profile  
 
PostPosted: Thu Aug 08, 2013 6:03 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Mar 20, 2013 8:04 pm
Posts: 13
Location: St. Louis, MO
I also had this 500 error issue every time I entered my login info (would take me to the admin login screen just fine, but would error out whenever I entered anything)

I found that the problem was in my configuration.php file. I moved my site from a development server to a live server and changed everything in this file appropriately except for the $log_path and $tmp_path entries. Set the correct path on these two items and everything is working just fine now. Hope this help someone!


Top
 Profile  
 
PostPosted: Thu Aug 15, 2013 5:47 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jul 29, 2013 5:46 am
Posts: 25
I am using the registration form that is already available in the user manager option in my website.

But once I click on the register button I get this message:
Code:
Server error
The website encountered an error while retrieving
http://prachi.matrimony4me.in/index.php/sample-sites-2?task=registration.register.
It may be down for maintenance or configured incorrectly. Here are some suggestions: Reload this webpage later.

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

_________________
ccra.ir
water-purifier.ir


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 1:44 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Nov 12, 2013 1:38 pm
Posts: 1
Not sure if this will solve anyone else's problems, but I had an internal server error when I migrated from a local server to a live server.

First, make sure you change the filename of htaccess.txt to .htaccess in your root directory.

Second, open the .htaccess file in a text editor and uncomment this line:

Code:
RewriteBase /


I am on rackspace, and this part of the htaccess is required to avoid the internal server error.

Hope that helps someone!


Top
 Profile  
 
PostPosted: Tue Apr 29, 2014 12:35 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Sep 10, 2008 6:05 pm
Posts: 288
Location: Essex, England, United Kingdom
I cleared my cache, used Admin Tools to fix my permissions, jobs a goodun

_________________
Just another lonely website designer trying to make his way.
https://www.squareballoon.co.uk


Top
 Profile  
 
PostPosted: Fri May 02, 2014 1:08 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Sep 20, 2008 10:35 pm
Posts: 1
In my case there was the wrong path in the /administrator/.htaccess


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 60 posts ]  Go to page Previous  1, 2



Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group