Joomla 2.5.1 Installer locking up on Step 4

Need help installing Joomla! 2.5? For all Joomla! 2.5 installation issues please use this forum. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
inkheartartist
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Feb 22, 2012 10:56 pm

Joomla 2.5.1 Installer locking up on Step 4

Postby inkheartartist » Fri Feb 24, 2012 7:01 pm

Hello, I have been attempting a fresh installation of Joomla 2.5.1 on a flash [drive] for 3 days now and I am stumped. This is the first time I have ever tried to work with this program and my web design knowledge is very limited.

The inevitable problem I keep running into is that, during the installation process of Joomla, on the database configuration step: I plug in all the information and press next and the loading sign washes over the page and it stays like that indefinitely. I've tried different browsers and put the flash [drive] in multiple Windows OS computers and whenever I get to that step, the same thing happens. I've scoured the internet and Joomla forums for information on this problem and found nothing quite like it.

When installing XAMPP I made a new database, username and password. During the making of the username I accidentally made a database with the same name. It's not the database I am trying to install Joomla onto. During the Joomla installation I select English (United States) for the language and the pre-installation check says that the recommended settings for display errors and output buffering are deviant from what they are supposed to be. I'm running XAMPP 1.7.7

All of the tutorials I have looked to for help use older versions of XAMPP and Joomla. Is there anything more current? I don't think I can proceed any further without some help so any information on this would be tremendously appreciated.

SweetSauer
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Feb 24, 2012 8:28 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby SweetSauer » Fri Feb 24, 2012 8:41 pm

I am also trying to install 2.5.1, USB install on XAMPP using control panel 3.0.2 with Apache 2.2.1. I am also getting stuck on Step 4. It creates somewhere between 8 and 12 tables in the database and hangs. I haven't been able to getting any different results other than not connecting to the database errors or the hanging on step 4 by changing database details, not requiring or requiring a password. I am going to try to download 1.5 and install it and then upgrade. This is a clean install.

SweetSauer
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Feb 24, 2012 8:28 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby SweetSauer » Sun Feb 26, 2012 1:05 am

Appear to have found my problem -- slow memory card that I was trying to install on. Was an old "hi-speed" compact flash card -- forgot that it was over 5 years old. Grabbed my USB stick and it worked quickly and correctly. I imagine I was getting time outs.

inkheartartist
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Feb 22, 2012 10:56 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby inkheartartist » Mon Feb 27, 2012 5:54 pm

Hmmm... Well I believe my flash [drive] is pretty current so I'm not sure that's my problem.

SweetSauer, did the installation of 1.5 and then upgrading it work for you?

SweetSauer
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Feb 24, 2012 8:28 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby SweetSauer » Mon Feb 27, 2012 7:21 pm

No, I couldn't get any iteration to load. Switched to the new flash [drive] and I got everything to work.

inkheartartist
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Feb 22, 2012 10:56 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby inkheartartist » Mon Feb 27, 2012 10:25 pm

Oh, I'm sorry. I thought your last post was by someone else for some reason. I'll give it a try. Thanks for the help!

Adzzz
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Feb 27, 2012 11:36 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby Adzzz » Mon Feb 27, 2012 11:50 pm

Hello,

I'm also having the same problem. I'm setting a new website up, all files have been FTP'd onto the webserver and I'm working through the installation - and it's refusing to proceed past step 4.

I have created and provided the correct access for the database, and the user/password has been entered correctly. I have logged into phpMyAdmin, and 61 tables were created (total of 356 records, db size is 250.6KB) - so I know that records are being created in tables... but for some reason, the system isn't letting me proceed to the FTP configuration.

Is there anything obvious I can check straight away? I'm going to leave the screen running all night to see if it frees itself up, but it's already been running for 10-15 minutes at least!

Thanks,

Adz

inkheartartist
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Feb 22, 2012 10:56 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby inkheartartist » Wed Mar 07, 2012 8:27 pm

I got a new hard [drive] to see if that was the problem but I'm still having the same hang up at step 4. On this new [drive], I am also having a problem with the Joomla installer recognizing users other then root. I've figured out my way around phpMyAdmin a bit more now and I'm seeing that, after 2 tries, the installer creates 20-29 tables 163 rows and then stops working.

I'll admit I'm getting a little impatient with it so I check shortly after beginning the database configuration and I haven't let it work for more then a half hour. How long is this process supposed to take? Am I just not giving it enough time?

fiddledebi
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Oct 14, 2010 5:37 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby fiddledebi » Wed Mar 28, 2012 6:32 pm

Can you tell me how you eventually resolved this? I'm having the same problem.

Thanks much!

Adzzz
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Feb 27, 2012 11:36 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby Adzzz » Wed Mar 28, 2012 8:18 pm

I binned the entire site, and then re-uploaded it all in binary mode rather than auto in my FTP client. Fixed the problem immediately.

switcher
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Mar 29, 2012 1:39 pm

Re: Joomla 2.5.3 Installer locking up on Step 4

Postby switcher » Thu Mar 29, 2012 1:58 pm

I am also having problems getting past step 4. I get this message:

Could not connect to the database. Connector returned number: 2

I'm using xampp on my local machine as I try to get to grips with Joomla so it's all a first time install using new downloads.

Any ideas please?

cecilsolomon
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Mar 31, 2012 3:09 am

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby cecilsolomon » Sat Mar 31, 2012 3:14 am

I have the same problem (I am installing 2.5.3)--and received the same prompt:

Could not connect to the database. Connector returned number: 2

However, I FTP'ed the files over to my host server. I am contacting the host to see if/how I need to establish the database myself.

cecilsolomon
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Mar 31, 2012 3:09 am

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby cecilsolomon » Sat Mar 31, 2012 3:34 am

I was able to complete the installation--in the Cpanel I found a wizard for installing a database and installed a MySQL database.

Switcher, I suspect that you may have something preventing the development of the database on your computer (but I am not sure--like I mentioned, I installed on a remote server and used Cpanel to build my own)

switcher
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Mar 29, 2012 1:39 pm

Re: Joomla 2.5.1 Installer locking up on Step 4

Postby switcher » Sat Mar 31, 2012 4:15 pm

I tried removing the Joomla and xampp stuff and re-installed everything from the beginning. It still failed, but after fiddling around and trying again it eventually worked. I have no idea why ...


Return to “Installation Joomla! 2.5”

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests