Blank Backend Page

Need help with the Administration of your Joomla! 2.5 site? This is the spot for you.
Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
ogtp
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Apr 02, 2012 4:36 am

Blank Backend Page

Postby ogtp » Mon Apr 02, 2012 4:41 am

Hi,

Its strange. I got blank page in the backend, I can see only the logout butoon, please see the picture attached, only for any user who has: Manager or Administrator access level.

Its fine when the user has: Super Power access level.

Please help.

Thanks
You do not have the required permissions to view the files attached to this post.

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Mon Apr 02, 2012 4:34 pm

At a guess, the access level 'Special' only had the 'Super Users' group ticked?

Check by logging into backend with super user then Users->Access Levels. Click on Special and see if "Manager", "Author" and "Super Users" are all ticked.
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

richardtuttle
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Apr 02, 2012 6:01 pm

Re: Blank Backend Page

Postby richardtuttle » Mon Apr 02, 2012 6:04 pm

I am having the same issue since upgrading this morning. The frontend appears just fine, but when I try to access the Admin section it givens a blank screen (except for the header/footer graphics) and no login entry availability at all -- just as the image in the first post above.

I have attempted accessing it via other browsers, clearing my cache, etc. all to no avail!

Ugh ... any suggestions on being able to access the Admin backend once again?!?

:-\

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Mon Apr 02, 2012 6:08 pm

richardtuttle wrote:I am having the same issue since upgrading this morning. The frontend appears just fine, but when I try to access the Admin section it givens a blank screen (except for the header/footer graphics) and no login entry availability at all -- just as the image in the first post above.

I have attempted accessing it via other browsers, clearing my cache, etc. all to no avail!

Ugh ... any suggestions on being able to access the Admin backend once again?!?

:-\

So its automatically logging you into Joomla's backend without authentication?
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

richardtuttle
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Apr 02, 2012 6:01 pm

Re: Blank Backend Page

Postby richardtuttle » Mon Apr 02, 2012 6:11 pm

It's not logging in at all. I attempt to get to the login screen (where it usually asks for the username/password) and it's simply a blank page ... it looks just like the image that was attached in the originating post here. ???

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Mon Apr 02, 2012 6:15 pm

Hmm, can you access /administrator/index.php?option=com_users ?

Obviously if you can then thats a security problem. The other thread in viewtopic.php?f=624&t=707759 has exactly the same problem.

Can you list your extensions please.

Edit: link was wrong
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

richardtuttle
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Apr 02, 2012 6:01 pm

Re: Blank Backend Page

Postby richardtuttle » Mon Apr 02, 2012 6:19 pm

ShMaunder wrote:Hmm, can you access /administrator/index.php?option=com_users ?

Obviously if you can then thats a security problem. The other thread in viewtopic.php?f=624&t=707759 has exactly the same problem.

Can you list your extensions please.

Edit: link was wrong


Yes I can see the complete list of users. However, there is no menu icons and no direct way to access anything else (control panel or otherwise). :( I know that we don't have very many extensions currently installed but don't know the list offhand and cannot access the Control Panel in order to give you a listing...

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Mon Apr 02, 2012 6:23 pm

richardtuttle wrote:
ShMaunder wrote:Hmm, can you access /administrator/index.php?option=com_users ?

Obviously if you can then thats a security problem. The other thread in viewtopic.php?f=624&t=707759 has exactly the same problem.

Can you list your extensions please.

Edit: link was wrong


Yes I can see the complete list of users. However, there is no menu icons and no direct way to access anything else (control panel or otherwise). :( I know that we don't have very many extensions currently installed but don't know the list offhand and cannot access the Control Panel in order to give you a listing...


OK, it is essential to get this list of extensions. There appears to be 4 users now affected by this (or something similar).

If you took a backup before the upgrade, roll back.

You can get a list of the extensions by looking in your SQL database (plugins table).
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

richardtuttle
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Apr 02, 2012 6:01 pm

Re: Blank Backend Page

Postby richardtuttle » Mon Apr 02, 2012 6:28 pm

List of extensions installed:
* Xmap
* Modules Anywhere
* Phoca PDF
* Phoca Gallery
* Phoca Maps
* Fox Contact
* DirectPHP
* Simple File Upload

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Mon Apr 02, 2012 6:38 pm

richardtuttle wrote:List of extensions installed:
* Xmap
* Modules Anywhere
* Phoca PDF
* Phoca Gallery
* Phoca Maps
* Fox Contact
* DirectPHP
* Simple File Upload

Cool, i'll post that in the other threads in a moment.

Also, is anything listed in <Joomla>/logs/error.php OR your web server logs (e.g. Apache logs) during the upgrade?

Edit: here is the other thread with it in viewtopic.php?f=615&t=707758
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

richardtuttle
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Apr 02, 2012 6:01 pm

Re: Blank Backend Page

Postby richardtuttle » Mon Apr 02, 2012 6:43 pm

ShMaunder wrote:Also, is anything listed in <Joomla>/logs/error.php OR your web server logs (e.g. Apache logs) during the upgrade?


No, nothing in the Joomla error log file at all.

And in the Apache error log file I just found the following entry: "[Mon Apr 02 11:26:15 2012] [error] File does not exist: /home/atavolab/public_html/administrator/sys_cpanel, referer: http://108.60.141.4/~atavolab/administrator/login.php "

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Mon Apr 02, 2012 6:56 pm

I believe the only way you'll fix this is to follow this link http://docs.joomla.org/Upgrading_from_a ... ng_version (look at Method C).

You may want to post/follow in viewtopic.php?f=615&t=707758&p=2779328 as well.

Edit: Make sure you backup your site before doing anything more. If the above fails then restore back to the backup you hopefully took before the initial upgrade. You should be good from a security POV (2 low priority security fixes in 2.5.4) until this issue can be resolved.
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

DeltaCreative
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Apr 02, 2012 9:30 pm

Re: Blank Backend Page

Postby DeltaCreative » Mon Apr 02, 2012 9:35 pm

I have the same blank back end Admin page as well. I went as far as nuking the administrator folder and uploading new files from the full package. No Change.

FrogButt22
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Apr 03, 2012 2:18 am

Re: Blank Backend Page

Postby FrogButt22 » Tue Apr 03, 2012 2:29 am

I am having the same issue with my website when I log into the backend. No menu bar no icons nothing Please help I am under a deadline and I have no way to rollback my website. Please tell me there is an easy fix.

tripthelight
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Apr 03, 2012 4:40 am

Re: Blank Backend Page

Postby tripthelight » Tue Apr 03, 2012 5:37 am

Interesting, I'm having the same problem and described in the exact same way... I can also access my users list via access /administrator/index.php?option=com_users. Hmmm... going to try the manual installation of the upgrade and then, if that doesn't work, roll it back.

DeltaCreative
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Apr 02, 2012 9:30 pm

Re: Blank Backend Page

Postby DeltaCreative » Tue Apr 03, 2012 7:53 pm

This problem is popping up under several different topics... I would urge users to read the topic titles before adding a new one. Together we may have a better chance of getting to the bottom of this bug...

richardtuttle
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Apr 02, 2012 6:01 pm

Re: Blank Backend Page

Postby richardtuttle » Wed Apr 04, 2012 4:48 pm

Finally, a solution that worked for me: I replaced the controller.php with the version from 2.5.3 and also replacing line 30 of helper.php (path: administrator/includes) from
if (!$user->authorise('core.login.admin')) {
to
if ($user->get('guest')) {

jeffhicks
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Tue Apr 03, 2012 5:19 pm

Re: Blank Backend Page

Postby jeffhicks » Wed Apr 04, 2012 6:04 pm

I tried this and it didn't work. Any other suggestions?

Jeff

tiranianu
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Dec 13, 2011 9:27 am

Re: Blank Backend Page

Postby tiranianu » Wed Apr 04, 2012 6:09 pm

What exactly controller.php want replace ?

gdarnton
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Apr 04, 2012 6:18 pm

Re: Blank Backend Page

Postby gdarnton » Wed Apr 04, 2012 6:28 pm

Thanks richardtuttle. That worked for me. :)
It is worth mentioning that the controller.php I replaced is located in administrator/components/com_admin. Others may be looking for it. I found the helper.php where you indicated.

tiranianu
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Dec 13, 2011 9:27 am

Re: Blank Backend Page

Postby tiranianu » Wed Apr 04, 2012 6:45 pm

Not work for me , again : Username and password do not match or you do not have an account yet.
PLEASE HELP

jeffhicks
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Tue Apr 03, 2012 5:19 pm

Re: Blank Backend Page

Postby jeffhicks » Wed Apr 04, 2012 6:58 pm

OK, I went back and retyped the new code in the helper.php and it worked! Thanks so much all!!!

cojackpilot
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Apr 03, 2012 3:50 pm

Re: Blank Backend Page

Postby cojackpilot » Thu Apr 05, 2012 6:48 pm

richardtuttle wrote:Finally, a solution that worked for me: I replaced the controller.php with the version from 2.5.3 and also replacing line 30 of helper.php (path: administrator/includes) from
if (!$user->authorise('core.login.admin')) {
to
if ($user->get('guest')) {


It worked for me!!! I don't know how you came up with this solution, but it's BRILLIANT! thanks a lot..

Structures
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Feb 10, 2012 12:04 am

Re: Blank Backend Page

Postby Structures » Fri Apr 06, 2012 4:12 pm

Sorry guys newbie here. Where is controller?

Structures
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Feb 10, 2012 12:04 am

Re: Blank Backend Page

Postby Structures » Fri Apr 06, 2012 4:19 pm

OK I found the controller folder Do I swap, overwrite the whole (Profile.php) file?

Structures
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Feb 10, 2012 12:04 am

Re: Blank Backend Page

Postby Structures » Fri Apr 06, 2012 4:52 pm

OK I have replaced the Controller.php and replaced line 30
Still no joy

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Fri Apr 06, 2012 9:06 pm

http://joomlacode.org/gf/project/joomla ... m_id=28354

The issue described in this thread has been "fixed" in the latest trunk.

---

Symptoms

This fix addresses the following symptoms (all of these must be a symptom):
    Automatic login to backend
    Attempting to logout of backend fails
    Backend login form never shows
    The admin modules such as main menu are missing or the backend is blank
    List of users are shown when browsed to /administrator/index.php?option=com_users&view=users
    Upgraded to Joomla! 2.5.4


Why is this happening

The Global Configuration's permissions for "Admin Login" has been set to allowed for the Public group. This could occur through a bad default or a user misconfiguration.


How to fix

There are two methods that should fix this. The first method doesn't require any modifications to core files and fixes the root cause of the problem (recommended). The second method requires a core file change and should only be attempted if the first method failed.

First Method
1) Browse to /administrator/?option=com_login
2) At the login form, enter a super user's username and password
3) Go to Site->Global Configuration then click on the "Permissions" tab
4) Under the Public drop down, set the "Admin Login" to "Not Set". Note: you should set all values in this Public drop down list to "Not Set" ( viewtopic.php?f=624&p=2785068#p2785053 ).
5) Click Save & Close
6) Try to log out and if the login form appears, this method worked and your site should be fixed.

Assumption: the "Guest User Group" setting located in the "User Manager" options is set to 'Public'.

Second Method
Replace the contents of /administrator/includes/helper.php with the contents on https://raw.github.com/joomla/joomla-cm ... helper.php . This fix will be included in J! 2.5.5.

After regaining access, you should go to the Global Configuration->Permissions then set the Public "Admin Login" to "Not Set". It might be a good idea to check all the permissions in this section to ensure it has the correct settings.

Update: several people have confirmed this fixes the issues as outlined in the symptoms.

Post Edits
07/04 21:44 - Added a better fix to the post
07/04 22:11 - Made the fix clearer
10/04 21:20 - Added assumptions to fix and tidied method 2
Last edited by ShMaunder on Tue Apr 10, 2012 8:23 pm, edited 15 times in total.
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

Structures
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Feb 10, 2012 12:04 am

Re: Blank Backend Page

Postby Structures » Fri Apr 06, 2012 9:53 pm

It has not fixed it for me. I just tried the steps again.

ShMaunder
Joomla! Explorer
Joomla! Explorer
Posts: 486
Joined: Mon Jul 05, 2010 7:22 pm
Location: UK
Contact:

Re: Blank Backend Page

Postby ShMaunder » Fri Apr 06, 2012 9:57 pm

OK, so you cannot logout of the backend, correct?

Did you also try to replace all the files (i.e. method C from the upgrade Wiki)?

Basically, we need to establish this is the same problem and not something like a module or access level problem.

Edit: @Structures - I've edited the post above, it now contains symptoms. Do you get all of those symptoms? If not then you have a different problem.
Shaun Maunder
JMapMyLDAP extensions - Joomla! 2.5/3.1/3.2 LDAP Integration & SSO
http://shmanic.com/tools/jmapmyldap/

NorfolkBroad
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Sun Feb 01, 2009 3:56 am

Re: Blank Backend Page

Postby NorfolkBroad » Sat Apr 07, 2012 2:33 am

I have this problem too. After the upgrade to 2.5.4 a couple of days ago everything seemed fine. I've only uploaded a few photos and videos via the frontend (which is working fine) in the meantime, but I tried to log in to the backend because I wanted to add a menu item and it went to the blank page with headers and footers as per the image posted earlier. I'm already logged in and I can't log out. I'm using one of the two super user accounts to login on the frontend and wondered if this was fooling the backend to think I was logged in there too. I overwrote the files with the full 2.5.4 installation package. Deleted the installation folder and tried accessing the backend again but nothing has changed.

I've just tried accessing /administrator/index.php?option=com_users and it lets me in - even though it didn't ask me for any login details.

Will go and try the change to the helper file suggested above and report back.
Last edited by NorfolkBroad on Sat Apr 07, 2012 2:38 am, edited 1 time in total.


Return to “Administration Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 6 guests