The Joomla! Forum ™



Forum rules


Règles du forum



Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Mon Apr 24, 2006 9:06 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 31, 2005 10:22 am
Posts: 29
Location: Paris
Bonjour,

J'ai un problème avec Community builder. quand j'inscris un membre,  Joomla génère automatiquement un message de confirmation d'inscription vers l'email du membre *. Or je ne veux pas que joomla envoi un email de confirmation au membre. Est-ce possible ?

Merci pour vos tuyaux

EmG

* voici le message :
Hello test  test,


You have been added as a user to http://monsite.com/Joomla_1.0.1-Stable-fr by an Administrator.

This email contains your username and password to log into the http://monsite.com/Joomla_1.0.1-Stable-fr site:


Username - test

Password - test



Please do not respond to this message as it is automatically generated and is for information purposes only

_________________
EMG


Last edited by mejean on Tue Apr 25, 2006 9:25 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Mon Apr 24, 2006 8:01 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sun Aug 21, 2005 9:18 pm
Posts: 1074
Location: SUISSE
Je propose une petite modification (à tester) du fichier components\com_registration\registration.php, ligne 179, remplacer :

Code:
   mosMail($adminEmail2, $adminName2, $email, $subject, $message);


par :

Code:
   if ($mosConfig_useractivation == '1') {
      mosMail($adminEmail2, $adminName2, $email, $subject, $message);
   }


Top
 Profile  
 
PostPosted: Tue Apr 25, 2006 3:17 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 31, 2005 10:22 am
Posts: 29
Location: Paris
Je viens d'essayer ta solution  mais ça ne marche malheureusement pas ! le membre reçoit toujours un message de confirmation !

Cordialement

Emmanuel
PS : j'utilise pour inscrire les membres le composant community builder peut-être y a t-il un conflit avec le module login ?

_________________
EMG


Top
 Profile  
 
PostPosted: Tue Apr 25, 2006 3:20 pm 
User avatar
Joomla! Hero
Joomla! Hero

Joined: Thu Aug 18, 2005 12:28 pm
Posts: 2716
Location: viewforum.php?f=19
Vérifie s'il n'y a pas un module de connexion spécifique à CommunityBuilder (et dépublie celui par défaut)

_________________
Jérôme Bussière - simple utilisateur
www.cardabelle.net


Top
 Profile  
 
PostPosted: Tue Apr 25, 2006 3:30 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 31, 2005 10:22 am
Posts: 29
Location: Paris
j'ai dépublié le module login form mais cela semble sans effet...

Emmanuel

_________________
EMG


Top
 Profile  
 
PostPosted: Tue Apr 25, 2006 7:40 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sun Aug 21, 2005 9:18 pm
Posts: 1074
Location: SUISSE
Hum, je n'avais pas fait attention qu'il s'agissait de l'enregistrement depuis l'admin de Joomla!  :-[

Donc on reprend dans le fichier administrator/components/com_users/admin.users.php, ligne 343 remplacer :

Code:
   if ($isNew) {


par :

Code:
   if ($isNew && false) {


Top
 Profile  
 
PostPosted: Tue Apr 25, 2006 8:00 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sun Aug 21, 2005 9:18 pm
Posts: 1074
Location: SUISSE
Pour anticiper : vu le message envoyé au membre il s'agit d'un enregistrement dans Joomla!. Pour ne pas envoyer de courriel lors de l'enregistrement dans l'admin de Community Builder, dans le fichier administrator/components/com_comprofiler/admin.comprofiler.php commenter les lignes 1144 et 1145.


Top
 Profile  
 
PostPosted: Wed Apr 26, 2006 12:06 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 31, 2005 10:22 am
Posts: 29
Location: Paris
peux tu me dire les 2 lignes à mettre en commentaire car chez moi ce sont celles-ci :
} else {
$lists['imageApproverGid']="".$acl->get_group_name($ueConfig['imageApproverGid'])."\n";


Merci

Emmanuel

_________________
EMG


Top
 Profile  
 
PostPosted: Thu May 04, 2006 4:01 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Sun Aug 21, 2005 9:18 pm
Posts: 1074
Location: SUISSE
Oups, il était en voie de passer aux oubliettes ce sujet.

Je n'avais pas fait attention à la version de Joomla! :
emg wrote:
Joomla_1.0.1-Stable-fr

Il est très vivement déconseillé d'utiliser une version de Joomla! inférieure à 1.0.4. Si possible utiliser la version 1.0.8 (-fr éventuellement  ;) ) patchée.

La version de Community Builder dans laquelle j'ai zieuté est la 1.0 RC2.


Top
 Profile  
 
PostPosted: Fri May 05, 2006 7:39 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 31, 2005 10:22 am
Posts: 29
Location: Paris
Bonjour,
J'ai mis à jour ma version de joomla. Je suis maintenant en 1.08. Je passerais bien à la version RC.O2 de CB mais j'ai des problèmes d'installation de composants et de modules. Je crains donc en les désinstallant de ne pas pouvoir réinstaller CB !!! (voir post suivant pour mes problèmes : http://forum.joomla.org/index.php?topic ... icseen#new )

Bref je désépère un peu et je pense qu'il y a un changement au niveau de la config du serveur (car à un moment donné tout fonctionnait parfaitement y compris l'installation de composants et de modules supplémentaires). Mlaheuresement je ne contrôle pas ce qui se passe coté serveur.

Emmanuel

_________________
EMG


Top
 Profile  
 
PostPosted: Tue Nov 15, 2011 1:06 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Apr 12, 2010 6:35 am
Posts: 12
emg wrote:
Bonjour,

J'ai un problème avec Community builder. quand j'inscris un membre,  Joomla génère automatiquement un message de confirmation d'inscription vers l'email du membre *. Or je ne veux pas que joomla envoi un email de confirmation au membre. Est-ce possible ?

Merci pour vos tuyaux

EmG

* voici le message :
Hello test  test,


You have been added as a user to http://monsite.com/Joomla_1.0.1-Stable-fr by an Administrator.

This email contains your username and password to log into the http://monsite.com/Joomla_1.0.1-Stable-fr site:


Username - test

Password - test



Please do not respond to this message as it is automatically generated and is for information purposes only


Bonjour, j'ai exactement le même problème sauf que j'utilise joomla 1.7.2 et Community Builder 1.7.1. Avez-vous une solution afin que cela soit uniquement community builder qui envoi un email avec login et pass. Merci pour votre aide.


Top
 Profile  
 
PostPosted: Mon Dec 19, 2011 5:21 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Fri Aug 19, 2005 1:04 pm
Posts: 697
Location: IdF - Centre
ag3 wrote:
Bonjour, j'ai exactement le même problème sauf que j'utilise joomla 1.7.2 et Community Builder 1.7.1. Avez-vous une solution afin que cela soit uniquement community builder qui envoi un email avec login et pass. Merci pour votre aide.

Je n'ai pas la réponse, mais si vous souhaitez en obtenir une je vous conseille de poster cette requête dans le forum adéquat qui traite des extensions pour J! 1.7.x -> viewforum.php?f=659

J! 1.0.x n'étant plus supporté par la communauté, même si un membre connaît la réponse il est probable qu'il ne fréquente plus cette partie des forums.

Je préfère que vous ré-exposiez le problème plutôt que de déplacer votre message, ou une partie du sujet. Cordialement.

_________________
Sébastien Pillias - french forum moderator

Vous êtes sur un forum d'entre aide : aidez les autres, les autres vous aideront !
Aidez-les à vous aidez en utilisant le fichier jtspost_fr.php : http://forum.joomla.org/viewtopic.php?t=272866 !


Top
 Profile  
 
PostPosted: Tue Dec 20, 2011 8:36 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Apr 12, 2010 6:35 am
Posts: 12
Bonjour,

Voici la réponse à votre question afin que Joomla n'envoie pas de mail en plus de celui de Community Builder. Voir ci-dessous :

As of Joomla 1.7 there is a bug/missing-feature (?) in Joomla API that automatically triggers a Joomla welcoming email when CB User Management is used to create a new user.

A relatively painless work-around is to find the:

administrator -> language -> en-GB -> en-GB.plg_user_joomla.ini file (and/or all relevant language specific instances)

and empty the relevant language strings:

PLG_USER_JOOMLA_NEW_USER_EMAIL_BODY=""
PLG_USER_JOOMLA_NEW_USER_EMAIL_SUBJECT=""


This will suppress Joomla email sending.

Only minor cosmetic drawback is that you will see a warning in backend:

Empty message body

when creating user.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 



Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group