Mehdi's Bridge for Phpbb2 (not 3 yet ...)

Discuss the integratoin of phpbb and Joomla! here.

Moderator: General Support Moderators

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Mehdi's Bridge for Phpbb2 (not 3 yet ...)

Postby mehdi » Wed May 17, 2006 2:09 am

Hi ,
I've developed a bridge for Phpbb that should offer significant advantages
over existing solutions:  no hack of the Joomla's core required , use core Joomla login, can use two separate database,  integration in joomla's template (if you wish) etc ...
It works well with current versions ie: Joomla 1.08 and Phpbb  2.020

I hope you don't mind , but I chose to release files and "official" explanations on my website only.
Get all required stuff at this link:
http://www.mehdiplugins.com/misc/phpbbjoom.htm

EDIT:
  • 7 June 2006, Bug Fix: If you already installed the bridge before, please update the file joomphpbb_engine.php and then run the script checkassoc.php from your forum's root.
  • CB users take a look here.
  • Some OpenSef versions induce problems for the bridge. To disable OpenSef only when the bridge is in use, follow these steps : Make a menu item to the component . Now in the configuration panel of Opensef exclude that menu item. You don't need that menu item anymore, so delete it.

EDIT2:
20 June 2006, just compiled an FAQ for this bridge:
http://www.mehdiplugins.com/misc/phpbbjoomfaq.htm

EDIT3:
8 september 2006, redirection bug fix.
The only issue I know yet related to this bug is: see this post (little arrow bug)
But this might have a more serious impact. Update anyway.

FAQ updated.
especially question related to define ( 'RG_EMULATION', 0 )
and also: How can I set different modules to be shown with my phpbb forum? How I can assign a different template ?  etc ....

quickmerge script improved (errors are more explicit)

EDIT4:
5 October 2006,
added an online script to quickly fix the CSS of the phpbb template when
integrated inside joomla template. here:
http://www.mehdiplugins.com/misc/cssintegrator.htm
Hopefully , it would help  people  to fix the CSS of their phpbb theme  faster, in the context of a visual
integration inside Joomla.  Also it could help newbies that know nothing about CSS.

Improved navigation in the menu of my website. ( so that  people are less lost between all the links)

EDIT5:
1 November 2006, workaround for the bug 24420 found in some php installs ( getcwd() returns random results in a callback ) .
If you are suffering from the "white page syndrome" when you login
(although gzip compression is disabled in Joomla and Phpbb),
then redownload that bridge and replace the file joomphpbb_engine.php by the new one.


EDIT6:
3 December 2006 .
if  after a server upgrade to php 5.2 (or above  ;) )
you are getting blank pages,
then you should redownload the bridge and update the joomphpbb_engine.php file

EDIT 7:
23 April 2007
fix for "external direct links" to topics.
This can be usefull if you a module that show latest posts on your frontpage.
As usual, replace the file joomphpbb_engine.php by the new one.
Yes I admit, it's a bit exasperating to click on one of the "latest topic links" and then be redirected
to the forum homepage. Fixed.

EDIT 8:
7 August 2007
Notice about Joomla 1.0.13:  Despites the new "salted passwords" introduced by Joomla 1.0.13 , the bridge works fine. However, if you plan to unbridge, it won't be as easy as before. Users added to phpbb after bridging (and only these ones) , will end up with "salted paswords" stored in phpbb's "user table"...

Added a minor fix, concerning "visual integration"...

EDIT 9:
7 January 2008
Ok, that's not the "big update" that some people are expecting,
but now it's not anymore necessary to hack Joomla in order to take advantage of Gzip Compression (for Joomla)
while using the bridge.
I still ask however to disable Gzip for Phpbb.

If you are looking for a bigger novelty look to the "other" bridge.

cheers,
Mehdi 

PS: the download link works only if javascript is enabled
Last edited by mehdi on Mon Jan 07, 2008 5:22 am, edited 1 time in total.

bladel
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu May 18, 2006 1:52 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby bladel » Thu May 18, 2006 1:58 pm

Hi,
I installed your brige, but on an new registration it doesn't create a new user in the phpbb2_users table. So can't log on in the forum. Do i have to change id to auto_increment?
I will send the link to my page with a PN.

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Thu May 18, 2006 2:29 pm

HI bladel,
I took a look to your PM
I would avoid to use two different domains for forum and joomla site (because  bridge not tested to work this way or conceived for this )  I mean:
www.mysite.com and  www.forum.mysite.com
I would use  instead : www.mysite.com and www.mysite.com/forum  "forum" is an example of subfolder of course.

but on an new registration it doesn't create a new user in the phpbb2_users table.


A new user is created in the phpbb2_users, only after the user is logged into joomla and visit the forum.
If the user has never visited the forum (being logged in joomla) , then no corresponding  phpbb account would  be created.

See also the PM I sent you...
Last edited by mehdi on Thu May 18, 2006 3:07 pm, edited 1 time in total.

bladel
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu May 18, 2006 1:52 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby bladel » Thu May 18, 2006 3:07 pm

Thanks dude it works now!!!!  ;D
Your the best ;)

paulnyc
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu May 18, 2006 5:38 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby paulnyc » Thu May 18, 2006 5:45 pm

Excellent bridge Mehdi!
I installed it and it works great with the unmodified version of phpBB 2.0.20, however when I install it on the modified version of Categories Hierarchy 2.1.4c (I like/need the Topic Calendar that can be added to the CH)  from http://ptifo.clanmckeen.com/index.php , I get the following error from FireFox:

The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies.

I hope this is just a small error which I can change by changing something from 0 to 1  :P
But I really need someone's help figuring out what is wrong. In advance thank you for the help.

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Thu May 18, 2006 10:02 pm

well I've performed a test on my local computer
I used  Categories Hierarchy 2.1.5 RC 7
I've seen small problems I tried to fix by modifying slightly joomphpbb_engine.php file (see attachement)
seems to work on my local computer,  so just give a try ...
You do not have the required permissions to view the files attached to this post.

paulnyc
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu May 18, 2006 5:38 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby paulnyc » Fri May 19, 2006 2:08 am

I am going to try the updated file in about 30 minutes, but just to add, with users already in Joomla it works perfectly, only gives me the error for newly created users.

Edit: In what order did you install the things for phpBB? Base forum, then CH and then the bridge or Base forum, then Bridge then CH...just curious although chances are it would not make a difference.

Edit 2: I just tried it again with CH 2.1.4c and the updated file you provided, same error occurs and ONLY while trying to login using a newly created account.
Last edited by paulnyc on Fri May 19, 2006 3:40 am, edited 1 time in total.

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Fri May 19, 2006 10:00 am

Hi paulnyc,
In what order did you install the things for phpBB? Base forum, then CH and then the bridge or Base forum, then Bridge then CH...


The easiest and  right order is: Base forum, then CH and then the bridge.
If you understand how file are processed you can change order.
Anyway, if you want to apply any other hack after bridge instal then you have to edit files with inc_ suffix instead of regular ones.


Understanding how file are processed
: If you take a look to "regular files" , you see that their content has been remplaced and that the new content has few lines (4 or 5)
Indirectly index.php is calling inc_index.php , login calling inc_login.php etc ...
Correct inclusion is done with the file joomphpbb_engine.php  that knows which file to include with the help of variable $phpbbCurPage.
For security reasons the direct access off all inc_ files must be blocked.
That's why I append at the begin of all inc_ files :

Code: Select all

<?php
if ( !defined('JOOM_PHPBB') )
{
   die("Hacking attempt");
}
?>


Edit 2: I just tried it again with CH 2.1.4c and the updated file you provided, same error occurs and ONLY while trying to login using a newly created account.


Sorry I didn't observe your problems... (on my local computer)
Try to use 2.1.5 RC 7 and see if you're not more lucky.
Problems I've observed with your modded version are a bit weird.
It refuses to work if  in the query string there's "option=com_phpbb". This is essential for login and logout.
Some links points to inc_ file instead of regular ones , I wonder why.
That's what I tried to fix (quick fix)  in joomphpbb_engine.php file.
It would probably require more times to study where problems come from
and what are the best way to fix them.
But frankly if I had spare times , I would prefer to adapt that bridge to be compatible with next version of Joomla 1.5
instead of to work with a particularly  phpbb modded version. I'm waiting also Olympus...
Last edited by mehdi on Fri May 19, 2006 2:38 pm, edited 1 time in total.

paulnyc
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu May 18, 2006 5:38 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby paulnyc » Sat May 20, 2006 12:01 am

I fixed one problem I had, now it is doing something different, when I login to Joomla (any account, old or new) and then press the link to the phpBB, it shows the logon screen in the center saying: "You are currently Logged in to the private area of this site"
The only option I have is to logout...blah I will experiment more with this and look more closely at the engine code...Thank you for the previous explanation it helped a lot so far.

Edit: Just to add, for the above mentioned install I did use the 2.1.5 RC 7 version.
Last edited by paulnyc on Sat May 20, 2006 12:03 am, edited 1 time in total.

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Thu May 25, 2006 3:53 am

Hi paulnyc

when I login to Joomla (any account, old or new) and then press the link to the phpBB, it shows the logon screen in the center saying: "You are currently Logged in to the private area of this site"


I suspect that the problem has nothing to do with CH.
You must configure your phpbb site to use exactely the same domain as joomla  and also for the bridge  ( i.e all settings begin  with www.)

check that in your joomla configuration file,  $mosConfig_live_site   value begin by www.
i.e for instance http://www.mysite.com

check that the value is the same for $joomUrl  in your  joomphpbb_conf.php file.

now in your forum's database look for the table phpbb_config and check that the setting "server_name" has again that same value
(here http://www.mysite.com )

I've observed the same problem elsewhere, and I can tell you that the reason was in fact a misconfiguration.

cheers
Mehdi

Morvela
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri May 26, 2006 5:02 am

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby Morvela » Fri May 26, 2006 5:06 am

I followed all your installation steps, using an unmodified phpbb 2.020 with subsilver default template and am getting the following error:

Cannot find "com_phpbb" component ...


It is displayed on my forum webpage with nothing else but a solid white background.

Any ideas?

Thanks for the help!   ;)

EDIT:  Guess I should add that when I link directly to "option=com_phpbb" I am getting this on the page with nothing else:

{PHPBB_BODY_HTML}
Last edited by Morvela on Fri May 26, 2006 5:09 am, edited 1 time in total.

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Fri May 26, 2006 1:11 pm

Morvela wrote:I followed all your installation steps, using an unmodified phpbb 2.020 with subsilver default template and am getting the following error:

Cannot find "com_phpbb" component ...




Well if it is unable to detect the component there's also a less obvious reason:
you didn't set properly the relative path in your joomphpbb_conf.php file.
Usually you set var $joomRel to "../"  because the forum is just in a
subfolder of Joomla's root.

EDIT:  Guess I should add that when I link directly to "option=com_phpbb" I am getting this on the page with nothing else:

{PHPBB_BODY_HTML}


That's normal. The bridge capture such output and replace the tag {PHPBB_BODY_HTML} by the output of your forum.
That's why I ask to not link as a component.

bladel
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu May 18, 2006 1:52 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby bladel » Fri May 26, 2006 5:32 pm

paulnyc wrote:[...] The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies. [...]


I had the same problem on my board, for some user, after they made a new registration it worked!

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Fri May 26, 2006 6:09 pm

had the same problem on my board, for some user, after they made a new registration it worked!

That's weird ...
You should ask users to try before to clean browser cach and  cookies  before adopting this solution.

paulnyc
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu May 18, 2006 5:38 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby paulnyc » Fri May 26, 2006 10:10 pm

I hate phpBB, I hate Joomla...many users keep getting the same error when accessing the forum:

The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies.

Any ideas? (yes they cleared the cookies/cache)

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Sat May 27, 2006 1:49 am

Hi paulnyc ...
what makes things harder in your case is that you use CH.
From what I've understood CH doesn't handle user table exactly the same way as phpbb....
So let's put this problem apart.

Otherwise I've just discovered today an annoying bug.
It will occurs if you delete a joomla user. EDIT: phpbb user
After under certain circumstance, your browser might be catch in an infinite redirection loop between forum index and the login page
resulting in the error you described.
I would advise until I write the fix, to avoid to delete Joomla  Phpbb users.
Delete/Block them from Joomla.

The bug  is a bit a long to describe. Easier to fix it. Have to do  with "joomphpbb_bridge" table (invalid entries that remain after you delete a joomla user Phpbb user)
Last edited by mehdi on Wed May 31, 2006 2:10 pm, edited 1 time in total.

paulnyc
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu May 18, 2006 5:38 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby paulnyc » Sat May 27, 2006 1:38 pm

Just to add, I do not use CH anymore. Want to make it work with just Joomla + CB 1.0 and the bridge + phpBB 2.0.20.
Are you saying that if lets say I create a user test... then delete him and then create him again it will redirect infinitely?

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Sat May 27, 2006 3:26 pm

Are you saying that if lets say I create a user test... then delete him and then create him again it will redirect infinitely?


Well if you insist. How to induce the bug.
- Create a joomla user.
- Visit the forum under that user account.
- now  delete that joomla user
- now under phpbb delete corresponding  user
- just after recreate a new user under joomla
- login with that new user under joomla.
- visit forum: bug should occurs.

Problems comes from that user_id in phpbb is  not auto_increment (very annoying , will disappear in phpbb3).
In order to work properly the bridge have this requirement:
in joomphpbb_bridge table each phpbb_id must be associated to an unique joom_id
and each joom_id must be associated to an unique phpbb_id
that's how joomla/phpbb users are binded

since user_id of phpbb is not auto_increment, then you can delete a phpbb user and recreate a new phpbb user  that have
same user id !
Thus you may have a duplicate entry in  joomphpbb_bridge table, i.e two joomla user associated to the same phpbb user .
This induce a conflict, bridge will refuse connection to one user as it won't consider it "as legitimate".
And you end up with "infinite" login/logout attempts.

Concerning CB, seems a lot people are using it .... Well slight modifications has to be done in order  that the bridge  work properly in conjunction with CB. Especially you aren't redirected to correct joomla login page/ register page by default (correspond to joomla's core).

Be patient , I'll release (very ?) soon  a "new version" of my bridge.
I don't like to release a new file each time I perform a little  modification.
I prefer to regroup them. So wait a bit...

Mehdi
Last edited by mehdi on Sat May 27, 2006 3:29 pm, edited 1 time in total.

paulnyc
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu May 18, 2006 5:38 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby paulnyc » Sat May 27, 2006 5:51 pm

I appreciate your help a lot Mehdi, and I am a very patient guy so take your time. All I want is to finally be done with my stupid website and get some sleep :p

mysticalone
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun May 28, 2006 1:18 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mysticalone » Mon May 29, 2006 9:00 pm

Great job bridging Joomla and phpBB2. I'm running into a problem though. akodarkgem template for Joomla has a body color element in it's css file and causes phpBB2 text to show up gray and hard to read. If I remove it, the color for the news on front page change. Any hacks or suggestions?

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Mon May 29, 2006 9:30 pm

Resolving css conflicts ....
I give some hints on my "hack page"
also you can compare orignal css (subsilver.css) and the one for integration (subSilverInteg.css)
Both css provided in subsilver folder.
if you understand difference, then you could do same thing for your website.
I assume of course that you use a different phpbb theme instead of the default one.

mysticalone
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun May 28, 2006 1:18 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mysticalone » Tue May 30, 2006 12:09 pm

phpBB CSS style is linked to the subSilverInteg, and I am using subSilver theme for now. My joomla theme has this

Code: Select all

BODY {
  background-color : #000000;
  color: #cccccc;
}


And mainCell and the span tags are used to fight this but these hacks do not seem to work. My guess is a problem in Internet Explorer or something in the CSS files it's overriding the elements. Either way maybe I should look for a new theme for Joomla.

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Tue May 30, 2006 1:10 pm

Try to clean your browser cache ...
Sometimes an old  css copy is kept in  browse cache ....
Otherwise  PM  me and send me link to your website so that I can take a (quick) look ...

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Tue May 30, 2006 2:57 pm

Hi mysticalone,
problem is pretty simple.
Your browser use by default a white background and black fonts.
Thus in the subsilver template, without "visual" integration, there's no need
to define default color for your background and default color for the font.
As soon as you enable "visual integration",
you are using by default  the font color defined by your Joomla's theme.
The problem can be easily fixed.
At the begin of your subSilverInteg.css just add:

Code: Select all

td.mainCell {
  background-color : #FFFFFF;
  color: #000000;
}


I'll add this the next time I update my bridge.

dehydratedchicken
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sat Mar 04, 2006 1:12 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby dehydratedchicken » Wed May 31, 2006 1:32 pm

Hi, I've just installed phpbb2 2.020, then CH and then the bridge

Ive fixed all template and file modifications to make it integrate properly - it now dispalys and works fine for me (the admin0 and for guests

However, as soon as a reigsterd member tries to enter the forum I get a

Code: Select all

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.


error.  I notice that people have also had similar problems and was wondering if anyone has managed to solve this

I have had a lot of problems getting CH to work with this bridge and just when I had it all figured out I get this problem right at the end.  Any help would be greatly appreciated

Regards

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Wed May 31, 2006 2:06 pm

hi dehydratedchicken (in powder ? I mean the dehydrated chicken  :laugh:)
until I take a closer look to CH and that I perform a
test on a live server consider there's no support for CH.

Now avoid to delete users from phpbb, (not Joomla, as I stated before, sorry for the mistake)
as it might induce a similar big  with or without CH.
If you can't wait that I release a fix for this bug ( would be done this week hopefully)
then delete joomphpbb_bridge table and recreate it. Now don't delete any more users from phpbb.
I'll try to  study CH this week too.

dehydratedchicken
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sat Mar 04, 2006 1:12 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby dehydratedchicken » Wed May 31, 2006 2:42 pm

Hi, Ok, I now have a slight improvement - i deleted the modifed sessions.php file from the includes folder and replaced it with the original file

this now appears to let registered members enter the forum for the first time

I cant see sub-forums anymore and now my Whos Online section at the bottom appears to be messed up

If anyone with perhaps more PHP knowledge is willing to help then I can send the original and CH version of the session file for you to have a look at and see what is causing this problem

best regards
Last edited by dehydratedchicken on Wed May 31, 2006 3:13 pm, edited 1 time in total.

User avatar
adec
Joomla! Explorer
Joomla! Explorer
Posts: 365
Joined: Sat Sep 03, 2005 8:56 pm
Location: UK
Contact:

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby adec » Wed May 31, 2006 5:53 pm

Hi Mehdi,

I just wanted to clarify something before I try your bridge...

At the moment i have Joomla installed at http://www.vincenttreacey.com ... and phpbb 2.20 (subsilver) installed at http://www.vincenttreacey.com/forum from what I've read this should be ok, and is a godsend not having to move the phpbb into the same database as Joomla...

The only query I had is that I've installed the attachment mod too .. is this still ok with your bridge ?

thanks

mehdi
Joomla! Explorer
Joomla! Explorer
Posts: 437
Joined: Tue Oct 04, 2005 3:56 pm

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby mehdi » Wed May 31, 2006 6:12 pm

hi ,
you mean that's a mod that allows attachement ... (because I see here no files in atachement  ;) ).
As long as it doesn't affect the way users are stored in phpbb database, I think it's ok.
Don't forget to use the quickprocess.bat file... Or modify all  files manually.
If there's new files introduced by the mod , then they  might need to be processed too...
In this case you have to modify quickprocess.bat because it processes only default files.
What's the critea to process file ? Well all pages that are seen from the frontend of phpbb
Normally, only files in the root(not files included by main pages)

User avatar
adec
Joomla! Explorer
Joomla! Explorer
Posts: 365
Joined: Sat Sep 03, 2005 8:56 pm
Location: UK
Contact:

Re: New Bridge for Phpbb 2.020 available (from Mehdi)

Postby adec » Wed May 31, 2006 7:01 pm

cool .. as soon as i get this phpbb 2.018 to 2.02 upg fixed i'll just go ahead and try your mod  :P

thanks

adec


Return to “phpbb - Joomla! Integration”

Who is online

Users browsing this forum: No registered users and 0 guests