Forbidden You don't have permission to access /administrator/index2.php on this

Need help upgrading your Joomla! website or converting to Joomla!?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
joomlaturk
Joomla! Explorer
Joomla! Explorer
Posts: 469
Joined: Thu Aug 18, 2005 10:40 pm
Location: las vegas USA
Contact:

Forbidden You don't have permission to access /administrator/index2.php on this

Postby joomlaturk » Fri Sep 01, 2006 4:43 am

İ go to site>>>template manager>>>site templates and try to EDİT HTML source.
when  I hit SAVE button I get this error message

Forbidden
You don't have permission to access /administrator/index2.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.37 Server at http://www.xxxxx.com Port 80


I use joomla 1011 . fresh installed.. SEF is closed. mambot patch is done.
Joomla! RG_EMULATION setting is `ON` instead of `OFF` in file globals.php ( I use joomlaboard forum)

Am I doing something wrong or this is from joomla 1011 bug??
Last edited by Anonymous on Fri Sep 01, 2006 4:46 am, edited 1 time in total.
joomla 1.6 Türk destek sitesi http://www.joomlaturk.net/

janstedehouder
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Sep 12, 2005 3:50 am

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby janstedehouder » Wed Sep 06, 2006 6:15 pm

I am having the same problem now. Earlier today everything was fine. I only updated the eWriting component. Now I get the same error message as mamboturk.

ivanji
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Sep 10, 2006 11:47 pm

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby ivanji » Mon Sep 11, 2006 12:21 am

This problem is not letting me continue doing changes on my template, same as you guys. Has anyone found the solution?

Everything was working fine and suddenly this thing happened. Any solution is really appreciated.

Forbidden
You don't have permission to access /administrator/index2.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.37 Server at xxxx.org Port 80



Ivan J

janstedehouder
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Sep 12, 2005 3:50 am

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby janstedehouder » Mon Sep 11, 2006 4:06 am

I am afraid no one came up with a solution other than restoring a backup of the site. So that is what I did.

User avatar
Hackwar
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3748
Joined: Fri Sep 16, 2005 8:41 pm
Location: NRW - Germany
Contact:

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby Hackwar » Mon Sep 11, 2006 4:14 pm

You have safe mode turned ON, which is preventing editing the file. turn it off or chown the file to your apache user.
god doesn't play dice with the universe. not after that drunken night with the devil where he lost classical mechanics in a game of craps.

Since the creation of the Internet, the Earth's rotation has been fueled, primarily, by the collective spinning of English teachers in their graves.

msmccue
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 22, 2006 8:11 pm

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby msmccue » Fri Sep 22, 2006 8:51 pm

I had the same problem with Joomla 1.0.11.  Everything worked great, even editing the configuration file, but I simply couldn't save or cancel out of editing the templates without generating a Forbidden error message.

It turned out that my hosting provider uses mod_security to protect the web server.  One of the rules looks for the string "mosConfig_absolute_path" and to return a Forbidden error.  This was added as a result of a rash of server incursions due to Joomla's old security problems a couple months ago.

That string shows up in the template's index.php, of course.  So, I edited the template and replaced the php code that inserts the absolute path with a hard-coded path.  It now works beautifully.

For example, I found the following near the bottom of the madeyourweb sample template:



I changed it to



and now I can edit at will.

Hope this helps somebody else.

Mike

MarkMcLT
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Mar 24, 2007 1:08 pm

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby MarkMcLT » Sat Mar 24, 2007 1:22 pm

I've just been dealing with this same problem on a clean install of 1.0.12.

The problem was not PHP Safe Mode. mod_security was the right clue, but changing the template index.php wasn't the solution for me. I was having problems with the rhuk_solarflare_ii template, not madeyourweb, and replacing $mosConfig_absolute_path did not help.

However I was able to disable mod_security from my host's (Server Logistics) site control panel by adding:

SecFilterEngine Off

to the configuration file.

Also see the following:

http://modsecurity.org/documentation/mo ... tml#N10152

Whether disabling mod_security is a good idea in general is a separate question, but it has solved my immediate problem.


Mark.

msmccue
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 22, 2006 8:11 pm

Re: Forbidden You don't have permission to access /administrator/index2.php on t

Postby msmccue » Sun Mar 25, 2007 1:34 am

I have not looked at this in a while, but I recall being able to set a SecFilter setting in my .htaccess that displayed the error message someplace that I could view (like /tmp/mysecoutput), then I did whatever generated the error, then read the output to determine the string that caused the issue.

You might try this in your htaccess:

SecFilterDebugLog /tmp/whatsmyloginid.myoutput  #just make sure the file name isn't already being used

Then, run the program or script to cause the failure, then examine the debug log output (found in /tmp/whatsmyloginid.myoutput).  If that doesn't work, then perhaps you can ask your hosting provider to tell you where the default SecFilterDebugLog is pointing and to let you know what is being recorded (if you can't view it yourself).

The general idea is that mod_security is catching something in the script that is probably harmless, and all you need to know is the string it doesn't like so you can make the necessary change in order to keep the security turned on.  Good luck!

Mike

waderw24
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Sat Oct 21, 2006 2:25 am
Location: VA, USA

Re: Forbidden You don't have permission to access /administrator/index2.php on this

Postby waderw24 » Fri Jun 01, 2007 4:31 am

the problem for me was that the template I was trying to upload had a TGZ extension, so I extracted it and then zipped it up , uploaded via template installer and it worked.

hope this helps.
Joomla! n00b - Thanks for your patience while I learn! :)

User avatar
miletic
I've been banned!
Posts: 134
Joined: Thu Aug 02, 2007 5:37 am
Location: Čečava
Contact:

Re: Forbidden You don't have permission to access /administrator

Postby miletic » Sun Feb 08, 2009 8:00 pm

I have same problem. I tray to install MyFriend component for CB. After editing component configuration I can't acces to /administrator. Site works fine, only links who started with /administrator not work... Someone?? (Joomla 1.0.15) :( ???
Tuga gleda unatrag, briga gleda okolo, a samo vjera, gleda gore.

rahulsonar
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Mar 19, 2009 6:18 am

Re: Forbidden You don't have permission to access /administrator

Postby rahulsonar » Thu Mar 19, 2009 6:21 am

Me too Having the same issue. I have tried all the solutions mentioned here, but no luck :(

Please help!!!!!

jeanw
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Jun 01, 2009 3:03 am

Re: Forbidden You don't have permission to access /administrator

Postby jeanw » Fri Jun 26, 2009 7:18 am

I've been searching these posts all day looking for a solution and found it on a google search. This worked for me:

Add the following lines to the .htaccess file in public_html.

Add lines to to end of file..

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

I'm no techie, but I've stopped getting that annoying error.

Jean

buffalohole
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Mon Mar 23, 2009 6:45 pm

Re: Forbidden You don't have permission to access /administrator

Postby buffalohole » Sat Jan 23, 2010 6:19 pm

Folks, Having an issue with Chronoforms. Set up the form, emails etc. and try to save and then get:

"You don't have permission to access /mysite/administrator/index2.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

The thing is that the demo form you can install works but when you dare to try to change the look and feel you get the heave-ho and the above permission error message. My host says permissions are fine, no word from Chronoform so I am relying on the good folk of the Joomla forum to help.
its a good looking form tool, now if it just worked!!!

is it a Joomla issue or something else? I have seen comments above ref "SAFE MODE and hta.access. Not exactly the greatest geek folks so if you can keep it simple.

Thanks in advance.

decomo95
Joomla! Intern
Joomla! Intern
Posts: 87
Joined: Mon Apr 27, 2009 3:30 pm
Location: San Jose, California
Contact:

Re: Forbidden You don't have permission to access /administrator

Postby decomo95 » Tue Mar 30, 2010 1:56 am

I have the same problem. None of my images can be accessed. The only things that are displayed are the description of the images. Whenever I tried to open an image, I get the error message "you don't have permission...". I have the .htaccess file with the SEF global setting turned on. I also tried to modify the .htaccess file by adding the lines suggested by jeanw, but neither one worked.
The weird thing about this is that my site has been running fine with all the images properly displayed. I am not sure what happened, but the images just cannot be displayed anymore.

Update: seems like there are many people experiencing this same error message but the situations are somewhat different. I am opening a new thread so as not to distract the current thread. thx.
http://www.drugzoo.com
Helping Consumers Reduce Drug Costs
http://Zlancer.com
Connecting Buyers and Freelancers to get projects completed.

TemhAAhmeT
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Oct 30, 2010 7:09 pm

Re: Forbidden You don't have permission to access /administr

Postby TemhAAhmeT » Sat Oct 30, 2010 7:46 pm

is there any other way to make this setting off? i submitted support ticket and waiting answer. if they say they cant change this setting, what can i do?

thanks

samreaksa
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Dec 25, 2010 2:55 am

Forbidden You don't have permission to access

Postby samreaksa » Tue Feb 01, 2011 8:23 am

Forbidden
You don't have permission to access /joomla on server.
--------------------------------------------------
Please help me........
i have install mamp server on my mac and change port form 8888 to 80 and
mysql 8889 to 80. but still can not access to install my joomla to mamp
server.

please help me......

Jayden
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Feb 23, 2009 3:08 am

Re: Forbidden You don't have permission to access /administr

Postby Jayden » Fri Jul 29, 2011 7:43 am

For me the folder permissions on the public_html folder were causing the issue. They were 744, I changed to 755 and it fixed it.

magaparlay
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Sep 10, 2011 11:17 am

Re: Forbidden You don't have permission to access /administr

Postby magaparlay » Sat Sep 10, 2011 11:26 am

Another common cause as well as permissions is the ownership of the file. You should chown on your webhost the owner to your webhosting accout, or 'nobody'. Then attempt to chmod with the correct permissions.

User avatar
costicanu
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Jan 12, 2009 9:05 pm
Location: Ploiesti, Romania
Contact:

Re: Forbidden You don't have permission to access /administr

Postby costicanu » Tue Sep 20, 2011 1:32 pm

That message is a temporary thing. I used sh404sef and a configuration thing caused this problem for me. From sh404sef Configuration >> Security >> and then you can deactivate anti-flood from there, or growing those requests numbers.

jalpesh
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Feb 10, 2011 10:08 am

Re:You don't have permission to access /images/resized/image

Postby jalpesh » Wed Dec 07, 2011 1:12 pm

Forbidden

You don't have permission to access /images/resized/images/stories/cd_410_200.jpg on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at demo.popsci.in Port 80

sistemifalcspa
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Jan 05, 2012 9:33 am
Location: Italy
Contact:

Re: Forbidden You don't have permission to access /administr

Postby sistemifalcspa » Fri Mar 09, 2012 9:37 am

if you use the Security htaccess or similar to increase the security , add this on the folder /Public_Folder/administrator :
add one file:
.htaccess
edit it and add
RewriteEngine Off
Order deny,allow
Deny from all
Allow from YourIP
Allow from 127.0.0.1
Allow from Your IP
( More line if you need )

Save.

in this way , you don't lost security level of your site and you don't receive the error.

;=) ciao

Jarod545
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Fri May 25, 2012 10:25 am
Contact:

Re: Forbidden You don't have permission to access /administr

Postby Jarod545 » Mon May 28, 2012 10:35 am

i got this message one time but it disappeared , i still dont know how that happen

mianjee
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Apr 22, 2013 1:26 pm

Re: Forbidden You don't have permission to access /administr

Postby mianjee » Mon Apr 22, 2013 1:28 pm

Try to disable or edit SE Linux settings as it worked for me. (If you are installing it on linux)


Return to “Upgrading - 1.0.x”

Who is online

Users browsing this forum: No registered users and 2 guests