http://localhost/joomla/

Need help installing Joomla!? For all Joomla! installation issues please use this forum.
Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

http://localhost/joomla/

Postby lowleong » Sun Mar 04, 2007 4:29 am

what happening ? i got the error message below ?
my localhost is on F [drive] and use the wamp as mine server. 
when i http://localhost/joomla/ i got error page ?

Warning: require_once(/path/to/joomla/install/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in F:\wamp\www\joomla\includes\joomla.php on line 71

Fatal error: require_once() [function.require]: Failed opening required '/path/to/joomla/install/includes/version.php' (include_path='.;C:\php5\pear') in F:\wamp\www\joomla\includes\joomla.php on line 71

dragonrider
Joomla! Ace
Joomla! Ace
Posts: 1045
Joined: Mon Aug 22, 2005 7:53 pm
Location: Ilkley, West Yorkshire, UK
Contact:

Re: http://localhost/joomla/

Postby dragonrider » Sun Mar 04, 2007 8:26 am

Is wamp running? Are you sure that the file is there? Have you not loaded all the files to your local installation? It has been known. ???

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9350
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: http://localhost/joomla/

Postby RussW » Sun Mar 04, 2007 8:38 am

Have you run the Web-installer yet? It looks like you have copied/renamed configuration.php-dist to configuration.php before running the installer. Either delete configuration.php or rename it and then run the Web-installer

Warning: require_once(/path/to/joomla/install/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in F:\wamp\www\joomla\includes\joomla.php on line 71


/path/to/joomla/install/ is the default example path in configuration.php-dist
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
Network SMARTS, Systems Engineering http://www.networksmarts.com.au/

lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

Re: http://localhost/joomla/

Postby lowleong » Sun Mar 04, 2007 4:39 pm

i have try to delete the configuration.php file or rename it and start wamp again
but seems no use ...
i still get the error page ?
i dont understand what is this means ?
i sure wamp is running ... and all the file is on there ...

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9350
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: http://localhost/joomla/

Postby RussW » Sun Mar 04, 2007 7:51 pm

What message or error do you see now?
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
Network SMARTS, Systems Engineering http://www.networksmarts.com.au/

lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

Re: http://localhost/joomla/

Postby lowleong » Mon Mar 05, 2007 1:53 pm

i don't understand what is that means ?
the error as below

Warning: require_once(/path/to/joomla/install/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in F:\wamp\www\joomla\includes\joomla.php on line 71

Fatal error: require_once() [function.require]: Failed opening required '/path/to/joomla/install/includes/version.php' (include_path='.;C:\php5\pear') in F:\wamp\www\joomla\includes\joomla.php on line 71

fc102184
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed Jan 31, 2007 1:31 pm
Location: The Netherlands
Contact:

Re: http://localhost/joomla/

Postby fc102184 » Mon Mar 05, 2007 3:35 pm

Hi,

I recommend to re-install Joomla and run the web-installer.
The configuration.php file is not correct and when you are going to edit this, it is even better just to re-install Joomla and use the web-installer.
And after that, keep your hands off the configuration.php file for a while. ;)

Cheers,
Gerard Nijboer

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9350
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: http://localhost/joomla/

Postby RussW » Mon Mar 05, 2007 8:05 pm

Otherwise, a quick option would be to change $mosConfig_absolute_path  from  /path/to/joomla/install/    to    F:\wamp\www\joomla\  then  change $mosConfig_live_site  if needed to " http://localhost/joomla "    in your configuration.php

See ow that goes, a lot easier than having to reinstall...
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
Network SMARTS, Systems Engineering http://www.networksmarts.com.au/

lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

Re: http://localhost/joomla/

Postby lowleong » Tue Mar 06, 2007 3:28 pm

hi
i have reinstall the wamp and unzip joomla in www folder run again still get the same
error page as below

Warning: require_once(/path/to/joomla/install/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in F:\wamp\www\joomla\includes\joomla.php on line 71

Fatal error: require_once() [function.require]: Failed opening required '/path/to/joomla/install/includes/version.php' (include_path='.;C:\php5\pear') in F:\wamp\www\joomla\includes\joomla.php on line 71

and after that i change the /path/to/joomla/install/    to    F:\wamp\www\joomla\  and $mosConfig_live_site  change to http://localhost/joomla i get the error message below

Parse error: parse error, unexpected T_STRING in F:\wamp\www\joomla\configuration.php on line 39

whats that means ?

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: http://localhost/joomla/

Postby ianmac » Tue Mar 06, 2007 3:49 pm

Go into your www folder and delete (or rename) configuration.php and try the web installer again.

The unexpected T_STRING was a syntax error in your configuration file.  If you have not run the installer, you should not have a configuration file.

Ian

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9350
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: http://localhost/joomla/

Postby RussW » Tue Mar 06, 2007 8:25 pm

delete the configuration.php and run the Web-Installer
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
Network SMARTS, Systems Engineering http://www.networksmarts.com.au/

lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

Re: http://localhost/joomla/

Postby lowleong » Wed Mar 07, 2007 3:38 pm

hi

i have delete the file or rename the configuration.php-dist to cofiguration.php it still get
the same error message ??? i don't know why !!!

if i delete the configuration.php file it will show "page cannot found"
if i rename the configuration.php-dist to configuration.php it show as below

Warning: require_once(/path/to/joomla/install/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in F:\wamp\www\joomla\includes\joomla.php on line 71

Fatal error: require_once() [function.require]: Failed opening required '/path/to/joomla/install/includes/version.php' (include_path='.;C:\php5\pear') in F:\wamp\www\joomla\includes\joomla.php on line 71

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: http://localhost/joomla/

Postby ianmac » Wed Mar 07, 2007 4:55 pm

delete everything in your F:\wamp\www\joomla directory (subdirectories and all), download the zip package again and unzip it.  Then give it a try.

You do NOT want to copy configuration.php-dist to configuration.php - this will NOT work.

Ian

lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

Re: http://localhost/joomla/

Postby lowleong » Thu Mar 08, 2007 4:16 pm

is that other way to install joomla ? i really like it ...
or i change the wamp server to other ?
pls give a clue ...

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4785
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: http://localhost/joomla/

Postby ianmac » Thu Mar 08, 2007 4:30 pm

I'm not sure I fully understood you.

Please see: http://help.joomla.org/content/category/15/99/132/ for the installation manual.

You should have no problem using Wamp.

Ian

lowleong
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jul 18, 2006 9:11 am

Re: http://localhost/joomla/

Postby lowleong » Sat Mar 10, 2007 4:54 pm

HI ALL

thank for advice i download the "Joomla_1.0.12-Stable-Full_Package" instead of "Joomla_1%2e0%2e0_to_1%2e0%2e12-Stable-Patch_Package"

and not problem with installation ...


Return to “Installation - 1.0.x”

Who is online

Users browsing this forum: No registered users and 6 guests