The Joomla! Forum ™






Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun May 27, 2007 8:13 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Feb 08, 2006 7:14 am
Posts: 44
I run a Joomla site.  The backend database is all the default latin...swedish... encoding.  However, the data is stored as Japanese EUC and everything displays correctly in Joomla.  However, I have 2 problems:

1) I need to get the data out of mySQL.  When I try to export the "content" table, everything turns to junk and it certainly doesn't maintain the encodings.  I am trying to do this through phpMyAdmin. 

2) I need to import a file into a database table.  The file is an EUC encoded CVS file.  In phpMyAdmin, I specify the import file as "CSV" encoding "Japanese EUC" and everything goes well.  However, all the Japanese is turned into question marks.

What I really don't understand is why I can submit Japanese from an HTML page and have it store perfectly in mySQL, I can view the data perfectly via a web page, but I just can't seem to get anything out or in via phpMyAdmin.

Can someone clear this up and explain to me how to get data into/out of mySQL?

Thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 



Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group