The Joomla! Forum ™

Forum rules

Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.

Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri Jul 13, 2007 8:20 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jul 13, 2007 7:18 am
Posts: 2
I use Joomsef (or sh404sef) for my website, but Joomsef(or sh404sef)  can not support lighhtpd. If we want to use lighttpd, how to config lighttpd in our lighttpd.conf?

Anybody know which SEF extensions can support lighttpd, and know how to configure lighttpd, please tell me, thank you!

Following is our lighttpd.conf. VirtueMart can not rewrite. Can you help me? Thank you!

$HTTP["host"] == "" {
$HTTP["url"] =~ "^.*(html|php|/).*$" {
magnet.attract-physical-path-to = ("/etc/lighttpd/joomla.lua")

server.document-root = "/var/www/php"
# server.error-handler-404 = "/dispatch.fcgi"
fastcgi.server = ( ".php" =>
( "phpapp" =>
( "socket" => "/var/tmp/php-fastcgi.socket",
"bin-path" => "/usr/bin/php-cgi",
"max-procs" => 2
url.rewrite-once = (
"^images*.(jpg|jpeg|gif|png)" => "$0",
"^/administrator.*$" => "$0",
"^/mambots.*$" => "$0",
"^/shop/(/|.htm|.php|.html|/[^.]*)$" => "/index.php",
"^/outac-blog/(/|.htm|.php|.html|/[^.]*)$" => "/index.php",
"^/help-with-faq/(/|.htm|.php|.html|/[^.]*)$" => "/index.php",
"^/outac-s-news/(/|.htm|.php|.html|/[^.]*)$" => "/index.php",
"(/|.htm|.php|.html|/[^.]*)$" => "/index.php"

PostPosted: Fri Jul 13, 2007 8:23 am 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Fri Aug 19, 2005 8:46 am
Posts: 3011
Location: Stockholm, Sweden
Mod Note Lorenzo: Moving this thread from Extensions Directory Forum >> 3rd Party Extensions/Components

Industributik -

PostPosted: Mon Jul 16, 2007 12:45 pm 
Joomla! Guru
Joomla! Guru

Joined: Sat Aug 20, 2005 3:15 pm
Posts: 508
Hi mrunix,

I have just released a new version of sh404SEF. It has an operating mode which does not require mod_rewrite, but relies on path info to operate. I'd be curious to know if this works with lighhtpd, but have no time to research this.
Beware this is not the default operating mode, you have to install, then go to configuration and set Rewrite mode to "no .htaccess".
There are actually two no .htaccess modes, just try both but be sure to purge sef url in between.


See all about sh404sef and Josetta at
I don't reply to PM anymore. Thanks for using sh404SEF

PostPosted: Sat Jul 16, 2011 10:21 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jun 27, 2011 1:59 pm
Posts: 23
Location: Thailand
1, switch apache to lighttpd in ur VPS/VDS

2, go to enable FastCGI:
1) Domain home–Domain Features–set Number Of Fastcgi and enable FASTcgi.

very important: if you enable Xcache, please must set the number to 1, otherwise your RAM will be eaten by many zombie.

To check this, run “netstat -anpo|grep “php-cgi”|wc -l”, if the result is “0″, it means you should change your number of fastcgi process mumber.

2) Domain home–domain–Fcgi Configuration–enable

3, add this to etc/lighttpd/lighttpd.conf

server.error-handler-404   = “/index.php”

4) Configure Joomla

on Joomla administrator panel, Global Configuration–SEO Settings–enable “Use Apache mod_rewrite” and “Search Engine Friendly URLs”, and in SH404SEF Configuration, select “with .htaccess(mod_rewrite)”.

5) done.

If you enable Joomla cache, you may can not delete the cache files on “Clean Cache”. In this case, go to Kloxo File Manager, deleted all cache files.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group