[MEDIUM:CONFIRMED:7714] Search Component - Problem with character "ň" and utf-8

This forum is for reporting bugs in Joomla!. Please don't report problems with extensions in here.
Forum rules
Forum Rules
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1255
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

[MEDIUM:CONFIRMED:7714] Search Component - Problem with character "ň" and utf-8

Postby H13 » Fri Jun 22, 2007 8:15 am

Hi to all, I am having problem with Search Component. If I enter "ň" character into search box I get the following error:

Warning: utf8_to_unicode: Incomplete multi-octet sequence in UTF-8 at byte 1 in D:\www\joomla\libraries\phputf8\utils\unicode.php on line 176

The same error was in [6719] but in [6731] not more.
http://forum.joomla.org/index.php?actio ... board=11.0

The next problem is, the search component change characters. e.g. in Czech language: 'žluťoučký kůň' to 'žluÅ¥ouÄ�ký kůÅ_' in search area.
Last edited by Robin on Sun Oct 21, 2007 5:46 pm, edited 1 time in total.
- Phoca Gallery - simple image gallery with slideshow - http://www.phoca.cz/phocagallery/
- Phoca Restaurant Menu - http://www.phoca.cz/restaurantmenudemo/

User avatar
akede
Joomla! Ace
Joomla! Ace
Posts: 1636
Joined: Fri Aug 12, 2005 6:15 am
Location: Munich, Germany
Contact:

Re: [7714] J!1.5 - Search Component - Problem with character "ň" and utf-8

Postby akede » Fri Jun 22, 2007 9:22 am

Hi,

I notified one of the devs about it - they need to check.


Alex
Joom!Fish 2.0 your free multilingual solution for Joomla! 1.5 i - http://www.joomfish.net - follow us on twitter @joomfish
Meet us at J and Beyond, 30.05 - 1.06.10, Wiesbaden, Germany - http://jandbeyond.org

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: [7714] J!1.5 - Search Component - Problem with character "ň" and utf-8

Postby friesengeist » Fri Jun 22, 2007 9:44 am

H13 wrote:The next problem is, the search component change characters. e.g. in Czech language: 'žluťoučký kůň' to 'žluÅ¥ouÄ�ký kůÅ_' in search area.


Confirmed.

Jinx, I'm wondering why we have to do a redirect after entering a search term at all, IMO it would be enough to have the search module perform a "GET" request to the correct URL, e.g. without SEF
or with SEF . I don't see any reason why the search term should be part of the URL, usually one does not want to have search engines index the our own search results ???

Alex, I think this thread should be moved to the 1.5 Q&T forum...
We may not be able to control the wind, but we can always adjust our sails

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [7714] J!1.5 - Search Component - Problem with character "ň" and utf-8

Postby Robin » Thu Jun 28, 2007 8:30 am

Mod note; moving to 1.5 Q&T

User avatar
CirTap
Joomla! Explorer
Joomla! Explorer
Posts: 418
Joined: Mon Dec 12, 2005 5:34 pm

Re: [7714] J!1.5 - Search Component - Problem with character "ň" and utf-8

Postby CirTap » Thu Jun 28, 2007 2:53 pm

friesengeist wrote:I don't see any reason why the search term should be part of the URL, ...

users may want to bookmark a "search result", and since the purpose of a search is the GET data from a system not to store (POST), the search phrase/term must be present in the URL.
http://www.w3.org/2001/tag/doc/whenToUseGet.html

The fact that an application may in addition save the incoming search term is not relevant from the user's p.o.v. Even if GETting data may imply data storage (for statistics) in the backend, using GET is still appropriate.

Have fun,
CirTap
You can have programs written fast, well, and cheap, but you only get to pick 2 ...

"I love deadlines. I like the whooshing sound they make as they fly by." Douglas Adams

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: [7714] J!1.5 - Search Component - Problem with character "ň" and utf-8

Postby friesengeist » Thu Jun 28, 2007 5:18 pm

CirTap wrote:
friesengeist wrote:I don't see any reason why the search term should be part of the URL, ...

users may want to bookmark a "search result", and since the purpose of a search is the GET data from a system not to store (POST), the search phrase/term must be present in the URL.
http://www.w3.org/2001/tag/doc/whenToUseGet.html


I should have written more clearly what I meant ;) The search word should be part of the URL which the user sees, but not part of the "static" parts within slashes. So something like http://localhost/joomla/search?q=blablabla is OK, whereas I don't see any reason why it should be http://localhost/joomla/search/blablabla.
We may not be able to control the wind, but we can always adjust our sails

User avatar
CirTap
Joomla! Explorer
Joomla! Explorer
Posts: 418
Joined: Mon Dec 12, 2005 5:34 pm

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby CirTap » Thu Jun 28, 2007 6:20 pm

friesengeist wrote:something like http://localhost/joomla/search?q=blablabla is OK, whereas I don't see any reason why it should be http://localhost/joomla/search/blablabla.

ok, I see...
it could be arguable whether form-submitted data should be transformed into a path-like URI ... likely to become error-prone. doesn't make writing rules for routing any easier.

CirTap
You can have programs written fast, well, and cheap, but you only get to pick 2 ...

"I love deadlines. I like the whooshing sound they make as they fly by." Douglas Adams

Websitemaker
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 246
Joined: Fri Sep 16, 2005 3:14 pm

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby Websitemaker » Mon Jul 30, 2007 1:19 pm

rev 8242 - still the same problem with local characters in search string .... 

if i try to search string "čćžšđČĆŽŠĐ" ... Joomla try to search string "Ä_Ä�žšÄ�Ä�Ä�ŽŠÄ_"

drank
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Sep 14, 2006 10:52 am

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby drank » Sat Aug 25, 2007 2:17 pm

Hi,

I have RC1 and still get this behavior when I search in Bulgarian - "тест" becomes "Ñ�еÑ�Ñ�".

Regards

User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1255
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby H13 » Sat Aug 25, 2007 2:40 pm

Last SVN - [8553] - still the same problem ... :P
- Phoca Gallery - simple image gallery with slideshow - http://www.phoca.cz/phocagallery/
- Phoca Restaurant Menu - http://www.phoca.cz/restaurantmenudemo/

User avatar
Jinx
Joomla! Champion
Joomla! Champion
Posts: 6569
Joined: Fri Aug 12, 2005 12:47 am
Contact:

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby Jinx » Sat Aug 25, 2007 3:01 pm

I have made changes on SVN, could you guys recheck this issue ?
Johan Janssens - Joomla Co-Founder, Lead Developer of Joomla 1.5

http://www.joomlatools.com - Joomla extensions that just work

Websitemaker
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 246
Joined: Fri Sep 16, 2005 3:14 pm

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby Websitemaker » Sun Aug 26, 2007 9:04 am

well it works with few characters but with some not ...

for example if i search "čćžđČŽĆĐ"  (slovenian special characters)

i get this link and it produces error (first and last characters are not right in searchword):

http://localhost/j15/index.php?searchwo ... om_content


searchword should be: 

searchword=%C4%8D%C4%87%C5%BE%C4%91%C4%8C%C5%BD%C4%86%C4%90



edit: 

also this string "šŠ" produces error

http://localhost/j15/index.php?searchwo ... om_content

but searchword is OK:  searchword=%C5%A1%C5%A0
Last edited by Websitemaker on Sun Aug 26, 2007 9:14 am, edited 1 time in total.

User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1255
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby H13 » Sun Aug 26, 2007 10:35 am

[8559] I still get the same error messages:

Notice: Trying to get property of non-object in D:\www\Joomla16\components\com_search\search.php on line 78
Warning: utf8_to_unicode: Incomplete multi-octet sequence in UTF-8 at byte 1 in D:\www\Joomla16\libraries\phputf8\utils\unicode.php on line 176
Warning: utf8_to_unicode: Incomplete multi-octet sequence in UTF-8 at byte 1 in D:\www\Joomla16\libraries\phputf8\utils\unicode.php on line 176


and ?_ instead of Czech characters ň, Ř, Á in Search Keyword form and in Search for ... with Google
- Phoca Gallery - simple image gallery with slideshow - http://www.phoca.cz/phocagallery/
- Phoca Restaurant Menu - http://www.phoca.cz/restaurantmenudemo/

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [UNDER REVIEW:7714] Search Component - Problem with character "ň" and utf-8

Postby Robin » Sun Aug 26, 2007 11:44 am

Q&T Note; changing status to confirmed

User avatar
kelb
Joomla! Guru
Joomla! Guru
Posts: 602
Joined: Mon Oct 02, 2006 3:08 am
Location: Turkey
Contact:

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with character "ň" and utf-8

Postby kelb » Tue Oct 16, 2007 10:20 pm

Fixed.
Every soul will taste of death.

User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1255
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with character "ň" and ut

Postby H13 » Wed Oct 17, 2007 8:43 am

Great!
- Phoca Gallery - simple image gallery with slideshow - http://www.phoca.cz/phocagallery/
- Phoca Restaurant Menu - http://www.phoca.cz/restaurantmenudemo/

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with character "ň" and ut

Postby Robin » Wed Oct 17, 2007 10:06 am

Confirmed and moving to resolved.

User avatar
Jinx
Joomla! Champion
Joomla! Champion
Posts: 6569
Joined: Fri Aug 12, 2005 12:47 am
Contact:

Re: [MEDIUM:FIXED:7714] Search Component - Problem with character "ň" and utf-8

Postby Jinx » Sat Oct 20, 2007 5:44 pm

Robin, you sure this has been fixed ?
Johan Janssens - Joomla Co-Founder, Lead Developer of Joomla 1.5

http://www.joomlatools.com - Joomla extensions that just work

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:FIXED:7714] Search Component - Problem with character "ň" and utf-8

Postby Robin » Sat Oct 20, 2007 6:53 pm

Jinx wrote:Robin, you sure this has been fixed ?


Hi Johan,

I tested just about everything that got reported in the thread. But I'll move it back to be sure, and re-test.

User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1255
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

Re: [MEDIUM:FIXED:7714] Search Component - Problem with character "ň" and utf-8

Postby H13 » Sat Oct 20, 2007 7:16 pm

Hi,

If I have a word e.g. "ňiň" in article and I want to search it with search function, I get no error message, but search function doesn't find this word.

e.g. there is a word "ňiň".

- I search "ňiň" - I get no results
- I search "nin" - I get all words which contain "ňiň"

SVN 9256

Jan
- Phoca Gallery - simple image gallery with slideshow - http://www.phoca.cz/phocagallery/
- Phoca Restaurant Menu - http://www.phoca.cz/restaurantmenudemo/

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:FIXED:7714] Search Component - Problem with character "ň" and utf-8

Postby Robin » Sun Oct 21, 2007 5:46 pm

I tested again, also with the latest results H13 posted. What I can confirm is the fact that too many results are returned so it does not look fixed yet. Re-opening report again.

darwajamadhu
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Apr 10, 2008 7:05 am

Search box is not displaying special characters

Postby darwajamadhu » Thu Apr 10, 2008 8:02 am

i am searching for "vote “no,” will" .first time it is giving results.but in the search box it is dispalying special chars for the double quotes.if i search as exact search,the result is not coming.why bcz,the double quotes are replaced with special chars in the search box.any solution for this?pls help me.

giris
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Feb 18, 2008 1:53 pm

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with char

Postby giris » Wed Apr 23, 2008 11:49 am

It seems that the problems with local characters is still there when you use an IIS as server, my testserver is an Apache and there it seems to work out fine.

IIS: http://www.naturpasset.se/index.php/com ... phrase=all

Apache: http://nrespons.itmedia.se/index.php/co ... phrase=all

Any ideas how to solve it on the IIS?

/Per-Erik

User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1255
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with char

Postby H13 » Wed Apr 23, 2008 12:45 pm

Hi, try to change the collation of your database tables (database, tables, columns). For me it works, I have had the latin_swedish collation (mysql default) in my columns. After changing it to utf-8 it works for me...
See: http://www.phoca.cz/articles/web/how-to ... -database/

Maybe it will help you.

Jan

giris
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Feb 18, 2008 1:53 pm

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with char

Postby giris » Wed Apr 23, 2008 8:25 pm

My tables and columns is already configured for UTF-8 :(

/Per-Erik

foo123
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu May 05, 2011 5:20 pm

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with

Postby foo123 » Wed May 11, 2011 10:28 am

For anyone that might be having a similar problem here is a solution to
unicode.php incomplete mutli-octet error.

I had this error when transferring articles form JCE to notepad++ and back.
With utf-8 encoding seems some character(s) didn't get encoded well, anyway
Change this in unicode.php at libraries/phputf8/utils/unicode.php line 167 onwards

Code: Select all

           
 } else {
                /**
                *((0xC0 & (*in) != 0x80) && (mState != 0))
                * Incomplete multi-octet sequence.
                */
                /*trigger_error(
                        'utf8_to_unicode: Incomplete multi-octet '.
                        '   sequence in UTF-8 at byte '.$i,
                        E_USER_WARNING
                    );

                return FALSE;*/
                    //initialize UTF8 cache
                    // mine
               $mState = 0;
                    $mUcs4  = 0;
                    $mBytes = 1;
            }


as for when this error happens when inserting foreign chars into searchboxes etc..
in Joomla 1.5.22 with JoomFish 2 and Virtuemart 1.1.8 when inserting foreign chars into searchboxes seems to work correctly.
Anyway just type the chars in a text-editor encode in utf8 and paste into search box
but previous hack would also do the job..

meldweny
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Wed Nov 07, 2007 4:27 pm

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with

Postby meldweny » Sun Feb 05, 2012 1:34 pm

i have the same error after installing jomsocial joomla 1.7
foo123
i tried your code but it gives blank page

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 21375
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: [MEDIUM:CONFIRMED:7714] Search Component - Problem with

Postby Per Yngve Berg » Sun Feb 05, 2012 7:16 pm

meldweny: This thread is from 2007 and is for Joomla 1.5.

Post your question making a new topic in the appropriate forum (j2.5/1.7).


Return to “Joomla! 1.5 Bug Reporting”

Who is online

Users browsing this forum: No registered users and 7 guests