Turning off Live Site Edit Option when logged in as Editor

Need help with the Administration of your Joomla! site? Pop your questions in here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
exrace
Joomla! Explorer
Joomla! Explorer
Posts: 281
Joined: Tue Aug 23, 2005 4:55 am
Location: On my CBR 1000rr...

Turning off Live Site Edit Option when logged in as Editor

Postby exrace » Sat Oct 08, 2005 2:39 pm

Is there a way to toggle off the "Edit" function when logged in as a user who can edit content?
The current template I am using and its corresponding CSS used makes the live site editor quite ugly and unreadable.
I will have my editors use the admin site instead until I can get the editor code to display correctly.

Doesn't look to be an option in global config.
Last edited by exrace on Sat Oct 08, 2005 4:34 pm, edited 1 time in total.
Love, Live PHP.
Love, Live Joomla!
Super Sonic Man...do you want to buy a RockeTheme rocket? -Gary Jules

User avatar
Slixter
Joomla! Ace
Joomla! Ace
Posts: 1572
Joined: Wed Aug 17, 2005 9:48 pm
Location: St Cloud, MN
Contact:

Re: Turning off Live Site Edit Option when logged in as Editor

Postby Slixter » Sat Oct 08, 2005 7:36 pm

Not without editing the code somewhere I would think, no option in the admin backend for that currently.

--Slixter
--Search the forums and you will find your answer

Ishmael
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Tue Aug 23, 2005 7:56 pm
Location: Orlando, FL
Contact:

Re: Turning off Live Site Edit Option when logged in as Editor

Postby Ishmael » Sat Oct 08, 2005 8:59 pm

exrace wrote:Is there a way to toggle off the "Edit" function when logged in as a user who can edit content?
The current template I am using and its corresponding CSS used makes the live site editor quite ugly and unreadable.
I will have my editors use the admin site instead until I can get the editor code to display correctly.

Doesn't look to be an option in global config.


I'm quite familiar with this problem having dealt with it recently. It is going to require access to the files on the server and a little editing PHP editing if you feel up to it.

The first thing to do is go to the /templates/yourtemplate/css directory and copy the template.css file;

cp template_css.css editor_template_css.css

I'm going to assume you're using Tinymce or area3xtd as your editor. The technique is the same for both.

If you're using tinmce go to /mambots/editors and open tinymce.php with vi. You'll find a line that looks like this:

$content_css    = 'content_css : "'. $mosConfig_live_site .'/templates/'. $template .'/css/template_css.css"';

Change it to this:

$content_css    = 'content_css : "'. $mosConfig_live_site .'/templates/'. $template .'/css/editor_template_css.css"';

Now go edit the editor_template_css.css for the color scheme that makes the editor usable.

User avatar
exrace
Joomla! Explorer
Joomla! Explorer
Posts: 281
Joined: Tue Aug 23, 2005 4:55 am
Location: On my CBR 1000rr...

Re: Turning off Live Site Edit Option when logged in as Editor

Postby exrace » Sat Oct 08, 2005 10:36 pm

Thanks!
I will give this a try and post back with my results.
Love, Live PHP.
Love, Live Joomla!
Super Sonic Man...do you want to buy a RockeTheme rocket? -Gary Jules

User avatar
carreon
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Sat Oct 08, 2005 11:16 pm
Location: Mexicali, Baja California, México
Contact:

Re: Turning off Live Site Edit Option when logged in as Editor

Postby carreon » Sun Oct 09, 2005 11:48 pm

It looks youre in the way to fix the main problem, anyway if still need to disable frontend edition then you can edit the file "includes/gacl.class.php" commenting some or all the following lines:

Code: Select all

      // actions
      $this->_mos_add_acl( 'action', 'add', 'users', 'author', 'content', 'all' );
      $this->_mos_add_acl( 'action', 'add', 'users', 'editor', 'content', 'all' );
      $this->_mos_add_acl( 'action', 'add', 'users', 'publisher', 'content', 'all' );
      $this->_mos_add_acl( 'action', 'edit', 'users', 'author', 'content', 'own' );
      $this->_mos_add_acl( 'action', 'edit', 'users', 'editor', 'content', 'all' );
      $this->_mos_add_acl( 'action', 'edit', 'users', 'publisher', 'content', 'all' );
      $this->_mos_add_acl( 'action', 'publish', 'users', 'publisher', 'content', 'all' );


Once you fix the main problem then you can remove the added comments and get it back to original.
Roberto Carreón
http://www.roalcana.com/ - Professional Extensions for Joomla!™


Return to “Administration - 1.0.x”

Who is online

Users browsing this forum: No registered users and 1 guest