The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Apr 05, 2007 6:17 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Mar 28, 2007 5:19 pm
Posts: 2
Hi everyone,

I am a newbie and created a site in a subdirectory of my site - http://www.mydomain.com/subdirectory - then I moved it to the main directory - http://www.mydomain.com. The site is up and running without a problem. I can access the administrator panel however when I log in I get the following error:

Warning: main(/home/users/web/b2247/pow.villaescape/htdocs/administrator/components/com_admin/admin.admin.php) [function.main]: failed to open stream: No such file or directory in /hermes/web06/b2247/pow.villaescape/htdocs/administrator/index2.php on line 62

Fatal error: main() [function.require]: Failed opening required '/home/users/web/b2247/pow.villaescape/htdocs/administrator/components/com_admin/admin.admin.php' (include_path='.:/usr/local/lib/php-4.4.4/lib/php') in /hermes/web06/b2247/pow.villaescape/htdocs/administrator/index2.php on line 62

I've checked my configuration.php file and all the changes were made hence the site working but just don't know what the problem is re above.

$mosConfig_MetaAuthor = '1';
$mosConfig_MetaDesc = 'Villa Escape your vacation villa in Barbados';
$mosConfig_MetaKeys = 'Barbados, vacation, rental, caribbean, beach, sea, ocean';
$mosConfig_MetaTitle = '1';
$mosConfig_absolute_path = '/home/users/web/b2247/pow.villaescape/htdocs';
$mosConfig_admin_expired = '1';
$mosConfig_allowUserRegistration = '0';
$mosConfig_back_button = '1';
$mosConfig_cachepath = '/home/users/web/b2247/pow.villaescape/htdocs/cache';
$mosConfig_cachetime = '900';
$mosConfig_caching = '0';
$mosConfig_db = 'xxxxxx';
$mosConfig_dbprefix = 'jos_';
$mosConfig_debug = '0';
$mosConfig_dirperms = '';
$mosConfig_editor = 'tinymce';
$mosConfig_enable_log_items = '0';
$mosConfig_enable_log_searches = '0';
$mosConfig_enable_stats = '1';
$mosConfig_error_message = 'This site is temporarily unavailable.
Please notify the System Administrator';
$mosConfig_error_reporting = '-1';
$mosConfig_favicon = 'favicon.ico';
$mosConfig_fileperms = '';
$mosConfig_fromname = 'Villa Escape';
$mosConfig_frontend_login = '1';
$mosConfig_frontend_userparams = '1';
$mosConfig_gzip = '0';
$mosConfig_helpurl = 'http://help.joomla.org';
$mosConfig_hideAuthor = '1';
$mosConfig_hideCreateDate = '1';
$mosConfig_hideEmail = '1';
$mosConfig_hideModifyDate = '0';
$mosConfig_hidePdf = '1';
$mosConfig_hidePrint = '1';
$mosConfig_hits = '1';
$mosConfig_host = 'mysql07.powweb.com';
$mosConfig_icons = '1';
$mosConfig_item_navigation = '1';
$mosConfig_lang = 'english';
$mosConfig_lifetime = '900';
$mosConfig_link_titles = '0';
$mosConfig_list_limit = '30';
$mosConfig_live_site = 'http://barbadosvillaescape.com';
$mosConfig_locale = 'en_GB';
$mosConfig_mailer = 'mail';
$mosConfig_mailfrom = 'villaescape@hotmail.com';
$mosConfig_ml_support = '0';
$mosConfig_multipage_toc = '0';
$mosConfig_offline = '0';
$mosConfig_offline_message = 'www.barbadosvillaescape.com is down for maintenance.
Please check back again soon.';
$mosConfig_offset = '-1';
$mosConfig_offset_user = '-5';
$mosConfig_pagetitles = '1';
$mosConfig_password = 'xxxxxxx';
$mosConfig_readmore = '0';
$mosConfig_secret = 'xxxxxx!';
$mosConfig_sef = '0';
$mosConfig_sendmail = '/usr/sbin/sendmail';
$mosConfig_session_life_admin = '1800';
$mosConfig_session_type = '0';
$mosConfig_shownoauth = '0';
$mosConfig_sitename = 'Villa Escape';
$mosConfig_smtpauth = '0';
$mosConfig_smtphost = 'localhost';
$mosConfig_smtppass = '';
$mosConfig_smtpuser = '';
$mosConfig_uniquemail = '1';
$mosConfig_user = 'xxxxxx';
$mosConfig_useractivation = '0';
$mosConfig_vote = '0';
setlocale (LC_TIME, $mosConfig_locale);
?>

Thanks in advance for all your help.


Top
 Profile  
 
PostPosted: Thu Apr 05, 2007 9:33 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Tue May 09, 2006 5:37 am
Posts: 1506
Location: Arid-Zona
It might be that in moving  your site you corrupted a file, something saved only partially, that sort of thing.

You might try the Joomla Tools Suite: http://extensions.joomla.org/component/ ... Itemid,35/

which includes Joomla Diagnostics... that's a tool that checks your file structure to see if there are missing or corrupt files.

_________________
http://www.motherroaddesigns.com


Top
 Profile  
 
PostPosted: Tue Apr 10, 2007 5:37 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Mar 28, 2007 5:19 pm
Posts: 2
Hi tydust,

Thank you for the help. I re-uploaded a couple of folders and my index2.php and now I can access my site's administrator panel.

Have a great day.

villatropical


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 



Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group