The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 17 posts ] 
Author Message
 Post subject: "Admin Session Expired"
PostPosted: Fri May 04, 2007 8:35 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Apr 09, 2007 1:55 am
Posts: 4
Hi, ever since I've made the admin session timeout longer, I havent been able to log into Joomla anymore. Session is expired as soon as I click login. So I cant even log in to change the timeout back to its previous value.

What can I do?
Joomla version; 1.0.12


Top
 Profile  
 
PostPosted: Fri May 04, 2007 9:05 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Thu Aug 18, 2005 8:55 pm
Posts: 19292
Location: Nijmegen, The Netherlands
Download the configuration.php to your local PC.
What's the value for:
$mosConfig_session_life_admin ?
Could you change it to $mosConfig_session_life_admin = '1800'; , upload the file to your site, and try again?

_________________
Kind Regards,
Peter Martin, Global Moderator - Community Leadership Team
http://www.db8.nl - Joomla specialist, Nijmegen, Nederland
Joomla 2.5 multilanguage in 10 steps: http://www.db8.nl/en/joomla-presentatio ... ge-website


Top
 Profile  
 
PostPosted: Thu May 17, 2007 2:30 am 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Wed May 09, 2007 6:04 am
Posts: 79
Location: Perth - Australia
My configuration.php shows my mosconfig was

Quote:
$mosConfig_session_life_admin = '1800';


but my administration session still timeout in less than 2 minutes.

Could u please tell me why?? and how can i solve this problem...

Thank You

_________________
Allan Chan
Webmaster and IT Manager.
http://www.ckwbgroup.com @ CKWBGroup - Sabah Developer, Contractor and Renovation Specialist
http://www.Trade-asy.com @ TradEasy - Cheapest Online Shopping Store in Perth, WA


Top
 Profile  
 
PostPosted: Tue Jun 26, 2007 11:49 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Mar 07, 2007 4:20 pm
Posts: 417
I had this exact problem.

Sick of getting timed out on the admin page, I maxed out the session lifetime field. Immediately all sessions were expired. Clearing cache did not help. Changed this value directly in config.php and reupped it. Still no go. Cleared cache again. Nope.

Solution: logged in as another (non super-admin) user. Voila, superadmin could now log in again.

HTH.


Top
 Profile  
 
PostPosted: Tue Jun 26, 2007 11:51 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Mar 07, 2007 4:20 pm
Posts: 417
ok so the real question remains, how do you increase your session lifetime?

I have set my mos-session-lifetime to various high values (several hours) and still keep getting kicked in way less time.

grrr...


Top
 Profile  
 
PostPosted: Tue Jun 26, 2007 11:56 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Jun 26, 2007 10:00 pm
Posts: 12
admin session thing pisses me off to. firefox will remember passwords so that helps, but it is still annoying. best solution: don't use joomla  ... lol


Top
 Profile  
 
PostPosted: Wed Jun 27, 2007 12:31 am 
User avatar
Joomla! Hero
Joomla! Hero

Joined: Sat Dec 31, 2005 1:58 am
Posts: 2780
server time affects the sessions time if the server time is incorrect this  will cause the time to be off verify the server time setting and your's.
the difference might be the problem.
you could clear the sessions table  in you database then try logging in

_________________
Loyd
http://k4lch.info
http://volstatehosting.com


Top
 Profile  
 
PostPosted: Wed Jun 27, 2007 2:42 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Mar 07, 2007 4:20 pm
Posts: 417
@llbbl- so what do you use instead?


Top
 Profile  
 
PostPosted: Wed Jun 27, 2007 2:43 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Mar 07, 2007 4:20 pm
Posts: 417
@k4lch- you really think clearing the sessions table in the db will solve a chronic short session issue?

I was thinking it might have more to do with security level and proxy IPs, as per another thread...

??


Top
 Profile  
 
PostPosted: Wed Jun 27, 2007 3:07 am 
User avatar
Joomla! Hero
Joomla! Hero

Joined: Sat Dec 31, 2005 1:58 am
Posts: 2780
it might help just suggestion to help solve problem

_________________
Loyd
http://k4lch.info
http://volstatehosting.com


Top
 Profile  
 
PostPosted: Wed Jul 04, 2007 1:12 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sun Oct 01, 2006 12:21 pm
Posts: 84
Location: Somewhere On Indonesia
i have the same problem.. i've changed $mosConfig_session_life_admin to '1800' too, but it doesnt work. until now, i still can log in to my site administrator backend.. can anyone have another suggestion?

and one notes, this problem came up after my site hosting upgrading it space.  and with this admin expired problem, my site only came up in frontend with this error message :

mossession::store failed
DB function failed with error number 1142
INSERT command denied to user 'myweb_joom1'@'localhost' for table 'jos_session' SQL=INSERT INTO jos_session ( `session_id`,`time`,`username`,`gid`,`guest` ) VALUES ( '2594a7b89d4e76ad89385e7e86b7c46e','1183554716','','0','1' )

anyone know how to solved this problems ? thanks

_________________
Signature rules: Literal URLs only - viewtopic.php?f=8&t=65


Last edited by otakkiri on Wed Jul 04, 2007 1:19 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Wed Jul 04, 2007 1:21 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sun Oct 01, 2006 12:21 pm
Posts: 84
Location: Somewhere On Indonesia
@k4lch

can you tell me how to clear session table in my database ? thanks

_________________
Signature rules: Literal URLs only - viewtopic.php?f=8&t=65


Top
 Profile  
 
PostPosted: Wed Jul 04, 2007 1:42 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Thu Aug 18, 2005 8:55 pm
Posts: 19292
Location: Nijmegen, The Netherlands
Do you have phpMyAdmin access to your database?
Open the database, backup (export) all tables before doing the following:
select the jos_sessions table and choose "empty".

_________________
Kind Regards,
Peter Martin, Global Moderator - Community Leadership Team
http://www.db8.nl - Joomla specialist, Nijmegen, Nederland
Joomla 2.5 multilanguage in 10 steps: http://www.db8.nl/en/joomla-presentatio ... ge-website


Top
 Profile  
 
PostPosted: Wed Jul 04, 2007 1:59 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sun Oct 01, 2006 12:21 pm
Posts: 84
Location: Somewhere On Indonesia
i've done that ... but it still doesnt works .... with the problems above ...  ???

_________________
Signature rules: Literal URLs only - viewtopic.php?f=8&t=65


Top
 Profile  
 
PostPosted: Tue Aug 21, 2007 6:28 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 16, 2007 11:25 pm
Posts: 21
I have the same problem with Joomla, $mosConfig_session_life_admin = '1800' its ok, everything looks ok, but there is now ansewrs to this problem, In my case I can log in but new users can't register (I have installed Community Builder)

_________________
Only exact URLs allowed in signature. Please read Forum Rules: viewtopic.php?f=8&t=65


Top
 Profile  
 
PostPosted: Tue Aug 21, 2007 7:51 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Thu Aug 18, 2005 8:55 pm
Posts: 19292
Location: Nijmegen, The Netherlands
andrespq77 wrote:
In my case I can log in but new users can't register (I have installed Community Builder)


What Joomla version do you use?
And what CB version?
For Joomla 1.0.13 you'll need to upgrade CB to get it working properly.

_________________
Kind Regards,
Peter Martin, Global Moderator - Community Leadership Team
http://www.db8.nl - Joomla specialist, Nijmegen, Nederland
Joomla 2.5 multilanguage in 10 steps: http://www.db8.nl/en/joomla-presentatio ... ge-website


Top
 Profile  
 
PostPosted: Wed Aug 22, 2007 2:08 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 16, 2007 11:25 pm
Posts: 21
Yes,

Thanks,

My host http://www.buyhttp.com helped me solve the problem, the checked my backend, everything and concluded as you said that the  problem was CB, I upgraded to 1.1.

My site has 1620 registed user so I didn't want to test and try solutions. http://www.profesionales.ec

_________________
Only exact URLs allowed in signature. Please read Forum Rules: viewtopic.php?f=8&t=65


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 



Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group