Joomla installation steps 4. Database configuration

This forum is for issues with installing Joomla! on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
somrat
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 14, 2008 12:35 pm

Joomla installation steps 4. Database configuration

Postby somrat » Thu Feb 14, 2008 12:57 pm

Hi All,

i have been trying to install the Joomla for past several days, but still could not put all together. After installing IIS,php, mysql i am trying to instsall joomla 1.5. But stuck on the step 4 (database configuration ) when i put following information i get the following error, and before that, do i need to create a full database for joomla installation? right now i only created a databes schema with no tables or values in it.


Database type : mysql
Hostname: localhost
username: root
password: *****
database name: Bangla

when i click [next] on joomla installation i get the following error:::

BLOB/TEXT column 'name' can't have a default value SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(90) NOT NULL default 'banner', `name` TEXT NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(150) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM


some reference about my system:::::

1.database schema: bangla
2.server : IIS 7
3.os : Vista
4. php version 5.2.4 (x64)
5. MySql v 6.0


Any help would be great full....

Best regards;

diransplace
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Jan 22, 2008 9:54 am

Re: Joomla installation steps 4. Database configuration

Postby diransplace » Thu Feb 14, 2008 4:46 pm

I have had similar expiriences in getting the php environment properly setup in Vista. Why not try wampserver? if this is a production environment which I am assuming it is.
Let me know how it goes.
Cheers

somrat
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 14, 2008 12:35 pm

Re: Joomla installation steps 4. Database configuration

Postby somrat » Thu Feb 14, 2008 9:46 pm

Thanks mate... I will try that tonight see what happens...

somrat
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 14, 2008 12:35 pm

Re: Joomla installation steps 4. Database configuration

Postby somrat » Sun Feb 17, 2008 7:46 am

Hi mate can you please kind of give me step by step installation of wamp server, mysql, php and joomla??

or just installing wamp server installs mysql, php and server..??

then do i need to turn off my IIS 7 and uninstall mysql before i do this.?

Besr regards;

somrat
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 14, 2008 12:35 pm

Re: Joomla installation steps 4. Database configuration

Postby somrat » Sun Feb 17, 2008 9:21 am

Thanks for your advice mate it's all working now,....!!

joels214
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Dec 18, 2008 9:18 am

Re: Joomla installation steps 4. Database configuration

Postby joels214 » Thu Dec 18, 2008 9:55 am

Hi,
Can anyone help me i have a problem with passing from 4th step of the joomla installation. It would just show me "PHP has encountered an Access Violation at 01BDAC5A" ...i am using Windows Server 2003 SP2 using IIS6.0,php5 and mysql 5.1.30..

Thank You


Return to “Joomla! 1.5 on IIS webserver”

Who is online

Users browsing this forum: No registered users and 2 guests