[Solved] Error!Could not find a Joomla! XML setup

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
crushim
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Feb 15, 2008 7:07 pm

[Solved] Error!Could not find a Joomla! XML setup

Postby crushim » Sun Mar 02, 2008 7:13 pm

My server
Opensuse 10.3
Apache 2.2.4
PHP 5.2.4
MySql 5.0.45
safe mode is off

I have search all over trying to figure out is this is a 1.5.1 bug or not. When I try upload File/ Install I recieve the following error

Error! Could not find a Joomla! XML setup file in the package.

Warning: file_get_contents(/srv/www/htdocs/mysite/tmp/install_47caec7b20725/ddj006/templateDetails.xml): failed to open stream: Permission denied in /srv/www/htdocs/mysite/libraries/domit/xml_domit_lite_parser.php on line 1082 .


This is my server and I have root access. All files and folder chmod 777 ( for troubleshooting purpose). The webserver is running under my credintials.I have been researching this for about a week and a half with no solutions. I also know that others are having this issue with no clear cut answer.
Last edited by crushim on Mon Mar 03, 2008 2:41 am, edited 1 time in total.

crushim
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Feb 15, 2008 7:07 pm

Re: Error!Could not find a Joomla! XML setup file in the package

Postby crushim » Mon Mar 03, 2008 2:40 am

I solved the issue by following these steps.

Follow these steps to configure your system for PHP:

Open the httpd.conf file so you can make changes.
Configure Apache to load the PHP module.
Find the list of LoadModule statements. Look for the following line:

LoadModule php5_module libexec/libphp5.soIf this line isn’t there, add it. If a pound sign (#) is at the beginning of the line, remove the pound sign.

For PHP 6, the line will be:

LoadModule php6_module libexec/libphp6.so
Configure Apache to recognize PHP extensions.
You need to tell Apache which files might contain PHP code. Look for a section describing AddType. You might see one or more AddType lines for other software. Look for the AddType line for PHP, as follows:

AddType application/x-httpd-php .phpIf you find it with a pound sign (#) at the beginning of the line, remove the pound sign (#). If you don’t find this line, add it to the AddType statements. This line tells Apache to look for PHP code in all files with a .php extension. You can specify any extension or series of extensions.

Start the Apache httpd server (if it is not running) or restart the Apache httpd server (if it is running).
You can start or restart the server with a script that was installed on your system during installation. This script might be apachectl or httpd.apache, and might be located in /bin or /usr/local/apache/bin. For example, you might be able to start the server by typing apachectl start, restart it by using apachectl restart, or stop it by using apachectl stop. Sometimes restarting is not sufficient; you must stop the server first and then start it.

hootocol
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 14, 2008 11:15 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby hootocol » Fri Mar 14, 2008 11:19 pm

I figured it out!!!! Open the templateDesigns.xml file and rename the beginning and ending 'install' tag to 'mosinstall'. Save the file and try again. Boom! It works.

mhoramm
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Apr 08, 2008 11:57 am

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby mhoramm » Tue Apr 08, 2008 12:00 pm

Thank you so much for posting the solution hootocol :D . I've been searching for this for a good while. It seems like a common problem and yet the solution is not widely known.

djvdthemaster
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Apr 08, 2008 5:15 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby djvdthemaster » Tue Apr 08, 2008 7:40 pm

Thanks for the solution!

estebanoliveros
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun May 25, 2008 7:05 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby estebanoliveros » Sun May 25, 2008 7:11 pm

dear Users,

I have solved my problem with XML with the simply solution! The template was installed, but now when I select it as a default tempalte in joomla and go to my web site, this is blank with only the text "Restricted Access".

please help me...

hugogee
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Dec 18, 2005 1:41 am

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby hugogee » Sat Jul 05, 2008 7:44 am

how are ppl supposed to evaluate your system?? If simple funct. is broken?

amaurib
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Feb 17, 2008 3:37 am

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby amaurib » Mon Oct 06, 2008 5:26 am

try changing the xml version on the head of your xml file
to

Code: Select all

<?xml version="1.0" encoding="utf-8"?>

User avatar
aniphreak
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Fri Oct 24, 2008 5:45 pm
Location: Metro Manila
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby aniphreak » Fri Jan 30, 2009 1:26 pm

thanks amaurib!!! that made my day :-)
Please read forum rules regarding signatures: viewtopic.php?f=8&t=65

cobolino
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed May 27, 2009 11:34 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby cobolino » Thu May 28, 2009 1:53 pm

you i have the same problem and i try to fix it with "hootocol" solution but know i got a different error now File "/homepages/0/d282643007/htdocs/joomla/media/install_4a1e962f6f731/siteground-j15-27/index.php does not exist!" what now !!!!

Alders
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jun 10, 2009 12:04 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Alders » Wed Jun 24, 2009 10:28 am

I changed install to mosinstall as suggested above - but it didn't help. Isn't this "bug" so big that an official fix has to be released?

BR / Bob

vjtemplates
Joomla! Explorer
Joomla! Explorer
Posts: 314
Joined: Sat Dec 27, 2008 6:16 am
Location: LA
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby vjtemplates » Thu Jun 25, 2009 6:04 am

This thread has been solved. Better you open a new thread.
Joomla Templates & VirtueMart Themes

http://www.vjtemplates.com

cfanmax2000
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Sep 22, 2009 4:15 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby cfanmax2000 » Tue Sep 22, 2009 4:17 pm

Check your templateDesigns.xml file to make sure it incldes the xml file itself.
Should look like this at or around line 20:

<files>

<filename>index.php</filename>

<filename>template_thumbnail.png</filename>

<filename>templateDetails.xml</filename>

</files>

Also insure line 2 install version reads <mosinstall type="template"> and not <install type="template"> and make sure the last line reads </mosinstall>, not </install>

It solved this error problem for me, hope this helps.

bbakersmith
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Oct 09, 2009 4:32 am

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby bbakersmith » Fri Oct 09, 2009 4:35 am

I ran into a similar error message, turned out to be an FTP configuration issue.

Solved it by uncommenting "local_umask=022" in /etc/vsftpd.conf

weelliam
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Jan 21, 2010 10:52 am

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby weelliam » Thu Jan 21, 2010 10:56 am

where do i find templateDesigns.xml is that part of joomla's install?

Frank_H
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Feb 05, 2010 1:06 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Frank_H » Fri Feb 05, 2010 1:12 pm

Also make sure you don't have any foreign characters in the text in the xml file.

I had an ö in the description, and this caused the "Error!Could not find a Joomla! XML setup" error when trying to install the template.

User avatar
Ghonjez
Joomla! Exemplar
Joomla! Exemplar
Posts: 8770
Joined: Sat Oct 18, 2008 3:02 am
Location: Mars
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Ghonjez » Tue Feb 09, 2010 7:29 am

weelliam wrote:where do i find templateDesigns.xml is that part of joomla's install?

You can find it on template folder you are using

p.s : In future, if you have a new question, please create a New post

:)

shareea
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Mar 10, 2010 6:27 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby shareea » Thu Feb 10, 2011 6:25 pm

Check to make sure you aren't installing a double compressed file (zip within a zip).

Solves error:
* JFolder::create: Infinite loop detected
* JFTP::store: Bad response
* Warning! - Failed to move file

dalearyous
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 111
Joined: Mon Mar 08, 2010 4:40 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby dalearyous » Thu Mar 03, 2011 7:21 pm

i have tried all these solutions and it still doesn't work

itchibahn
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Feb 23, 2008 10:04 pm
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby itchibahn » Sun Jun 05, 2011 1:49 am

Thanks to amaurib, your solution worked, and allowed to install.
But now, the forum page won't come up. The component page won't come up either for configuration.

inner
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jan 08, 2010 10:07 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby inner » Sat Jul 16, 2011 9:07 am

Thanks fot all but for me the best solution was delete all the description text in xml file and result like this <description>
<![CDATA[<h1>Notepad Chaos for Joomla 1.5</h1]]>
</description>
every thing is rigth now

Spirmy25
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 30, 2011 6:36 am
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Spirmy25 » Fri Sep 30, 2011 6:37 am

I have downloaded the file again and tried to reinstall. Still receive the same error. Can someone please help?

Fonias
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Nov 16, 2009 1:19 am
Location: Ελλάδα
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Fonias » Sat Dec 31, 2011 9:29 pm

i have tried everything and still doesn't work. Do you have any news?

Mariascc
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Tue Dec 13, 2011 5:46 am
Location: By a group of trees on a hill

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Mariascc » Thu Jan 12, 2012 1:55 am

andy12
Post subject: Re: [Solved] Error!Could not find a Joomla! XML setup
PostPosted: Tue Nov 08, 2011 2:23 pm
Joomla! Fledgling
Joomla! Fledgling
Offline

Joined: Fri Nov 04, 2011 10:00 am
Posts: 2
Location: USA
Spirmy25 wrote:
I have downloaded the file again and tried to reinstall. Still receive the same error. Can someone please help?

Even I am having the same problem :'(

***** Manual signatures are NOT allowed *****
Love All Serve All..
vintage engagement rings
yellow diamond engagement rings

Top
Profile

Fonias
Post subject: Re: [Solved] Error!Could not find a Joomla! XML setup
PostPosted: Sat Dec 31, 2011 9:29 pm
Joomla! Apprentice
Joomla! Apprentice
Offline

Joined: Mon Nov 16, 2009 1:19 am
Posts: 9
Location: Ελλάδα
i have tried everything and still doesn't work. Do you have any news?

***** Manual signatures are NOT allowed *****
http://kissamostv.gr/




I also have this very same problem when I try to install extensions. Any ideas or answers please? ;D
DR
"The world is a wickedly wonderfully peaceful place!"

toddb575
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 27, 2012 7:53 am
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby toddb575 » Fri Jan 27, 2012 8:31 am

Fonias wrote:i have tried everything and still doesn't work. Do you have any news?



Hi,

Unexpected errors may also occur if Joomla is installed into a folder where other files already exist. For instance, if you at anytime published from the builder and then installed Joomla to the same folder the Joomla installation will not work correctly.

louisjunwe
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Feb 23, 2012 5:08 pm
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby louisjunwe » Fri Feb 24, 2012 3:05 am

Should change the xml encoding when install other language version
Code:
<?xml version="1.0" encoding="utf-8"?>

User avatar
john-wh
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Feb 18, 2012 11:31 am
Location: Bradenton, FL

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby john-wh » Fri Feb 24, 2012 12:49 pm

amaurib wrote:try changing the xml version on the head of your xml file
to

Code: Select all

<?xml version="1.0" encoding="utf-8"?>


I'd similar problems and this solution worked for me, so I suggest that everyone that has this problem try this method first. 8)
Proudly using Joomla at
http://www.webhosting-top10.com/

Aprentice
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 17, 2012 5:29 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby Aprentice » Wed Feb 29, 2012 4:38 pm

I know now what my error was. I didn't notice that I was trying to use a template that wasn't supported by the joomla version installed. I mean, I was trying to install a joomla 2.5 template in my joomla 1.5 :-[

Could be one of your troubles too ;)

aakashdavis
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sat Apr 21, 2012 3:19 am
Location: India
Contact:

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby aakashdavis » Sat Apr 21, 2012 3:47 am

hootocol wrote:I figured it out!!!! Open the templateDesigns.xml file and rename the beginning and ending 'install' tag to 'mosinstall'. Save the file and try again. Boom! It works.


How did it worked by changing name to mosinstall!!! ???
~Aakash
A computer once beat me at chess, but it was no match for me at kick boxing
http://akashtablet.in/
Moving http://aadhaaruid.org/ from WP to Joomla

MsVette
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Mar 10, 2011 9:46 pm

Re: [Solved] Error!Could not find a Joomla! XML setup

Postby MsVette » Fri Jun 22, 2012 6:36 pm

shareea wrote:Check to make sure you aren't installing a double compressed file (zip within a zip).


This worked for me! :)


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 10 guests