The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 164 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next
Author Message
PostPosted: Sun Mar 02, 2008 8:16 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Mar 02, 2008 8:11 pm
Posts: 1
Hello,
when trying to use Joomla's install features (templates, modules...) I get the following error:

JFTP::store: Bad response
Warning! - Failed to move file

Also, when trying to edit the configuration file through Joomla, I receive the following message of hate:

JFTP::write: Bad response
An Error has occurred! Unable to open configuration.php file to write!

I can upload the templates through FTP or edit the config file with notepad but I'd like to get the interface working.

Any ideas?

Edit: Also, when the website is in offline mode, the page loads fine and displays the proper message. However, if it is not in offline mode, I receive the following error:

Direct Access to this location is not allowed.

Something tells me all these problems are linked.


Top
 Profile  
 
PostPosted: Wed Mar 26, 2008 10:48 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Feb 08, 2008 4:41 pm
Posts: 14
Hi

I had the same problem, so to fix it you must :
- First: Change the chmod to 777 (755 the default chmod) of your "configuration.php" file.
- Second: Update your configuartion server on the BE.
- Third: Change the chmod again to 755 of your "configuration.php" file of course.

This procedure will resolve your problem.

Cordially.


Top
 Profile  
 
PostPosted: Fri Mar 28, 2008 1:00 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 23, 2007 10:04 pm
Posts: 9
Did not work for me


Top
 Profile  
 
PostPosted: Fri Mar 28, 2008 8:18 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Feb 08, 2008 4:41 pm
Posts: 14
Hi,

Ok, so you have the same error message ?

When you change the chmod, check that the access attribute are : -rwxrwxrws.

Cordially.


Top
 Profile  
 
PostPosted: Sat Mar 29, 2008 12:49 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 23, 2007 10:04 pm
Posts: 9
that is correct. the same error. settings as mentioned.

another thing I just noticed is in the red circle.

Image
Image


Top
 Profile  
 
PostPosted: Sat Mar 29, 2008 1:48 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Nov 11, 2007 11:15 pm
Posts: 2
I have the same problem.

I am trying to configure joomla 1.5.2 server Apache 2.2.3 - PHP Version 4.4.4 - on Linux Debian.
Domine user is: dominename.com

The position of CMS is on www.dominename.com/directory/
and also on the third level domain directory.dominename.com

Tests performed:
I changed all chmod Joomla folders and files with 777.
Package loaded: com_joomlaxplorer_1.6.2.zip (same problem with others package)
Effects encountered: the folder created dominename.com/directory/ftp/com_joomlaxplorer_1.6.2/
but the package is not completely unzipped to folder.
Error: Warning! - Failed to move file
Image

What do I do now? It isn't a problem of permissions file.

I tried to unpack the whole package directly in the subfolder dominename/directory/ftp/com_joomlaxplorer_1.6.2/ reloaded the zip file: Nothing , same error.

I tried to reload the package with the fields, installation by folder, and Install from URL: Nothing same mistake.

Has anyone the solution?


Top
 Profile  
 
PostPosted: Sat Mar 29, 2008 10:55 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Nov 11, 2007 11:15 pm
Posts: 2
Hello. This morning I've try to configure
subdomine.domine.com.

I've problem with configuration.php because in AdminPanel, when I try to enable ftp joomla doesn't change the value.
I've edit the configuration with $ftp_enable = '1'

When I've uploading a package the joomla system response

* JFolder::create: ??Infinite loop detected??
* JFTP::store: Bad response
* •Warning! - Files to move the file•

in bottom:
INFINITE LOOP DETECTED jlanguage::_() [/home/httpd/vhosts/sarrabus.com/subdomains/joomla/httpdocs/libraries/joomla/methods.php:122]

:( :( :( ????


Top
 Profile  
 
PostPosted: Sun Mar 30, 2008 7:21 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Mar 30, 2008 6:51 pm
Posts: 43
I have EXACTLY the same problem as Mister X. The site works fine, but I cannot upload any modules/templates etc and there are two that I badly need so my site is basically in limbo until I sort this out.

I have tested the FTP credentials out and I am certain they are fine, I have ensure that all the Directories shown in the Joomla Directory Permissions are all writeable.

I badly need some help from someone! please !


Top
 Profile  
 
PostPosted: Mon Mar 31, 2008 6:03 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Mar 07, 2007 1:12 pm
Posts: 1
I hope this helps, because i had the same prob, all i did was changed all the folders in the public_html to 777 once finished changed back to 755, worked for me on 1.5.2


Top
 Profile  
 
PostPosted: Mon Mar 31, 2008 7:34 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Mar 30, 2008 6:51 pm
Posts: 43
Ok, I am resolved now. What I did was disable the FTP settings in Global Config, and now it works a treat !!

I'll try the option above and then turn FTP back on, and see what happens!


Top
 Profile  
 
PostPosted: Tue Apr 01, 2008 12:47 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
I am having the same error messages. i looked through my configuration.php and i see no reference to chmod 777 or 755
It seems I cannot upload anything through the interface.
I cannot upload templates or modules. Error message:
JFTP::store: Bad response
Warning! - Failed to move file

Or images. Error message is:
Upload failed (407)

And I cannot create new folders in the media manager. Error message is:
JFTP::mkdir: Bad response
JFTP::chmod: Bad response
JFTP::mkdir: Bad response
JFTP::chmod: Bad response
JFTP::write: Bad response

I suspect my configuration.phpis missing a few lines of code or something. I don't know enough to mess around in there.
Relevant settings sare currently:
var $gzip = '1'; var $ftp_enable = '1'; var $sef_rewrite = '0';
no sign of chmod, mkdir or write.

Client would like a gallery that they can upload onto so it is important functionality.
Help please? JO


Top
 Profile  
 
PostPosted: Tue Apr 01, 2008 12:53 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
One more thing... if i try to change global configuration though interface I get this error message:
An Error has occurred! Unable to open configuration.php file to write!
Just another clue for any budding sleuths out there.
thanks, Jo


Top
 Profile  
 
PostPosted: Tue Apr 01, 2008 7:36 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Mar 30, 2008 6:51 pm
Posts: 43
Jo, the reference to chmod 777 is not meant to refer to any setting inside the php file, it's a reference to the security permissions of the file itself. If you right click on the file in your favourite FTP client, and select file attributes (I used FileZilla) you will see the read, write and execute permission checkboxes, you need to ensure that you check off the boxes until you get to 777 !!

Image



Image


Top
 Profile  
 
PostPosted: Tue Apr 01, 2008 10:19 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Apr 01, 2008 10:13 pm
Posts: 2
I've got exactly the same problem...
joomla 1.5.2 core-Installation was fine, but now i can't install anything.
I always get the following two lines:

JFTP::store: Bad response
Warning! - Failed to move file

Permissions are all ok, chmod 777 / 755 does not do the trick.
FTP-settings in global-config are ok, too!
I've got a bad feeling that safe-mode = on has something to do with that problem :-( (although it shouldn't)


Top
 Profile  
 
PostPosted: Tue Apr 01, 2008 10:26 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Mar 30, 2008 6:51 pm
Posts: 43
So did you actually DISABLE the ftp option in the Global config?


Top
 Profile  
 
PostPosted: Wed Apr 02, 2008 12:52 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
Hey scoffers, thanks muchly for the translation of codespeak, it is appreciated.
So I followed your advice:
[quote="Scoffers"]
If you right click on the file in your FTP client, and select file attributes you will see the read, write and execute permission checkboxes, you need to ensure that you check off the boxes until you get to 777 !!


using Fetch I chmoded my configuration.php both with and without ftp enabled, both times getting this message:
Attachment:
fetchmsg.jpg

then the ftp transcript states:
Attachment:
fetchmsg2.jpg

same messages received if i tried to chmode to 755.

it seems since installing joomla all my php permissions are denied, not just for this domain but all the others also. very disturbing. I can´t find the files permission options inside my server interface. Can you chmode from the server?
I will try deleting the config file, then reactivate the ftp access to other sites then uploading another version of conffig with chmod 777. perhaps it will work... but frustration is setting in.
Advice so very welcome...


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Wed Apr 02, 2008 3:44 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Apr 01, 2008 10:13 pm
Posts: 2
Enabling or disabling the ftp-feature in global config doesn't solve the problem.
It's the old safemode-problem !
Safemode OFF and all is working - but now I've got the old wwwrun problem...
Thought Joomla 1.5.2 shold solve all these things...
Well - right now I'm searching for a decent joomla hoster in Austria ...

Andy


Top
 Profile  
 
PostPosted: Sat Apr 05, 2008 12:16 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Feb 22, 2008 4:38 am
Posts: 6
I, too, am having this problem now. I've tried everything mentioned and nothing has worked.

Anybody find any solutions?


Top
 Profile  
 
PostPosted: Sat Apr 05, 2008 9:04 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 05, 2005 9:53 pm
Posts: 20
Location: Brisbane, Australia
Scoffers wrote:
Ok, I am resolved now. What I did was disable the FTP settings in Global Config, and now it works a treat !!

I'll try the option above and then turn FTP back on, and see what happens!


That is fine if your hoster doesn't have safe mode on but like me I am stuck up the proverbial creek.

Someone from the core team please help!

Jason


Top
 Profile  
 
PostPosted: Mon Apr 07, 2008 12:42 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
Right, i have tried turning safe mode off and on, (default for my server is off) neither one make a difference to my issue. Because Joomla has frozen the ftp for my ENTIRE SERVER i cannot chmod the config file. Is there another way of chmoding a file? either through my server (media temple) or from my [drive]?

Please assist.


Top
 Profile  
 
PostPosted: Mon Apr 07, 2008 1:05 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 05, 2005 9:53 pm
Posts: 20
Location: Brisbane, Australia
My hoster, would not turn off safe mode and I could not get the FTP access layer to work (I suspect bugs in Joomla on this one) however my hoster changed secutiry settings so I could still use PHP without turning Safe Mode off.

I will send them an email and see if they can explain what they did.

Jason


Top
 Profile  
 
PostPosted: Mon Apr 07, 2008 8:03 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
SO... I have had small small success. After figuring out how to chmod my config file I have set permissions to 777 and ftp disabled, now the config file can be altered through the CMS interface. but that doesn't fix any of the upload issues.

the error when trying to upload images is now this:
JFolder::create: Could not create directory
JFolder::create: Could not create directory

along with an error :
Upload failed (407)

attempts at installation still result in :
Warning! - Failed to move file

when i chmod the config file back to 755 the old error messages show up.
so really, that aint progress.
Along with general support I have requested my host (media temple) turn on "power mode" which is some kind of extra safe mode for shared servers. Has anyone successfully installed Joomla on this hosting environment?
Anyhow this is a steep learning curve for an apparently easy to install CMS..

extra info; my system info output:
Attachment:
systeminfo.png


and the output from / a phpinfo.php file:
http://www.cherrystew.com/phpinfo.html

JOOMLA!!! are you listening? HELP?


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Mon Apr 07, 2008 8:51 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 05, 2005 9:53 pm
Posts: 20
Location: Brisbane, Australia
It is my understanding that if you have the ftp access layer turned off it doesn't matter what the the ftp security settings are because Joomla is using php. So your php user security settings then come into play.

Jason


Top
 Profile  
 
PostPosted: Mon Apr 07, 2008 3:28 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Tue Aug 23, 2005 3:31 pm
Posts: 375
Location: Austria
Hi all,

I'm troubled by the same issue.

Originally i moved my the Site from my Devserver (php5 and mysql5) to the clients hoster (mysql 4) and i'm running into the same troubles as mentioned above with SafeMode ON.

There is an interesting bug: When i upload an image with the Media Manager it says "Completed" but the file doesn't appear to be on the server (not on FTP and not in Media Manager).

Hope to get this fixed soon!

_________________
http://www.cycomsplat.com - I work for you !
http://www.kindaktuell.at - I'm running this !


Top
 Profile  
 
PostPosted: Tue Apr 08, 2008 1:52 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
Right i went on a chmod rampage, everytime I came across a file I couldn't alter or command i couldn't execute I chmoded all files in the file path to 777 and disabled ftp in the config. Finally I can use other FTP programs to upload folders and create folders through the CMS. Though I still can't install anything, upload photos or use the folders i create because permission is assigned to apache (?). And really what is the point of a CMS if the interface doesn't work?
By default every Joomla file has been set with permissions 644. this seems to be the root of a few of my problems, though not all of them. Is this standard or something that my server is doing?

Is there a serverside way of installing style templates?
Is there a way to reset all permission throughout the site without having to do it file by file?


Top
 Profile  
 
PostPosted: Tue Apr 08, 2008 1:26 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Mar 28, 2008 8:28 am
Posts: 22
I've been having similar problems. Because of a poor internet connection I had to ask one of the support people at my web host to put it up for me. As I have no idea how long it'll take until this is resolved I'm needing to ask him to take it down and put up a previous version.

I think I'll wait till version 1.5...stable, stable comes out. ;)


Top
 Profile  
 
PostPosted: Sun Apr 13, 2008 1:31 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Apr 01, 2008 12:13 am
Posts: 9
I have asked media temple to ¨power mode¨my server, which apparently messes with the server safe mode. Unfortunately nothing has changed. (except error message for uploading images has now changes to 404)
I am generally annoyed and I have wasted so much time trying to run joomla. I would just like a straight answer...

Is the problem with joomla or with my server_ Has anyone EVER INSTALLED JOOMLA SUCCESSFULLY on a media temple shared server?

Is there any Joomla consultants in Melbourne Australia? I currently equate Joomla with extreme levels of boredom and frustration. Anyone care to help me change this perception? I would never recommend this product to anyone.
:'( :-\ :( >:(
Never in my life have I been [drive] to put smilies in a correspondance, that is how disturbed I am by this whole experience


Top
 Profile  
 
PostPosted: Sun Apr 13, 2008 9:21 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 05, 2005 9:53 pm
Posts: 20
Location: Brisbane, Australia
If your hoster has "messed with the safe mode" turn off the ftp access layer and use php to install extensions and templates. The whole reason someone would use ftp is because safe mode is on.

HTH

Jason


Top
 Profile  
 
PostPosted: Tue Apr 15, 2008 3:51 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Wed Jun 21, 2006 7:53 am
Posts: 66
Location: UK
Hey Guys

Have the same problem. currently reinstalling Joomla manually taking a while but it seems shortcuts( i.e. using cgi scirpts like in Fantastico) causes this . check out link below:

[url]
viewtopic.php?f=429&t=270195&p=1220335[/url]

Tim


Top
 Profile  
 
PostPosted: Tue Apr 15, 2008 6:50 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Wed Jun 21, 2006 7:53 am
Posts: 66
Location: UK
Hey guys

Right 2 part solution... firstly had to manually install Joomla then secondly manually edit the config.php file. details below

This def fixed it for me. Let us know how it goes.

DodgyNet wrote:
Hi One and All,

It's nice to make a first post that has an answer to a problem that seems to have faced many people (myself included.

The Problem
I got JFTP error messages in multiple places. For example, when attempting to add a folder in the Media Manager I got:
JFTP::mkdir: Bad response
JFTP::chmod: Bad response
JFTP::mkdir: Bad response
JFTP::chmod: Bad response
JFTP::write: Bad response

If I tried to change anything in Global Configuration I got:
JFTP::write: Bad response
An Error has occurred! Unable to open configuration.php file to write!

This was frustrating as JTS-Post reported:
Diagnostic Information
Joomla! Version: Joomla! 1.5.1 Production/Stable [ Seenu ] 8-February-2008 22:00 GMT
configuration.php: Writable (Mode: 604 )


My Solution
Not to be deterred I trawled these forums and found a possible solution in the post entitled For all those with JFTP errors.

That didn't quite work, but pointed the way. I downloaded the configuration.php file and manually edited the following lines:
from
var $ftp_root = '/htdocs';
to the full path of
var $ftp_root = '/home/fhlinux150/s/SITENAME/user/htdocs';
and then disabled FTP thus:
var $ftp_enable = '1';
to
var $ftp_enable = '0';

Uploaded the file, refreshed the admin screen and now everything works fine! Go figure!!

Hope this helps someone.


Nb: if your installing a template or module or add on from joomla 1.0.xx then you will need legacy mode on for the install to work . Find this in the Plugins Manager under the extensions tab... its there don't know why but it took me ages to find it lol


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 164 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next



Who is online

Users browsing this forum: No registered users and 38 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group