The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 67 posts ]  Go to page 1, 2, 3  Next
Author Message
PostPosted: Mon Mar 24, 2008 2:14 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Mar 21, 2008 12:13 pm
Posts: 69
Hello. I wonder how to remove the /index.php/ in the search engine-friendly URL. I put on SEF URL:s and added suffixes but it seems as if every site or so is under index.php. How can it be that? I did make a search on the topic here but it was really hard to understand what you should do. :/

_________________
If you like Star Wars, you are very welcome to take a look at my SW website - http://www.galacticempire.se . ^^
Alla svenskar/norsker/dansker, gillar ni Star Wars/liker dere StarWars? Check the link above.
Signature rules: Literal URLs only!


Top
 Profile  
 
PostPosted: Mon Mar 24, 2008 3:18 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Mar 21, 2008 12:13 pm
Posts: 69
Do I have to alter the configuration.php for doing this, I thought I found someone sayign that here.

_________________
If you like Star Wars, you are very welcome to take a look at my SW website - http://www.galacticempire.se . ^^
Alla svenskar/norsker/dansker, gillar ni Star Wars/liker dere StarWars? Check the link above.
Signature rules: Literal URLs only!


Top
 Profile  
 
PostPosted: Sat May 03, 2008 8:43 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat May 03, 2008 8:16 pm
Posts: 2
Hi,

I am also having the same problem..all the URLs are coming under index.php

for example the if the site default page is: http://www.abc.com/index.php

then all other URL's will be like this:
http://www.abc.com/index.php/catgegory-name1
http://www.abc.com/index.php/catgegory-name2
http://www.abc.com/index.php/catgegory-name3

But actually it should be

http://www.abc.com/catgegory-name1
http://www.abc.com/catgegory-name2
http://www.abc.com/catgegory-name3

The community at joomla has number of talented people who will provide a good fix for this and with that hope I eagerly await here

Thanks in advance.


Top
 Profile  
 
PostPosted: Sat May 03, 2008 9:26 pm 
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 16, 2006 12:20 am
Posts: 3193
Location: 127.0.0.1
mod note: moved to administration

In Global Configuration, did you set "Use Apache mod_rewrite" to yes? (and then subsequently rename htaccess.txt to .htaccess)

_________________
Backup, backup, backup!
The "Master" .htacess file by Nicholas http://snipt.net/nikosdion/the-master-htaccess


Top
 Profile  
 
PostPosted: Mon May 05, 2008 4:39 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat May 03, 2008 8:16 pm
Posts: 2
Hi,

When I set "Use Apache mod_rewrite" to yes and also renamed htaccess.txt file to .htaccess, the result is all respective URL will be correct when we hover the mouse on it, but when u click and try to land on that page then it will say oops...page not found error.

So URL looks fine now but not able to understand why they are not opening.

Any other things that we should look into?


Top
 Profile  
 
PostPosted: Mon May 05, 2008 10:09 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
possibly make sure var $live_site = '' is completed with your own site URL in the configuration.php file in joomla_root/ directory.

Andy


Top
 Profile  
 
PostPosted: Thu May 08, 2008 4:01 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu May 08, 2008 3:48 pm
Posts: 2
I am having the same problem and wondering if someone has a solution for this

my site is http://www.ashakiran.com/asha and you click and the links and they will fail but if I remove the index.php then it works fine. I have enabled the mod_rewrite and have renamed the htaccess.txt to .htaccess

Any solutions to this?


Top
 Profile  
 
PostPosted: Sat May 10, 2008 7:42 am 
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 16, 2006 12:20 am
Posts: 3193
Location: 127.0.0.1
hsvjoomla wrote:
I am having the same problem and wondering if someone has a solution for this

my site is http://www.ashakiran.com/asha and you click and the links and they will fail but if I remove the index.php then it works fine. I have enabled the mod_rewrite and have renamed the htaccess.txt to .htaccess

Any solutions to this?

Looked fine to me.

_________________
Backup, backup, backup!
The "Master" .htacess file by Nicholas http://snipt.net/nikosdion/the-master-htaccess


Top
 Profile  
 
PostPosted: Sat May 10, 2008 11:53 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 06, 2008 4:44 am
Posts: 3290
Location: Seattle, WA, USA
Hi. The site http://www.ashakiran.com/asha appears to be working as desired for me (no index.php). Mark

_________________
Mark Dexter
"Well...how did I get here?"


Top
 Profile  
 
PostPosted: Wed Jul 09, 2008 8:35 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 02, 2008 3:56 am
Posts: 6
Hi all,
http://www.secretvillasbali.com/index.php/booking-villa.html

This is my website and I cannot remove the index.php at all I have .htaccess on my root folder.
I have put the $livesite to my web URL.

Done every possible things that are on this forum.

Even I have tried all the combination of the configuration for SEF but no result.

When the URL is http://www.secretvillasbali.com/booking-villa.html it says
Not Found

I am using Joomla 1.5

Any help will be appreciated


Top
 Profile  
 
PostPosted: Wed Jul 09, 2008 4:40 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 06, 2008 4:44 am
Posts: 3290
Location: Seattle, WA, USA
Hi. I don't know if this is related, but it looks like you might have a file "index.html" in your root directory. Is this by design? If not, you could try deleting this file. Hope this helps. Mark

_________________
Mark Dexter
"Well...how did I get here?"


Top
 Profile  
 
PostPosted: Thu Jul 10, 2008 12:52 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 02, 2008 3:56 am
Posts: 6
Thanks for the help
But that did not help me out.
It shows Not Found when
Image

This is my seo settings.


Top
 Profile  
 
PostPosted: Thu Jul 10, 2008 1:04 am 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 06, 2008 4:44 am
Posts: 3290
Location: Seattle, WA, USA
Hi. What are the contents of your .htaccess file? Mark

_________________
Mark Dexter
"Well...how did I get here?"


Top
 Profile  
 
PostPosted: Thu Jul 10, 2008 1:07 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 02, 2008 3:56 am
Posts: 6
Oh that may be the problem
I have nothing in the .htaccess file
Its blank
Can you just suggest what should I put inside it


Top
 Profile  
 
PostPosted: Thu Jul 10, 2008 1:14 am 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 06, 2008 4:44 am
Posts: 3290
Location: Seattle, WA, USA
Hi. I think it's supposed to be the contents of the htaccess.txt file that installs in your home directory. So just find a copy of that file, rename it to .htaccess, and maybe that will fix your problem. Mark

_________________
Mark Dexter
"Well...how did I get here?"


Top
 Profile  
 
PostPosted: Thu Jul 10, 2008 1:26 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 02, 2008 3:56 am
Posts: 6
Hi Mark,
I don't have any htaccess.txt file.
How can I get it and when I checked with other website with the same host company it didn't had the htaccess.txt either.
Can you just send me the code for the htaccess
Samir


Top
 Profile  
 
PostPosted: Thu Jul 10, 2008 1:41 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jul 02, 2008 3:56 am
Posts: 6
Hi Mark,
It worked, I was doing this for more than a week.
But you saved my life mate.
I just read this post:

http://forum.joomla.org/viewtopic.php?f=432&t=304366

and when I paste the code there in my .htaccess it worked fine.

You are gr8 man.

Thanks a lot.

Samir


Top
 Profile  
 
PostPosted: Wed Jul 16, 2008 1:14 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jun 26, 2008 9:08 pm
Posts: 7
I just wanted to add that I read the comments in this post, set all the SEO settings to Yes, changed htaccess.txt to .htaccess and everything worked wonderfully. Didn't have to change var $live_site = ''; It was empty. Am running Joomla 1.5.3. Thanks!


Top
 Profile  
 
PostPosted: Mon Jul 21, 2008 2:50 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Sep 15, 2006 2:50 pm
Posts: 25
Hi

I have just a small related problem: how can I exclude an url from being rewritten? More exactly, I found out that the SEO engine is braking my RSS/Atom syndication. The bare url (.../index.php?option=com_content&view=section&id=1&Itemid=46&lang=en&format=feed&type=rss) is working fine, but when I place it on the page and activate SEO, it gets distorted and does'n work anymore. I think I know how (edit .htaccess to omit "&format=feed&type=rss" from rewriting engine), but I'm not very good with these apache commands. Can anyone help me with this?

Thanks


Top
 Profile  
 
PostPosted: Fri Jul 25, 2008 8:43 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Fri Apr 11, 2008 1:11 am
Posts: 16
If ever someone come back in this thread.. I would be also intersted in a solution to exclude rss links to be rewritten....

_________________
Tahiti Full Screen VR Panoramas
http://www.direct2brain.net


Top
 Profile  
 
PostPosted: Sat Nov 15, 2008 1:37 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Nov 01, 2008 7:15 am
Posts: 10
Location: New Zealand
I found this to be extremely helpful. It fixed all my problems.
http://extensions.siliana.com/en/sh404S ... ation.html


Top
 Profile  
 
PostPosted: Mon Mar 23, 2009 1:40 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Mar 17, 2009 6:00 pm
Posts: 14
Thank lot, it works for my website! Cheer!


Top
 Profile  
 
PostPosted: Mon Mar 23, 2009 4:50 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Oct 25, 2008 1:47 pm
Posts: 13
thx for this


Top
 Profile  
 
PostPosted: Tue Apr 28, 2009 1:23 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Dec 08, 2005 8:31 pm
Posts: 13
OK. I have all the same issues. index.php in every URL.

I have taken great care to follow all steps, 1 by 1.

No luck.

If I switch to .htaccess from htaccess.txt, the whole site goes down.

If I keep it at htaccess.txt, the site works -- but I get the infernal index.php in every dang url!

Is there another fix for this? It's got to something simpler!

Vexing.


Top
 Profile  
 
PostPosted: Tue Apr 28, 2009 1:54 am 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 06, 2008 4:44 am
Posts: 3290
Location: Seattle, WA, USA
Hi. Is this a hosted site or a local site? You need to have the mod_rewrite service enabled in your Apache server. If you are running locally, I think you need to uncomment the line in the file C:\xampp\apache\conf\httpd.conf (on my Windows system) that reads: LoadModule rewrite_module modules/mod_rewrite.so.

If this is hosted, you need to find out with your host how to enable this module.

Hope this helps. Mark

_________________
Mark Dexter
"Well...how did I get here?"


Top
 Profile  
 
PostPosted: Tue Apr 28, 2009 11:16 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Dec 08, 2005 8:31 pm
Posts: 13
Hosted.

The thing is, I have 5 other Joomla! sites hosted on the server, no problems. The other Joomla! installations are 1.0 -- this is my first 1.5 on the server. Mod_rewrite is enabled.

So, yeah, the re-writes work no problem for earlier versions of Joomla.

The issue appears to be with 1.5. I'm stumped.


Top
 Profile  
 
PostPosted: Tue Apr 28, 2009 1:22 pm 
User avatar
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sun Apr 06, 2008 4:44 am
Posts: 3290
Location: Seattle, WA, USA
Well, I can tell you that this works in 1.5 for people, and it works locally as well if you enable the module in Apache. So I don't know why it's not working for you, but I am pretty sure it is not an across-the-board Joomla 1.5 issue. Good luck getting it sorted out. Mark

_________________
Mark Dexter
"Well...how did I get here?"


Top
 Profile  
 
PostPosted: Tue Apr 28, 2009 3:08 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Dec 08, 2005 8:31 pm
Posts: 13
Well, the only solution that worked --

-- I took the .htaccess file from my Joomla 1.01 installations

...deleted the 1.5 .htaccess file. Replaced it with the old htaccess file from version 1.01.

Now it works.


Top
 Profile  
 
PostPosted: Thu Jun 25, 2009 11:12 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Jun 25, 2009 9:24 am
Posts: 7
humvee wrote:
possibly make sure var $live_site = '' is completed with your own site URL in the configuration.php file in joomla_root/ directory.

Andy


Im quite new to joomla also php . . Is it possable to show how this should look so i can copy it please ? Also im having no problems editing the txt files . but i cant edit the php file, Im using 1 & 1 web hosting

Thanks


Top
 Profile  
 
PostPosted: Mon Sep 21, 2009 3:57 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Sep 21, 2009 3:46 am
Posts: 4
Location: North America
Geoff wrote:
In Global Configuration, did you set "Use Apache mod_rewrite" to yes? (and then subsequently rename htaccess.txt to .htaccess)


Thanks! It works just perfect.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 67 posts ]  Go to page 1, 2, 3  Next



Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group