Output Buffering problem

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
OpT1mUs
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Apr 07, 2008 5:32 pm

Output Buffering problem

Postby OpT1mUs » Mon Apr 07, 2008 5:37 pm

When I installed Joomla 1.5 in the preisntall chech Output Buffering was On and it's recommended that it should be Off
(if I'm not mistaken), so what I would like to know is :
Can i have any problems with Joomla because of output buffering, and if yes, how would they manifest?

Thanks in advance.
Last edited by humvee on Thu Mar 18, 2010 9:36 pm, edited 1 time in total.
Reason: marked as resolved

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Output Buffering problem

Postby humvee » Tue Apr 08, 2008 8:58 am

OpT1mUs wrote:It would be nice if anyone actually responded.
All other topics about output buffering problem that I found via search had 0 replies...

You are not entitled to a response this is a community and people put in their time voluntarily if you want support on demand then I suggest you pay for it!

Have you bothered checking out the PHP site for description of the setting?
Did you read the Pre-Installation screen for Joomla!

"These settings are recommended for PHP in order to ensure full compatibility with Joomla!
However, Joomla! will still operate if your settings do not quite match the recommended."


Don't expect everything will always work as a result of having a setting that does not match the recommendation. Joomla! will still operate but it may well be that it won't provide you with the full functionality that you would otherwise get.

OpT1mUs
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Apr 07, 2008 5:32 pm

Re: Output Buffering problem

Postby OpT1mUs » Tue Apr 08, 2008 9:09 am

I suggest you reread my post and please point me out where did you see me demanding anything in
"It would be nice if..."

How can I turn off output buffering?

[Mod Note: The element quoted in my note was a bump post by you that was deleted. Suggest you "reread" the Forum Rules!]

dirijat
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Fri Aug 22, 2008 10:17 pm

Re: Output Buffering problem

Postby dirijat » Wed Sep 10, 2008 9:56 am

Add to your .htaccess file this string:

Code: Select all

php_value output_buffering Off


That's ALL! ;)

abusa1
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Mar 20, 2009 6:10 am

Re: Output Buffering problem

Postby abusa1 » Fri Mar 20, 2009 6:31 am

You can turn off standard ouput_buffering in the PHP.ini file like this

output_buffering = Off

Open your PHP.ini in Notepad and search for "output_buffering" and replace word On with Off. Note: there are several places where output_buffering may appear when you search. The line you need is the one that says "output_buffering = On" (this is assuming that you want to turn off the output_buffering).

To find PHP.ini on windows you can:
1. Locate a WAMPSERVER icon (located near clock on a taskbar).
2. Left click the icon and a menu will popup.
3. Go up to PHP folder and side menu will pop out.
4. In a side menu find and click on php.ini to edit it.

faribeiro
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Tue Aug 04, 2009 9:46 pm

Re: Output Buffering problem

Postby faribeiro » Wed Dec 23, 2009 1:34 pm

If I use a web server. How can edit php.ini?

I showd install firt? I don't find the file php.ini.

honeytran
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Mar 17, 2010 6:26 pm

Re: Output Buffering problem

Postby honeytran » Wed Mar 17, 2010 6:38 pm

When I installed my joomla, I had the display errors "on" and output buffering "on".

to change this:
1. left click on wampp-->php-->php settings-->and then uncheck or check whatever settings you need to.

iwingmusic
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jun 04, 2010 8:56 pm

Re: Output Buffering problem

Postby iwingmusic » Fri Jun 04, 2010 8:58 pm

add this to your .htaccess file:

Code: Select all

php_value output_buffering "0"

User avatar
svempa
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Thu Oct 12, 2006 9:07 am
Location: Karlstad, Sweden

Re: Output Buffering problem

Postby svempa » Tue Jun 15, 2010 8:21 am

iwingmusic wrote:add this to your .htaccess file:

Code: Select all

php_value output_buffering "0"

Worked like a charm, just tested it with the new J1.6 Beta3 on a shared host :)

andronikos1990
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Nov 15, 2010 10:07 pm

Re: Output Buffering problem

Postby andronikos1990 » Mon Nov 15, 2010 10:10 pm

Many thanks to all of you. I think that

"left click on wampp-->php-->php settings-->and then uncheck or check whatever settings you need to"

is the easier and most functional settings mentioned here. I recommend those instructions.

At least they worked for me.

cosmikel
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 04, 2011 5:21 pm

Re: Output Buffering problem

Postby cosmikel » Fri Feb 04, 2011 5:44 pm

andronikos1990
Hi I'm a newbie and got stuck at this installation point with the same error.

I cannot find the place you mention !

Have looked in the folder c:\wamp
but found no php or php settings,

So I thought you might mean the Apache server at http://localhost/
but also could not find it.

could you please expand on the path and where I can find it?:
"...wampp-->php-->php settings-->..."

Grateful for any help! :-)

cosmikel
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 04, 2011 5:21 pm

Re: Output Buffering problem

Postby cosmikel » Fri Feb 04, 2011 6:05 pm

Found the answer on another forum!

For all newbies!!!

Not stated or apparent is the hidden WAMPSERVER icon (hidden in Windows 7 anyway) at the bottom right hand side of the desktop. Click on that and all will be clear.

Only took me an hour to find it! Ha! Ha! ;-)

muadib25
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Apr 16, 2011 9:49 am

Re: Output Buffering problem

Postby muadib25 » Sat Apr 16, 2011 9:53 am

iwingmusic wrote:add this to your .htaccess file:

Code: Select all

php_value output_buffering "0"

Hello!

I put this line in various places in .htaccess and uploaded it back to the server, but when I do recheck the Output Buffering is still on. :(

Any clues?

User avatar
alfredo_tripicchio
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Fri Dec 02, 2005 3:28 pm
Location: Ischia, Naples, Italy
Contact:

Re: Output Buffering problem

Postby alfredo_tripicchio » Mon May 23, 2011 11:25 am

I use this and it works:

Code: Select all

php_flag output_buffering off


Alfredo
Alfredo Tripicchio

User avatar
ariyagallery
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat May 28, 2011 4:39 am
Location: osaka,japan
Contact:

Re: Output Buffering problem

Postby ariyagallery » Sat May 28, 2011 4:49 am

please help me
in the way of instalation joomla i have to change PHP setting for output bufering off
I search for PHP.ini for change that but I do not have that and ahve to file called
PHP.ini-development
PHP.ini-production
what should i do? which one must be changed and how
by dubble click on this two file none of them do not open
what shuld I do for opening this two file and which one must be modified
an how ?
dear friend your prompt reply will be appreciated
with thanks
ariya gallery

FC360
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jun 08, 2011 4:03 pm

Re: Output Buffering problem

Postby FC360 » Wed Jun 08, 2011 9:52 pm

I'm getting the same and tried the htaccess suggestion but it didn't work and I don't have a clue where this php.ini file is located since I am on a shared server.


Where in the htaccess file should the line go? My htaccess file has a load of text in it and I'm not sure where to put the text.

arvendal
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Wed Mar 28, 2007 1:19 pm

Re: Output Buffering problem

Postby arvendal » Thu Aug 04, 2011 8:19 am

Sometimes the ISP has made configurations on their servers which you don't may override with commands in .htaccess. Maybe this is the case when you don't get you .htaccess to work?

Rgds

Milbo
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Aug 08, 2008 7:33 am

Re: Output Buffering problem

Postby Milbo » Tue Sep 27, 2011 10:41 am

For me the main question is not answered:

Why is joomla 1.7 recommending output buffering to be off? Our component uses for the email the commands http://php.net/manual/en/book.outcontrol.php , which afaik need output buffering, so I ask again: "Can i have any problems with Joomla because of output buffering, and if yes, how would they manifest?"
and yes, this is common knowledge "Don't expect everything will always work as a result of having a setting that does not match the recommendation. Joomla! will still operate but it may well be that it won't provide you with the full functionality that you would otherwise get."

But that does not help me to understand the problem as user. I am developer and it is a lot easier to see first the problem as user to know then how to fix the problem.

Atm it seems so that virtuemart2 recommends output buffering ON, so what is the glitch? With output buffering to off, vm2 wont be able to send html emails afaik. But what is the problem in joomla1.7 then? Template issues?

Milbo
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Aug 08, 2008 7:33 am

Re: Output Buffering problem

Postby Milbo » Wed Oct 12, 2011 5:25 pm

http://stackoverflow.com/questions/2148 ... ing-in-php

It seems that ob_start works anyway our mail works also without. Maybe the link above helps to understand why it should be avoided. But it seems there wont be any glitch, the problems arise, when there is a component insisting that output buffering must be enabled, which can lead to lousy programming style.

Milbo
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Fri Aug 08, 2008 7:33 am

Re: Output Buffering problem

Postby Milbo » Fri Oct 14, 2011 5:51 pm

???? This does not really make sense to any of my posts.

I just answer what happens when output buffering is ON. There was no answer, so we didnt stop searching for it. After we found out, I thought I should provide the information, because this is the thread you find, when you google for it.

odalcet
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Apr 08, 2010 8:36 pm

Re: Output Buffering problem

Postby odalcet » Mon Oct 31, 2011 5:45 am

I'm installing Joomla 1.7.2 in my local server. ( Ubuntu 10.10 )

php.ini is located at /etc/php5/apache2

I modified line 284:

before:
output_buffering = 4096

after:
output_buffering = Off

Then I restarted apache2:

/etc/init.d/apache2 restart

Then I reloaded my browser and Joomla said

ouput buffering - recommended : off - actual: off

- - -- - - - - - - - - -

Pending issue: confguration.php writeable. Joomla says still not supported

forumexpert01
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Nov 05, 2011 3:30 pm

Re: Output Buffering problem

Postby forumexpert01 » Sat Nov 05, 2011 3:34 pm

thanx... i solved my such pblms

Shortlike
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Nov 05, 2011 5:40 pm

Re: Output Buffering problem

Postby Shortlike » Sat Nov 05, 2011 5:43 pm

thanks..

Vysero
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Jan 27, 2012 8:42 pm

Re: Output Buffering problem

Postby Vysero » Sun Jan 29, 2012 2:47 pm

When I try to right click my wamp icon all it does is refresh the server. I tried both "php_value output_buffering "0"" and "php_flag output_buffering off" to my .htaccess file neither worked. What do I need to do to get output buffering turned to off? I am currently still in the setup process, can I change it later?

OlySoftCIO
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Jun 06, 2012 2:08 pm

Re: Output Buffering problem

Postby OlySoftCIO » Wed Jun 06, 2012 2:17 pm

Changes in the .htaccess files will only work based on the default configuration of the Apache server and on the default PHP5 configuration. I'm setting up a client with Ubuntu12.04-server lts as thier base server and the changing .htaccess provides no joy.

However, making the change in the php.ini file as @odalcet suggested worked wonders.

Peace!

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Output Buffering problem

Postby humvee » Fri Jun 08, 2012 9:41 am

If you have access to the main server configuration files such as php.ini then that is what you edit.
If you do not have such access (most people on shared hosting) then you have to use htaccess/local php.ini files that you create.
In order for an .htaccess file and or local php.ini files to work the server has to be configured to allow such changes to be made in the first place. SOme hosts prohibit this and it is not a given that a newly installed AMP server is properly configured to allow this either.

ubiquetous
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Apr 17, 2013 6:06 am
Location: Buffalo, NY

Re: Output Buffering problem

Postby ubiquetous » Wed Apr 17, 2013 6:35 am

abusa1 wrote:You can turn off standard ouput_buffering in the PHP.ini file like this

output_buffering = Off

Open your PHP.ini in Notepad and search for "output_buffering" and replace word On with Off. Note: there are several places where output_buffering may appear when you search. The line you need is the one that says "output_buffering = On" (this is assuming that you want to turn off the output_buffering).

To find PHP.ini on windows you can:
1. Locate a WAMPSERVER icon (located near clock on a taskbar).
2. Left click the icon and a menu will popup.
3. Go up to PHP folder and side menu will pop out.
4. In a side menu find and click on php.ini to edit it.


Thanks for the tip. This worked for my setup. The only difference is that I have XAMPP installed instead of WAMP. So my process was:

1. Go to xampp_install_dir/php/
2. Opened the php.ini file with Notepad
3. Searched for the phrase "output_buffering" using Find
4. Changed value from

Code: Select all

output_buffering=4096
to

Code: Select all

 output_buffering=Off

5. Saved php.ini and closed Notepad
6. Opened XAMPP control panel
7. Stopped Apache & MySQL
8. Restarted Apache & MySQL

Thanks again.


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 6 guests