Warning! - Failed to move file

This forum is for general questions about extensions for Joomla! version 1.5.x.
Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
afroman
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Mar 22, 2008 2:43 am

Warning! - Failed to move file

Postby afroman » Sun May 11, 2008 7:39 pm

Hello, I have just installed joomla 1.5.3 but when I try to install new extensions (templates, components, modules) it says "Warning! - Failed to move file"

Please I need help thnx

jmc
Joomla! Guru
Joomla! Guru
Posts: 682
Joined: Thu Aug 18, 2005 9:10 pm
Location: Hey! I'm in Hartlepool! We hang monkeys!!!
Contact:

Re: Warning! - Failed to move file

Postby jmc » Sun May 11, 2008 8:25 pm

Hi, afroman!
I think you'll find that this is a file/folder "permissions" issue and will be due to your server setup. You may need to temporarily chmod777 the necessary target folders for the installation (the error message will tell you which folder is the problem).
HTH,
John Mc
When all of your wishes are granted, many of your dreams will be destroyed...

afroman
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Mar 22, 2008 2:43 am

Re: Warning! - Failed to move file

Postby afroman » Sun May 11, 2008 8:36 pm

Thnx for your replay ...
So when I install Joomla First I had problems with my config...php wich I upload manually ...
But now the error just saying me "Warning! - Failed to move file" not more

Thanks

afroman
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Mar 22, 2008 2:43 am

Re: Warning! - Failed to move file

Postby afroman » Mon May 12, 2008 3:48 am

Need Help Here Please :-[

gorlaz
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Aug 22, 2006 8:57 pm

Re: Warning! - Failed to move file

Postby gorlaz » Thu May 22, 2008 9:20 pm

Hey,

I'm getting this error too - same version 1.5.3

Unfortunately the error doesn't give the folder location that the perms need to be changed on - how do you go about finding it?

Cheers,

alpori
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu May 22, 2008 9:26 pm
Location: Mexico
Contact:

Re: Warning! - Failed to move file

Postby alpori » Thu May 22, 2008 10:47 pm

I also have tried pretty much all the various solutions to no avail. I have bypassed the template installation SW via the control panel and FTP, but cannot find the adequate folder for the extensions (plugins, modules etc) so that I could install manually. Hence the assistance request, I did follow the suggestion of diagnosing via the post assitant (excellent resource)

Problem Description:
Unable to install templates, plugins, extensions or anything via the Install/uninstall, Could install manually but not the extension, modules or plugins

Log/Error Message:
JFTP::mkdir: Bad Response

JFolder::create:Could not create directory Warning¡ - Failed to move file

Actions Taken To Resolve:
:)
Yootheme suggested to deactivate ftp support through the global support and the the log error message changed to the 2nd error message.
Was able to install templates manually through FTP directly on the template folder. But I don´t know which folders to install the plugins and extensions.

Diagnostic Information
Joomla! Version: Joomla! 1.5.3 Production/Stable [ Vahi ] 22-April-2008 22:00 GMT
configuration.php: Writable (Mode: 644 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.24.3-grsec ( i686) | Web Server: Apache/1.3.39 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.30 OpenSSL/0.9.7a PHP-CGI/0.1b ( restauracion.masclientes.com.mx ) | PHP Version: 4.4.7
PHP Requirements: register_globals: Enabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): No | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 4.1.22-standard ( Localhost via UNIX socket )

gorlaz
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Aug 22, 2006 8:57 pm

Re: Warning! - Failed to move file

Postby gorlaz » Mon May 26, 2008 9:23 pm

It looks like a permission error on my server.

Only problem is that the All the folders in Help > System info are Unwritable BUT their permissions are already 755 which I thought would give me as administrator whilst logged into Joomla access but apparently not.

I ended up ftping the unzipped template I wanted in there but this isn't a good enough solution for components etc.

Is the only way to solve this stuff to chmod every folder to 777 then back again??? I hope not as that seems inherently insecure and worse than my old 1.0 installation.

Insomn3ak
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Oct 20, 2007 9:39 pm

Re: Warning! - Failed to move file

Postby Insomn3ak » Tue May 27, 2008 11:58 pm

I was having the exact same problem. I made sure the components folder was 777, but also the administrator/components folder had to be 777 as well. It finally succeeded but threw the following warnings:

* JInstaller::install: The language file 'languages/de-DE.com_mtwmigrator.ini' could not be installed because the Administrator language package for 'de-DE' has not been installed or does not exist.
* JInstaller::install: The language file 'languages/es-ES.com_mtwmigrator.ini' could not be installed because the Administrator language package for 'es-ES' has not been installed or does not exist.
* JInstaller::install: The language file 'languages/pt-BR.com_mtwmigrator.ini' could not be installed because the Administrator language package for 'pt-BR' has not been installed or does not exist.
* JInstaller::install: The language file 'languages/pl-PL.com_mtwmigrator.ini' could not be installed because the Administrator language package for 'pl-PL' has not been installed or does not exist.


That shouldn't be a big deal though, since I'm aware those don't exist and only need "English" installed.

gorlaz
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Aug 22, 2006 8:57 pm

Re: Warning! - Failed to move file

Postby gorlaz » Wed May 28, 2008 12:17 am

Cool.

The other way I got it to work was to enable the FTP layer and use my normal FTP account (a restricted one doesn't seem to work on my shared hosting for some reason - but I think this is the hosting and not Joomla).

Once I did that it uploaded without me needing to change the perms on the folders.

GeoNine
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Mar 20, 2006 9:06 am

Re: Warning! - Failed to move file

Postby GeoNine » Wed Jul 09, 2008 9:09 pm

Found the answer to this one on a joomlashack thread. If you modify the permissions on the /tmp folder to 777 you should be all set.

at the command line: chmod 777 ./tmp

brunsona
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Thu Jan 04, 2007 12:52 am

Re: Warning! - Failed to move file

Postby brunsona » Wed Jul 09, 2008 9:44 pm

The first thing to check is in your Global Configuration dialog box. Make sure the path to the tmp folder is correct or you will not be able to load anything. The path that works for me is /home/hosting-user/public_html/tmp/ - replace hosting-user with the username you use when you log into cPanel or whatever on your web host.

I've hit this a few times when I've moved a site from a dev server to a production server and either forgot to change the tmp path or screwed it up. Get this right and the installer should be able to create the folder and work great.
-a-

erickjes
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Aug 09, 2008 2:24 am

Re: Warning! - Failed to move file

Postby erickjes » Thu Oct 09, 2008 1:41 pm

Thanks GEONINE that really helped, and I have no problems installing templates now!

HeinzAhoy
Joomla! Intern
Joomla! Intern
Posts: 60
Joined: Fri Dec 05, 2008 6:03 pm
Location: spain

Re: Warning! - Failed to move file

Postby HeinzAhoy » Thu Nov 12, 2009 3:40 pm

Thank you soooo much brunsona!! that did the trick! ;D

banshee_z71
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Tue Nov 07, 2006 8:03 am
Contact:

Re: Warning! - Failed to move file

Postby banshee_z71 » Thu Jan 28, 2010 4:45 pm

Just tried to install a component on a new site and got the error. Here is a cheatsheet I made a while back with all the directories that need a chmod on them for joomla to work correctly

http://codersresource.com/joomla/general/how-to-set-up-joomla-directory-permissions

sideway
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Feb 07, 2010 2:31 pm

Re: Warning! - Failed to move file

Postby sideway » Sun Feb 07, 2010 10:40 pm

Followed your instructions and it worked - of course! After struggling all weekend to work out how to get my local site onto my host server, I was expecting more hours of frustration.

Hooray!! Thanks a lot brunsona ;D

skione
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Tue Nov 27, 2007 1:09 pm

Re: Warning! - Failed to move file

Postby skione » Thu Jun 10, 2010 12:22 am

Anyone who tells you to chmod any file on a web server doesn't know what they are saying. I was researching an issue (that ended up being me transposing a 6 to a 9) and came across this post.

chmod a file to 777 on a web accessible folder is asking for your server to be rooted.

files should be 644 and folders should be 755 and all should be owned by your web server user.

Once you have your site setup it is also a bad idea to remove all write permissions from your configuration.php file

eliteeservices
Joomla! Apprentice
Joomla! Apprentice
Posts: 42
Joined: Sun Jul 02, 2006 5:24 am
Contact:

Re: Warning! - Failed to move file

Postby eliteeservices » Tue Jul 27, 2010 12:44 am

Isn't chmodding entire directories as this user suggested:

http://codersresource.com/joomla/genera ... ermissions

a VERY bad security practice?

There seems to be issues with how joomla is installed on various servers and ownership permissions.

Trying to make this work on http://vector-informatics.com/cms

Any help?
Elite E Services, Inc.
http://www.eesfx.com EES FX
http://startvector.com Dealer SEO and Internet Marketing

skione
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Tue Nov 27, 2007 1:09 pm

Re: Warning! - Failed to move file

Postby skione » Tue Jul 27, 2010 1:51 am

Here is the problem, when you move joomla from one server to another you need to update the paths in the configuration.php file. Especially the tmp path as that is where Joomla uploads installation files and plugins. All files and folders should be owned by the same user that your domain run's under. Some servers have a single user (apache or www-data for instance) others will use susexec and run each domain under a separate user account ("the right way"). Additionally folders and files should have different permissions (folders: 755 and 644 for files except configuration.php which should be all read only unless you are making changes to it purposefully)

YOU SHOULD NEVER CHMOD ANY DIRECTORY 777 ON ANY WEB SERVER FOR ANY REASON EVER!

Seriously if you have chmod permissions and you don't know this you are a retard with a loaded pistol.

If you are having permissions issues the only reason to try this is to rule something out but in the end there is always a better and safer way. Chmod'ing any folder to 777 basically wipes the security off your site and you will become a porn landing page or part of a zombie spam network very quickly.

And you might not even notice until your ISP shuts you down for spamming.

Of course all of this if for linux/apache, windows IIS has similar rules.

piercerides
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Aug 16, 2007 6:23 pm

Re: Warning! - Failed to move file

Postby piercerides » Wed Aug 25, 2010 12:46 am

I've read every post on these topics. I've tried everything from changing permissions on EVERY FILE to 777 to simply enabling and disabling the ftp server in the configuration.

I reverted back to Joomla 1.5.17 and everything works.

It is a bug in joomla that they need to address. I am using GoDaddy unlimited account. I understand many of the issues are with people not being able to edit files that are not accesible to them since they are using a shared server.

Will joomla's pro's give us an update when this bug will be worked out for us non-server owners.

skione
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Tue Nov 27, 2007 1:09 pm

Re: Warning! - Failed to move file

Postby skione » Wed Aug 25, 2010 1:45 am

Dude there is no bug. I explain it very clearly in my post. I have hundreds of Joomla sites running on dozens of servers from 1.0.13 thru 1.5.20 and have seen this again and again (usually after I moved the files)

It is most likely a problem with the path in your configuration.php

zbikow
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue May 18, 2010 9:07 pm

Re: Warning! - Failed to move file

Postby zbikow » Thu Aug 26, 2010 6:36 pm

Just to let know others having the same issue. My problem was that the files were owned by root (see ls -l) and should've been by www:www. chmod -R helped.

znetlive
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Sep 16, 2010 6:28 pm

Re: Warning! - Failed to move file

Postby znetlive » Thu Sep 16, 2010 6:37 pm

When you do not use FTP your directory and file permissions need to be set. The problem is that there are a lot of directories and their default setting is 755 which is safe and makes it impossible for users of the same server to place files in you directory. 755 does not make it possible to install or uninstall languages, templates or extensions.

If you change it to 777, you will be able to install and uninstall all your stuff, but… its not that safe.

To make it easy you can make a php file which sets all the directory settings right to 777 when you want to install stuff, and sets it back to 755 when you are done.

The following files need to be set tot 777 to make installation possible:

/administrator/backups/
/administrator/components/
/administrator/language/
/administrator/language/en-GB/
/administrator/language/nl-NL/
/administrator/modules/
/administrator/templates/
/components/
/images/
/images/banners/
/images/stories/
/language/
/language/en-GB/
/language/nl-NL/
/language/pdf_fonts/
/modules/
/plugins/
/plugins/content/
/plugins/editors/
/plugins/editors-xtd/
/plugins/search/
/plugins/system/
/plugins/user/
/plugins/xmlrpc/
/tmp/
/templates/
/cache/

As you can see there are extra languages installed in my default install, so if you use extra languages include them in the list.

You can create a chmod.php file like this:
==============================================
<?php
if ($_GET['chmod']) { $ftp_chmod = $_GET['chmod']; } else { $ftp_chmod = "0755"; }
echo "chmod=".$ftp_chmod;

$ftp_server='your server';
$ftp_user='the user';
$ftp_pass='the password';
$conn_id = ftp_connect("$ftp_server");
ftp_login($conn_id, $ftp_user, $ftp_pass);

if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/backups/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/components/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/language/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/language/en-GB/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/language/nl-NL/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/modules/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/administrator/templates/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/components/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/images/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/images/banners/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/images/stories/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/language/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/language/en-GB/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/language/nl-NL/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/language/pdf_fonts/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/modules/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/content/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/editors/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/editors-xtd/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/search/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/system/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/user/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/plugins/xmlrpc/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/tmp/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/templates/')) { echo "<!--succes-->
"; } else { echo "failed"; }
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' /httpdocs/cache/')) { echo "<!--succes-->
"; } else { echo "failed"; }

ftp_close($conn_id);
?>

==============================================

When you go to example.com/chmod.php?chmod=0777 the directories are set to 777. To restore to 0755 go to example.com/chmod.php?chmod=0755.

As you can see you still need to use your FTP files, so why not use them as the default setting.

Alternative script that may be easier to modify:
==============================================
<?php

// your ftp credentials
$ftp_server='ftp.yourserver.com';
$ftp_user='yourusername';
$ftp_pass='yourpassword';

// where is Joomla installed? (trailing slash required)
$base = '/public_html/web/';

// what files or directories need chmod applied? (trailing slash optional)
$dirs = array( 'administrator/backups',
'administrator/components',
'administrator/language',
'administrator/language/en-GB',
'administrator/modules',
'administrator/templates',
'administrator/cache',
'components',
'images',
'images/banners',
'images/stories',
'media',
'language',
'language/en-GB',
'language/pdf_fonts',
'modules',
'plugins',
'plugins/content',
'plugins/editors',
'plugins/editors-xtd',
'plugins/search',
'plugins/system',
'plugins/user',
'plugins/xmlrpc',
'tmp',
'templates',
'cache'
);

// default to safe 0755 setting
if ($_GET['chmod']) {
$ftp_chmod = $_GET['chmod'];
} else {
$ftp_chmod = "0755";
}
echo "chmod=".$ftp_chmod.'<br/>';

// connect via ftp and apply chmod
$conn_id = ftp_connect("$ftp_server");
ftp_login($conn_id, $ftp_user, $ftp_pass);
foreach( $dirs as $dir ){
if (ftp_site($conn_id, 'CHMOD '.$ftp_chmod.' '.$base.$dir)) {
echo "success ";
} else {
echo "failed ";
}
echo $base.$dir.'<br/>';
}
ftp_close($conn_id);

echo 'DONE';
?>
==============================================

banshee_z71
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Tue Nov 07, 2006 8:03 am
Contact:

Re: Warning! - Failed to move file

Postby banshee_z71 » Wed Sep 29, 2010 5:59 am

I wanted to add something to this thread. For a long time the only way I was able to install components, modules or plugins was to change the directories to 777. I know this is not the best way and many people on this thread would say it was dumb rather than providing an actually solution.

If your paths in the configuration.php are correct then it is likely that only the user apache has write access to the folders. If you are using Plesk there is an easy way to fix this. This can also be done without Plesk using Apache suEXEC and running PHP as FastCGI. I wrote and article of how to do this. If anyone has POSITIVE feedback or anything to improve this let me know.

http://codersresource.com/joomla/general/fix-755-permission-issues-with-running-php-as-fastcgi

Thanks,

Ron

skione
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Tue Nov 27, 2007 1:09 pm

Re: Warning! - Failed to move file

Postby skione » Wed Sep 29, 2010 8:39 am

You never want anything on a web server set to 777, that last 7 means EVERYONE can write to the folder or file. The first 7 means the owner can read, write and execute the folder or file. So long as the folder or file is OWNED by the web user (apache, httpd, www-data, or a specific user if you are using suexec) AND the paths to your tmp folder are CORRECT, you will have no problem installing anything for Joomla.

To recap:
1. find out what is the CORRECT web user for your domain or server
2. set the paths correctly
3. set write access for the OWNER (the first 7) and possibly the GROUP (The second 7) but never EVERYONE (the last 7)

User avatar
JMcGrey17
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Oct 28, 2010 1:31 pm
Location: San Jose, California
Contact:

Re: Warning! - Failed to move file

Postby JMcGrey17 » Thu Oct 28, 2010 3:51 pm

Find the exact folder/location of the files you wanted to delete...make sure the parent directory must set its permission to 777 in order for you to delete such files.
Have a file that you can't access? FileCure provides a fast and easy way to identify files that Windows cannot open find the software you need to open them.

jloday
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Nov 09, 2010 6:21 pm

Re: Warning! - Failed to move file

Postby jloday » Tue Nov 09, 2010 6:31 pm

Wow, it is amazing to me how many people in this thread are begging to get hacked by changing the permissions. I have been running into this problem myself with 1.5.21. Though I haven't moved my site. So I am going to check out the config.php file. I have been hacked soooo many times by having the wrong permissions. All it takes is once and your site and be really messed up.

jloday
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Nov 09, 2010 6:21 pm

Re: Warning! - Failed to move file

Postby jloday » Tue Nov 09, 2010 8:48 pm

skione: I did exactly what you said and it work. Very easy too. Thanks.

asans
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jan 22, 2011 5:16 am

Re: Warning! - Failed to move file

Postby asans » Sat Jan 22, 2011 5:26 am

I've got a good when the tmp and template folders set to 755

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16022
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Warning! - Failed to move file

Postby leolam » Sat Jan 22, 2011 5:44 am

NEVER EVER set any permissions to '777' That is the worst advise ever! http://docs.joomla.org/Security_Checklist_7

Leo 8)
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

holymoly
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Apr 06, 2011 3:32 am

Re: Warning! - Failed to move file

Postby holymoly » Wed Apr 06, 2011 3:46 am

just like all the other fellas said no need to give 777 permissions anywhere.

here is what you do:

1st: find the user name for your web server (if you're using apache chance are it is www-data .. double check by using this command: cat /etc/passwd)

2nd: all you need to do is chown these folders (my joomla installation is in this folder /var/www/joomla)
chown www-data:www-data /var/www/joomla/tmp
chown www-data:www-data /var/www/joomla/templates

then navigate to your www folder (or whatever that might be) and double check by using:
ls -la

you should see that both your "tmp" and "templates" folders are now owned by www-data

3rd: navigate to your joomla webserver (localhost/joomla/administrator), then click "Extensions" -> "Extension Manager" and use the upload package option. (The file you're uploading should be in ZIP format, otherwise it might not work).

4th: set the default template from the "extension manager" again and you should be set.


Now how the heck to do you add some content?

good luck


Return to “Extensions for Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 14 guests