PHP.ini file upload limit?

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
ronronmx
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Tue Feb 19, 2008 8:01 pm

PHP.ini file upload limit?

Postby ronronmx » Mon May 12, 2008 12:43 am

Hey guys,
Sorry if this has been asked a million times before, but i couldn't find what i'm looking for...and i hope this is the right forum to post this in.

So i made my upload size limit bigger in my php.ini file, but it doesn't seem to be affecting the joomla media manager...I still can't upload any vids over 2 mgs ? My Joomla install is in: myroot/joomla and my php.ini file is in: myroot. Should it be in the Joomla root instead?

I have also changed the upload size limit in the Joomla Global Configuration as well as included all the right extensions i want to upload. I am running Joomla 1.5.3

Thx in advance for any help!
Stephane

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: PHP.ini file upload limit?

Postby humvee » Mon May 12, 2008 10:30 am

what error are you actually receiving when you are trying to upload an image?
Andy

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19082
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: PHP.ini file upload limit?

Postby dhuelsmann » Mon May 12, 2008 1:18 pm

Also check on the Joomla backend php info and see which php.ini file it is referencing and its location. Local installs frequently have more then one php.ini but Joomla may be referencing a different one then you changed. Also, did you restart apache after the change?

ronronmx
Joomla! Intern
Joomla! Intern
Posts: 62
Joined: Tue Feb 19, 2008 8:01 pm

Re: PHP.ini file upload limit?

Postby ronronmx » Mon May 12, 2008 5:04 pm

Hey guys, thx for your replies! I was able to figure it out after talking to my host thought :D

humvee: I wasn't getting any errors, it would just upload the file, finish, refresh the browser and the file wasn't there. I think i wasn't getting any errors because i'm using the flash uploader. When i tried using the HTML one, i did get an error, but i don't remember which one :-[

dhuelsmann I am not using a local install, my test site is located on my hosting account at HostMonster.com. But i have a question for you, when you say "check on the Joomla backend php info and see which php.ini file it is referencing and its location", where or how do i check this?

Thx for your help!
Stephane

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19082
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: PHP.ini file upload limit?

Postby dhuelsmann » Mon May 12, 2008 6:53 pm

ronronmx wrote:Hey guys, thx for your replies! I was able to figure it out after talking to my host thought :D
dhuelsmann I am not using a local install, my test site is located on my hosting account at HostMonster.com. But i have a question for you, when you say "check on the Joomla backend php info and see which php.ini file it is referencing and its location", where or how do i check this?
Stephane


Doesn't much matter if you are not in a local install
backend -> help -> system info -> php information -> 6th item down -> Configuration File (php.ini) Path

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: PHP.ini file upload limit?

Postby humvee » Tue May 13, 2008 9:46 am

The following is a piece I wrote for the 1.0 Help Screens and covers the settings that may need adjusting.

There is usually an upper limit to the size of image files that can be uploaded through the Media Manager. This upper limit is indicated by, for example, "[Max = 8M]", which indicates that files bigger than 8 megabytes cannot be uploaded. This limit is set in the PHP configuration file (php.ini) and may differ between web servers and web hosts. The limit cannot be altered from within Joomla! Some hosting companies do not allow the limit to be altered at all!

To allow larger files to be uploaded it will probably be necessary to increase the upload_max_filesize and the post_max_size settings.

For very large files it may also be necessary to increase the max_execution_time and the memory_limit settings.


hth

Andy

dannyt3
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Wed Nov 07, 2007 8:47 pm

Re: PHP.ini file upload limit?

Postby dannyt3 » Fri Jul 11, 2008 4:32 pm

I am getting this error: Upload failed, please check your filesize!

Max size in bytes is set to 10000000. I do not have a php.ini file. Do I need to create one? Joomla 1.5.

radjoom
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Oct 24, 2008 5:29 pm

Re: PHP.ini file upload limit?

Postby radjoom » Fri Oct 24, 2008 6:08 pm

Hello,

sometimes is not the max filesize the problem when using media manager.
I found out, that the number of files in a folder is a second limitation.
Loading up a couple of icons shows me that problem. There is a limitation
near about 200 - 256 files in a folder.
If this limit is reached, media manager cannot longer show the folder, neither
in detailed or thumbnail format.
Deleting a few files outside of Joomla (up to 1.5.7) with any filemanager, so
that the max number comes under the limit of 200 - 256 files (sometimes
different), media manager can show everything again.

Where is the limit for that problem inserted?

asmas
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Nov 24, 2008 10:24 am

Re: PHP.ini file upload limit?

Postby asmas » Mon Nov 24, 2008 10:42 am

Hello
Thanks 4 ur reply I just googled the problem.
I do chages in php.ini file as par "dhuelsmann" told.
I can upload file but only upto 9MB above 9MB it does not upload.
And doesn't throw any exception.
I'm not getting why does this happen?
Plz reply. ???

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19082
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: PHP.ini file upload limit?

Postby dhuelsmann » Mon Nov 24, 2008 1:13 pm

asmas wrote:Hello
Thanks 4 ur reply I just googled the problem.
I do chages in php.ini file as par "dhuelsmann" told.
I can upload file but only upto 9MB above 9MB it does not upload.
And doesn't throw any exception.
I'm not getting why does this happen?
Plz reply. ???


What is your file size set to in global configuration system tab? Try changing it to 0 and see if it helps.

asmas
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Nov 24, 2008 10:24 am

Re: PHP.ini file upload limit?

Postby asmas » Tue Nov 25, 2008 7:16 am

That is not working.
Still the problem is there to upload file above 9M. :(

Muslim82
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Fri Aug 08, 2008 11:08 am

Re: PHP.ini file upload limit?

Postby Muslim82 » Tue Nov 25, 2008 11:19 am

sometimes, the hosting companies make it a limitation for their users. Like hosmonster.com has a limitation of 50MB, does not matter what size you put in php.ini, they dont allow more than 50MB.

asmas! you should check the php settings from joomla as dhuelsmann explained above in

backend -> help -> system info -> php information -> (search for) upload_max_filesize

and see what are the limits for local and master values. OR, try contacting your host, they are the right persons to speak with regarding this issue, as this is more to a hosting problem than to joomla.

Anyway, a while back when I had this issue, I spoke with my hosting and they suggested me to go tophp config from cpanel and change to php5 (single php.ini), it solved my problem. But you should backup your files and database first, as it was advised by my host.

Hope it may help.
http://www.KitaboSunnat.com
محکم دلائل و براہین سے مزین متنوع و منفرد کتب پر مشتمل مفت آن لائن مکتبہ

asmas
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Nov 24, 2008 10:24 am

Re: PHP.ini file upload limit?

Postby asmas » Tue Nov 25, 2008 11:39 am

Thanks for reply :)

ozzy1000
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Wed Jan 07, 2009 9:56 pm

Re: PHP.ini file upload limit?

Postby ozzy1000 » Fri Jan 30, 2009 3:29 pm

This might point into the right direction. I was having the same problem. When trying to upload a file I would get something like "JFile::read: Unable to open file". See attached file.

What gets me is that it doesn't complain about the file size at all. But when I tried uploading a file size less than 2MB(default) it works just fine.

Conclusion: check php.ini allowed filesize upload or try uploading a small file to test it.

Good luck.
You do not have the required permissions to view the files attached to this post.

asmas
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Nov 24, 2008 10:24 am

Re: PHP.ini file upload limit?

Postby asmas » Sat Jan 31, 2009 4:48 am

I' solved the problem of "file upload limit" .
Chnage the size in php.ini file as well as in root folder u will get cache folder there are some files where u can change the limit of file upload.
That files are:
cache\joomfish-en-GB\90366616d57f9f6d9b8857ebc171b906.php
cache\joomfish-hn-IN\3ac9e47dc324550924a1bdc3d3a2bf32.php
cache\joomfish-mr-IN\1809dd54be9ee9628cf2a7e729a2e56d.php
cache\joomfish-mr-IN\5367c7f6e9f2dbcb7e043f53905eb6b4.php

In these files set the maxfilesize as per requirement.
I hope this will help u. :)

emal011
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Mon Aug 31, 2009 9:50 am

Re: PHP.ini file upload limit?

Postby emal011 » Fri Apr 16, 2010 12:08 pm

humvee wrote:The following is a piece I wrote for the 1.0 Help Screens and covers the settings that may need adjusting.

There is usually an upper limit to the size of image files that can be uploaded through the Media Manager. This upper limit is indicated by, for example, "[Max = 8M]", which indicates that files bigger than 8 megabytes cannot be uploaded. This limit is set in the PHP configuration file (php.ini) and may differ between web servers and web hosts. The limit cannot be altered from within Joomla! Some hosting companies do not allow the limit to be altered at all!

To allow larger files to be uploaded it will probably be necessary to increase the upload_max_filesize and the post_max_size settings.

For very large files it may also be necessary to increase the max_execution_time and the memory_limit settings.


hth

Andy


Ok, I already tryit, but my requirements are for 1G file, so I configured like this:

PHP.ini Configuration 1 wrote:upload_max_filesize: 2G
post_max_size: 1.5G
max_execution_time: -1
memory_limit: 256M


And what was the result? I could´t make a session in my web site(for go to the download site, you have to be login)!! Always when I was trying to make session, the web page refresh itself and nothing. I though, it was Joomla! you klein!! but not, i couldn´t even enter to phpmyadmin!! WT#?!

That´s mean, I have to set it back the Php file. Ok, I did it! But I need to make the system able to upload bigger files, so I tryit again!

PHP.ini Configuration 2 wrote:upload_max_filesize: 950M
post_max_size: 900M
max_execution_time: -1
memory_limit: 128M


I try with a 22Mb zip file, and works, so that´s mean it works. Now trying with a 70Mb file... FastCGI timeout Error >:( !! I thought with -1 was enough, but isn´t. So:

PHP.ini Configuration 3 wrote:upload_max_filesize: 950M
post_max_size: 900M
max_execution_time: 10000
memory_limit: 128M


Error again! damn! :'( FastCGI? What is that! :-[ I mean I know what it is, but why now? I already test it under another Pc with APache and all works great!!(with 2G configuration)
Ok I search for a solution, and I "found it"!

fcgiext.ini Configuration wrote:[Types]
php=PHP

[PHP]
ExePath="C:\Program Files\PHP\php-cgi.exe"
ActivityTimeout=1000
IdleTimeout=3600


ActivityTimeout!! by default is 300 but I put it 1000, just for testing..

Uploading 70Mb file... Ok works
Uploading 500Mb file... I'm still waiting...but at least it works and I get not error message, until... :pop

I hope this can help somebody or just can help me! :D

emal011
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Mon Aug 31, 2009 9:50 am

Re: PHP.ini file upload limit?

Postby emal011 » Fri Apr 16, 2010 1:32 pm

1 hour and 30 min... just for one 400Mb file, and become no answer!! somebody have an idee?

tarequlhasan
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu May 06, 2010 5:20 am

Re: PHP.ini file upload limit?

Postby tarequlhasan » Thu May 06, 2010 8:13 am

try this it works for me

modify your .htaccess file
suphp_configpath /home/panelbox_username/public_html/

and creat a php.ini file in your public_html

then go to php config from cpanel and change to php5

emal011
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Mon Aug 31, 2009 9:50 am

Re: PHP.ini file upload limit?

Postby emal011 » Thu May 06, 2010 9:40 am

Mmm... I´m under windows Server 2003, IIS 6, PhP5 ...

scoopy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 188
Joined: Sat Jul 19, 2008 7:08 am

Re: PHP.ini file upload limit?

Postby scoopy » Mon Nov 29, 2010 9:28 pm

I thought I had an upload limit issue, however, my issue was that the tmp directory wasn't set in the php.ini file

In particular:

upload_tmp_dir="/home/XXXXXX/public_html"

This wasn't load in

Sorted now :)

williams0627
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed May 25, 2011 3:27 am

Re: PHP.ini file upload limit?

Postby williams0627 » Wed May 25, 2011 3:39 pm

With my sample template I do not know where to get the php.ini but I as well have a 2MB upload limit and I need 8mb for a template that I purchased from Ice Theme. I am using godaddy with Jmmola hosting

rantaris
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Oct 19, 2010 12:54 am

Re: PHP.ini file upload limit?

Postby rantaris » Thu Oct 20, 2011 1:40 am

tarequlhasan wrote:try this it works for me

modify your .htaccess file
suphp_configpath /home/panelbox_username/public_html/

and creat a php.ini file in your public_html

then go to php config from cpanel and change to php5


Works awesome! My installation was defaulting to /usr/lib/... obviously not my area on the server. Once I changed my path to /home/myusername/public_html, everything worked a treat!

sitinuraini
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Feb 10, 2012 7:49 am

Re: PHP.ini file upload limit?

Postby sitinuraini » Fri Feb 10, 2012 7:55 am

Hi, i get this error...

JFile::read: Unable to open file: ''
Warning! - Failed to move file
Error. Unable to upload file

uploaded any pdf file there is ok, but when upload pdf with many image file i cant.. joomla give above error.. how i'll solve this? i have see php.ini, my upload max file and post max file is greater than my pdf file. so i think there is no problem with uploaded size... i only update the website as an administrator.. how can i reach the file php.ini or re-install back without disturbing existing website..

sitinuraini
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Feb 10, 2012 7:49 am

Re: PHP.ini file upload limit?

Postby sitinuraini » Fri Feb 10, 2012 8:49 am

tarequlhasan wrote:try this it works for me

modify your .htaccess file
suphp_configpath /home/panelbox_username/public_html/

and creat a php.ini file in your public_html

then go to php config from cpanel and change to php5



**********************************************************
tarequlhassan, can u help me how to do y :( our solution?


Return to “Administration 1.5”

Who is online

Users browsing this forum: Bing [Bot] and 8 guests