Where are articles stored

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
cruix
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Aug 25, 2008 8:58 am

Where are articles stored

Postby cruix » Mon Aug 25, 2008 9:04 am

Hello

recently my page was hacked, and does not display any contents.
Im trying save what is left on server, but I did not manage to find the folder where articles are stored. Can someone provide the default location for articles.
I m using Joomla 1.5

best regards
Janez

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: Where are articles stored

Postby Tonie » Mon Aug 25, 2008 9:37 am

Articles are stored in the Mysql database, not on the file system. You can use a tool like Phpmyadmin to take a look at the information in the database or export data from it.

smekdesign
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Mon Jul 17, 2006 7:44 pm

Re: Where are articles stored

Postby smekdesign » Thu Sep 04, 2008 4:06 am

i exported the jos_categories, jos_sections, and jos_content from one database and imported into
a clean joomla install and all the articles popped up fine!

conical
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun May 24, 2009 5:08 pm

Re: Where are articles stored

Postby conical » Fri Sep 18, 2009 12:01 am

Thank You!

Very useful information! My site was hacked (yes, I am a n00b ...lesson learned hopefully)
Being able to transfer the database to a fresh install has saved me many hours and a lot of stress.

When I become more expert hopefully I will be able to help others

C

ttnae
Joomla! Intern
Joomla! Intern
Posts: 67
Joined: Wed Mar 11, 2009 1:58 am
Location: Michigan
Contact:

Re: Where are articles stored

Postby ttnae » Sat Feb 04, 2012 5:29 am

I'm so sure that this is SOOOO simple but I'm just not seeing it.

OK, I have backups of my half ass working site (LOL) so i'm safe to play. I've noticed that the DB has two different prefixes, jos_ and bak_. The bak_ 'content, sections, categories...' I can see my articles and everything else.

In the jos_ tables, there doesn't appear to be any info but it doesn't even look the same.

So, I can link to the db but not the correct tables????

I trued changing to bak in global conf but that crashed. I'm out of ideas for tonight.

This is a small site that I can rebuild rather quicklybut this is kinda fun plus I hate to let this site beat me. :)


Return to “Administration 1.5”

Who is online

Users browsing this forum: No registered users and 6 guests