The Flash Module Extension

This forum is for extensions for Joomla! version 1.0

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
seanamac
Joomla! Apprentice
Joomla! Apprentice
Posts: 46
Joined: Tue Apr 22, 2008 12:56 am

The Flash Module Extension

Postby seanamac » Mon Sep 15, 2008 6:50 pm

Hi all. I installed The Flash Module but I'm having trouble getting my flash movie to work in the module position. The only thing I'm not sure about when setting up the module, is it is looking for Object Name/ID and i'm not sure what I should be putting there, if anything. Can anyone help?!?

adahunt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Oct 21, 2008 11:01 pm

Re: The Flash Module Extension

Postby adahunt » Tue Oct 21, 2008 11:18 pm

Hi,

Hopefully you have gotten a resolution by now, but....

The Object Name / ID is the id number of your module. In my case it is 71. You can see that at the very far right of all the modules listed before you go into edit it.

The Flash Module Public user1 All mod_flashmod 71

You need to have your path relative to the swf file. /images/stories/videos/ is my path.

Make sure the permissions on your file are set properly. 755 works. Also make sure you have spelled your file name correctly....It is case sensitive Mine is PugetSound.swf and last but not least, but maybe should be first. Does the file work outside of your site? Never hurts to check even if that seems silly.

Hope that helps

HWold
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jul 01, 2008 1:00 pm

Re: The Flash Module Extension

Postby HWold » Thu Oct 23, 2008 7:44 am

Hi there,

Is this a module to show Flash movies trough the website? I'm looking for a flash player to embed in Joomla! to play off Flash movies stored on the local server.

Thank you.

adahunt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Oct 21, 2008 11:01 pm

Re: The Flash Module Extension

Postby adahunt » Thu Oct 23, 2008 6:23 pm


WebBloomer
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Feb 14, 2009 5:18 pm

Re: The Flash Module Extension

Postby WebBloomer » Sat Feb 14, 2009 5:23 pm

I have a rather simple question for you. When I post my flash content, it only shows on the top-level navigation links. My flash header will not display on sub-menu items.
I have all menu items selected in the module options as well as using an absolute directory for the flash file. Does anyone have any suggestions?

***** Manual signatures are NOT allowed *****

My question is now resolved. Check the following post to see how it was fixed.
Last edited by WebBloomer on Thu Feb 19, 2009 3:18 am, edited 2 times in total.

WebBloomer
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Feb 14, 2009 5:18 pm

Re: The Flash Module Extension

Postby WebBloomer » Thu Feb 19, 2009 3:16 am

Yay, I resolved the issue!

There was a conflict between the Joomla!'s Search Engine Friendly URLs and The Flash Module's "Display Using JavaScript" option in the "Advanced Parameters" section of the module.

With both turned on, the module will not display on sub-pages. However, if you turn just one of these options off, the module appears on all pages. Obviously I want the search engine URLs turned on, so I opted to not display the flash module using JavaScript.

WaLa!

jrroger
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Dec 08, 2008 4:34 pm

Re: The Flash Module Extension

Postby jrroger » Sat Mar 14, 2009 2:48 pm

Something Wrong

I am working with Joomla 1.5.9 and I created a file in Flash to try to add an swf object to my template that is Depio2(image1), the first way used to get it was to create the banner place on template (image 2) and use the banner module from Joomla!, and I got it, but the flash just never started, just show itself but never made any “movement”, then I thought the problem was the use of Banner module and I installed The Flash Module to work in my template, but I got the seam effect at using the banner module for Joomla(image 3), what do you think could be the problem?

1.- Depio2 Template doesn’t permit swf files on template (At using module, its mean I’m not working on template, it is on module, banner module )
2.- . I did not create a good swf file and it is my noob error.
3.- The universe conspire against to me and I will give up this (Never)

Thank you in advance for your help and comments about it…

I don’t send a link to check it, because I am working on Wamp before to upload to my server.

Image
Image 1


Image
Image 2


Image
Image 3

trusting
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Tue Feb 10, 2009 4:49 am

Re: The Flash Module Extension

Postby trusting » Sun Mar 29, 2009 2:38 am

There was a conflict between the Joomla!'s Search Engine Friendly URLs and The Flash Module's "Display Using JavaScript" option in the "Advanced Parameters" section of the module.

With both turned on, the module will not display on sub-pages. However, if you turn just one of these options off, the module appears on all pages. Obviously I want the search engine URLs turned on, so I opted to not display the flash module using JavaScript.


Thank you for posting the solution. It helped me!

Teresa :)

jrroger
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Dec 08, 2008 4:34 pm

Re: The Flash Module Extension

Postby jrroger » Sun Mar 29, 2009 7:54 pm

that does not work on mine, thanks!

rcampbell67
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue May 12, 2009 3:16 pm

Re: The Flash Module Extension

Postby rcampbell67 » Thu May 14, 2009 12:28 am

Hi all,

I have installed the flash module and have used it to show a swf file. That all seems to work fine. But my swf file includes attached files. The attached flv plays just fine and so does does that attached audio but the attached jpgs don't load. Can you tell me what I might be doing wrong

jamesmeijer1234
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Fri May 15, 2009 6:43 pm

Re: The Flash Module Extension

Postby jamesmeijer1234 » Fri May 15, 2009 8:55 pm

well i tried and it didnt work on my intallation

ficaiboyz
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sat Jun 27, 2009 7:28 am

Re: The Flash Module Extension

Postby ficaiboyz » Fri Jul 03, 2009 6:02 am

Hi all. I installed The Flash Module but I'm having trouble getting my flash movie to work.I set File Path,Filename and Object Name / ID already but i got white blank.
Can anyone help?!?

porcupinetree
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jun 03, 2009 9:45 am

Re: The Flash Module Extension - PLEASE HELP!!

Postby porcupinetree » Fri Jul 10, 2009 9:45 am

Well I'm at my wits end. Please can someone help me here? I want to put Flash into a module to display on a page other than the homepage. I've downloaded this plug-in, made sure I have entered everything correctly but the Flash doesn't display, I just get a white box.

Prior to this download I tried using a custom html module and inserted html code, in fact several different bits of code. The nearest I got was some embed code which worked in browsers Firefox, Chrome and Safari but crucially not Internet Explorer.

This extension will solve all my Joomla probs if it could work as I need different Flash movies on each page of my website. I've read through forums, made sure I've got Javascript turned off.

Is there something fundamental I'm missing here?

trusting
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Tue Feb 10, 2009 4:49 am

Re: The Flash Module Extension

Postby trusting » Sat Jul 11, 2009 5:31 am

The nearest I got was some embed code which worked in browsers Firefox, Chrome and Safari but crucially not Internet Explorer.

This extension will solve all my Joomla probs if it could work as I need different Flash movies on each page of my website. I've read through forums, made sure I've got Javascript turned off.

Is there something fundamental I'm missing here?


There is something fundamental missing: Support for Flash in IE 7 & 8 64-bit browsers.

IE 7 also comes in a 32-bit version that can play Flash (which is why there is some confusion about it working fine in IE for one person and not working for another).

Check this article from Adobe: http://kb2.adobe.com/cps/000/6b3af6c9.html

Flashmod works quite well; embed code works well, too. The problem is Adobe's lack of support for 64-bit browsers.

Teresa

porcupinetree
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jun 03, 2009 9:45 am

Re: The Flash Module Extension

Postby porcupinetree » Sat Jul 11, 2009 9:01 pm

You say Flashmod works well. How weird is this?:
I use create a new module using Flashmod link to a Flash file and it play fine in all browsers. I then do the same for another Flash file and link that module to another page. It doesn't work. I created the Flash file at the same time, it almost identical except there are different pics in it. I've made sure all the paths etc. are correct.

No other flash files work. Why should the first work and not others. I even deleted the first one, recreated it, deleted the Flashmod and recreated it. It worked. So why not the others???!!!! I'm stunned . Can anyone please help!!

porcupinetree
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jun 03, 2009 9:45 am

Re: The Flash Module Extension

Postby porcupinetree » Sat Jul 11, 2009 10:05 pm

..and now the original one is not working!

porcupinetree
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jun 03, 2009 9:45 am

Re: The Flash Module Extension

Postby porcupinetree » Sun Jul 12, 2009 4:45 pm

Okay for you newbies out there problem solved. My problem was in the path. Flash Module won't render Flash movies from within the stories folder. If you use images/flash directory they will work fine from within a module on any page. :)

porcupinetree
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jun 03, 2009 9:45 am

Re: The Flash Module Extension

Postby porcupinetree » Sun Jul 12, 2009 4:59 pm

By the way, using Flash Module plug in is the only way I have found to play Flash movies correctly in Firefox, IE, Google Chrome and Safari. I've had problems with it rendering in IE using the JCE Editor film strip and by html coding directly in a custom html module.

trusting
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Tue Feb 10, 2009 4:49 am

Re: The Flash Module Extension

Postby trusting » Sun Jul 12, 2009 9:14 pm

Porcupinetree,

That's an interesting observation about flashmod not working if the file is in images/stories (default image folder). I had placed mine in images/flash as a convenience. Thanks for sharing.

I've noticed that even if you paste the code in the html pop-up box, the editor (JCE or TinyMCE) will sometimes strip or alter the code. It's easy to check whether it's doing that: paste the code, close the pop-up box, then re-open the box to view the code.

If you discover that the editor is stripping or altering the code, there are two options:
1) Add this mod which allows you to paste html, php, javascript, etc. without alteration:
http://extensions.joomla.org/extensions/edition/custom-code-in-modules/1758/details

2) In global configuration, disable the editor (select "no editor"), paste the code, and save. Re-enable the editor when you're done. This option works, but you may run into the same problem (stripped code) again if you need to edit the mod later.

Teresa :)

porcupinetree
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jun 03, 2009 9:45 am

Re: The Flash Module Extension

Postby porcupinetree » Mon Jul 13, 2009 8:40 am

Yes I changed global configuration to No Editor it's the only way for Joomla not to strip code out, on JCE or TinyMC. but you're right if you then want to edit that module again using an editor it'll strip it out.

I found that even using No Editor setting, Flash wouldn't render in IE from the module (though if you want it on the homepage, pasting directly into index.php would). The Flash Module works brilliantly without the need to change editors too. Highly recommended.

By the way, the reason I think Flash wouldn't work from stories is because the Global Configuration path for media was set to images, the path for images set to images/stories. Might work if you changed the media path. :)

User avatar
MrCT
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Sat Jul 15, 2006 9:42 pm
Location: Lulea, Sweden

Re: The Flash Module Extension

Postby MrCT » Mon Aug 17, 2009 11:40 am

Is there any way to use this module to show several flash files?

Lets say I have a directory ' images/flash/front_banners/ ' with three flash files in it. These files are only to be shown on the Front page. Whenever the page is reloaded the module picks a random file.

bloodywicked
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Oct 19, 2009 9:38 pm

Re: The Flash Module Extension

Postby bloodywicked » Mon Oct 19, 2009 9:51 pm

hey there,

this module seems to be the answer of all of my flash ads prayers. But of course, i can get to work :(. i still get the blank/white space where the .swf banner should be playing.

I've tried all the settings, from file_path/file_name case sensitivity, to toggle the Javascript option Yes/No. I also set the .swf file security to ("Everyone" Read access). there's got to be something that i'm missing giving the fact other people had no issue at all o.O I took a snap shot of current config, but here's a quick summary:

Joomla 1.5.14 (stable)
The Flash Module v3.0.2
Mod class sufix: clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
file path: images/flash
file-name: banner.swf
dem: w=120 l-600px
Object name/ID = 132 (the module ID# as it appears on my joomla mod manager)
flash player: 9.00
Quality = High and Window mode (currently to set to window, but also tried transparent)
Javascript : Currently set to Yes, but also tried the No option.

You'll help is greatly apperciated.

thank you
You do not have the required permissions to view the files attached to this post.

trusting
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Tue Feb 10, 2009 4:49 am

Re: The Flash Module Extension

Postby trusting » Mon Oct 19, 2009 10:39 pm

Bloodywicked, What browser are you using? If IE, is it 32 or 64-bit version?

bloodywicked
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Oct 19, 2009 9:38 pm

Re: The Flash Module Extension

Postby bloodywicked » Tue Oct 20, 2009 1:48 am

@ trusting, the browser is 32-bit.

keithyoung89
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 176
Joined: Wed Jan 09, 2008 9:12 pm

Re: The Flash Module Extension

Postby keithyoung89 » Tue Oct 20, 2009 7:53 pm

I'm getting the same problem as bloodywicked. However, I don't think anything's needed in mod class suffix and I wonder if the object/ID is in fact the ID of the module (although that's what I'm trying.

The white block appears where you have Window Mode set to 'window' and it disappears if you set it to 'transparent' (which is what I need to use)

It's very frustrating when you see reviews saying how easily this mod worked on installation but I can't get a peep out of it!

All help very gratefully received!

User avatar
kabam
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 116
Joined: Thu Aug 18, 2005 3:38 pm
Location: Maryland, USA
Contact:

Re: The Flash Module Extension

Postby kabam » Tue Oct 20, 2009 10:23 pm

Well... I had no idea that this thread even existed... :-[

To answer a few questions....

Module Class Suffix - This the same style suffix that is available in all other Joomla! modules. This is explained in the pop-up help that is available when your mouse-over the parameter title. This only needs to be set if you are applying individual styles to your module.

Object Name / ID - This is the ID that is assigned to the actual object tag that plays your SWF so that it can be addressed by scripting languages. In most cases this can be left blank and definitely does not need to match the ID of the module.

File Path - You should be able to set this to anything relative to your website's root. For example, I am currently working on a where my File Path is set to "templates/template1/images" because the SWF I am working with is template specific.


If anyone has any other questions, please feel free to post them to this thread and I will answer them as soon as I can.

Thank you!
Michael
Michael - Vice President / Lead Developer
KABAM.net - Making Websites Work!
Author of Bookmark Us, The Flash Mod, and more.

keithyoung89
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 176
Joined: Wed Jan 09, 2008 9:12 pm

Re: The Flash Module Extension

Postby keithyoung89 » Wed Oct 21, 2009 4:45 pm

Michael - many thanks for resolving this. I confirm it was my error in not having successfully copied the .swf file to the correct folder I thought I'd done this).
I note that there is no need to complete the Object Name/ID parameter.

Keith

jillianheinrich
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Tue Feb 03, 2009 12:04 am
Location: Sydney, Australia

Re: The Flash Module Extension

Postby jillianheinrich » Tue Nov 10, 2009 7:04 am

I am also having the blank white space issue. I have Adobe Flash Player 10 installed. Would this be this issue, as you can only select up to Flash Player 9 in the Parameters? Also, how does this affect users who may have varying versions of Flash Player installed?

Appreciate your assistance.

User avatar
kabam
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 116
Joined: Thu Aug 18, 2005 3:38 pm
Location: Maryland, USA
Contact:

Re: The Flash Module Extension

Postby kabam » Fri Nov 13, 2009 12:49 pm

Most of the time a "blank white space" issue is caused by the path parameter being incorrect. Check your path in your code (view source on your page) and make sure that it is pointing to the correct location for the SWF.

The Flash 10 may be an issue as well. You can either add this to the parameters in the XML file yourself post-install OR you can wait for me to publish a version that does this for you. I'll try to take care of this in the next few days.
Michael - Vice President / Lead Developer
KABAM.net - Making Websites Work!
Author of Bookmark Us, The Flash Mod, and more.

optimized
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Thu Nov 19, 2009 5:46 pm

Re: The Flash Module Extension

Postby optimized » Tue Dec 01, 2009 1:09 am

When I create a 'simple' swf file without a text file the module works
great but now i have moved onto .txt files I do not now where to put or
what to call the txt file!

Any help really appreciated.

Thanks,


Return to “Extensions - 1.0.x”

Who is online

Users browsing this forum: No registered users and 3 guests