The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 31 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: where is php.ini file
PostPosted: Sat Dec 06, 2008 4:01 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 27, 2008 10:10 pm
Posts: 26
Does anyone know where I can find the php.ini file in the joomla installation folder?

Thanks


Top
 Profile  
 
PostPosted: Sat Dec 06, 2008 4:36 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sun Oct 02, 2005 12:50 am
Posts: 18769
Location: Omaha, NE
wsabba01 wrote:
Does anyone know where I can find the php.ini file in the joomla installation folder?

Thanks

Not typically in a Joomla folder unless you put it there. backend (administrator) -> help -> system info -> PHP Information Tab -> 6th block down -> Configuration File (php.ini) Path

will show you the path to the php.ini file in your installation.

_________________
Regards, Dave
http://www.kiwaniswest.org


Top
 Profile  
 
PostPosted: Sat Dec 06, 2008 4:42 pm 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Dec 06, 2008 4:37 pm
Posts: 1
dhuelsmann wrote:
wsabba01 wrote:
Does anyone know where I can find the php.ini file in the joomla installation folder?

Thanks

Not typically in a Joomla folder unless you put it there. backend (administrator) -> help -> system info -> PHP Information Tab -> 6th block down -> Configuration File (php.ini) Path

will show you the path to the php.ini file in your installation.

Thanks you.


Top
 Profile  
 
PostPosted: Sat Dec 06, 2008 4:57 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 27, 2008 10:10 pm
Posts: 26
Thanks


Top
 Profile  
 
PostPosted: Sat Aug 22, 2009 7:27 pm 
Joomla! Intern
Joomla! Intern

Joined: Tue Oct 11, 2005 7:03 am
Posts: 54
sorry, stupid question. but mine says:
Configuration File (php.ini) Path /usr/lib

but i don't know where the usr/lib path is. I can't find it when i look with my FTP. I recently moved all my files from one folder to another and used a backup. did this possibly cause a problem?

thanks.


Top
 Profile  
 
PostPosted: Sat Aug 22, 2009 8:35 pm 
User avatar
Joomla! Master
Joomla! Master
Online

Joined: Sun Oct 02, 2005 12:50 am
Posts: 18769
Location: Omaha, NE
joe m wrote:
sorry, stupid question. but mine says:
Configuration File (php.ini) Path /usr/lib

but i don't know where the usr/lib path is. I can't find it when i look with my FTP. I recently moved all my files from one folder to another and used a backup. did this possibly cause a problem?

thanks.

If you are on a shared server, you typically don't have access with FTP to your php.ini. You will need to adjust some parameters in your configuration.php if you moved your installation.

_________________
Regards, Dave
http://www.kiwaniswest.org


Top
 Profile  
 
PostPosted: Sun Aug 23, 2009 9:23 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Mar 23, 2006 5:01 am
Posts: 8
wsabba01 wrote:
Does anyone know where I can find the php.ini file in the joomla installation folder?

Thanks

You can create php.ini at Joomla Directory. I do it usually.

_________________
Experto Joomla
Servicios y Asesoría Joomla! en Español
[url]Experto-Joomla.com[/url]


Top
 Profile  
 
PostPosted: Sun Aug 23, 2009 11:08 pm 
Joomla! Intern
Joomla! Intern

Joined: Sun Aug 23, 2009 10:59 am
Posts: 60
You can also set php variables in .htaccess if you're on shared hosting - for example:

Code:
php_flag safe_mode on
php_flag disable_functions show_source
php_value include_path ".:/home/includes/php/


Top
 Profile  
 
PostPosted: Tue Aug 25, 2009 4:47 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Aug 25, 2009 4:21 am
Posts: 1
I stiil cannot find the file. Inside help folder didn’t have system info file?

Thank you


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Tue Aug 25, 2009 6:12 am 
Joomla! Intern
Joomla! Intern

Joined: Sun Aug 23, 2009 10:59 am
Posts: 60
For your XAMP local installation log in to the Joomla Administrator backend ---- then from the menus ---- help ---- system info ------- PHP information (& then scroll down to see where your php.ini file is stored)

On a new installation on your webhost "htaccess.txt" is stored in the ROOT of the installation - i.e one level above the Administrator folder - where you see:

/administrator
/cache
/components
/images
/includes
/installation
/languages
/libraries
/logs
/media
/modules
/plugins
/templates
/tmp
/xmlrpc
htaccess.txt ---------- rename this to .htaccess

in .htaccess you can add set php variables if you do not have access to php.ini because you are on shared hosting


Top
 Profile  
 
PostPosted: Wed Aug 26, 2009 1:34 am 
Joomla! Explorer
Joomla! Explorer

Joined: Fri Jul 03, 2009 5:38 pm
Posts: 443
php.ini locations:

XAMPP - http://www.apachefriends.org/en/faq-xam ... tml#phpini
WAMP - http://www.wampserver.com/en/faq.php
MAMP - "/Applications/MAMP/conf/php5/php.ini"

You can also use the following commands to find php.ini from the shell:

> updatedb
> locate php.ini

_________________
Joseph Davis
Technical Support Representative
jdavis@hosting.com
http://hosting.com


Top
 Profile  
 
PostPosted: Wed Aug 26, 2009 2:27 am 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Aug 26, 2009 2:19 am
Posts: 114
Location: Jeddah-Saudi Arabia
it realy helped
thanks alot

_________________
PHP designer,
manager,RISEMYWEB
http://www.9or.cc | صور
http://www.risemyweb.com | موقعي


Top
 Profile  
 
 Post subject: Re: here is php.ini file
PostPosted: Sun May 30, 2010 12:14 am 
Joomla! Intern
Joomla! Intern

Joined: Sat Dec 19, 2009 8:46 pm
Posts: 79
Location: Kona Hawaii
I found that my host said that the php.ini need to be where the script was ran.
In this case for media manager it had a limit of 2mb.
Reason for this was uploading large files Acrobat PDF

I simply place a php.ini file into the administration folder of Joomla 1.5. Upon this PHP recognized the new php settings.

Here are the php.ini file i created:

register_globals = Off
upload_max_filesize = 30M
post_max_size = 30M
memory_limit = 30M
upload_tmp_dir = 30M
max_execution_time = 180


Top
 Profile  
 
PostPosted: Sun Feb 27, 2011 2:10 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Jul 11, 2010 2:13 am
Posts: 3
This worked for me. Thanks

I simply place a php.ini file into the administration folder of Joomla 1.5. Upon this PHP recognized the new php settings.

Here are the php.ini file i created:

register_globals = Off
upload_max_filesize = 30M
post_max_size = 30M
memory_limit = 30M
upload_tmp_dir = 30M
max_execution_time = 180[/quote]


Top
 Profile  
 
PostPosted: Fri May 13, 2011 3:03 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 28, 2011 7:26 pm
Posts: 5
I did what the some of the guys tried above, created a php.ini text file and uploaded via ftp to the ADMINISTRATOR folder but nothings seems to happen. I'm trying to change the execution time..
What am i doing wrong??!?!


Top
 Profile  
 
PostPosted: Sat May 14, 2011 10:56 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat May 14, 2011 10:52 am
Posts: 21
dhuelsmann wrote:
wsabba01 wrote:
Does anyone know where I can find the php.ini file in the joomla installation folder?

Thanks

Not typically in a Joomla folder unless you put it there. backend (administrator) -> help -> system info -> PHP Information Tab -> 6th block down -> Configuration File (php.ini) Path

will show you the path to the php.ini file in your installation.


This was useful, thanks...

_________________
Transitioning these from Flash... be kind to me...
car insurance companies
vehicle insurance


Top
 Profile  
 
PostPosted: Tue May 24, 2011 4:26 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue May 24, 2011 4:22 pm
Posts: 1
I want to upload a and attach a 4Mb PDF to an article - ive been told I need to change my php.ini and this is controlled by the hosting provider

1 - is this true?
2 - I can seem to find a php.ini even when looking with FTP

Whats the best way to make this simple change?


Top
 Profile  
 
PostPosted: Tue May 24, 2011 5:18 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Mon Aug 29, 2005 10:17 am
Posts: 13979
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Create a txt file with notepad and insert
Code:
upload_max_filesize = 100M
. Save as max.txt. Upload to your server to the root of your Joomla installation (your public_html-folder) and rename max.txt to php.ini

Done

Leo 8)

_________________
-- Joomla Professional Support Services : http://gws-desk.com --
-- Good & Cheap Joomla Sites Ready To Roll : http://gws-deals.today --
-- Joomla Specialized Hosting Solutions : www.gws-host.com --
-- Member Joomla Bug Squad --


Top
 Profile  
 
PostPosted: Sun Jul 10, 2011 10:36 am 
Joomla! Intern
Joomla! Intern

Joined: Thu Mar 04, 2010 9:03 am
Posts: 80
Ok, I do not get anything from this information above.

Where do I find the php.ini so I can change the size of uploaded videos? Where do I change the values on this?

Can someone pls say the direction?


Top
 Profile  
 
PostPosted: Wed Aug 10, 2011 11:33 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Aug 10, 2011 11:29 am
Posts: 1
in system info it says Configuration File (php.ini) Path /web/conf
I dont know where is /web/conf
can anyone please help
in system info it says PHP config WRITEABLE

Thanks


Top
 Profile  
 
PostPosted: Sat Sep 17, 2011 1:21 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jun 20, 2011 7:45 am
Posts: 28
I had the same problem. Spent about 6 hours in frustration with no results.

I was trying to upload Community Builder. After changing all the permissions, creating my pwn php.ini (according to inctructions in one of above posts) and doing god knows what else I ended up contacting my hosting company and asking them if there is anything they can do about it. It took them less than 5 minutes to fix it and i have FINALLY uploaded the component.

So, if you are on a shared server, just contact them and get them to do it for you! If they refuse - find yourself another hosting company - it is not a difficult thing to change and they really should not object to that!

This really heped me http://www.joomlapolis.com/support/tuto ... p-settings


Top
 Profile  
 
PostPosted: Mon Sep 19, 2011 8:06 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Sep 19, 2011 8:03 pm
Posts: 2
Thanks Image


Top
 Profile  
 
PostPosted: Tue Sep 27, 2011 10:44 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Sep 27, 2011 10:40 am
Posts: 1
Quote:
Here are the php.ini file i created:

register_globals = Off
upload_max_filesize = 30M
post_max_size = 30M
memory_limit = 30M
upload_tmp_dir = 30M
max_execution_time = 180


This work 100% for me - I dropped the php.ini file in the Administrator folder and could upload the component that timed out before. (Fabrik)

(The upload failed and said: "There was an error uploading this file to the server.")

Thanks!


Top
 Profile  
 
PostPosted: Tue Sep 27, 2011 12:54 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Sep 27, 2011 12:05 pm
Posts: 1
maggie0608 wrote:
my way to handle this is to create php.ini at the Joomla Directory


Important can easy create php.ini


Top
 Profile  
 
PostPosted: Mon Oct 03, 2011 4:57 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Oct 03, 2011 4:19 pm
Posts: 32
php.ini can be placed anywhere. Run phpinfo() and see where it is.

_________________
Please read forum rules regarding the use of signatures: viewtopic.php?f=8&t=65


Top
 Profile  
 
PostPosted: Sat Nov 19, 2011 6:32 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Nov 19, 2011 6:22 am
Posts: 3
I'm also having the same issue, although i'm currently still developing the website locally and is not hosted online just yet. I'm trying to install a template which is 3.7mb in size

I've run the phpinfo() and it appears that my php.ini is located in /etc (for those windows people this is one of the hidden configs folders on a MAC)

I'm running OSX 10.7.2 at the moment and i've gone into the /etc folder and there is no php.ini file but there is a php.ini.default file. I've taken ownership of that file and modified the file to:

max_upload_filesize to 20M

Ran the phpinfo() and its still saying 2M

I've made a new php.ini file and placed it in the root folder of my website folder and the same in the administrator folder, consisting of

register_globals = Off
upload_max_filesize = 30M
post_max_size = 30M
memory_limit = 30M
upload_tmp_dir = 30M
max_execution_time = 180

Ran the phpinfo() and its still saying 2M... =(

Any help would be much appreciated...


Top
 Profile  
 
PostPosted: Wed Nov 23, 2011 1:02 am 
Joomla! Virtuoso
Joomla! Virtuoso
Online

Joined: Sat Oct 01, 2011 7:06 pm
Posts: 4520
On xampp it is in the php folder. Did you look there?

_________________
Issue with migrating? Include logs/joomla_update.php in your report!


Top
 Profile  
 
PostPosted: Wed Nov 23, 2011 1:10 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Nov 19, 2011 6:22 am
Posts: 3
Hi sovainfo,

I did not use XAMPP to install mySQL.. i downloaded the mySQL and installed that instead... bugger! If i used XAMPP, i would assume i would have been able to control this setting from a UI of some sort..

Issue is still present.. =(


Top
 Profile  
 
PostPosted: Wed Nov 23, 2011 9:32 am 
Joomla! Virtuoso
Joomla! Virtuoso
Online

Joined: Sat Oct 01, 2011 7:06 pm
Posts: 4520
php.ini is not related to mysql, it is to php. Where did you install php. The php.ini is in that folder.

_________________
Issue with migrating? Include logs/joomla_update.php in your report!


Top
 Profile  
 
PostPosted: Thu Nov 24, 2011 12:58 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sat Nov 19, 2011 6:22 am
Posts: 3
f memory serves me correctly, i also manually installed phpMyAdmin to interact with the database using a user friendly UI. I've searched in the installed folder for the php.ini file or anything related or similar with no success. I've even created my own php.ini file in the phpMyAdmin folder to no success again. I've even tried searching my entire mac for php.ini and nothing is coming up.. =/

Not too sure which file is overriding or defaulting the PHP max file size..
Does PHP default to a certain hidden file perhaps, or is there a file that points to a default file if no php.ini is found?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 31 posts ]  Go to page 1, 2  Next



Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group