The Joomla! Forum ™






Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Thu Mar 19, 2009 6:34 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 23, 2008 3:29 am
Posts: 15
Joomla_1.5.9.
Virtuemart 1.1.3.
Joomfish 2.0.2.
--------------
Macintosh OS X 10.5.6.
MAMP
Apache Version : 2.0.59
MySQL 5.0.41
PHP 4.4.8 & 5.2.6
eAccelerator 0.9.5.3 control panel
Apache Environment (GATEWAY_INTERFACE) CGI/1.1
apache2handler Loaded Modules mod_rewrite (yes)
----------------------------------------------------------
Settings:
Search Engine Friendly URLs - Yes
Use Apache mod_rewrite - Yes

Hello,
Thanks for the software and all your hard work.
I’m running on my localhost server and because I already have Joomla installed in the root, I am testing in a double sub directory: /MAMP/jvirtuemart/Joomla/

ie: .htaccess

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

RewriteBase/MAMP/Jvirtuemart/Joomla/ (NOTE:) I have also tried this without the MAMP.

# Options +FollowSymLinks (NOTE:) I have also tried this uncommented.
#
# mod_rewrite in use
RewriteEngine On

The main thing is: My home page always loads no problem: Address:
http://localhost:8888/MAMP/Jvirtuemart/Joomla/

But, when I turn on (Use Apache mod_rewrite) and "Search Engine Friendly URLs" only the home page works. All other pages give me a 404 Not Found message including Virtuemart.

I have checked in the Apache file that the mod_rewrite is uncommented and in my php settings it shows that the module is loaded. I have double checked all versions for compatibility or known bug releases and I seem to have all the latest versions with no reported issues. After a solid week of working on this I just can’t think of any place else to look or things to try. I have tried this test for Apache:
RewriteRule (.*) http://www.google.com/
with no luck.

I have read the posts here and find no one with such a basic problem expressed. I do not use sh404sef
or any other third party plug-ins or components. It just doesn't work in the basic Joomla install.

Any suggestions would be greatly appreciated.

Thanks

Wayne


Top
 Profile  
 
PostPosted: Thu Mar 19, 2009 7:40 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Sun Oct 02, 2005 12:50 am
Posts: 18728
Location: Omaha, NE
Check all three options in the seo options section

_________________
Regards, Dave
http://www.kiwaniswest.org


Top
 Profile  
 
PostPosted: Fri Mar 20, 2009 2:08 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 23, 2008 3:29 am
Posts: 15
dhuelsmann,

Thanks for the quick reply. Funny thing is it worked for a minute but not for all links and after the first 404 page not found happened, all the others stopped working. I cleared the cash but no matter what could not get things working again.

Wayne


Top
 Profile  
 
PostPosted: Fri Mar 20, 2009 4:14 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Sun Oct 02, 2005 12:50 am
Posts: 18728
Location: Omaha, NE
Let's test to see if mod_rewrite is enabled on your server. Place only the following code in .htaccess:
Code:
RewriteEngine On
Options +FollowSymLinks
Redirect /google.html http://www.google.com

Now point your browser to: http://www.yoursite.com/google.html
If it redirects you to Google - mod_rewrite is working.
If it gives you an error - mod_rewrite is not working.

Note: Replace "www.yoursite.com" with your actual web site domain.

_________________
Regards, Dave
http://www.kiwaniswest.org


Top
 Profile  
 
PostPosted: Fri Mar 20, 2009 5:37 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Sep 23, 2008 3:29 am
Posts: 15
dhuelsmann,

Thanks again,

Yes I had done that with no response. At this point after reading the debate between users and Google, and the fact that I'm having so much troube getting this to work, I may just not use SEO.

Link to Google artical on blog:
http://googlewebmastercentral.[URL banned]. ... -urls.html

And the debate here on Joomla:
viewtopic.php?f=544&t=366842

Thanks

Wayne


Top
 Profile  
 
PostPosted: Sat Mar 21, 2009 3:22 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Oct 28, 2008 6:03 pm
Posts: 6
I'm getting the exact same problem. I really want to get this working. I tried testing the mod rewrite, and it does go to google when I put http://www.yoursite.com/google.html

What should I do?

Any help would be greatly appreciated ;)


Top
 Profile  
 
PostPosted: Sun Mar 22, 2009 4:44 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Feb 21, 2006 10:06 am
Posts: 45
Location: Agaete, Gran Canaria
dhuelsmann wrote:
Let's test to see if mod_rewrite is enabled on your server. Place only the following code in .htaccess:
Code:
RewriteEngine On
Options +FollowSymLinks
Redirect /google.html http://www.google.com

Now point your browser to: http://www.yoursite.com/google.html
If it redirects you to Google - mod_rewrite is working.
If it gives you an error - mod_rewrite is not working.

Note: Replace "www.yoursite.com" with your actual web site domain.


Well, the google trick works, so i got mod rewrite working. Joomla still produces 404 pages... Any ideas?


Top
 Profile  
 
PostPosted: Mon Mar 23, 2009 2:09 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Oct 28, 2008 6:03 pm
Posts: 6
I just realized what I was doing wrong. I forgot to add the dot in front of the .htaccess file when renaming it from htaccess.txt :-[

It works great now ;D

Anyone else who is having the sef problem, check to make sure there is a dot infront of the htaccess file when you rename it ;)


Top
 Profile  
 
PostPosted: Mon Mar 23, 2009 2:46 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Feb 21, 2006 10:06 am
Posts: 45
Location: Agaete, Gran Canaria
I got it working by usin a different .htaccess file, might be the default one (as the one I had probably wasn't)...


Top
 Profile  
 
PostPosted: Mon Jan 10, 2011 6:39 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Fri Aug 06, 2010 1:56 pm
Posts: 109
ldigital wrote:
I just realized what I was doing wrong. I forgot to add the dot in front of the .htaccess file when renaming it from htaccess.txt :-[

It works great now ;D

Anyone else who is having the sef problem, check to make sure there is a dot infront of the htaccess file when you rename it ;)


You Genius, Upgrade immediatley to Joomla Master in my book !

Thank You, a simple . and everything works. Yippeeee


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 



Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group