Installation errors XAMPP - WAMPServer 2 and PHP5.3

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Installation errors XAMPP - WAMPServer 2 and PHP5.3

Postby humvee » Sun Aug 02, 2009 6:51 am

Hi
Currently as at J1.5.14 - Joomla! is not compatable with the PHP5.3.x releases. You should ensure that your server be it remotely hosted or on your localhost (home computer) only uses PHP5.2.x. http://www.php.net/downloads.php#v5

The latest release of WAMPServer 2 has the latest PHP5.3 version installed by default and you need to obtain the latest PHP5.2.x release addon from http://www.wampserver.com/en/addons_php.php

Meanwhile...XAMPP is currently running Beta testing on XAMPP version 1.7.2.x this too has the PHP5.3 installed. It is "unfortunately" highlighted on the homepage blog of http://apachefriends.org (logical place for it :)) but you should not use this for running Joomla! Download the latest stable release containing PHP5.2.x from http://www.apachefriends.org/en/xampp.html

Remember Joomla! does not currently work with PHP5.3

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Installation errors XAMPP - WAMPServer 2 and PHP5.3

Postby humvee » Thu Aug 06, 2009 1:09 pm

Anyone interested in helping to test Joomla! and PHP5.3 compatability please look at this request Testing Help with PHP 5.3.0


User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Installation errors XAMPP - WAMPServer 2 and PHP5.3

Postby humvee » Thu Feb 18, 2010 11:32 pm

Please note that with the release of version 1.5.15 in November 2009 Joomla! does work with PHP 5.3.x however earlier versions prior to 1.5.15 will not.


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 5 guests