The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Thu Mar 11, 2010 2:06 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Sep 24, 2008 6:06 pm
Posts: 198
Location: Bangalore
Hi,

I have some tutorial based on HTML, XML and ANT and other topics which i want to publish in Joomla Based site.

The Problem is when i copy and paste into article editor, Example code gets convert into some different tag.

I want to get code block functionality in Article Editor which most of the forum is having to highlight code example.


Any suggestion?

_________________
cmsGalaxy Team, Web Developer, Bangalore, India
Website Design - Development - SEO - Joomla
www.cmsGalaxy.com


Top
 Profile  
 
PostPosted: Sat Apr 10, 2010 12:35 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Fri Aug 12, 2005 7:19 am
Posts: 10541
Location: Leeds, UK
You need to enable the geshi plugin from the plugin manager.

Example usage

Syntax usage :
<pre xml:lang="php">
echo $test;
</pre>

_________________
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/


Top
 Profile  
 
PostPosted: Sat Apr 10, 2010 1:06 pm 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Wed Mar 04, 2009 9:50 am
Posts: 922
Location: Silicon Valley, CA, USA
Also be aware of a bug in the front-end article editor (admin-side is fine)

http://forum.joomla.org/viewtopic.php?p=1918535#p1918535


Top
 Profile  
 
PostPosted: Sat May 08, 2010 3:39 am 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Wed Sep 24, 2008 6:06 pm
Posts: 198
Location: Bangalore
Thanks for your input. but my problem is different.

When i copy some XML or html code into joomla article(programming tutorial Program) it does not display...

plz have a look on this link http://www.scmgalaxy.com/component/cont ... maven.html

_________________
cmsGalaxy Team, Web Developer, Bangalore, India
Website Design - Development - SEO - Joomla
www.cmsGalaxy.com


Top
 Profile  
 
PostPosted: Sat May 08, 2010 5:33 am 
User avatar
Joomla! Guru
Joomla! Guru

Joined: Wed Mar 04, 2009 9:50 am
Posts: 922
Location: Silicon Valley, CA, USA
Then, probably
http://docs.joomla.org/Why_does_some_HT ... n_1.5.8%3F

Your XML is probably getting "cleaned" just like HTML does.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 



Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group