Upgrading from Joomla 1.6.3 to 2.5

Need help upgrading your Joomla! website or converting to Joomla! 2.5?
Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
gizmo77
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Jan 23, 2008 4:10 pm

Upgrading from Joomla 1.6.3 to 2.5

Postby gizmo77 » Sat Feb 04, 2012 10:35 pm

I had trouble with this and wanted to post the solution I found.

For current Joomla 1.6.3 sites (and potentially 1.6.0, 1.6.1 and 1.6.2): Before upgrading to Joomla 2.5 you will first need to upgrade to 1.6.4. Go to this link to find the Stable Patch package:http://joomlacode.org/gf/project/joomla/frs/?action=FrsReleaseBrowse&frs_package_id=5957

If that link does not work, you will need to do a site search for the patch upgrade since 1.6 is not listed on the standard Joomla files download page anymore.

I had trouble getting the patch to install through the installer. To work around this, I updated the site manually. To update your site manually: 1- download the patch to your computer, 2- unzip it, 3- upload each file to it's proper folder on your site one file at a time. It sounds tedious, but this only took me about 15-20 minutes.

Once that was done, I was able to follow the installation instructions found here: http://docs.joomla.org/Upgrading_from_1.6.4_or_earlier

Before and after the installation, I had "JFTP" errors using the installer. i also got errors when I tried to install from the tmp directory. To fix this, I turned off the "Enable FTP" setting in the Global Configuration. I found that tip in this post, and there are many other tips for troubleshooting upgrades for a 1.6.x site here as well:http://forum.joomla.org/viewtopic.php?p=2466041 I found the post looking for a solution to the first error I got, which said "The PHP temporary directory is not set" and "setting this in your php.ini file might fix the issue."

In summary, if attempting to upgrade your 1.6.x site, I suggest you manually upgrade it to 1.6.4 FIRST before doing anything else.

Return to “Migrating and Upgrading to Joomla! 2.5”

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests