Fatal error: Allowed memory size of 16777216 bytes exhausted

Need help upgrading your Joomla! website or converting to Joomla! 2.5?
Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Ubique1964
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu May 26, 2011 9:14 am

Fatal error: Allowed memory size of 16777216 bytes exhausted

Postby Ubique1964 » Tue Feb 28, 2012 12:13 pm

Guys every time I try and update from one ver to another I always get a memory error, how on earth can I fix this so I can update to 2.5

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 7037837 bytes) in E:\hshome\annettej\extremeclangaming.com\libraries\joomla\filesystem\file.php on line 360

Ubique1964
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu May 26, 2011 9:14 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby Ubique1964 » Fri Mar 02, 2012 4:12 am

Serious not one reply since posting this either you ppl are [censored], you wouldn't know if ur being [censored] by an elephant.

See if this get a reply

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16153
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby leolam » Sat Mar 03, 2012 10:37 am

You want help you behave..you do not behave you do not get help
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

Ubique1964
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu May 26, 2011 9:14 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby Ubique1964 » Sat Mar 03, 2012 2:57 pm

Yay thank you mate, much appreciated

Ubique1964
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu May 26, 2011 9:14 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby Ubique1964 » Sat Mar 03, 2012 2:58 pm

leolam wrote:You want help you behave..you do not behave you do not get help



Yes mummy Pffffft

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 21592
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby Per Yngve Berg » Sat Mar 03, 2012 6:20 pm

Use the Forum Post Assistant.

Increase the memory limit in php on your web server. It's probably set to 16M.
If editing the php.ini file does not work, you have to talk to your host.
It's set to 128M on the web hotels I am using. Joomla runs without a hitch.

Ubique1964
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu May 26, 2011 9:14 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby Ubique1964 » Sat Mar 03, 2012 10:51 pm

Per Yngve Berg wrote:Use the Forum Post Assistant.

Increase the memory limit in php on your web server. It's probably set to 16M.
If editing the php.ini file does not work, you have to talk to your host.
It's set to 128M on the web hotels I am using. Joomla runs without a hitch.


Thank you very much mate, I can't find where to edit it in the php.ini anyway lol

Forum Post Assistant (v1.2.0) : 3rd March 2012 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 1.7.1-Stable (Ember) 26-Sep-2011
Joomla! Platform :: Joomla Platform 11.2.0-Stable+Modified (Omar) 27-Jul-2011
Joomla! Configured :: Yes | Writable (666) | Owner: 0 (uid: /gid: ) | Group: 0 (gid: ) | Valid For: 1.7 and above
Configuration Options :: Offline: 0 | SEF: 0 | SEF Suffix: 0 | SEF ReWrite: 0 | .htaccess/web.config: No | GZip: 0 | Cache: 0 | FTP Layer: 0 | SSL: 0 | Error Reporting: -1 | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 0 | Database Credentials Present: Yes

Host Configuration :: OS: Windows NT | OS Version: 5.2 | Technology: i586 | Web Server: Microsoft-IIS/6.0 | Encoding: gzip,deflate,sdch | Doc Root: E:/hshome/annettej/ssaclan.com | System TMP Writable: Yes

PHP Configuration :: Version: 5.2.17 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 6135 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: 1 | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 10M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 60 | Memory Limit: 400

MySQL Configuration :: Version: 5.0.77-log (Client:5.0.51a) | Host: --protected-- (--protected--) | Collation: utf8_general_ci (Character Set: utf8) | Database Size: 3.69 MiB | #of _FPA_TABLE: 284
Detailed Environment :: wrote:PHP Extensions :: bcmath () | calendar () | com_dotnet (0.1) | ctype () | date (5.2.17) | filter (0.11.0) | ftp () | hash (1.0) | iconv () | json (1.2.1) | odbc (1.0) | pcre () | Reflection (0.1) | session () | libxml () | standard (5.2.17) | tokenizer (0.1) | zlib (1.1) | SimpleXML (0.1) | dom (20031129) | SPL (0.2) | wddx () | xml () | xmlreader (0.1) | xmlwriter (0.1) | cgi-fcgi () | curl () | gd () | mysql (1.0) | Zend Engine (2.2.0) |
Potential Missing Extensions :: zip | openssl | mbstring | mysqli | mcrypt | suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: No | PHP SU: Yes | Custom SU (Cloud/Grid): No
Potential Ownership Issues: Maybe
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (777) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) |
Templates Discovered :: wrote:Templates :: SITE :: atomic (1.7.0) | beez5 (1.7.0) | beez_20 (1.7.0) | hexicon_gamer (1.0) |
Templates :: ADMIN :: bluestork (1.7.0) | hathor (1.7.0) |

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 21592
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby Per Yngve Berg » Sun Mar 04, 2012 9:10 am

This is strange: Memory Limit: 400. It should have been 128M.
Talk to your host about it.

simplicitySimon
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Fri Sep 22, 2006 3:24 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby simplicitySimon » Wed May 16, 2012 3:15 am

Just to clear this up... although it is an old post. The "php.ini" file can be found in the Administrator folder and can easily be edited by any TEXT editor.
Around line 6 - change upward the memory allocation.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16153
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby leolam » Wed May 16, 2012 5:52 am

simplicitySimon wrote:Just to clear this up... although it is an old post. The "php.ini" file can be found in the Administrator folder
This depends entirely on your host. This has nothing to do with Joomla but just is hosting related if additional php.ini files are needed/allowed or not. Joomla has no php.ini file.

Leo 8)
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

simplicitySimon
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Fri Sep 22, 2006 3:24 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby simplicitySimon » Wed May 16, 2012 6:30 am

hi Leo
Beg your pardon... probably correct and just my old 'work-arounds'. Without going to great extent... and if my memory serves me correctly... then you can create a file for that particular directory/folder without causing too much havoc.
From memory it was an old "hack" to also work around the "register globals" of previous versions. Probably best to do a search for "php.ini" and read the associated documentary. Mine went something like this...

Code: Select all

register_globals = 0
magic_quotes_gpc = 1
safe_mode = 1
memory_limit = 56M


which was all it took to get the memory resized and the globals turned off
Simon

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16153
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby leolam » Wed May 16, 2012 6:56 am

simplicitySimon wrote:hi Leo
Beg your pardon... probably correct and just my old 'work-arounds'. Without going to great extent... and if my memory serves me correctly... then you can create a file for that particular directory/folder without causing too much havoc.
From memory it was an old "hack" to also work around the "register globals" of previous versions. Probably best to do a search for "php.ini" and read the associated documentary.
My dear Simon, this depends entirely if your host needs and/or allows you to set up additional php.ini files yes or not. And I do have some knowledge with thousands of Joomla users hosted on our own servers in our hosting business I think :laugh:

Btw your memory limit is too low: set to 96 Mb the minimum and Magic Quotes is now deprecated and has actually been removed in current PHP releases anyway and Safe mode should be "off" so you need to update your settings and remove the MQ all together

Cheers
Leo 8)
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

omthoke
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue May 15, 2012 5:31 pm
Location: India
Contact:

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby omthoke » Wed May 16, 2012 7:20 am

PHP.ini files may not be visible if you're accessing a shared web server, so you can't blame the poor guy who wasn't able to find it! Besides, messing with such files without proper knowledge can lead to disasters...

And, yes increasing the memory size should fix it.

simplicitySimon
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Fri Sep 22, 2006 3:24 am

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby simplicitySimon » Wed May 16, 2012 7:48 am

Hi again Leo, thanks.
Your recommendations prompt a question - the site itself is very old... 1.0.12 from memory. If in following your advice, will it impact upon the Joomla installation - ie. can I follow your advice knowing that we are running PHP 5... though with such an old version of Joomla?
TIA. Simon

User avatar
xristo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Jul 06, 2010 11:48 pm
Location: Charlotte, NC
Contact:

Re: Fatal error: Allowed memory size of 16777216 bytes exhau

Postby xristo » Fri Oct 31, 2014 5:39 pm

Thank you to everybody who commented here. I can't believe my host allowed it, but putting the php.ini file in my administrator directory fixed the blank config screens AND putting the same php.ini file in my sites root fixed the issues of site / pages not displaying.

Thank you, thank you, thank you... a 2 year old post, who knew!

Just for the record, running;

joomla 3.3.6
K2 v2.6.8
sh404SEF 4.4.5.2230
RSFirewall v2.7.3
JCE 2.4.3
Gavick theme JOHN - Gavern v.3.11
PHP v5.4.33


Return to “Migrating and Upgrading to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 3 guests