Can't Install 2.5 on PHP 6.0

Need help installing Joomla! 2.5? For all Joomla! 2.5 installation issues please use this forum. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.
Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
travelinjester
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Apr 14, 2012 9:31 am

Can't Install 2.5 on PHP 6.0

Postby travelinjester » Sat Apr 14, 2012 9:35 am

When i try to instal la fresh 2.5 Joomla I get this error..

Code: Select all

Fatal error: Declaration of JInstallation::_createSession() must be compatible with that of JApplication::_createSession() in C:\AppServ\www\installation\includes\application.php on line 361


Works with php 5.2.6 needed 6.0 for some extensions..

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Can't Install 2.5 on PHP 6.0

Postby humvee » Sun Apr 22, 2012 8:20 am

Joomla! is only approved for use on the STABLE software releases detailed in the Technical Requirements. PHP 6.0 is not a stable release of the language and is not therefore considered valid for testing Joomla! against. If you have need for it to be installed then I would suggest a separate development Web server with the specs that you want and you must accept that there are/will be limitations as to the Joomla! performance at this time.


Return to “Installation Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 8 guests