The Joomla! Forum ™



Forum rules


Please use the mailing list here: http://groups.google.com/group/joomla-dev-general rather than this forum.



Post new topic Reply to topic  [ 79 posts ]  Go to page Previous  1, 2, 3  Next
Author Message
PostPosted: Wed Jul 04, 2012 12:21 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jan 26, 2009 9:04 am
Posts: 28
chanderjeet wrote:
I am using Joomla 2.5.6 with XAMPP and this is how I fixed it :
- Open C:\xampp\php (or wherever your xampp is installed)
- Open php.ini in notepad and search for [PECL]
- This will take you to a section with lot of extensions listed.
- Add the following line just above the [PECL]
extension=php_openssl.dll
- Save the file
- Restart the apache service and you should be good :D


I can not thank you enough... had the same problem with wamp....
1. so retarded that a wamp's default configuration is so poor (lot of things disabled which are needed for normal php use, like for instance php_fileinfo - no zip decompression if this is not enabled)
2. Joomla's error messages really suck..... That I know for a long time, and am dissapointed every time

Nevertheless, thank you chanderjeet


Top
 Profile  
 
PostPosted: Tue Jul 10, 2012 11:36 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Jul 10, 2012 11:28 pm
Posts: 1
My contact form is not working. First I thought it was problems with my server.
I checked the server settings and I saw they were ok, I always used settings for PHP Mail, as it did not work at all, I tried configuring the Sendmail that also did not work, finally I tried setting the SMTP and neither worked.

Below are the error messages I get:
PHP Mail: Could not instantiate mail function.
Sendmail: Unable to run: /usr/sbin/sendmail
SMTP: The following address failed: myuser@mydomain.com.br

The email settings fields are:
Method: SMTP
E-mail Sender: mymail@mydomain.com.br
Sender Name: mySendername
Sendmail Path: /usr/sbin/sendmail
Authentication: yes
Security: SSL
Port: 587
User: mymail + mydomain.com.br
Password: **********
Server: mail.mydomain.com.br

Finally, I did uninstall the version 2.5.6 and install the version 1.5.26 because all my other sites are running this version (1.5.26). Believe it or not, it worked perfectly with PHP Mail, Sendmail and SMTP!

So, I believe that are a something wrong with the 2.5.6 Joomla! version.
I will try to downgrade to versin 2.5.4 or 2.5.3 to test the results.


Top
 Profile  
 
PostPosted: Fri Jul 20, 2012 4:12 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Jul 20, 2012 4:04 am
Posts: 1
matt_nz wrote:
I had a similar issue, J15 email sent ok, upgraded to J25, same settings, same server, email would not send, no error messages.

I tried installing a fresh 2.5.4 into a sub folder on the server and the email sent ok, so it seemed like an issue with that one Joomla install that had been upgraded.

As Joomla's email functions are in the libraries folder, I downloaded a fresh J25 zip, and uploaded the libraries folder to my site (overwriting), the email works now.

I'm not sure why this would happen, as I done my Joomla 2.5 upgrade with a fresh J25, and just migrated the database with spupgrade, obviously something went wrong with the libraries folder somewhere.


I just need to thank you. I'd spent over 4 hours straight trying everything possible to get my contact form to work. And then I read your post and replaced my libraries folder and the emails are working perfectly.
I registered this account just to say thanks.


Top
 Profile  
 
PostPosted: Sun Jul 22, 2012 12:47 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Dec 06, 2011 9:30 pm
Posts: 15
I am not sure if this will help anyone else but i have been struggling with this for the past few days.

Turned out all i needed to do was uncheck the "Use URL rewriting" in the global config.


Top
 Profile  
 
PostPosted: Thu Aug 02, 2012 9:14 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 11, 2010 11:08 am
Posts: 32
Hello all, hopefully I have a solution here that will solve all this.

I had exactly the same problem as everyone here and did an enormous amount of digging and have spent some serious time trying to sort the problem out.

I came across this post:

http://www.fox.ra.it/forum/13-submissio ... rrive.html

It seems that it's a spam filter in my case created by Google Apps and others uses SPF (please read link above).

All I did to stop this from happening was to go to the area where I manage my domain with Google apps and then to "settings" and then "email" settings which in my case can be found on the left column, if you scroll down the page you will see and area for "Email Whitelist". In that box simply put the IP address of the server that is hosting your website and click save.

I am now receiving emails from PHP and SMTP fine.

I hope this helps as I obviously don't know if you are Google Apps users or not and so am unsure if you have the option to do so with your email provider, but in short just add a whitelist entry of your servers static ip and it should be fine.

Nick


Top
 Profile  
 
PostPosted: Thu Aug 02, 2012 9:27 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jan 26, 2009 9:04 am
Posts: 28
nicklucas wrote:
Hello all, hopefully I have a solution here that will solve all this.

I had exactly the same problem as everyone here and did an enormous amount of digging and have spent some serious time trying to sort the problem out.

I came across this post:

http://www.fox.ra.it/forum/13-submissio ... rrive.html

It seems that it's a spam filter in my case created by Google Apps and others uses SPF (please read link above).

All I did to stop this from happening was to go to the area where I manage my domain with Google apps and then to "settings" and then "email" settings which in my case can be found on the left column, if you scroll down the page you will see and area for "Email Whitelist". In that box simply put the IP address of the server that is hosting your website and click save.

I am now receiving emails from PHP and SMTP fine.

I hope this helps as I obviously don't know if you are Google Apps users or not and so am unsure if you have the option to do so with your email provider, but in short just add a whitelist entry of your servers static ip and it should be fine.

Nick


M8 the problem you are refering to is not the Joomla doesn't send mails, but rather that you are not reciving e-mails. If you set up your mail using google maps it's pretty obvious that you have to add a SPF record to "authorize" google to send mails via your domain name.

We had a problem where you couldn't send e-mails...


Top
 Profile  
 
PostPosted: Thu Aug 02, 2012 9:50 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 11, 2010 11:08 am
Posts: 32
I wasn't receiving emails to my destination although I was receiving copies of the submitted contact forms so that could be seen as it wasn't sending emails.

If I changed my email to my personal Yahoo! email it for some reason worked fine.

Perhaps I have misunderstood as I am not a developer and missed the obvious addition of and SPF record as on two other Joomla 1.5.26 sites that I have I didn't have to do any of this.

Funnily enough I now have the same problem on another 2.5.6 website identical to one that is working fine and sitting on the same server with the same ip!


Top
 Profile  
 
PostPosted: Thu Aug 02, 2012 11:46 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Dec 11, 2010 11:08 am
Posts: 32
The problem I was having has been solved, it was a silly error where I was missing a couple of letters off the end of my MX entries due to cutting and pasting. Now works fine.


Top
 Profile  
 
PostPosted: Mon Aug 06, 2012 12:44 am 
Joomla! Intern
Joomla! Intern

Joined: Wed Apr 25, 2007 12:19 pm
Posts: 80
Location: Pennsylvania, USA
I had the same problem - actually with 2.56. Tried changing php and smtp, gmail account as well as domain account. Finally did a fresh install into a new folder, copied all the folders over to my joomla directory, and immediately it all worked. In case it helps others, here's my situation:

I downloaded the files from joomla.org. This was a new install - no copies of joomla at all on that domain. I downloaded to a Mac, so the files were unzipped for me. I actually zipped them back up to upload and install. This was the installation that didn't work.

For the second install, I used the joomla installer off my host's cpanel. This was all installed to a separate folder. I tried the contact form quicklyon the new install and it worked out of the box. I copied all the folders, but none of the files from the new joomla folder and just pastes them on top of my original installation (I did make a backup first, just in case)

Everything worked when installed by my host installer.

Could there be a glitch somewhere that the file off joomla.org is hitting and therefore downloading a just slightly corrupt version? Or could there be something to the fact that mine was to a Mac and I unzipped and then rezipped? Just tossing out some ideas in case others have the issue and can tie it together with something I did.


Top
 Profile  
 
PostPosted: Mon Aug 06, 2012 6:29 am 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Jan 26, 2009 9:04 am
Posts: 28
bbcjraj wrote:
Everything worked when installed by my host installer.


Based on what you've described I'd say you had problems with permissions or file ownership.. That would explain why everything worked when you installed directly on the host...


Top
 Profile  
 
PostPosted: Thu Aug 09, 2012 2:46 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Apr 26, 2010 12:14 pm
Posts: 2
matt_nz wrote:
I had a similar issue, J15 email sent ok, upgraded to J25, same settings, same server, email would not send, no error messages.

I tried installing a fresh 2.5.4 into a sub folder on the server and the email sent ok, so it seemed like an issue with that one Joomla install that had been upgraded.

As Joomla's email functions are in the libraries folder, I downloaded a fresh J25 zip, and uploaded the libraries folder to my site (overwriting), the email works now.

I'm not sure why this would happen, as I done my Joomla 2.5 upgrade with a fresh J25, and just migrated the database with spupgrade, obviously something went wrong with the libraries folder somewhere.


Hi,

Tried same solution as you describe, bur no luck. Then I tried uploading a libraries folder from a previous version (2.5.4) and now it works!

/Jeppe


Top
 Profile  
 
PostPosted: Thu Aug 09, 2012 6:12 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Feb 04, 2009 9:06 pm
Posts: 5
Hey!
I had the same problem... Using J2.5.6, on Apache server.
First it sended mails fine.
Then suddenly not sending mails at all, and weird redirecting to pages which supposed to be thank you page...
I changed those parameters when trying redirect to thank you page, and then forgot to change them back...

I changed options in Contact > contact options > contact form parameters
session check > Yes
Custom reply > No

and it started to send again!
Dunno about you, but worked for me and hope you find this useful to try too.


Top
 Profile  
 
PostPosted: Sun Aug 19, 2012 6:09 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Sun Aug 19, 2012 6:05 pm
Posts: 2
Can anyone help - When I submit from my contact form the copy of the email is sent the to address I specify but the form submission is not sent to the email address I have associated with the contact form. so email is working, but not being sent to the contact as it should be. Any ideas?

Contact form: http://74.54.219.19/~fitline/index.php? ... Itemid=259


Top
 Profile  
 
PostPosted: Mon Aug 20, 2012 3:37 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Aug 17, 2012 9:19 pm
Posts: 1
I'm running the Joomla! Version Joomla! 2.5.1 Stable [ Ember ] 2-Feb-2012 14:00 GMT

.. My config sends a copy email but doesn't send contact form to host email...
I'm using SMTP:
Port : 25


Top
 Profile  
 
PostPosted: Wed Sep 05, 2012 2:43 pm 
User avatar
Joomla! Fledgling
Joomla! Fledgling

Joined: Wed Apr 06, 2011 4:51 pm
Posts: 1
I eventually found that it is the port number. Joomla recommended port is 25 - I host through UK2.net and they use different port numbers - once I checked on their FAQ I found their recommended port number and it works.

yeeha! ;)

had problems on another build and the above didnt work so I did this as well:

I changed options in Contact > contact options > contact form parameters
session check > Yes
Custom reply > No


Last edited by lucindalee on Wed Sep 12, 2012 10:31 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Sep 06, 2012 10:16 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Sep 06, 2012 10:11 am
Posts: 3
Location: Athens, Greece
Hello Joomla Forum ,

i have found the solution for this error.

The problem is with joomla 2.5.* and the php 5.3.*

you have to check in the joomla administrator Site > System Information > Php Settings

after check the Safe Mode in my joomla 2.5 was ON so the email function is not working for me.

i have to go in the php.ini settings to set the safe_mode = off ( DISABLE )

and now my email form works great.

Thank you


Top
 Profile  
 
PostPosted: Tue Oct 02, 2012 10:31 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Tue Oct 02, 2012 10:15 pm
Posts: 1
I had problems with contact form, i solved by disconnecting the captcha pluguin and by going to:
Components» Contacts» "my contac"»options»Form»Allow Captcha on Contact»None Selected.

worked for me!
;D


Top
 Profile  
 
PostPosted: Thu Nov 22, 2012 10:11 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Aug 16, 2011 11:45 pm
Posts: 16
Has anyone come up with a REAL solution yet? This is driving. Im using google SMTP. tried every trick or work around listed. Im not on an WAMP or XAMP server either.


Top
 Profile  
 
PostPosted: Fri Nov 23, 2012 12:54 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Nov 23, 2012 12:51 am
Posts: 1
to resolve the issue, go to site -> my profile and enter your email. the domain email. You will start receiving emails.


Top
 Profile  
 
PostPosted: Wed Dec 05, 2012 6:29 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Mar 12, 2012 6:07 pm
Posts: 5
Hi,

does anyone found a solution to this "bug"?

I'm using Joomla! 2.5.8 Stable and i'm facing the same problem! I've contacted my host provider, and he says the problem should be from joomla, and that maybe i should re-install the "core" files of Joomla to solve the issue!


thanks,


Top
 Profile  
 
PostPosted: Wed Dec 19, 2012 9:35 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Nov 19, 2012 12:08 pm
Posts: 3
Ok I fix it on my site,
I work on Centos with Cpanel PHP 5.4 using GMail account
Joomla version 2.5.8:
Mailer: SMTP
From Email: your@gmail.com (or your domain if it's Google Apps)
From Name: your name
Sendmail path: /usr/sbin/sendmail
SMTP Authentication: Yes
SMTP Security: TTL
SMTP Port: 587
SMTP Username: your@gmail.com (or your domain if it's Google Apps)
SMTP Password: *********
SMTP Host: smtp.gmai.com


Top
 Profile  
 
PostPosted: Fri Jan 04, 2013 7:54 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Aug 27, 2012 2:22 pm
Posts: 16
nicnic wrote:
Can't really understand Simz explaination. Tried all other options and my site still dosen't send anything.

Host hasn't found any solution so far.

This is getting anoying. :-\


Simz has a link in his post, which leads you to a page with 2 scripts. 1st script sends mail with smpt and 2nd sends mail with smtp and ssl. Copy these 2 scripts on page on the root of your site, change the parameters for host, username etc accordignly , and run the pages. Correct the errors of the messages untill you have no errors. If you get to this point you have the correct parameters for sending mail with smtp.


Top
 Profile  
 
PostPosted: Fri Jan 04, 2013 8:29 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Mon Aug 27, 2012 2:22 pm
Posts: 16
I had the same problem with my contact form on my localhost testbed.
My configuration is
win7, Joomla 2.5.8, php 5.4.7 and using google apps account.

The solution that worked for me is similar to avimoto (2nd page) and chanderjeet (1st page).
The main difference is that I used
SMTP Security TLS.
These are the correct solution and you should work upon these.
Important:
Google needs ssl to make authentication, and the simplest way to do this is by enabling openssl extension for php.
This requirement maybe is needed for other mail providers also.

To enable it find your php.ini and search for "extension=php_openssl.dll" uncomment it and restart your web server.

To check if ssl has been enabled, on the admin section go to Site->System Information->PHP information and search for "Registered Stream Socket Transports". If you see there the values "ssl", "sslv3", "sslv2", "tls" then your ok.

To test your configuration use these scripts : http://www.rackspace.com/knowledge_center/article/how-do-i-test-php-smtp-functionality (these scripts are mentioned from simz on the 1st page of this thread).

If something is wrong, these 2 scripts will show you some error messages that you can google them and solved them.

When you get no more error messages then you are ready to go.

Work that way, be patient and eventually it will work.


Top
 Profile  
 
PostPosted: Fri Jan 18, 2013 4:06 pm 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Tue Sep 28, 2010 6:34 pm
Posts: 107
Location: Hull, Yorkshire
I've actually spend months trying to resolve this on Joomla 2.5.

Thanks to AviMoto's post on here I have finally managed (I think) to get somewhere.
It is no longer displaying an error message when I send a mail from my locahost (I'm building the site on WAMP server).

I've had to create a googlemail account (in the UK I cannot create a gmail account because of some sort of trademark infringements), but then followed AviMoto's detailed SMTP credentials. If you are in the UK and wishing to use the Google SMTP option, remember to replace 'gmail' with 'googlemail' in every instance - including the smtp server address.

I've received the confirmation email. Just waiting to see if I receive the contact email itself now...fingers crossed.


Top
 Profile  
 
PostPosted: Fri Jan 25, 2013 5:12 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jan 18, 2012 3:35 pm
Posts: 13
Location: Long Island, NY
hemuliina wrote:
Hey!
I had the same problem... Using J2.5.6, on Apache server.
First it sended mails fine.
Then suddenly not sending mails at all, and weird redirecting to pages which supposed to be thank you page...
I changed those parameters when trying redirect to thank you page, and then forgot to change them back...

I changed options in Contact > contact options > contact form parameters
session check > Yes
Custom reply > No

and it started to send again!
Dunno about you, but worked for me and hope you find this useful to try too.


Did the same thing! Thanks for the post! Problem solved! :D


Top
 Profile  
 
PostPosted: Sun Mar 03, 2013 9:44 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun Mar 03, 2013 9:34 pm
Posts: 19
Location: Houten, Netherlands
Hello,

I also had problems with sending email with Joomla version 2.5.9.
The problems occured with the contact form sending nothing and also in the administrator when i tried to add a new user (not able to send email then).

The last problem was solved by switching off the safe mode.
But the problem with the contact form remained.
After putting session check to NO and Custom reply to NO the contactform worked again.
I do not understand the use of session check and custom reply, but I'm glad it helps.

Strange is that no problem with the same host occured in version 1.5.23 and with 2.5.9 with another host it works also OK.


Top
 Profile  
 
PostPosted: Wed Mar 06, 2013 3:47 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Mar 06, 2013 3:15 am
Posts: 5
Thank You Thank You Thank you !!!!

I have a Joomla 3.0.1 install with a quickstart template. I've had the same issue. The post about going to System --> Global --> Contacts --> then under form turn off session check and session reply worked.


Top
 Profile  
 
PostPosted: Wed Mar 13, 2013 11:47 am 
User avatar
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Tue Sep 28, 2010 6:34 pm
Posts: 107
Location: Hull, Yorkshire
I think that the easiest resolution to this problem here is to use Google SMTP. I now use it on every one of my installations - and everything is working just fine.
All you have to do is setup a gmail account (or googlemail in the uk and perhaps in some other countries too), use port 256 and select the SSL security option. For the SMTP username: just use your Gmail/Googlemail address; and for your SMTP password, use your Gmail/Googlemail password. For SMTP server, use either smtp.googlemail.com (if in uk) or smtp.gmail.com.
That should work.


Top
 Profile  
 
PostPosted: Fri Mar 15, 2013 6:12 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Fri Mar 15, 2013 5:56 pm
Posts: 1
Just for those like me who are new to Joomla and might have missed the obvious...

I set up a new site (well two) from supplied templates and went through some of the above to try to get my contact form results mailed to me. Then I noticed I didn't have the email I wanted to send to listed in my "Contact Us" contact. After I put it in, it worked. Here's how:

1. Select "Components" from the top level menu in the Joomla administrator backend, then "Contacts"
2. Click on whatever contact entry you are using for your contact form page, mine was named "Contact Us" (big surprise)
3. Select "Contact Details" on the right side and put in the email you want the contents of the form sent to

This wwas on Joomla 2.5, but I also did it on an older 1.5 site and it worked.


Top
 Profile  
 
PostPosted: Thu Mar 21, 2013 3:41 pm 
Joomla! Enthusiast
Joomla! Enthusiast

Joined: Tue Sep 28, 2010 7:04 am
Posts: 201
Location: Melbourne, Australia
Hi,

I Had the same exact problem.

Joomla is not sending any emails from PHPMail, SendMail or SMPT

Solution,

Joomla was sending email to the email addess listed in Componant>Contact>Contact Form(you are using)>Contact Details.

Mine was Joomla Version 1.6.3.

Hope this will help someone.

Regards,
XeontCS

_________________
http://www.xeont.com.au - Computer Parts | Forum
http://www.chicshop.com.au - ChicShop


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 79 posts ]  Go to page Previous  1, 2, 3  Next



Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group