No Administrator Login (username/pass) on admin page

Need help upgrading your Joomla! website or converting to Joomla! 2.5?
Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

No Administrator Login (username/pass) on admin page

Postby zipdadog » Fri May 04, 2012 12:54 pm

hi there,

just installed updates from 1.6.4 to 2.5.4
ver 1.6.4 to 1.6.5 & 1.6.6 via ftp method
ver 1.6.6 to 1.7 via joomla admin control panel / module installer
ver 1.7 to 2.5.4 via joomla admin control panel / module installer

had logged in via admin a few times, no issue, shut down for a few hour cam back not able to login!!!

Problem Description :: Forum Post Assistant (v1.2.1) : 4th May 2012 wrote:No Admin Site Login panel on administrator page
Last PHP Error(s) Reported :: Forum Post Assistant (v1.2.1) : 4th May 2012 wrote:[03-May-2012 04:36:56 UTC] PHP Notice: XML error: not well-formed (invalid token) at line 26, column 63 in /home/friends4/public_html/libraries/simplepie/simplepie.php on line 1801
Actions Taken To Resolve by Forum Post Assistant (v1.2.1) 4th May 2012 wrote:posting issue in forum.
Forum Post Assistant (v1.2.1) : 4th May 2012 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 2.5.4-Stable (Ember) 2-April-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Yes | Read-Only (444) | Owner: friends4 (uid: 1310/gid: 1298) | Group: friends4 (gid: 1298) | Valid For: 2.5 and above
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 0 | SEF ReWrite: 0 | .htaccess/web.config: Yes | GZip: 0 | Cache: 0 | FTP Layer: 0 | SSL: 0 | Error Reporting: -1 | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 0 | Database Credentials Present: Yes

Host Configuration :: OS: Linux | OS Version: 2.6.18-374.3.1.el5.lve0.8.44 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | Doc Root: /home/friends4/public_html | System TMP Writable: Yes

PHP Configuration :: Version: 5.3.10 | PHP API: cgi-fcgi | Session Path Writable: Unknown | Display Errors: 1 | Error Reporting: 22519 | Log Errors To: error_log | Last Known Error: 03rd May 2012 14:36:56. | Register Globals: 0 | Magic Quotes: | Safe Mode: 0 | Open Base: | Uploads: 1 | Max. Upload Size: 10M | Max. POST Size: 10M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 128M

MySQL Configuration :: Version: 5.1.62-cll (Client:5.1.62) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 462.97 KiB | #of _FPA_TABLE: 71
Detailed Environment :: wrote:PHP Extensions :: Core (5.3.10) | date (5.3.10) | ereg () | libxml () | openssl () | pcre () | sqlite3 (0.7-dev) | zlib (1.1) | bcmath () | calendar () | ctype () | curl () | dom (20031129) | hash (1.0) | fileinfo (1.0.5-dev) | filter (0.11.0) | ftp () | gd () | gettext () | SPL (0.2) | iconv () | session () | json (1.2.1) | mbstring () | mcrypt () | mysql (1.0) | mysqli (0.1) | standard (5.3.10) | Phar (2.0.1) | posix () | pspell () | Reflection ($Revision: 321634 $) | imap () | SimpleXML (0.1) | soap () | sockets () | exif (1.4 $Id: exif.c 321634 2012-01-01 13:15:04Z felipe $) | tidy (2.0) | tokenizer (0.1) | xml () | xmlreader (0.1) | xmlrpc (0.51) | xmlwriter (0.1) | xsl (0.1) | zip (1.9.1) | cgi-fcgi () | timezonedb () | eAccelerator (0.9.6.1) | suhosin (0.9.33) | PDO (1.0.4dev) | pdo_sqlite (1.0.1) | SQLite (2.0-dev) | pdo_mysql (1.0.2) | htscanner (1.0.1) | imagick (3.0.1) | ionCube Loader () | Zend Guard Loader () | Zend Engine (2.3.0) |
Potential Missing Extensions ::

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: No | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (777) | logs/ (777) | tmp/ (777) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) |

Elevated Permissions (First 10) :: None cache/ (777) | logs/ (777) | tmp/ (777) |
Extensions Discovered :: wrote:Components :: SITE :: com_mailto (2.5.0) | CB Mamblog Tab (1.2) | CB Mambo Author Tab (1.2) | Yanc Integration (1.2) | com_wrapper (2.5.0) |
Components :: ADMIN :: com_redirect (2.5.0) | com_banners (2.5.0) | com_menus (2.5.0) | com_weblinks (2.5.0) | com_content (2.5.0) | Gantry (3.2.19) | com_checkin (2.5.0) | com_messages (2.5.0) | com_cache (2.5.0) | com_users (2.5.0) | com_joomlaupdate (2.5.0) | com_installer (2.5.0) | com_newsfeeds (2.5.0) | comprofiler (1.4) | com_media (2.5.0) | com_login (2.5.0) | com_finder (2.5.0) | com_categories (2.5.0) | com_plugins (2.5.0) | com_modules (2.5.0) | com_search (2.5.0) | com_config (2.5.0) | com_templates (2.5.0) | com_languages (2.5.0) | com_cpanel (2.5.0) | com_admin (2.5.0) |

Modules :: SITE :: mod_weblinks (2.5.0) | mod_whosonline (2.5.0) | mod_finder (2.5.0) | RokTabs (1.4) | mod_footer (2.5.0) | mod_articles_latest (2.5.0) | mod_search (2.5.0) | mod_syndicate (2.5.0) | mod_stats (2.5.0) | mod_feed (2.5.0) | mod_breadcrumbs (2.5.0) | RokNavMenu (1.4) | mod_articles_archive (2.5.0) | mod_login (2.5.0) | mod_articles_news (2.5.0) | mod_random_image (2.5.0) | mod_users_latest (2.5.0) | mod_banners (2.5.0) | mod_articles_categories (2.5.0) | CB Login (1.4) | sigplus (1.4.2.6) | mod_wrapper (2.5.0) | mod_menu (2.5.0) | mod_articles_category (2.5.0) | mod_languages (2.5.0) | CB Workflows (1.4) | mod_custom (2.5.0) | mod_articles_popular (2.5.0) | mod_related_items (2.5.0) |
Modules :: ADMIN :: mod_version (2.5.0) | mod_latest (2.5.0) | mod_quickicon (2.5.0) | mod_title (2.5.0) | mod_logged (2.5.0) | mod_multilangstatus (2.5.0) | mod_feed (2.5.0) | mod_toolbar (2.5.0) | mod_login (2.5.0) | mod_popular (2.5.0) | mod_unread (1.6.0) | mod_menu (2.5.0) | mod_online (1.6.0) | mod_custom (2.5.0) | mod_submenu (2.5.0) | mod_status (2.5.0) |

Plugins :: SITE :: plg_captcha_recaptcha (2.5.0) | plg_editors_tinymce (3.4.9) | plg_editors_codemirror (1.0) | plg_search_weblinks (2.5.0) | plg_search_categories (2.5.0) | plg_search_content (2.5.0) | plg_search_contacts (2.5.0) | plg_search_newsfeeds (2.5.0) | plg_authentication_joomla (2.5.0) | plg_authentication_gmail (2.5.0) | plg_authentication_ldap (2.5.0) | plg_user_joomla (2.5.0) | plg_user_contactcreator (2.5.0) | plg_user_profile (2.5.0) | plg_content_joomla (2.5.0) | plg_content_geshi (2.5.0) | Content - Image gallery - sigp (1.4.2.6) | plg_content_loadmodule (2.5.0) | plg_content_finder (2.5.0) | plg_content_pagebreak (2.5.0) | plg_content_emailcloak (2.5.0) | plg_content_vote (2.5.0) | plg_content_pagenavigation (2.5.0) | plg_finder_weblinks (2.5.0) | plg_finder_categories (2.5.0) | plg_finder_content (2.5.0) | plg_finder_contacts (2.5.0) | plg_finder_newsfeeds (2.5.0) | plg_quickicon_extensionupdate (2.5.0) | plg_quickicon_joomlaupdate (2.5.0) | plg_extension_joomla (2.5.0) | plg_editors-xtd_image (2.5.0) | plg_editors-xtd_article (2.5.0) | plg_editors-xtd_pagebreak (2.5.0) | plg_editors-xtd_readmore (2.5.0) | plg_system_cache (2.5.0) | plg_system_remember (2.5.0) | plg_system_languagecode (2.5.0) | plg_system_logout (2.5.0) | plg_system_sef (2.5.0) | plg_system_languagefilter (2.5.0) | plg_system_redirect (2.5.0) | System - RokExtender (1.0) | plg_system_log (2.5.0) | System - Gantry (3.2.19) | plg_system_p3p (2.5.0) | plg_system_debug (2.5.0) | plg_system_highlight (2.5.0) |
Templates Discovered :: wrote:Templates :: SITE :: siteground-j16-10 (1.0.0) | rt_modulus_j16 (1.6.0) | beez_20 (2.5.0) | atomic (2.5.0) | beez5 (2.5.0) |
Templates :: ADMIN :: hathor (2.5.0) | bluestork (2.5.0) |
"An investment in knowledge pays the best interest."
Ben Franklin

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: No Administrator Login (username/pass) on admin page

Postby humvee » Fri May 04, 2012 3:04 pm

[Mod note: Moved from Installation Forum to Upgrading Forum;]

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Sat May 05, 2012 3:02 am

Screen dumps added for clarity of issue.
You do not have the required permissions to view the files attached to this post.
"An investment in knowledge pays the best interest."
Ben Franklin

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: No Administrator Login (username/pass) on admin page

Postby humvee » Sat May 05, 2012 11:15 pm

Possible option First backup site and database again as a precaution.

Upload a copy of the 2.5.4 directories and files to the server to overwrite what is currently there.

DO NOT upload the installation directory as you are obviously not reinstalling.

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Sun May 06, 2012 4:52 pm

Thanks Humvee for moving to correct thread and possible option to try. Unfortunately a fresh install (via fpt method) did not fix the problem!

Wondering if it's worth while seeing if i can change current admin template via myphpadmin tables?
"An investment in knowledge pays the best interest."
Ben Franklin

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 953
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby euoceo » Sun May 06, 2012 5:28 pm

I'm a little confused (wouldn't be the first time). Your screen shot shows an admin login block, but your description of "No Admin Site Login panel " says you are not getting that. What am I missing?

Did you disable any system plugins? You might need to go into phpmyadmin and check and make sure "Authentication - Joomla" and "User - Joomla!" are enabled ("1") in the plugin table.
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Sun May 06, 2012 6:04 pm

euoceo wrote: I'm a little confused (wouldn't be the first time). Your screen shot shows an admin login block, but your description of "No Admin Site Login panel " says you are not getting that. What am I missing?


Screen shots are to illustrate
1) my current admin page (i.e. the lack of an admin black as you describe it) and;
2) what the typical default admin page should look like (purely for the noobs so i don't get silly questions).

euoceo wrote: Did you disable any system plugins?

No plugins have been disabled.

euoceo wrote: You might need to go into phpmyadmin and check and make sure "Authentication - Joomla" and "User - Joomla!" are enabled ("1") in the plugin table.


Im assuming your referring to the jos_comprofiler_plugin table?
"An investment in knowledge pays the best interest."
Ben Franklin

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 953
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby euoceo » Sun May 06, 2012 10:20 pm

Oh! I see there are 2 pictures there.. lol

I assume you have FTP access? Check permissions on the admin templates.
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Mon May 07, 2012 2:00 am

administrator and public templates are okay (755) this is also confirmed on the JPA post above.
"An investment in knowledge pays the best interest."
Ben Franklin

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 953
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby euoceo » Mon May 07, 2012 3:34 am

Use phpmyadmin and look at the template_styles table, make sure there are entries for bluestork and hathor and one of them has their "home" column set to 1. Beyond that, I've reached all that can be guessed at via back and forth forum posts vs. direct access to the website/cpanel/etc.
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Mon May 07, 2012 4:46 am

Thanks for posting and ideas euoceo, bluestork (admin) set to 1 and rt_modulus_j16 (public) set to 1.

Think i might restore site back from known working ver 1.6 backup and try again.
You do not have the required permissions to view the files attached to this post.
"An investment in knowledge pays the best interest."
Ben Franklin

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 953
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby euoceo » Mon May 07, 2012 6:00 am

Anything in the sites error logs when you try to go to admin area?
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Mon May 07, 2012 6:21 am

[Mon May 07 16:17:58 2012] [error] [client 220.237.19.71] File does not exist: /home/friends4/public_html/401.shtml

This error message was generated because i typed admin rather than administrator, hence page not found.
"An investment in knowledge pays the best interest."
Ben Franklin

sfigattomambo
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 11, 2006 7:17 am

Re: No Administrator Login (username/pass) on admin page

Postby sfigattomambo » Mon May 07, 2012 8:26 am

I've the same issue after automatically upgrading from Joomla 1.7.3 to Joomla 2.5.4.
No Administration login fields (username / password) on admin page.
Is it possibile to find a manual upgrade package? It could be a test trying to bypass Joomla automatic upgrade process.

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Mon May 07, 2012 9:18 am

Oh crap! Yes it's possible to to do a manual upgrade, simply download the full package (unzip/uncompress) and then upload to server via ftp. I've already tried a fresh reinstall of 2.5.4 but no success.

I've rolled back the site to 1.6.4 and retrying fresh install again - this time i'll only use the manual process.
"An investment in knowledge pays the best interest."
Ben Franklin

sfigattomambo
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 11, 2006 7:17 am

Re: No Administrator Login (username/pass) on admin page

Postby sfigattomambo » Mon May 07, 2012 11:04 am

Thanks!
Now I'm restoring my 1.7.0 version in order to try with a manual installation.
I'll keep you updated.

sfigattomambo
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 11, 2006 7:17 am

Re: No Administrator Login (username/pass) on admin page

Postby sfigattomambo » Tue May 08, 2012 8:19 am

No good news with manual upgrade.
Waiting to find a permanent solution, I solved using a Joomla 2.5.3 "administrator" directory version instead of the new 2.5.4 version.

Regards

User avatar
zipdadog
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Tue Jun 21, 2011 11:31 am
Location: Australia
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby zipdadog » Tue May 08, 2012 9:01 am

Ah good to know, yeah my installs worked fine up to version 1.7, then it went pear shaped during 2.5 install!! So bad it completely stuffed the site!

I've literally started again - i.e. moved all old joomla into a common folder on server and done fresh install of 2.5 from cpanel softaculous app installer. Once i've duplicated the content i'll delete all old 1.6 and 1.7 folder/files.

by the way has the problem been experienced with all templates or just one of them?
"An investment in knowledge pays the best interest."
Ben Franklin

sfigattomambo
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 11, 2006 7:17 am

Re: No Administrator Login (username/pass) on admin page

Postby sfigattomambo » Tue May 08, 2012 1:52 pm

The problem has been experienced with all the 2 admin template.
I've activate them, one at a time, directly from phpMyAdmin (due to the the inability to directly access the admin control panel).

I'm waiting for a new fixing release (I hope :) )

moka88
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu May 31, 2012 10:44 pm

Re: No Administrator Login (username/pass) on admin page

Postby moka88 » Thu May 31, 2012 10:46 pm

I'm having the exact same problem, does anyone know a fix? :'(

moka88
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu May 31, 2012 10:44 pm

Re: No Administrator Login (username/pass) on admin page

Postby moka88 » Thu May 31, 2012 11:05 pm

Found fix!

to file administrator/includes/helper.php

Remove

Code: Select all

if (!$user->authorise('core.login.admin')) {



Replace with

Code: Select all

if (($user->get('guest')) || !$user->authorise('core.login.admin')) {

User avatar
euoceo
Joomla! Guru
Joomla! Guru
Posts: 953
Joined: Fri Sep 12, 2008 2:48 pm
Location: Sacramento
Contact:

Re: No Administrator Login (username/pass) on admin page

Postby euoceo » Fri Jun 01, 2012 5:33 am

Modifying the core files is not a 'fix'.
Joomla! Web Hosting, Design, and Consulting.
Portfolio: http://www.calweb.com/joomla
Please do not PM me for help, use the forums first.


Return to “Migrating and Upgrading to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 5 guests