How to change my post_max_size in my server ?

Need help installing Joomla! 2.5? For all Joomla! 2.5 installation issues please use this forum. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

How to change my post_max_size in my server ?

Postby gopijack » Fri May 18, 2012 10:01 am

Hi ,

In Joomla2.5 i have given some condition for uploading files,in my demo server its working fine.

but for my client server file is not uploading,

its showing error as " increase post_max_size and upload_max_filesize to 10M"

I ask my client to check his post_max_size and set to 10M,but he saying -> "I have set higher limit" only.

Now what to do ?

In my server working fine,for my client server not uploading the file and showing error as

" increase post_max_size and upload_max_filesize to 10M"

Please gave me a advice.


Thanks in advance :eek:
Last edited by humvee on Mon Aug 13, 2012 8:23 am, edited 1 time in total.
Reason: Marked as resolved as per OP
Thanks & Regards
Gopi.A

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16292
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: How to change my post_max_size in my server ?

Postby leolam » Fri May 18, 2012 10:04 am

You have WHM on your server?

Leo 8)
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

Re: How to change my post_max_size in my server ?

Postby gopijack » Fri May 18, 2012 10:10 am

Hi,

May i knew about WHM ? what does it will do ?

if it is not present we have to install ?

???
Thanks & Regards
Gopi.A

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 16292
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: How to change my post_max_size in my server ?

Postby leolam » Fri May 18, 2012 10:20 am

With what program you run your server management? cPanel?

Leo
-- Joomla Professional Support Services : https://gws-desk.com --
-- Joomla Specialized Hosting Solutions: https://gws-host.com --
-- Joomla Professional Web Development & Design :www.gws-studio.com
-- Member Joomla Bug Squad --

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: How to change my post_max_size in my server ?

Postby humvee » Sun May 20, 2012 4:08 pm

Try running theForum post Assistant on both the client and development server to provide the comparative information to help us try and resolve the issue.

User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

Re: How to change my post_max_size in my server ?

Postby gopijack » Fri Jun 01, 2012 6:33 am

yes , we are using cpanel only...

but i don't knew the reason why file in not uploading in client server,anything we need to set in client server ?

or else we need to increase the post_max_size in his php.ini file ?
Thanks & Regards
Gopi.A

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: How to change my post_max_size in my server ?

Postby humvee » Fri Jun 01, 2012 8:48 pm

locate the php.ini file (assuming access is available to it i.e it is a dedicated or virtual server and not just a shared hosting)
open it an a suitable text editor - Notepad++, Dreamweaver or similar (not any Microsoft editor)
Use the find function to locate upload_max_filesize (not the commented out version starting with ; )
to:

Code: Select all

upload_max_filesize = 128M

Use the find function to locate post_max_size (not the commented out version starting with ; )
Change to:

Code: Select all

post_max_size = 8M

If the error continues to show then increase the post_max_size to 16M.

User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

Re: How to change my post_max_size in my server ?

Postby gopijack » Mon Jun 04, 2012 4:25 am

Hi,

I have already did in my localhost and its working for me and also in my demo server no issues,

but in my client demo server it showing issues like "Increase the post_max_size".

May i knew the reason and how to increase the post_max_size in server ? via .htaccess file or any other ways ?

if we need to edit in .htaccess file then how to edit which type of code i need to place for increasing the post_max_size ?

can you please advice me... :-)
Thanks & Regards
Gopi.A

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: How to change my post_max_size in my server ?

Postby humvee » Mon Jun 04, 2012 7:27 am

Well in the first instance if you do not have access to the server php.ini file on the client server then you or the client should contact the host and try and get them to change the settings for you.

At the same time you need to clarify what settings they permit you to change either with .htaccess or local php.ini files (which you would add within the joomla_root/ and joomla_root/administrator/ directories).

User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

Re: How to change my post_max_size in my server ?

Postby gopijack » Mon Jun 04, 2012 7:36 am

ok Andy,

I will forward to my client... Once i got reply from my client i will inform what result we get ...

thanks for replying and i will keep touch you...
Thanks & Regards
Gopi.A

User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

Re: How to change my post_max_size in my server ?

Postby gopijack » Tue Jun 05, 2012 5:19 am

Hi,

From my client side.

1) The file size limit is already set to 10MB in PHP.ini

2) Even if I upload a file under 10MB (only 55.4kb) the error is shown when that file is small enough.

then issues was in file or server side ?

Please give me advice.
Thanks & Regards
Gopi.A

User avatar
gopijack
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Wed Oct 20, 2010 7:32 am

Re: How to change my post_max_size in my server ?

Postby gopijack » Mon Aug 13, 2012 5:46 am

i have changed some condition and it was working fine.
Thanks & Regards
Gopi.A


Return to “Installation Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 5 guests