The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Mon May 28, 2012 2:42 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 24, 2011 2:37 am
Posts: 10
I am having a big problem. Have tried to upgrade my Akeeba Backup as an extension in Joomla.

I am running Joomla 1.7.3. Akeeba 3.3.10 was installed. I was informed by Joomla that an update was available. Downloaded Akeeba 3.5.1. Tried to install it directly to my remote site. It would not install. Instead it gave me the message "Component Install: Custom install routine failure." So then I tried the same thing to my localhost and got the same result. I have spent hours on the Internet trying to find a solution to the problem.

Would appreciate any help you can give because at the moment I have no backup facility on my site.


Last edited by humvee on Fri Jun 15, 2012 10:01 am, edited 1 time in total.
Marked Resolved


Top
 Profile  
 
PostPosted: Tue May 29, 2012 12:02 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Fri Aug 12, 2005 7:19 am
Posts: 10513
Location: Leeds, UK
If you read the installation notes for akeeba backup on the akeeba backup web site you will see that the latest version will NOT work with Joomla 173 which is out of date and insecure. You need to upgade your version of Joomla to 2.54 urgently for security reasons and then you will be able to upgrade akeeba as well. There is no pint in taking backups of a web site that can be hacked

_________________
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/


Top
 Profile  
 
PostPosted: Tue May 29, 2012 4:54 pm 
Joomla! Intern
Joomla! Intern

Joined: Thu Feb 11, 2010 5:59 pm
Posts: 93
brian I think Bryboy wants to backup the current site before he upgrades, which is good practice...

Bryboy get Akeeba backup 3.3.13 which is compatible with 1.7 ( https://www.akeebabackup.com/compatibility.html )

Read and download here: https://www.akeebabackup.com/download/a ... -3-13.html

Once you are done, upgrade to Joomla latest version and read on the Akeeba website how to upgrade to their latest version.


Top
 Profile  
 
PostPosted: Wed May 30, 2012 9:46 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 24, 2011 2:37 am
Posts: 10
Thank you for this information. I had wondered if compatibility might be the issue. I'm suprised I didn't stumble upon some documentation which told me about the incompatibility before I tried to install. Even more why Joomla allowed it to tell me 'an update was available' for an incompatible version!!! At the moment my site has a whole bunch of 0 Kb Akeeba files on it under com_akeeba so I will have to hope that a reinstall and upgrade of Joomla fixes that part of it before I then try to reinstall Akeeba. I will post developments on the site so you are aware what has transpired but thanks again for this help.


Top
 Profile  
 
PostPosted: Fri Jun 15, 2012 6:04 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 24, 2011 2:37 am
Posts: 10
Thanks all. The wrong version was the problem here. Upgraded version and was eventually able to get replacement files from my wamp site which once uploaded got the website operational again. Thanks for your help - I certainly should have read the documentation first. More haste, less speed!!!


Top
 Profile  
 
PostPosted: Fri Jun 15, 2012 10:01 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
[Mod note: Moved from Template Forum to Extensions Forum;]


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 



Who is online

Users browsing this forum: No registered users and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group