The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Jun 30, 2012 9:04 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat Mar 13, 2010 11:39 am
Posts: 54
Hi,

I just installed Joomla 2.5.6, everything went oke, but now I want to make changes to the global configuration and when I hit save I get the following error:

JFTP: :write: Bad response
Could not save data. Error: Could not write to the configuration file


I searched the web for a solution and found this article.
http://docs.joomla.org/Cannot_save_Glob ... on_changes

So I checked the configuration.php file, checked the ownership of it. I also checked the ftp settings and everything seems the way it should be.

I have multiple joomla sites, compared the settings, which are the same. Only on this website I have this problem. It was a fresh install of Joomla 2.5.6

I also found some other forum topics, but none of them seemed to have the solution for me.

Please help. ;)
Thanks!
Ellen (the netherlands)

_________________
http://www.ellenvandrunen.com - Ellen van Drunen Photography


Last edited by humvee on Mon Jul 02, 2012 9:12 pm, edited 1 time in total.
Marked as resolved


Top
 Profile  
 
PostPosted: Sat Jun 30, 2012 9:12 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
Please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Please follow the instructions in the post and the program pack closely.


Top
 Profile  
 
PostPosted: Sat Jun 30, 2012 9:13 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
[Mod note: Moved from Admin Forum to Installation Forum;]


Top
 Profile  
 
PostPosted: Sat Jun 30, 2012 9:21 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat Mar 13, 2010 11:39 am
Posts: 54
Log/Error Message :: Forum Post Assistant (v1.2.1) : 30th June 2012 wrote:
Could not write to the configuration file
Actions Taken To Resolve by Forum Post Assistant (v1.2.1) 30th June 2012 wrote:
chmod configuration.php
checked owner
checked ftp settings
Forum Post Assistant (v1.2.1) : 30th June 2012 wrote:
Basic Environment :: wrote:
Joomla! Instance :: Joomla! 2.5.6-Stable (Ember) 19-June-2012
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Yes | Writable (644) | Owner: fietsj (uid: 873/gid: 873) | Group: fietsj (gid: 873) | Valid For: 1.5
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 1 | SEF ReWrite: 1 | .htaccess/web.config: Yes | GZip: 0 | Cache: 0 | FTP Layer: 1 | SSL: N/A | Error Reporting: default | Site Debug: 0 | Language Debug: 0 | Default Access: N/A | Unicode Slugs: N/A | Database Credentials Present: Yes

Host Configuration :: OS: Linux | OS Version: 2.6.9-78.0.8.ELsmp | Technology: i686 | Web Server: Apache/2.0.52 (Red Hat) | Encoding: gzip, deflate | Doc Root: /var/www/html | System TMP Writable: Yes

PHP Configuration :: Version: 5.3.9 | PHP API: cgi-fcgi | Session Path Writable: Unknown | Display Errors: | Error Reporting: 30711 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 10M | Max. POST Size: 10M | Max. Input Time: 60 | Max. Execution Time: 60 | Memory Limit: 24M

MySQL Configuration :: Version: 5.0.92-community (Client:4.1.22) | Host: --protected-- (--protected--) | Collation: utf8_general_ci (Character Set: utf8) | Database Size: 366.76 KiB | #of _FPA_TABLE: 72
Detailed Environment :: wrote:
PHP Extensions :: Core (5.3.9) | date (5.3.9) | ereg () | libxml () | openssl () | pcre () | sqlite3 (0.7-dev) | zlib (1.1) | bz2 () | calendar () | ctype () | curl () | hash (1.0) | fileinfo (1.0.5-dev) | filter (0.11.0) | ftp () | gettext () | gmp () | SPL (0.2) | iconv () | json (1.2.1) | pcntl () | session () | standard (5.3.9) | posix () | pspell () | Reflection ($Revision: 321634 $) | Phar (2.0.1) | shmop () | SimpleXML (0.1) | sockets () | exif (1.4 $Id: exif.c 321634 2012-01-01 13:15:04Z felipe $) | sysvmsg () | sysvsem () | sysvshm () | tokenizer (0.1) | wddx () | xml () | zip (1.9.1) | cgi-fcgi () | dba () | dom (20031129) | gd () | imap () | ldap () | mbstring () | mcrypt () | mysql (1.0) | mysqli (0.1) | odbc (1.0) | PDO (1.0.4dev) | pdo_mysql (1.0.2) | PDO_ODBC (1.0.1) | pdo_sqlite (1.0.1) | xmlreader (0.1) | xmlrpc (0.51) | xmlwriter (0.1) | xsl (0.1) | mhash () | Zend Engine (2.3.0) |
Potential Missing Extensions :: suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:
Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) |

Elevated Permissions (First 10) :: None
Extensions Discovered :: wrote:
Components :: SITE :: com_mailto (2.5.0) | com_wrapper (2.5.0) |
Components :: ADMIN :: com_admin (2.5.0) | com_banners (2.5.0) | com_cache (2.5.0) | com_categories (2.5.0) | com_checkin (2.5.0) | com_config (2.5.0) | com_content (2.5.0) | com_cpanel (2.5.0) | com_finder (2.5.0) | com_installer (2.5.0) | com_joomlaupdate (2.5.0) | com_languages (2.5.0) | com_login (2.5.0) | com_media (2.5.0) | com_menus (2.5.0) | com_messages (2.5.0) | com_modules (2.5.0) | com_newsfeeds (2.5.0) | com_plugins (2.5.0) | com_redirect (2.5.0) | com_search (2.5.0) | com_templates (2.5.0) | com_users (2.5.0) | com_weblinks (2.5.0) | Widgetkit (1.0.4) | com_zoo (2.5.20) |

Modules :: SITE :: mod_articles_archive (2.5.0) | mod_articles_categories (2.5.0) | mod_articles_category (2.5.0) | mod_articles_latest (2.5.0) | mod_articles_news (2.5.0) | mod_articles_popular (2.5.0) | mod_banners (2.5.0) | mod_breadcrumbs (2.5.0) | mod_custom (2.5.0) | mod_feed (2.5.0) | mod_finder (2.5.0) | mod_footer (2.5.0) | mod_languages (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_random_image (2.5.0) | mod_related_items (2.5.0) | mod_search (2.5.0) | mod_stats (2.5.0) | mod_syndicate (2.5.0) | mod_users_latest (2.5.0) | mod_weblinks (2.5.0) | mod_whosonline (2.5.0) | mod_wrapper (2.5.0) | Widgetkit (1.0.0) | Widgetkit Twitter (1.0.0) | ZOO Item (2.5.0) | ZOO Comment (2.5.0) | ZOO Tag (2.5.0) | ZOO Category (2.5.0) |
Modules :: ADMIN :: mod_custom (2.5.0) | mod_feed (2.5.0) | mod_latest (2.5.0) | mod_logged (2.5.0) | mod_login (2.5.0) | mod_menu (2.5.0) | mod_multilangstatus (2.5.0) | mod_popular (2.5.0) | mod_quickicon (2.5.0) | mod_status (2.5.0) | mod_submenu (2.5.0) | mod_title (2.5.0) | mod_toolbar (2.5.0) | mod_version (2.5.0) | ZOO Quick Icons (2.5.0) |

Plugins :: SITE :: plg_authentication_gmail (2.5.0) | plg_authentication_joomla (2.5.0) | plg_authentication_ldap (2.5.0) | plg_captcha_recaptcha (2.5.0) | plg_content_emailcloak (2.5.0) | plg_content_finder (2.5.0) | plg_content_geshi (2.5.0) | plg_content_joomla (2.5.0) | plg_content_loadmodule (2.5.0) | plg_content_pagebreak (2.5.0) | plg_content_pagenavigation (2.5.0) | plg_content_vote (2.5.0) | Content - Widgetkit (1.0.0) | Content - ZOO Shortcode (2.5.0) | plg_editors_codemirror (1.0) | plg_editors_tinymce (3.5.2) | plg_editors-xtd_article (2.5.0) | plg_editors-xtd_image (2.5.0) | plg_editors-xtd_pagebreak (2.5.0) | plg_editors-xtd_readmore (2.5.0) | plg_extension_joomla (2.5.0) | plg_finder_categories (2.5.0) | plg_finder_contacts (2.5.0) | plg_finder_content (2.5.0) | plg_finder_newsfeeds (2.5.0) | plg_finder_weblinks (2.5.0) | Smart Search - ZOO (2.5.0) | plg_quickicon_extensionupdate (2.5.0) | plg_quickicon_joomlaupdate (2.5.0) | plg_search_categories (2.5.0) | plg_search_contacts (2.5.0) | plg_search_content (2.5.0) | plg_search_newsfeeds (2.5.0) | plg_search_weblinks (2.5.0) | ZOO Search (2.5.0) | plg_system_cache (2.5.0) | plg_system_debug (2.5.0) | plg_system_highlight (2.5.0) | plg_system_languagecode (2.5.0) | plg_system_languagefilter (2.5.0) | plg_system_log (2.5.0) | plg_system_logout (2.5.0) | plg_system_p3p (2.5.0) | plg_system_redirect (2.5.0) | plg_system_remember (2.5.0) | plg_system_sef (2.5.0) | System - Widgetkit (1.0.0) | System - Widgetkit ZOO (1.0.0) | System - Widgetkit Joomla (1.0.0) | System - ZOO Event (2.5.0) | plg_user_contactcreator (2.5.0) | plg_user_joomla (2.5.0) | plg_user_profile (2.5.0) |
Templates Discovered :: wrote:
Templates :: SITE :: atomic (2.5.0) | beez5 (2.5.0) | beez_20 (2.5.0) | yoo_cloud (1.0.5) |
Templates :: ADMIN :: bluestork (2.5.0) | hathor (2.5.0) |

_________________
http://www.ellenvandrunen.com - Ellen van Drunen Photography


Top
 Profile  
 
PostPosted: Sun Jul 01, 2012 3:15 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat Mar 13, 2010 11:39 am
Posts: 54
:( complete reinstall didn't do the trick...

Is there a solution to this? Can anyone please help me out?

I am able to install some modules, but a new template for instance doesn't work either. And I am not able to adjust global configuration settings..

During template installation I get this message:
JFTP: :store: Bad response
JInstaller: :Install: Failed to copy file /var/www/html/tmp/install_4ff06a2889c93/yoo_cloud_j25/templateDetails.xml to /var/www/html/templates/yoo_cloud/templateDetails.xml
Template Install: Could not copy setup file.

_________________
http://www.ellenvandrunen.com - Ellen van Drunen Photography


Top
 Profile  
 
PostPosted: Mon Jul 02, 2012 6:42 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Wed Aug 17, 2005 10:27 pm
Posts: 14715
Location: Kent, England
[Mod Note: Bump post by ellenvanderzwan deleted. Please do not bump your messages. Read the Forum Rules for full details.
There is an issue with the configuration of your server and it currently is Valid For: 1.5 only according to the FPA.
Is this a local LAMP server you have installed yourself?
As you have the server using the PHP API: cgi-fcgi you should not need the FTP Layer and it may be this that is causing the issues.
Edit the configuration.php file directly and return the FTP layer settings to their default values.
Code:
   public $ftp_host = '127.0.0.1';
   public $ftp_port = '21';
   public $ftp_user = '';
   public $ftp_pass = '';
   public $ftp_root = '';
   public $ftp_enable = '0';

Do this rather than trying to reset using the Global Configuration interface as this sometimes does not work.


Top
 Profile  
 
PostPosted: Mon Jul 02, 2012 6:47 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Sat Mar 13, 2010 11:39 am
Posts: 54
Thanks for the comment. I am not able to configure the server myself, but I will contact them.

For now I switched off the FTP and I do not seem to have any issues anymore. I am able to change the global configurations and I am able to upload templates and modules. So it looks good to me now.

Thanks again for your suggestion!
Ellen

_________________
http://www.ellenvandrunen.com - Ellen van Drunen Photography


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 



Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group