No input file specified. J! 2.5 + godaddy

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
kevtheirish
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Fri Feb 29, 2008 7:18 pm

No input file specified. J! 2.5 + godaddy

Postby kevtheirish » Sun Jul 15, 2012 3:00 pm

real quick... getting No input file specified when i click submit an article from the front end. Also when I try to click on "Read More" I get the same result.
GoDaddy support gave me this solution:
To Enable Joomla! SEF URLs




Log in to your Joomla! control panel ( http://coolexample.com/administrator , where coolexample.com is the domain name and directory where you installed Joomla!).

From the Site menu, select Global Configuration.

In the SEO Settings section, from the Search Engine Friendly URLs field, select Yes, and then click Save.

Log in to your Account Manager.

Click Web Hosting.

Next to the account you want to use, click Launch.

From the Tools menu, select FTP File Manager.

From the left menu, select the directory where you installed Joomla!

NOTE: If you installed Joomla! in your root directory, click html.




Select htaccess.txt, and then click Edit.

Locate the line of text

# RewriteBase /

and delete the # from the line of text.

Select all of the text and copy it to your clipboard, and then click Close.

Click New, paste the content from your clipboard, and then click Save.

In the Enter file name field, enter .htaccess, and then click OK.



Simple changes, such as installing new modules or plugins to the Joomla configuration, can trigger common issues with SEF URLs. You can troubleshoot your Joomla SEF URLs by disabling and then re-enabling them. If you need more information, see Enabling Joomla! Search Engine Friendly URLs.



To Troubleshoot Joomla! SEF URLs




Make sure your .htaccess file is configured to allow SEF URLs. If you are not sure how to do this, see Rewriting .htaccess Files for SEF URLs in Joomla!

Log in to your Joomla control panel. (If Joomla is installed on the root level, the admin panel URL is http://coolexample.com/administrator , where coolexample.com is the domain name and directory where you installed Joomla).

From the Site menu, select Global Configuration.

In the SEO Settings section, from the Search Engine Friendly URLs, select No, and then click Save.

In the SEO Settings section, from the Search Engine Friendly URLs, select Yes, and then click Save.




I found this solution:
viewtopic.php?f=618&t=729649&p=2842458&hilit=No+input+file+specified#p2842458

but dont know where the php.ini file is located to try it... I've checked thru FileZille and Godaddy's file manage w/o any luck

any help resolving this would be greatly appreciated

TYIA


Godaddy + linux
J! 2.5.6 Stable
pHp 5.3.13
Apache
Currently using "Landscape" template, however issues are present in default template as well

kevtheirish
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Fri Feb 29, 2008 7:18 pm

Re: No input file specified. J! 2.5 + godaddy

Postby kevtheirish » Mon Jul 16, 2012 9:43 pm

Update


It only happens when SEF URLs are on






When SEF is turned on and URL rewrite is on i get
The requested URL /using-joomla/extensions/components/content-component/article-categories/73-test-2 was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

glapolla
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jun 04, 2011 2:33 am

Re: No input file specified. J! 2.5 + godaddy

Postby glapolla » Mon Jul 16, 2012 11:06 pm

Change
RewriteBase /
to
RewriteBase /using-joomla

in your .htaccess file

kevtheirish
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Fri Feb 29, 2008 7:18 pm

Re: No input file specified. J! 2.5 + godaddy

Postby kevtheirish » Thu Jul 26, 2012 11:42 pm

it worked for when SEO is off but same issue w/ SEO on


Return to “General Questions/New to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 5 guests