The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Jul 23, 2012 8:20 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Jul 23, 2012 7:34 pm
Posts: 1
Hello.

I have successfully implemented the RTMP code using the custom tag with a single file (tested both flv and mp4) using AVR v1.2.7.1054 w/ JW Player using Joomla 1.5 and a rocket theme. However, I am having trouble with bitrate dynamic switching though.

I have tried referring to a rss xml file containing the links to the videos {rtmp...}video.xml{/rtmp} as well as copying the hard code from a working single video file and replacing {file...} with {Levels: [ {bitrate='3500' width='1920' file='video1920.flv'} ] }

see below..

This works: {rtmp...}video.mp4{rtmp}
This does not work: {rtmp...}videobitrate.xml{rtmp}

videobitrate.xml file contains:
<rss version="2.0" xmlns:media="http://search.yahoo.com/mrss/"
xmlns:jwplayer="http://developer.longtailvideo.com/">
<channel>
<title>Playlist with RTMP Dynamic Streaming</title>
<item>
<title>video</title>
<description>video</description>
<media:group>
<media:content bitrate="3500" url="video720.flv" width="1280" />
<media:content bitrate="1800" url="video576.flv" width="1024"/>
<media:content bitrate="900" url="video432.flv" width="768" />
<media:content bitrate="600" url="video288.flv" width="512" />
<media:content bitrate="300" url="video144.flv" width="256" />
</media:group>
</item>
</channel>
</rss>

This script in an article does not work either:

<script type="text/javascript">
swfobject.embedSWF('/plugins/content/avreloaded/jwplayer-4.3.132.swf','avreloaded0','576','324','9.0.115','/plugins/content/avreloaded/expressinstall.swf',
{width:'512',height:'288',
autostart:'false',
controlbar:'over',
skin:'/plugins/content/avreloaded/five.swf',
image:'image works fine ',
levels: [
{ bitrate: 3500, width: 1280, file: 'video720.flv' },
{ bitrate: 1800, width: 1024, file: 'video576.flv' },
{ bitrate: 900, width: 768, file: 'video432.flv' },
{ bitrate: 600, width: 512, file: 'video288.flv' },
{ bitrate: 300, width: 256, file: 'video144.flv' }
],
streamer:'rtmp://s-masked-w.cloudfront.net/cfx/st',
type:'rtmp',

etc...
</script>
note I took out the file as I was anticipating levels: would work in its place..


Thoughts?


Top
 Profile  
 
PostPosted: Wed Jul 25, 2012 12:10 am 
User avatar
Joomla! Champion
Joomla! Champion

Joined: Thu Aug 18, 2005 2:09 am
Posts: 5657
Location: California
.
Looks like you have a mix of newer embed code and an older player, incorrect XML file, etc., etc.
Quite a mess.

I am guessing you found how to add an RTMP tag to AVR from one of my older posts.

If I remember correctly the v4.3.132 player does not support multi-bitrate.
The v4.7 player does support it (IIRC).
So the AVR embed code could be adjusted to use the newer player.

I can attach the v4.7 player SWF here.
With a correct XML file it should work.

If you would like help to get it working, please provide real media links for me to test.

.

_________________
██ AllMedia4Joomla Project
██ http://sourceforge.net/projects/allmedia4joomla/
██ AllMedia YöuTube Feed Gallery module released
██ Download: http://sourceforge.net/projects/allmedia4joomla/files/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 



Who is online

Users browsing this forum: No registered users and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group