The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Jul 31, 2012 8:37 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu May 12, 2011 4:35 pm
Posts: 2
Hi,

I have a version 1 Joomla site.

I'd like to try and export tables for 'content', and also 'sections', from this old site to use in a new installation of the latest version of Joomla.

Is this feasible? I tried (successfully) importing a single article without too many problems.

The idea behind doing this is essentially to save me having to manually copy and paste approx 700 articles into a new Joomla site.

Thanks for any feedback.

J.


Top
 Profile  
 
PostPosted: Tue Jul 31, 2012 11:26 pm 
Joomla! Explorer
Joomla! Explorer

Joined: Fri Nov 11, 2011 9:43 pm
Posts: 455
Location: Chicago, IL
How are you coding skills? I'm actually in the middle of an identical project, migrating a thousands of articles from 1.5 to 2.5. In the end, I wrote a script to load a mysqli object list, then used a foreach loop to cycle through each row, manually made adjustments to the data, and then inserted the object.

Another option is to use PHP My Admin to export a sql file with all the content data and then import it, but you need to be sure column headers and insert data matches up to the new formatting.

I know JUpgrade and SPUpgrade handle migrations from 1.5 to 2.5, I would check to see if they can handle 1.0. They both have options to just migrate the articles and if it works could save you A LOT of time.

Good luck!


Top
 Profile  
 
PostPosted: Mon Aug 13, 2012 7:15 am 
Joomla! Fledgling
Joomla! Fledgling

Joined: Mon Aug 13, 2012 4:24 am
Posts: 3
I was updating a joomla 1.0.15 to JM2.5, the content and categories was not the problem, but virtuemart users make a headache.... actualy I sucesfull the update.

You need to work in a WAMP or XAMP server, not work in a live web.
The WAMP have APACHE 2.4.2, MYSQL 5.5.25a, PHP 5.3.14.
The mysql its not compatible with migrator1.5 tools, and I make a changes over plugins php files.

the steps were:
0- Install the JM1.0.15 DB and files in your WAMP and make it a working site.
1- Install migrator and dump sql db from the working site JM1.0.15 to get a "JM1.5 DB compatible".(select the necesary plugins in "Create Migration SQL File", content, users, etc).
2- Next install a clean JM1.5 without sample date, and overwrite the JM1.5 DB with the dump sql (you need to use import Myadmin or the tool for migration in some step of JM1.5 installation)
3- Move images from JM1.0.15 to respective directories in JM1.5, and test that all its working in front end.( content, users in backend, categories, etc)
4- Next install "Jupgrade" in the JM1.5 and start it to update to a new JM2.5.


Migrator 1.5 http://www.4shared.com/zip/b9abMHFa/migrator.html?refurl=d1url compatible with MYSQL 5.5.25.
Jupgrade http://redcomponent.com/jupgrade
Migrator Plugins for Virtuemart VM.zip
PD: the customs fields in virtuemart 1.0 are not compatible with 2.0.
PD: to install the plugins in migrator Upload all tablename.php files to the administrator/component/com_migrator/plugins folder on your Joomla! install

I hope that this will usefull for you.

Saludos!!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 



Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group