File is too large to upload

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
skbohler
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Mon Nov 30, 2009 6:14 pm

File is too large to upload

Postby skbohler » Mon Aug 27, 2012 2:27 pm

Hello,

We have a new installation of Joomla 2.5.4 running under IIS 7.

When trying to upload an image, it gives the error:

"This file is too large to upload."

Our max upload is 10 MB.
post_max_size in php.ini is set to 8M

The files I'm trying are less than 1 MB.

We manage our own server (no hosting company involved).

All permissions look fine.

Any tips would be greatly appreciated!

Steve

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 21832
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: File is too large to upload

Postby Per Yngve Berg » Mon Aug 27, 2012 3:05 pm

post_max_size should be larger than max upload.

skbohler
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Mon Nov 30, 2009 6:14 pm

Re: File is too large to upload

Postby skbohler » Mon Aug 27, 2012 3:21 pm

OK, I'll try that. Thanks.

axiale05
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Sun Jun 03, 2007 12:12 pm

Re: File is too large to upload

Postby axiale05 » Thu Aug 30, 2012 6:30 pm

@skbohler can you verify if it's working on your side? I've tried and its not working on mine..

cmbay
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Thu Dec 31, 2009 11:53 pm
Location: Oregon, USA

Re: File is too large to upload

Postby cmbay » Sat Sep 01, 2012 8:32 pm

I had the same problem although it was on an Apache server. Even though my hosting control panel showed a upload_max_filesize of 64 megabytes, in Joomla Administrator > Site > System Information > PHP Information showed:
post_max_size 8M
upload_max_filesize 2M

Putting

Code: Select all

post_max_size = 10M
upload_max_filesize = 10M
into a php.ini file didn't work. It was ignored. I had to add

Code: Select all

php_value post_max_size 10M
php_value upload_max_filesize 10M
to the .htaccess file in the site root.

At first, Joomla didn't report the change but I logged out and back into the Administrator. Then I checked the System Information again and the new values were shown. My files will now upload.

Joomla 2.5.6, PHP Version 5.3.15
Charles

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: File is too large to upload

Postby humvee » Sun Sep 02, 2012 2:51 pm

If you are on a remote hosted server you should speak to the host and get the values changed by them in the main php.ini file which on shared hosting only they will be able to do. Otherwise you should check with the host what restrictions they have with regard changing settings in either local php.ini or .htaccess files. This option will vary from host to host so if you subsequently transfer the files you may have issues.

On Dedicated servers, Virtual Servers, and on localhost installations you should be able to directly access the server's main php.ini file and change the settings directly.

IMPORTANT
Make sure that you change the existing "live" settings and not those that are in any information panels within the document (these are prefixed with the # (hash/pound sign) as the php.ini file is a hierarchy based document and if you make changes at the top and the same variables have different values lower down then the later values will be the ones that apply.

grayfish
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Sun Sep 02, 2012 12:40 am

Re: File is too large to upload

Postby grayfish » Sun Sep 02, 2012 3:07 pm

I think this will work for you.
First, find out your FTP settings (username, host and password) these are often sent with an email when you first register to your domain.

Now download a Ftp software i recomend filezilla if youre on Pc, since it's free and easy. if your'e on mac then Cyber duck is nice.

Now connect with your settings trough your FTP Client, you should now se a folder called "Public_htm", go into that.

Now find a folder called "tmp" and extract your exteension so it's in a folder in your "tmp" folder.

now go to your Joomla/administrator site and select extension mananger then install from directory and after tmp add
"/*the name of the folder you extracted in tmp folder*" and then hit install.

It should do the trick :) i hope i was to some help :)

*edit*
saw that you manange your own server, then ignore the ftp part and go directly to the folder were your homepage is :)

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: File is too large to upload

Postby humvee » Sun Sep 02, 2012 3:18 pm

You should also update Joomla to 2.5.6 as a matter of priority.

raycarter2012
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Oct 13, 2012 2:06 pm

Re: File is too large to upload

Postby raycarter2012 » Sat Oct 13, 2012 2:25 pm

On Linux shared hosting accounts you can find the default system php.ini and php5.ini files here:
/web/conf/php.ini
/web/conf/php5.ini

Upload a file (for example info.php) to the root with this content:
<pre>
<? system("cat /web/conf/php5.ini"); ?>
</pre>

Then hit this page with a browser, eg: http://yoursite.com/info.php

Copy the text and place into a new php.ini or php5.ini file, make your changes (for example, max_upload_size etc) and upload to your server's root. To check if it worked go to system information in the joomla backend and open php settings.

For me newly placed php.ini works and php5.ini doesnt.


Return to “General Questions/New to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 13 guests