Install Joomla on local machine

Need help installing Joomla! 2.5? For all Joomla! 2.5 installation issues please use this forum. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
walinaimi786
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Sep 18, 2012 11:43 am

Install Joomla on local machine

Postby walinaimi786 » Mon Sep 24, 2012 11:13 am

when I install Joomla 2.5 on my local machine it gives me below error

"Fatal error: Declaration of JInstallation::_createSession() must be compatible with that of JApplication::_createSession() in C:\AppServ\www\Joomla Sites\installation\includes\application.php on line 360"

I have window XP Pro, I have installed Apache 2.6
I did create empty data base
localhost is "http://localhost/JoomlaSites/installation/index.php"

Can someone help me where is the problem and how can I fix this with many thanks in advance.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Install Joomla on local machine

Postby humvee » Tue Sep 25, 2012 8:59 am

C:\AppServ\www\Joomla Sites\installation\includes\application.php on line 360

http://localhost/JoomlaSites/installation/index.php

In the path to the site folder you have a space between Joomla and Sites
In URL you do not.

It is not wise to use capital letters or any special characters or whitespace in directory or file names for just this reason. This is even more pertinent when using systems such as AMP which follow UNIX standards. Replace spaces with the only two characters that you should use and that will be recognised by all systems which are the underscore or the hyphen. Windows does not care about such distinctions but other OS and software does.

If this does not resolve the issue and is it appears you have installed the AMP components individually rather than use one of the stacks available, please run the Forum Post Assistant to provide the information to help us try and resolve the issue.
Please follow the instructions in the post and the program pack closely.


Return to “Installation Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 9 guests