Upgrade from Joomla 1.7.3 ??

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
wingnut144
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 130
Joined: Sun Sep 23, 2007 2:51 am

Upgrade from Joomla 1.7.3 ??

Postby wingnut144 » Tue Oct 16, 2012 5:18 pm

We use Joomla as a Intranet for our office and we're currently using Joomla 1.7.3

I noticed that Joomla 3.x has come out.....are there instructions on how I can upgrade from 1.7.x to 3??

sovainfo
Joomla! Champion
Joomla! Champion
Posts: 7436
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from Joomla 1.7.3 ??

Postby sovainfo » Tue Oct 16, 2012 5:46 pm

Yes, and the instructions are to stick with J2.5.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

wingnut144
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 130
Joined: Sun Sep 23, 2007 2:51 am

Re: Upgrade from Joomla 1.7.3 ??

Postby wingnut144 » Tue Oct 16, 2012 6:09 pm

Why is that??

sovainfo
Joomla! Champion
Joomla! Champion
Posts: 7436
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from Joomla 1.7.3 ??

Postby sovainfo » Tue Oct 16, 2012 6:26 pm

Read the announcement, first board!
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

User avatar
Nick Savov
Joomla! Ace
Joomla! Ace
Posts: 1075
Joined: Tue Apr 13, 2010 7:40 pm
Location: Iowa

Re: Upgrade from Joomla 1.7.3 ??

Postby Nick Savov » Tue Oct 16, 2012 9:39 pm

Hi wingnut144,

You need to update from 1.7.3 to 2.5.7 ASAP. Please make a backup before proceeding and consult with Joomla's documentation:
http://docs.joomla.org/Upgrading_from_J ... Joomla_2.5

Then check out the Joomla 3 FAQ:
http://community.joomla.org/blogs/commu ... 0-faq.html

Kind regards,
Nick
Online Joomla Training at: http://www.ostraining.com/online/

"God is most glorified in us, when we are most satisfied in Him" - http://www.desiringgod.org/

cyford
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Jan 09, 2012 3:23 pm

Re: Upgrade from Joomla 1.7.3 ??

Postby cyford » Wed Nov 20, 2013 7:44 pm

i am not seeing any way to complete this upgrade from 1.7.3

1) There are no updates internally. and get error (XML error: EntityRef: expecting ';' at line 3)
2 ) the patches are from 1.7 - 1.7.5 and 1.7.4 - 1.7.5 ( and both error out)
http://www.weblinksonline.co.uk/updatin ... wards.html
***** Manual signatures are NOT allowed ***** ERROR ***** Manual signatures are NOT allowed *****


JInstaller: :Install: Error SQL DB function failed with error number 1060
Duplicate column name 'ordering' SQL=ALTER TABLE `qi93d_languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;
SQL =

ALTER TABLE `#__languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;

Files Update: SQL error file DB function failed with error number 1060
Duplicate column name 'ordering' SQL=ALTER TABLE `qi93d_languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;
SQL =

ALTER TABLE `#__languages` ADD COLUMN `ordering` int(11) NOT NULL default 0 AFTER `published`;

***** Manual signatures are NOT allowed *****
Allen Ford
http://www.cyfordtechnologies.com

cyford
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Jan 09, 2012 3:23 pm

Re: Upgrade from Joomla 1.7.3 ??

Postby cyford » Wed Nov 20, 2013 7:59 pm

ok i learned that even with the errors it did upgrade.. till i got to Joomla_3.1.6-Stable-Update_Package.zip
now i get -
Fatal error: Call to undefined method InvalidArgumentException::get() in

and the complete site is down :(


Return to “Migrating and Upgrading to Joomla! 3.x”

Who is online

Users browsing this forum: leolam and 13 guests