The Joomla! Forum ™



Forum rules


Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.



Post new topic Reply to topic  [ 24 posts ] 
Author Message
PostPosted: Thu Nov 15, 2012 12:36 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 15, 2012 12:21 pm
Posts: 6
Hi there,

yesterday i have seen the update message at the control centre update button:

update to joomla 3.0.1.

i had a running 2.5.6. and for security quickly i installed the 2.5.x to 2.5.8 patch
to upgrade after that to 3.0.1

now its the system message
there is NO UPDATE needet because i have the actual 2.5.8 version

:-(

ca i upgrade a 2.5.8. to a 3.0.2 version ?
how ?

thanks and best greetings from thuringia
http://www.two-sports.com


Top
 Profile  
 
PostPosted: Thu Nov 15, 2012 1:39 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Tue Sep 19, 2006 10:51 am
Posts: 259
Location: Malaysia
1) Login to the backend
2) Drop down "Components" and click "Joomla Update"
3) Click "Options"
4) Select "Short term support" for update server
5) Save & close

_________________
"Whether you're a programmer or a seamstress, it's all about new techniques, simplifying old techniques, and consolidating steps. Making things go faster -- but not worse. Better."
— Martha Stewart for Wired


Top
 Profile  
 
PostPosted: Thu Nov 15, 2012 5:58 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 15, 2012 12:21 pm
Posts: 6
... sorry - doesn't work

LTS
STS
Test

always the same since update from 2.5.6 with package (2.5.x to 2.5.8).
there ist everything ok and actual, the update button says.


Top
 Profile  
 
PostPosted: Thu Nov 15, 2012 11:05 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jun 20, 2012 5:47 am
Posts: 45
Location: Goshen, Utah, USA
After changing to short term support. You will then need to go to the control panel dashboard and then click on the link "Joomla! is up-to-date".

You should then see:
Quote:
Joomla! Update
No updates available

You already have the latest Joomla! version, 3.0.1.

Next
Click on the button at the top of that screen that says Purge Cache

You will then see that there is an update available for 3.0.2 and then you can apply the update.

You should then see:
Quote:
Joomla! Update
No updates available

You already have the latest Joomla! version, 3.0.2.

_________________
============
John Boone
http://www.boonewebmaster.com - Web Design - Joomla 3.x
http://www.genealogyarticles.com - Articles about Genealogy - Joomla 2.5.x


Top
 Profile  
 
PostPosted: Thu Nov 15, 2012 11:38 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 15, 2012 12:21 pm
Posts: 6
NO STOP READ MY FIRST QUESTION

i am ONE STEP BEFORE 3.0.1 !!!!!

Keine Aktualisierungen verfügbar
Es ist bereits die aktuellste Joomla!-Version 2.5.8 installiert.

i updatet 2.5.6 to 2.5.8

in 2.5.6. there was the information "update to 3.0.1"
BUT NOW
in 2.5.8. there is no message update to ..... anything

also cache cleaning has no effect !


Top
 Profile  
 
PostPosted: Thu Nov 15, 2012 11:46 pm 
User avatar
Joomla! Apprentice
Joomla! Apprentice

Joined: Wed Jun 20, 2012 5:47 am
Posts: 45
Location: Goshen, Utah, USA
Sorry my mistake. No need to yell this is a friendly forum with the intent to help others.

_________________
============
John Boone
http://www.boonewebmaster.com - Web Design - Joomla 3.x
http://www.genealogyarticles.com - Articles about Genealogy - Joomla 2.5.x


Top
 Profile  
 
PostPosted: Fri Nov 16, 2012 2:00 am 
User avatar
Joomla! Master
Joomla! Master

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25005
Location: @Webdongle
Is it a live site ?

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html


Top
 Profile  
 
PostPosted: Fri Nov 16, 2012 9:37 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 15, 2012 12:21 pm
Posts: 6
jdbdrwho wrote:
Sorry my mistake. No need to yell this is a friendly forum with the intent to help others.


thank you 4 your help - it was no critic !


and the other question was: LIVE SITE ? --> YES !


Top
 Profile  
 
PostPosted: Fri Nov 16, 2012 12:47 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25005
Location: @Webdongle
betriebsdruckth wrote:
...
and the other question was: LIVE SITE ? --> YES !
Then the answer to your original question is 'Don't do it !!!'

Quote:
Joomla 3.0 is recommended for more experienced users and developers.

http://www.joomla.org/download.html

If you need to ask how to do it then you are not experienced. Thus trying to do it on a live site would be to say the least not very clever.

You need to make a backup of your site and test update/upgrade on test environment.

Do you have xampp or similar on your computer ?

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html


Top
 Profile  
 
PostPosted: Sat Nov 17, 2012 11:04 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 15, 2012 12:21 pm
Posts: 6
OK again and shorter

why there WAS a button "update to 3.0.1" (as i had 2.5.6)

and NOW ther is NO button ???
(after my syfety update to the highest 2.5.(8))

dont tell me i am not experieced because i had only a simple question ...
i am on the way with joomla since 1.xxx - so please dont tell me to try a xammp or something -
my question is only about the missing button - and again: why did joomla show me this function in 2.5.6. and not more in 2.5.8 ???


Top
 Profile  
 
PostPosted: Sat Nov 17, 2012 2:00 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25005
Location: @Webdongle
It was not a personal attack on you, it was an observation on you wanting to update/upgrade from 2.5 to 3.0 on a live site.

betriebsdruckth wrote:
...
dont tell me i am not experieced because i had only a simple question ...
...
The answer to your question is not simple ... to update/upgrade from 2.5 to 3.0 is not a simple matter.


betriebsdruckth wrote:
...
i am on the way with joomla since 1.xxx - so please dont tell me to try a xammp or something -
Then you should know not to update/upgrade between different series on a live site.


betriebsdruckth wrote:
...
my question is only about the missing button - and again: why did joomla show me this function in 2.5.6. and not more in 2.5.8 ???
Well one of your questions was
betriebsdruckth wrote:
ca i upgrade a 2.5.8. to a 3.0.2 version ?
how ?
When I asked if it was a live site and you replied 'Yes' ... then I gave the answer which IMHO was correct.

If you are experienced and want to update/upgrade from 2.5.8 to 3.0.2 then I wish you luck.

As for 2.5.6 showing 3.0.x is available for update ... that should only happen if the Joomla update options have been changed. After using the 2.5.x to 2.5.8 patch then Joomla update component shows up to date ... until cache is cleared in Module manager >>> update tab. But even then the Joomla update options must have been changed in the first place.

I still maintain that anyone updating/upgrading ... from 2.5 to 3.0 on a live site ... is not as experienced as they think they are. Also, to change the settings on a live site to STS ... is not the act of an experienced user. Also would add that experience is learning from mistakes not the length of time doing something. If you are making the mistake of updating/upgrading 2.5 to 3.0 on a live site ... that speaks for itself.

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html


Top
 Profile  
 
PostPosted: Sun Nov 18, 2012 11:10 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Thu Nov 15, 2012 12:21 pm
Posts: 6
hello Webdongle,

thank you very much 4 accepting my words.
somebody was answering without reading my words.

VERY USEFUL was: until cache is cleared in Module manager >>> update tab.
i cleared every cache around but not this cache ;-)
now there is another small error: Update: :Collection: „http://update.martiinkolle.dk/xml/extensions.xml“ kann nicht geöffnet werden!
???

i never updated a live site from version to version because there was no possibility via update function since 2.5
(i should accept, that the update function is not a real update function - from version to version)

I DONT WANT TO UPDATE THIS LIVE SITE NOW

thanks 4 the LTS STS tip, but i never used (changed) this options.
the update message @ 2.5.6. was really there (thats the grounding of my questions)

http://www.two-sports.com


Top
 Profile  
 
PostPosted: Tue Nov 20, 2012 4:47 am 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Tue Apr 13, 2010 7:40 pm
Posts: 1070
Location: Iowa
By the way, please be sure to check out the Joomla 3 FAQ:
http://community.joomla.org/blogs/commu ... 0-faq.html

Kind regards,
Nick

_________________
Online Joomla Training at: http://www.ostraining.com/online/

"God is most glorified in us, when we are most satisfied in Him" - http://www.desiringgod.org/


Top
 Profile  
 
PostPosted: Tue Nov 20, 2012 11:18 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sat Aug 06, 2011 8:33 pm
Posts: 16
Transfered HERE


Last edited by Maisondouf on Tue Nov 20, 2012 11:36 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Nov 20, 2012 11:22 pm 
User avatar
Joomla! Ace
Joomla! Ace

Joined: Tue Apr 13, 2010 7:40 pm
Posts: 1070
Location: Iowa
Hi Maisondouf,

Please open up a new topic for your issue.

Kind regards,
Nick

_________________
Online Joomla Training at: http://www.ostraining.com/online/

"God is most glorified in us, when we are most satisfied in Him" - http://www.desiringgod.org/


Top
 Profile  
 
PostPosted: Fri Mar 08, 2013 1:22 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun May 27, 2012 9:19 pm
Posts: 10
Hi , I have a question directly related to this post.
I accept that updating from 2.5.8 to the 3's is something experienced developers should do. Is it therefore safe to simply stay with 2.5.8 version?


Top
 Profile  
 
PostPosted: Thu Mar 14, 2013 9:42 pm 
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sat Oct 01, 2011 7:06 pm
Posts: 3925
No, that is not safe. You need to upgrade to J2.5.9 and continue to do so for other releases in J2.5.


Top
 Profile  
 
PostPosted: Thu Mar 14, 2013 10:57 pm 
User avatar
Joomla! Master
Joomla! Master

Joined: Sat Apr 05, 2008 9:58 pm
Posts: 25005
Location: @Webdongle
If your 2.5.8 is showing 3.0.x available then set your Joomla update component's >>> Options to LTS.

_________________
'When I'm right nobody remembers when I'm wrong nobody forgets.'

http://weblinksonline.co.uk/joomla-faq.html


Top
 Profile  
 
PostPosted: Tue Mar 19, 2013 10:48 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Mar 19, 2013 10:45 am
Posts: 6
Hi

Sorry if this has already been answered....

But under components i dont have the Joomla update menu item?

Im running 2.5.8 and want to upgrade to 3.x as this is a new server and no sites live yet

Help??


Top
 Profile  
 
PostPosted: Tue Mar 19, 2013 11:52 am 
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sat Oct 01, 2011 7:06 pm
Posts: 3925
Call Joomla! update directly: http://localhost/j258/administrator/index.php?option=com_joomlaupdate


Top
 Profile  
 
PostPosted: Tue Mar 19, 2013 12:07 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Mar 19, 2013 10:45 am
Posts: 6
thanks

using that direct link, i get red errors

Error loading component: com_joomlaupdate, 1

then whem i try to set short term, i get

Fatal error: Call to a member function filter() on a non-object in .........libraries/joomla/application/component/modelform.php on line 261

and it wont save setting

any ideas? should i upgrade to 2.5.9, then to 3.x?

Thx


Top
 Profile  
 
PostPosted: Tue Mar 19, 2013 12:17 pm 
Joomla! Virtuoso
Joomla! Virtuoso

Joined: Sat Oct 01, 2011 7:06 pm
Posts: 3925
You shouldn't get those errors. Maybe run discover and install missing stuff and check the database and fix.

When both of these don't work, consider to overwrite the distribution without the installation folder.

When you want to go for J3, download the patch and manually install it using extension installer. Should be needed to update to 259 first, it doesn't hurt if you do.

Assuming you have investigated your extensions on compatibility for J3! If not don't go to J3.


Top
 Profile  
 
PostPosted: Tue Mar 19, 2013 12:35 pm 
Joomla! Apprentice
Joomla! Apprentice

Joined: Tue Mar 19, 2013 10:45 am
Posts: 6
thx, the discover didthe trick,

selected joomla update and installed.... now looks as per instructions !! thx very much


Top
 Profile  
 
PostPosted: Wed May 22, 2013 6:06 pm 
Joomla! Fledgling
Joomla! Fledgling

Joined: Thu Feb 09, 2012 6:27 pm
Posts: 4
This is a known issue. Here is the solution:
No-updates-shown-in-current-version
There are some reports that updates that have been released are not shown in the current (older) version. If this occurs, go to the Updates tab of the Extensions Manager. Click the clear cache icon. Then click the check for updates icon.
(from this page: http://docs.joomla.org/No-updates-shown ... nt-version)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 24 posts ] 



Who is online

Users browsing this forum: erni49 and 36 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group