The Joomla! Forum ™





Post new topic Reply to topic  [ 21 posts ] 
Author Message
PostPosted: Tue Jul 18, 2006 4:45 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Thu Sep 01, 2005 11:19 pm
Posts: 273
Location: Minneapolis, USA
OK folks,

I got a patch out for my two projects tonight. Upgrade to them ASAP.

BSQ Sitestats
http://forge.joomla.org/sf/projects/bsq_sitestats

JoomlaLib
http://forge.joomla.org/sf/projects/joomlalib

If you notice any other security issues, please send me a PM or contact me via our BSQ Sitestats forum on http://forum.4theweb.nl

Thanks,
Brent

_________________
Developer, bsq_sitestats module.
www.bs-squared.com


Last edited by RobS on Wed Jul 19, 2006 4:46 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Jul 18, 2006 5:08 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun May 07, 2006 11:48 am
Posts: 8
Aloha!
Should we uninstall the component through the back-end?  Will this remove the current stats in the db?

Mahalos!


Top
 Profile  
 
PostPosted: Tue Jul 18, 2006 5:14 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Thu Sep 01, 2005 11:19 pm
Posts: 273
Location: Minneapolis, USA
Upgrading
http://wiki.4theweb.nl/w/BSQ_Upgrading

_________________
Developer, bsq_sitestats module.
www.bs-squared.com


Top
 Profile  
 
PostPosted: Tue Jul 18, 2006 5:14 am 
Joomla! Apprentice
Joomla! Apprentice

Joined: Sun May 07, 2006 11:48 am
Posts: 8
Super mahalos for the very quick reply!


Top
 Profile  
 
PostPosted: Tue Jul 18, 2006 5:48 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
Brent - installed BSQ just fine.  Everything looks good.  I am getting this in my log and I'm not sure what to make of it...

For the last several days I have had like a million of these entries...

Every minute I have an entry from an "Indeterminable" browser that keeps hitting this url:

http://www.girlscantwhat.com/component/ ... ss;action/

that link leads to the forum page.

There seem to be 4 or more IP addresses that do this.  These are not googlebots - at least I don't think they are - the googlebots actually say googlebot when you look up the IP address.  And searchbots don't repeatedly hit the same page over and over again.  The IP address tells me nothing other than all 4 or so of them US based.

I ask what these hits are because I found evidence of a hacking attempt on my site last night (no damage done) so I am looking everything over very closely now.  Hmmm

Any ideas?  They are still showing even after installing the latest about a half hour ago.  Thanks!

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Tue Jul 18, 2006 6:35 am 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
Hey I found another strange thing.

When I checked the stats after the install of 2.1.1, I saw that a friend had been on my site in the last couple of minutes.  So I IM'd her and asked her if she was.  She said she hadn't been on my site all day.  Joomla shows her logged in and she's listed in the stats.  The log shows her looking at two really old blog articles.  Very odd.  May not be related to BSQ but I thought I'd mention it.

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Wed Jul 19, 2006 5:46 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
drummergirl wrote:
Every minute I have an entry from an "Indeterminable" browser that keeps hitting this url:

http://www.girlscantwhat.com/component/ ... ss;action/

that link leads to the forum page.

There seem to be 4 or more IP addresses that do this.  These are not googlebots - at least I don't think they are - the googlebots actually say googlebot when you look up the IP address.  And searchbots don't repeatedly hit the same page over and over again.  The IP address tells me nothing other than all 4 or so of them US based.


Just an update...I blocked these IPs and everything seems to be fine now.  I am noticing on the "hits per day" graph that the lat point on the right shows the previous days date when you hover over it, but that is the point that keeps going up throughout the day as more hits are counted.  It also seems to jump to the next day (meaning rollover to the correct day) late in the evening.  Not sure what that is based on.  The actual time on the hits is the same as my server.

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Thu Jul 20, 2006 12:40 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Jan 27, 2006 4:03 pm
Posts: 97
drummergirl wrote:
I am noticing on the "hits per day" graph that the lat point on the right shows the previous days date when you hover over it, but that is the point that keeps going up throughout the day as more hits are counted.  It also seems to jump to the next day (meaning rollover to the correct day) late in the evening.  Not sure what that is based on.  The actual time on the hits is the same as my server.
Same problem here, but I am using an earlier 2.0 version. I think this has been an issue for a while.


Top
 Profile  
 
PostPosted: Thu Jul 20, 2006 1:33 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Thu Sep 01, 2005 11:19 pm
Posts: 273
Location: Minneapolis, USA
Please don't jack this thread for bug reports. I'm looking for security issues only.

_________________
Developer, bsq_sitestats module.
www.bs-squared.com


Top
 Profile  
 
PostPosted: Thu Jul 20, 2006 3:45 pm 
Joomla! Intern
Joomla! Intern

Joined: Fri Jan 27, 2006 4:03 pm
Posts: 97
I'm sorry.  :-[
It looked like this entire thread was about the upgrade because the first post directed security issues to be handled outside this thread.


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 8:44 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Fri Nov 03, 2006 7:42 pm
Posts: 76
can you advise in the template.php where the following is insetred

if(file_exists($mosConfig_absolute_path."/components/com_bsq_sitestats/bsqtemplateinc.php"))
{
        require_once($mosConfig_absolute_path."/components/com_bsq_sitestats/bsqtemplateinc.php");
}
?>

Thankyou


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 8:46 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
I have mine right after the tag.  :)

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 8:55 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Fri Nov 03, 2006 7:42 pm
Posts: 76
thankyou, I think it works lol


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 9:11 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Fri Nov 03, 2006 7:42 pm
Posts: 76
would I be right in saying that this is correct?

if(mosCountModules('right')>0) { ?>
                                     

                                         
                                     

                                     
                                     

                               

                               
                           
                   
               
               
         
     


         
         
     
if(file_exists($mosConfig_absolute_path."/components/com_bsq_sitestats/bsqtemplateinc.php"))
{
        require_once($mosConfig_absolute_path."/components/com_bsq_sitestats/bsqtemplateinc.php");
}
?>





Does it look ok, and does the stats not start until 24 hours?

Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 9:15 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
Looks good.  You should start getting daily stats immediately.  I just clicked your link so there should be at least one hit to your home page.  Look on the summary tab.  On the referrers tab it should show that hit coming from joomla.org.


:pop  <-- where did this little guy come from?  cute!

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 9:53 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Fri Nov 03, 2006 7:42 pm
Posts: 76
Where did he come from  :pop


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 9:55 pm 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Fri Nov 03, 2006 7:42 pm
Posts: 76
Well Ive tried all of that but there are no statistics as yet, Ive had 4 members and 3 guests on line in 120 minutes - but nothing to show  ???


Top
 Profile  
 
PostPosted: Wed Nov 08, 2006 10:06 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
What are the settings for 'hit tracking' in your configuration?

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Thu Nov 09, 2006 8:02 am 
User avatar
Joomla! Intern
Joomla! Intern

Joined: Fri Nov 03, 2006 7:42 pm
Posts: 76
These are set to the following:-

Track hits =-Yes


Top
 Profile  
 
PostPosted: Thu Nov 09, 2006 1:14 pm 
User avatar
Joomla! Explorer
Joomla! Explorer

Joined: Wed Feb 22, 2006 9:51 pm
Posts: 322
Location: Illinois
I am not sure what is going on at this point.  You might PM the developer.  ???

_________________
Gretchen
http://www.GirlsCantWhat.com


Top
 Profile  
 
PostPosted: Thu Dec 20, 2007 8:03 am 
I've been banned!

Joined: Wed Dec 19, 2007 10:36 pm
Posts: 21
will the installation effect my database in any way? thanks in advance

_________________
smile


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ] 



Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group