Simple Image Gallery 3.0

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
amnikolaou
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Jun 27, 2013 9:16 pm

Simple Image Gallery 3.0

Postby amnikolaou » Thu Jun 27, 2013 9:32 pm

Hi, I installed the Simple Image Gallery 3.0 and the following error apperars when I view my article in the frontend

SCREAM: Error suppression ignored for
( ! ) Notice: Undefined variable: defaultImagePath in C:\wamp\www\joomla25\plugins\content\jw_sig\jw_sig.php on line 129
Call Stack
# Time Memory Function Location
1 0.0010 383176 {main}( ) ..\index.php:0
2 0.1790 7169184 JSite->dispatch( ) ..\index.php:42
3 0.1930 7544848 JComponentHelper::renderComponent( ) ..\application.php:197
4 0.2031 7566864 JComponentHelper::executeComponent( ) ..\helper.php:351
5 0.2039 7613552 require_once( 'C:\wamp\www\joomla25\components\com_content\content.php' ) ..\helper.php:383
6 0.2137 8061000 JController->execute( ) ..\content.php:16
7 0.2137 8061048 ContentController->display( ) ..\controller.php:761
8 0.2293 8931104 JController->display( ) ..\controller.php:74
9 0.2436 9694456 ContentViewArticle->display( ) ..\controller.php:722
10 0.2949 10633112 JDispatcher->trigger( ) ..\view.html.php:123
11 0.2961 10633808 JEvent->update( ) ..\dispatcher.php:161
12 0.2961 10634328 call_user_func_array ( ) ..\event.php:71
13 0.2961 10634352 plgContentJw_sig->onContentPrepare( ) ..\event.php:71
14 0.2961 10634384 plgContentJw_sig->renderSimpleImageGallery( ) ..\jw_sig.php:44

How can I fix it?

User avatar
jhdesign
Joomla! Guru
Joomla! Guru
Posts: 662
Joined: Sun Aug 21, 2005 11:15 pm
Location: Toronto, Ontario, Canada.
Contact:

Re: Simple Image Gallery 3.0

Postby jhdesign » Fri Jun 28, 2013 1:42 pm

Note the error "Undefined variable: defaultImagePath"

Did you set the image path in the plugin parameters?
Jacob Hodara ~ Joomla! developer
Joomla Website Development, Custom Programming, Support, Security, Migration and more..., [ New Clients Welcomed ]
LinkedIn: http://ca.linkedin.com/in/jacobhodara
Web: http://www.jh-design.com

amnikolaou
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Jun 27, 2013 9:16 pm

Re: Simple Image Gallery 3.0

Postby amnikolaou » Fri Jun 28, 2013 8:40 pm

Yes I did . I set the Root folder for image galleries->images/stories. The specified folder exists.

If I can't solve it, is there any other suggestion for a free plug-in that creates thumbnails?

User avatar
jhdesign
Joomla! Guru
Joomla! Guru
Posts: 662
Joined: Sun Aug 21, 2005 11:15 pm
Location: Toronto, Ontario, Canada.
Contact:

Re: Simple Image Gallery 3.0

Postby jhdesign » Fri Jun 28, 2013 8:47 pm

Jacob Hodara ~ Joomla! developer
Joomla Website Development, Custom Programming, Support, Security, Migration and more..., [ New Clients Welcomed ]
LinkedIn: http://ca.linkedin.com/in/jacobhodara
Web: http://www.jh-design.com

amnikolaou
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Jun 27, 2013 9:16 pm

Re: Simple Image Gallery 3.0

Postby amnikolaou » Sun Jun 30, 2013 2:02 pm

Thanks . I solved my problem with another component.

summerrose
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Jun 30, 2013 5:27 am

Re: Simple Image Gallery 3.0

Postby summerrose » Sun Jun 30, 2013 9:32 pm

thanks for sharing...

User avatar
jhdesign
Joomla! Guru
Joomla! Guru
Posts: 662
Joined: Sun Aug 21, 2005 11:15 pm
Location: Toronto, Ontario, Canada.
Contact:

Re: Simple Image Gallery 3.0

Postby jhdesign » Mon Jul 01, 2013 10:06 pm

amnikolaou wrote:Thanks . I solved my problem with another component.


Which component? The information may be helpful for other users.
Jacob Hodara ~ Joomla! developer
Joomla Website Development, Custom Programming, Support, Security, Migration and more..., [ New Clients Welcomed ]
LinkedIn: http://ca.linkedin.com/in/jacobhodara
Web: http://www.jh-design.com

amnikolaou
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Jun 27, 2013 9:16 pm

Re: Simple Image Gallery 3.0

Postby amnikolaou » Fri Sep 27, 2013 1:46 pm

The new component I tried is Admiror Gallery and it works fine for me.

angi76
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Feb 25, 2014 11:22 am

Re: Simple Image Gallery 3.0

Postby angi76 » Tue Feb 25, 2014 11:30 am

there is an error at line 129. I did not understand what it was but I solved by commenting the line and by inserting a previous line in which I specify the path in order to avoid the error.
I write here the two lines as I did in the file:

$galleries_rootfolder = 'images';
//$galleries_rootfolder = ($params->get('galleries_rootfolder')) ? $params->get('galleries_rootfolder') : $pluginParams->get('galleries_rootfolder', $defaultImagePath);

those who want to use this plugin can do so and if anyone understands the error on line 129 and solves it, is better!


Return to “General Questions/New to Joomla! 2.5”

Who is online

Users browsing this forum: No registered users and 13 guests