Joomla 3.1.5 Error RE: Magic Quotes

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.
Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
spock9458
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Apr 16, 2012 4:39 pm

Joomla 3.1.5 Error RE: Magic Quotes

Postby spock9458 » Fri Aug 02, 2013 3:29 pm

I am running Joomla 3.1 in a test environment, and just installed the upgrade to version 3.1.5. Now in the Admin back end I have an error on every page at the top, with a pink background, that says:

Error

Your host needs to disable magic_quotes_gpc to run this version of Joomla!

I have checked with my host, and I have verified by running a phpinfo() file, all settings for magic quotes say "Off".

How do I fix this problem? Any help will be appreciated. Thanks.
Last edited by spock9458 on Fri Aug 02, 2013 3:48 pm, edited 1 time in total.

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11274
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby brian » Fri Aug 02, 2013 3:42 pm

On many hosts they turn off magic quotes with a local php.INI file but this needs to be done on every directory on some server configurations. It looks like this is what your hosts have done. You can confirm this by putting the phpinfo file in the /administrator folder.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

spock9458
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Apr 16, 2012 4:39 pm

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby spock9458 » Fri Aug 02, 2013 3:47 pm

You were exactly right, Brian. I uploaded the php.ini file they had provided for me, to the administrator directory, and the error message has disappeared. Thanks for your help.

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11274
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby brian » Fri Aug 02, 2013 4:22 pm

Glad to have helped. I wish host would get a clue though and disable it properly
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

sgriesbach
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jun 27, 2012 9:11 pm
Location: Los Angeles, CA
Contact:

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby sgriesbach » Mon Aug 12, 2013 4:46 am

yes thank you! this fixes the problem on Hostgator dedicated server

K2a
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Sep 09, 2013 9:01 pm

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby K2a » Tue Sep 10, 2013 7:06 pm

Hi! I am a beginner I encounter the same problem, I would like to know where to find the php.ini file should I ask my hosting provider?
thank you for help me

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11274
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby brian » Tue Sep 10, 2013 7:10 pm

Ask your hosting provider the best way to disable magic quotes in THEIR server. There are many ways to do it and YOUR hosting provider can do this best for you.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 830
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby ozneilau » Wed Oct 16, 2013 4:00 am

brian wrote:On many hosts they turn off magic quotes with a local php.INI file but this needs to be done on every directory on some server configurations. It looks like this is what your hosts have done. You can confirm this by putting the phpinfo file in the /administrator folder.

Thanks Brian, this helped me too! :)

Rather than copy the php.ini to the /administrator folder, you can add a line to your .htaccess file like this:

Code: Select all

SetENV PHPRC /home/[account-name]/public_html

(or something similar depending on the folder structure on the server) so the php.ini settings apply to your whole website.
Please request help via the forums rather than by PM so everyone can benefit from the conversation.
NEIL ROBERTSON
Webilicious Web Design and Development
http://webilicious.com.au

payal88
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 11, 2015 7:55 am

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby payal88 » Wed Mar 11, 2015 8:08 am

I have the same error:
Error Your host needs to disable magic_quotes_gpc to run this version of Joomla!

None of the above method helped.

Any other suggestion?

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 830
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby ozneilau » Wed Mar 11, 2015 9:03 am

You may be able to disable magic quotes via your hosting control panel. Look for "PHP Settings" or similar.

Or ask your hosting company.
Please request help via the forums rather than by PM so everyone can benefit from the conversation.
NEIL ROBERTSON
Webilicious Web Design and Development
http://webilicious.com.au

User avatar
bhaumik
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri May 18, 2012 6:24 am

Re: Joomla 3.1.5 Error RE: Magic Quotes

Postby bhaumik » Fri Oct 23, 2015 5:27 am

Thanks a lot brian :) , your following trick did worked for me.

On many hosts they turn off magic quotes with a local php.INI file but this needs to be done on every directory on some server configurations. It looks like this is what your hosts have done. You can confirm this by putting the phpinfo file in the /administrator folder.


Return to “Administration Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 20 guests